了解 Commander

Commander 是一种软件实用工具，包括在 BarTender 的企业版中。如果无法使用命令行或 ActiveX 自动操作，或者其使用成本很高，那么可以借助于该工具，使用 BarTender 来执行自动标签打印。Commander 可以作为应用程序运行，或在 Windows 2000、XP 和 2003 上作为 Windows 服务运行。

Commander 工作原理

如果应用程序需要标签，则它只需创建一个触发事件（称为“触发器），例如，将文件放在您在网络上所选择的位置，或给您选择的帐户发送电子邮件。Commander 将检测该文件（或电子邮件）是否就位，然后“唤醒”BarTender，后者将把您的数据引入标签设计中，并自动打印标签。

触发器文件或消息可能为空，但也可能包含数据，这些数据将由 BarTender、Commander 启动的其它应用程序或 Commander 本身读取。由于创建触发器的应用程序可以在不同触发器中包含不同内容，因此，Commander 将执行的任务以及将使用的数据可以由应用程序动态定义。

例如，一个内部指令执行应用程序在数据库中输入有关指令的数据，然后将名为 NewOrder.dat 的空文件保存在 Commander 将查看的目录中。Commander 查找该文件并启动 BarTender，其标签格式已配置为在指定时间后在数据库中查询所输入的指令。BarTender 读取数据并打印标签。然后，Commander 删除 NewOrder.dat 文件并恢复对目录的监视。

在 Windows 2000、XP 或 2003 计算机上，Commander 可以配置为作为 Windows 服务在计算机打开的任意时刻运行，无论是否有人实际登录到计算机上。并且，可以运行多个 BarTender 进程，以提高性能。

有关如何使用 Commander 帮助的详细信息，请单击此处。


使用联机帮助

全部显示 全部隐藏

本帮助右侧窗口中始终包括最近查看过的主题。在每个帮助主题的右上角，都有一个“主页”链接。单击该链接可返回到本帮助的起始页。

左侧有 5 个选项卡：

  • 目录。帮助目录。浏览找到任一主题，然后双击将其打开。

  • 索引。帮助索引。其中包括您最可能查找的词。单击任何一个词。如果该词仅与一个主题相关，右侧将显示该主题。如果该词与多个主题相关，则列出这些主题。请单击所需的主题。

  • 搜索。一个全文搜索实用程序。有关此选项卡的使用方法，请参见以下内容。

  • 收藏夹。您最常查看的帮助主题的列表。要将某帮助主题添加到该列表中，请打开相应的主题，然后打开收藏夹选项卡，再单击选项卡底部的添加按钮。

  • 词汇表。词汇表包含标签和条形码行业的重要术语的定义。

顶部的按钮栏上有以下按钮：

  • 隐藏/显示。切换左侧窗格的可见性。

  • 定位。显示您当前打开的主题在目录中的位置。（有些主题未包含在目录中。）

  • 后退。再次打开您查看的上一个主题。

  • 前进。返回到您按后退按钮时打开的主题。

  • 打印。打印当前主题。

  • 选项。 打开特殊菜单。有关详细信息，请单击该行。

    • 隐藏选项卡/显示选项卡。与隐藏/显示按钮的功能一样（参见上文）。

    • 后退。与后退按钮的功能一样（参见上文）。

    • 前进。与前进按钮的功能一样（参见上文）。

    • 主页。打开本帮助的首页。

    • 停止。取消打开本帮助中的 Internet 网页。

    • 刷新。再次打开本帮助中当前显示的页。

    • 1 Seagull。与“Seagull”按钮的功能一样（请参阅下文）。

    • 2 跳转。与跳转按钮的功能一样（参见下文）。

    • Internet 选项。打开 Windows 和 Internet Explorer 的“Internet 选项”对话框。

    • 打印。与打印按钮的功能一样（参见上文）。

    • 搜索突出显示启用/禁用。启用和禁用与搜索选项卡一起使用的一项功能（参见上文）。当该功能启用时，如果您使用搜索选项卡查找帮助主题，则在从搜索选项卡打开任何主题时，将突出显示您搜索的词。

  • Seagull。打开 Seagull Scientific 的 Web 主页。

  • 跳转。打开一页，在此，您可以输入特定帮助主题的文件名，立即打开该主题。通常，此功能只在 Seagull Scientific 技术支持部门的指导下使用。

使用“搜索”选项卡

如果要查找有关 Commander 某个重要主题的所有相关内容，索引选项卡中可能会列出该词。如果在那里找不到它，或从逻辑上来说需要进行更复杂的搜索，可以使用搜索选项卡。

简单搜索

使用搜索选项卡的最简单方法是在选项卡顶部的文本框中键入所需词，然后单击列出主题。所有包含该词的主题都将显示在该选项卡上较大的文本框中。要打开其中任一主题，仅需单击它，然后单击显示，或双击该主题。

注意：那些包含该词的相近语法变化形式的主题也将列出。例如，如果搜索词为“water”，则除包含“water”的主题外,还将列出包含“watering”和“watered”的主题。不过，不会查找以“water”开头但实际并非单词“water”的语法变化形式的词，如“waterfall”。请参见下面的使用通配符搜索。

缩小搜索范围

要将搜索范围缩小到仅包含所有词的主题，仅需键入一个以上的单词并在词之间留空格。例如，要查找有关从标签格式中删除文本对象的主题，可以在文本框中输入“删除文本对象”（不加引号）。

扩大搜索范围

要将搜索范围扩大到包含两个词中任何一个（或三个或三个以上词中至少一个）的主题，必须在词与词之间输入逻辑字符“OR”（有时称作布尔值“OR”）。要输入布尔词，请单击文本框右侧的小按钮。按钮上有一个指向右侧的箭头。布尔词下拉列表随即展开。单击 OR。例如，如果要查看与删除有关的主题，但不清楚帮助中使用的词是“删除”还是“去除”，可以输入“删除 OR 去除”作为搜索词。这样，就会列出包含这两个词中任何一个的主题。

排除特定主题

要排除包含某些词的主题，请在搜索词后加上布尔词 NOT，并在其后面输入相关的词。例如，如果要查找所有提到数据库的主题，但不查找有关 SAP IDoc 的主题，可以使用“database NOT IDoc”作为搜索词。

使用密切相关的词获取主题

如果要查找包含两个（或更多）密切相关词的主题，可以在词之间加上布尔词 NEAR。例如，如果搜索“删除文本”，那么生成的列表中会包含只是碰巧有“删除”和“文本”两个词而并非真与删除文本有关的主题。但如果搜索“删除 NEAR 文本”，则生成的主题列表将缩短，所有主题都极可能至少与删除文本部分相关。

注意：要查找确切的多词短语，请将其用引号括起来。例如，在包括引号的情况下，使用 "删除文本" 将仅查找包含该确切短语的主题。这样找到的结果可能会太狭窄：例如，有些主题可能包含有关删除文本的信息，但其中没有与搜索短语完全一样的短语。

复杂布尔搜索

您可以在搜索术语中使用括号，将布尔表达式嵌套在其它布尔表达式中（最大深度可达五层）。例如，使用“文本 AND (删除 OR 去除)”将查找所有包含词“文本”且至少包含“删除”和“去除”两个词之一的主题。

注意：虽然 AND 是下拉列表中的一个布尔运算符，但该运算符并非完全必要。搜索功能会将词之间的空格解释为 AND。因此，“文本 (删除 OR 去除)”等价于“文本 AND (删除 OR 去除)”。

注意：如果您在搜索表达式中使用多个布尔运算符，但未使用括号，则搜索功能认为：除了第一个和最后一个搜索词之外，您希望在所有搜索词后添加右括号（在表达式的开头是一串左括号）。于是，“文本 AND 删除 OR 去除”将被解释为“(删除 AND 文本) OR 去除”，而“文本 AND 删除 OR 去除 NOT IDoc”则被解释为“((文本 AND 删除) OR 去除) NOT IDoc”。

使用通配符搜索

搜索时可以使用标准的 Windows 通配符“*”和“?”。“?”作为单个字符或数字的占位符。“*”表示一串字符和数字的占位符。搜索“water?”（不带引号）将找到包含“waters”的主题，而搜索“water*”（不带引号）将找到包含“waterfall”和“waterproof”的主题。

其它缩小或扩大搜索范围的方法

在搜索选项卡的底部有一些复选框，使用它们可以打开或关闭特定的搜索功能。

在上次结果中搜索。选中该选项后，每次搜索都将忽略那些在上次搜索中未找到的主题。

匹配相近的词。选中该选项后，搜索结果中将包含与搜索词相近的词的主题，即使主题中并不包含搜索词本身。

仅搜索标题。选中该选项后，将仅列出其标题与搜索表达式匹配的主题。


词汇表

DCOM

Distributed Common Object Model（分布式公共对象模型）的缩写。一个帮助 Windows 应用程序彼此相互进行交互的 Windows 协议。

ODBC

Open Data Base Connectivity（开放数据库互连）的缩写。一个用于在不同制造商开发的应用程序之间交换数据的协议。

SAP

“Systems, Applications, and Products in Data Processing”（数据处理过程中的系统、应用程序和产品）的缩写。此术语是德国 SAP Aktiengesellschaft 公司注册的商标。

UNC

“Universal Naming Convention”（通用命名约定）的缩写，一个命名网络上的资源的国际协议。

标签格式

标签的模板。

定界

使用某些指定为分隔符的字符来分隔文件中的不同数据项的过程。例如，在以逗号定界的名称文件中，各名称之间用逗号分隔（分界）。

格式

在 Seagull 文档中，当上下文表明此词的指“标签格式”时，它具有特殊的含义。请参见本词汇表中的“标签格式”。

脚本

一种极简短的软件程序，用于执行简单任务，运行时通常没有用户界面。请参见帮助主题“Commander 脚本”。

轮询

定期检查某些事件是否发生。

命令处理器

确保命令被执行的软件部分。请参见帮助主题“性能增强概述”。

命令行参数

在面向字符的用户界面中启动程序时为程序提供的少量信息。参数在命令行中输入，紧随启动程序的命令之后。例如，如果在命令行中输入了以下内容，则其中“bartend”为启动程序的命令，而“/PRNTYPE=laser”为命令行参数：“bartend /PRNTYPE=laser”

事件日志

Windows 2000/XP 计算机上记录错误、消息和其它来自各程序的事件的文件。

序列标签

依次递增每个标签上的编号而生成的一系列标签。按照这种方法生成的标签，编号都不相同，但每个编号都在指定的范围内。这一系列标签中的标签都不相同。


技术支持

本联机帮助系统提供的信息可解答大多数技术问题。如果在查阅本联机帮助之后依然存在问题，可随时通过以下电话号码和电子邮件地址与我们的技术支持部门联系：

区域 | 语音电话 | 传真 （通过传真发送的技术支持请求将以传真形式答复。） | Internet （通过 Internet 发送的技术支持请求将通过 Internet 答复。）
美国 | +1 425 641 1408 | +1 425 641 1599 | TechSupport@SeagullScientific.com
欧洲 | +34 91 435 55 45 | +34 91 578 05 06 | EuroTech@SeagullScientific.com
亚太地区 | +886 2 3765 2440 | +886 2 3765 2467 | AsiaTech@SeagullScientific.com

您必须注册您的软件才能获得支持

要获得技术支持，您必须自购买产品之日起十天内单击此链接在线注册您的产品。只有在注册之后，才能得到技术支持。

您必须在计算机旁边拨打电话

在通过电话请求技术支持时，一定要在运行 Commander 的计算机旁边拨打电话。这将使我们的技术人员更容易帮助您。

退货

如果您直接通过 Seagull Scientific, Inc. 购买了 Commander，之后觉得该产品不合用，则可以在购买之日起三十天内将其退回 Seagull。不过，您必须先通过上面提供的电话号码与我们的技术支持部门联系。届时，我们将发给您一个退货号码（Merchandise Authorization Number，RMA#）并提供我们的收货地址。

注意：如果您是通过其它渠道购买了 Commander，则退货条件可能有所不同。有关退货政策的信息，请与您的分销商联系。


主窗口

在 Commander 主窗口中，可以创建任务和任务列表。该窗口包括：

  • 主菜单。通过这些菜单可以使用 Commander 的所有功能。请参见本帮助的“菜单引用”部分。

  • 主工具栏。通过工具栏可以使用最常见的功能。

  • 任务列表网格。当前任务列表中所有任务的列表，包括以下各列：任务名称、触发器类型、上次运行时间、已经运行的次数和任务处理的当前状态。

  • 日志窗口。Commander 消息将显示在此窗口中。

另请参见：

了解 Commander


创建任务列表

创建或修改任务列表

创建或修改任务列表的步骤如下所示：

  1. 单击新建工具栏按钮或从文件菜单中选择新建，打开一个新的任务列表文件。如果要修改现有的任务列表，则单击打开按钮，或从文件菜单中选择打开，然后浏览到该任务列表文件并单击打开。

  2. 通过单击添加工具栏按钮，或从任务菜单中选择添加，可以开始一个新的任务定义。如果要编辑现有任务，突出显示该任务，然后单击属性工具栏按钮或从任务菜单中选择属性。

  3. 使用任务选项 对话框输入有关该任务的详细信息，并选择和配置触发此任务时将执行的命令。

  4. 单击确定保存该任务。

  5. 对于任务列表中所需的每项任务重复步骤 2-4。

  6. 突出显示某个任务，然后单击工具栏上的删除按钮，或从编辑菜单选择删除选项，或按一下键盘上的 DELETE 键，可以从列表中删除该任务。

  7. 根据需要，使用编辑菜单中的剪切、复制和粘贴菜单项对任务重新排序，或将任务从一个任务列表移到另一个任务列表。

  8. 单击文件菜单上的保存以保存任务列表。


定义任务

“任务选项”对话框

使用任务选项对话框可以定义任务的属性。（从任务菜单中选择添加或属性，或单击工具栏上的添加或属性按钮，可以打开该对话框。）

注意：如果 Commander 作为一项服务运行，则该对话框将仅在服务已配置为满足特定条件时才打开。

  • 名称字段。填写任务名称。

  • 触发器。确定触发器类型。

  • 触发器选项卡。用于设置触发器的属性以及 Commander 搜索触发器的方式。

  • 命令选项卡。用于定义触发任务时将执行的命令。

  • 重置为默认设置按钮。将这两个选项卡上的所有设置恢复为其默认值。


“触发器”选项卡

全部显示 全部隐藏

使用此选项卡可以设置任务触发器的属性。根据所设置的触发器类型不同，此选项卡上的可用选项也不同：

触发器类型为“文件”时…

如果触发器类型为“文件”，则此选项卡上包含以下选项：

  • 检测方法。用于选择检测方法：立即或轮询。如果选择“立即”，则当操作系统报告在扫描的目录中创建了一个新的触发器文件时，Commander 将立即进行响应。如果选择“轮询”，则 Commander 仅按设置的时间间隔检查是否存在触发器。

  • 轮询间隔。用于设置轮询的时间间隔（单位：毫秒）。

  • 要扫描的文件夹。用于输入 Commander 从中查找触发器文件的目录的完整路径。（单击此处查看是否必须使用完整的 UNC 路径。）

  • 要查找的文件。用于指定触发器文件的名称。可以使用标准的 Windows 通配符“*”和“?”。

  • 检测响应。用于指定 Commander 在找到触发器文件之后（但在开始执行任务之前）立即对该文件执行的操作。可以选择删除文件或重命名文件。

注意：仅当 BarTender 或任务调用的其它任何应用程序都不需要打开文件时，才删除此文件。（若要删除文件，文件不得设置为只读属性。）如果要保存文件（例如，BarTender 要使用该文件作为数据库），则可以重命名该文件，以使 Commander 不会多次对它进行响应。如果 Commander 发现具有新名称的文件已存在，则将在当前文件的名称后添加一个数字。例如，如果选择将文件重命名为 file.dat，而名为 file.dat 的文件已经存在，则 Commander 最终会将该文件重命名为 file(1).dat。

  • 新扩展名。如果在检测响应列表中选择了重命名文件，则这一选项用于指定该触发器文件的扩展名。

  • 锁定的文件超时。用于设置 Commander 试图打开它最初找到的、被其它应用程序锁定的触发器文件的时间。如果 Commander 在指定时间内无法打开文件，则将跳过该文件，并继续扫描以查找其它触发器文件。

  • File Encoding. Used to select the encoding of the trigger file. Your options are:

    • Unicode

    • Unicode (Big Endian)

    • UTF-8

    • 使用系统默认值

    • 阿拉伯语 (1256)

    • 波罗的语 (1257)

    • 中欧字符 (1250)

    • 简体中文 (GB-2312, 936)

    • 繁体中文 (Korea, Big 5, 950)

    • 西里尔字母 (1251)

    • 希腊语 (1253)

    • 希伯来语 (1255)

    • 韩语 (Hangul, 949)

    • 韩语 (Johab, 949)

    • 日语 (SHIFT-JIS, 932)

    • 泰语 (874)

    • 土耳其语 (1254)

    • 美国、西欧 (ANSI, 1252)

    • 越南语 (1258)

触发器类型为“电子邮件”时…

如果触发器类型为“电子邮件”，则此选项卡上包含以下选项：

  • 邮件系统。用于选择所使用的电子邮件系统的类型。单击设置按钮可以打开一个对话框，从中可以向 Commander 输入有关电子邮件系统的特定详细信息。

  • 检查间隔。用于指定 Commander 检查新电子邮件的频率。

  • 主题文本框。用于指定 Commander 应在电子邮件消息的主题行中查看的文本。可以使用标准的 Windows 通配符“*”和“?”。

  • 邮件到达时。用于指定 Commander 在处理电子邮件消息后，对该电子邮件消息执行的操作。

  • 转发给。如果在邮件到达时列表中选择了转发并删除电子邮件，则此选项用于指定 Commander 转发电子邮件消息的目标电子邮件地址。

  • 保存到文件。用于确保 Commander 将电子邮件消息保存到文件。复选框右侧的文本框用于设置路径和文件名。您可以键入路径，或单击浏览按钮以浏览到该路径。如果希望将数据从电子邮件消息传递到 BarTender，则必须启用此框。（有关如何将文件名和路径告知 BarTender 的详细信息，请参见 BarTender 的帮助。）还可以参见具有 Commander 变量 <触发器文件名> 的文件，并在 BarTender 命令行上使用该变量。例如，可以将变量用作 /D= 参数的值。（有关命令行参数的信息，请参见 BarTender 的帮助。）

注意：如果未启用此复选框，则 Commander 的特殊文件变量将为空。

  • Encode Save File As. Used to select the encoding of the file you are saving.

    • This setting is not used if the Save To File box is not checked.


“命令”选项卡

使用此选项卡可以定义触发任务时将执行的命令。

  • 命令类型下拉列表。用于选择每个命令的命令类型。可用的选项有：

  • BarTender。通过此命令类型可以控制 BarTender。

  • 操作系统。这一命令类型可以是通过从开始菜单中选择运行而直接向操作系统传递的任何命令行。

  • Commander 脚本。此选项指示 Commander，触发器自身包含所需命令的脚本。

  • 命令字段和“. . .”按钮。此字段的用途视命令类型不同而不同：

  • BarTender。命令字段包含 BarTender 命令参数。单击“. . .”按钮可以显示 BarTender 命令选项对话框，从中可以指定命令参数。

  • 操作系统。命令字段包含命令及其命令行参数（如果有）。单击“. . .”按钮可以打开操作系统命令选项对话框，从中可以输入命令行。

  • Commander 脚本。命令字段始终包含 Commander 变量 <触发器内容>。单击“. . .”按钮可以显示一个对话框，在此可以将脚本与 BarTender 命令处理器相关联。


“BarTender 命令选项”对话框

使用此对话框可以生成一系列 BarTender 命令参数，由于最大程度地减少了手动键入操作，因而可减少出错的机会。

添加参数时，命令参数窗口将显示命令，而且在所有选项卡上都可以看到该命令。

此对话框上有以下选项卡：

  • 格式

  • 打印

  • 文本文件

  • SAP R/3 IDoc

  • OLE DB / ODBC

  • 常规


“格式”选项卡

使用此选项卡可以添加 BarTender 命令参数，以指定 BarTender 应使用的格式和打印机。

  • 要使用的格式

若要指定特定格式，请单击文件并输入格式的路径和文件名。可以将每个路径和文件名用引号引起来，从而列出多个格式。例如，"c:\formats\ship.btw" "c:\formats\return.btw"。（单击此处查看是否必须使用完整的 UNC 路径。）

  • 要使用的打印机

如果希望 BarTender 使用特定打印机，而无论它是否为在格式中指定的打印机，则可单击系统打印机并从下拉列表中选择该打印机。


“打印”选项卡

使用此选项卡可以添加与打印相关的 BarTender 命令参数。

  • 打印复选框。如果希望在执行任务时 BarTender 打印一个或多个标签，则选中此框。

  • 同样标签的份数复选框。如果希望每个标签打印多份，则选中此框，并在框中输入份数。

  • 序列标签数复选框。如果希望 BarTender 打印一系列序列标签，则选中此框，并在框中输入数值。

  • 开始记录编号复选框。如果 BarTender 将从文件中读取数据，且您希望它从某个记录（第一个记录除外）开始，则选中此框并在框中输入编号。

  • 显示“打印”对话框复选框。如果希望 BarTender 暂停并显示打印对话框，以等待用户响应后再打印，则选中此框。

有关这些选项的详细意义，请参见 BarTender 联机帮助。


“文本文件”选项卡

使用此选项卡可以添加 BarTender 命令参数，以指示 BarTender 从已定界的文本文件中读取数据。

  • 使用文本文件复选框。如果希望 BarTender 从文本文件读取数据，则选中此框并在框中输入路径和文件名。（单击此处查看是否必须使用完整的 UNC 路径。）

注意：可以将要从中读取数据的文本文件用作触发器文件。为此，请在使用文本文件框中输入变量“<触发器文件名>”。（有关详细信息，请参见 Commander 变量。）

  • 完成后删除文件复选框。如果希望 BarTender 在读取文本文件后删除该文件，则选中此框。


“SAP R/3 IDoc”选项卡

使用此选项卡可以添加 BarTender 命令参数，以指示 BarTender 从 SAP R/3 IDoc 文件中读取数据。

  • SAP R/3 IDoc 文件复选框。如果希望 BarTender 从 IDoc 文件读取数据，则选中此框，并在框中输入路径和文件名。（单击此处查看是否必须使用完整的 UNC 路径。）

注意：可以将要从中读取数据的 IDoc 文件用作触发器文件。为此，请在使用文本文件框中输入变量“<触发器文件名>”。（有关详细信息，请参见 Commander 变量。）

  • 完成后删除文件复选框。如果希望 BarTender 在读取 IDoc 文件后删除该文件，则选中此框。


“OLE DB / ODBC”选项卡

使用此选项卡可以添加 BarTender 命令参数，以指定 OLE DB 或 ODBC 登录信息。

  • 用户名文本框。输入 OLE DB 或 ODBC 用户名。

  • 口令文本框。输入 OLE DB 或 ODBC 用户口令。口令在屏幕上将显示为一串星号。


“常规”选项卡

使用此选项卡可以向命令处理器分配任务，并添加无法在 Bartender 命令选项对话框的其它任何选项卡上添加的各种 BarTender 命令行参数。

  • 命令处理器下拉列表。选择所需处理器的名称。（如果您在配置特定命令处理器的过程中打开该对话框，由于您已经选择了要配置的命令处理器，因此，该列表将灰显。）

  • 设置按钮。单击此按钮可以设置或修改 BarTender 命令处理器。

  • 关闭格式复选框。如果希望在任务执行完毕后关闭在 BarTender 过程中打开的所有格式，则选中此框。这不会关闭在 BarTender 的其它正在运行的实例中打开的格式，包括在同一个命令处理器下运行的那些实例。

  • 保存格式复选框。如果希望在任务执行完毕后保存在 BarTender 过程中打开的所有格式，则选中此框。这不会保存在 BarTender 的其它正在运行的实例中打开的格式，包括在同一个命令处理器下运行的那些实例。

  • 其它命令参数文本框。输入在 Bartender 命令选项对话框的其它任何选项卡上无法添加的任何所需的命令参数。请参见 BarTender 联机帮助中的“命令行参数参考”。（如果在此处添加的任何参数包含路径，请单击此处查看是否必须使用完整的 UNC 路径。）


查看 BarTender 消息

如果直接运行 BarTender（而不通过 Commander），将不时地显示信息、警告或错误消息。如果希望在从 Commander 运行 BarTender 时查阅这些消息，首先必须将 BarTender 配置为将其消息记录到日志文件中，以供日后查看。有关详细信息，请参阅 BarTender 联机帮助中的“‘消息设置’对话框”。


操作系统命令选项

“操作系统命令选项”对话框

使用此对话框可以输入操作系统命令。命令的语法应准确无误，就像通过从 Windows 开始菜单中选择运行直接向操作系统传递命令时输入命令一样。

此功能可用于运行 Java、Visual Basic 脚本或批文件。还可以在操作系统命令行中使用 Commander 变量。例如，<触发器内容> 变量在任务执行时将被触发器文件的内容所替代。这些内容本身可以是一系列操作系统命令。

注意： 如果将 Commander 作为一项服务运行，则操作系统命令行中的所有路径可能必须使用完整 UNC 路径。有关详细信息，请单击此处。


Commander 脚本

Commander 脚本是 Commander 可以读取和执行的一组编写的指令。创建触发器的应用程序可以向触发器中添加脚本。这样，应用程序向 Commander 发出的指令将随触发器不同而不同，而不是在响应特定类型的每个触发器时执行完全相同的操作。Commander 脚本关键字所列如下。

%RUN%

%RUN% "<可执行文件的路径和文件名> [<命令行参数>]"

指示 Commander 运行可执行文件。在运行 BarTender 之外的其它程序时需要该关键字。命令行参数为可选项。

示例：

%RUN% "C:\WINNT\notepad.exe order.txt"

%BTW%

%BTW% <BarTender 命令行参数>

提示 Commander 后面的内容是 BarTender 命令行参数。不包括 BarTender 可执行文件的路径和名称。这些参数将发送到在 Commander 脚本命令选项对话框中设置的命令处理器。有关其它信息，请参见 BarTender 联机帮助中的“命令行参数”。

示例：

%BTW% /D="R:\Db\Text\ADDRESS.DAT" /FirstRecordFieldNames /DD

%MIN%

%MIN%

指示 Commander 以最小化模式运行 BarTender。

%END%

%END%

指示 Commander 该触发器中已没有其它命令行。当触发器中同时包含命令和输入文件数据时，需要该关键字。所有输入数据均必须位于 %END% 之后。

注意： 如果将 Commander 作为一项服务来运行，Commander 脚本中的所有路径可能必须使用完整 UNC 路径。有关详细信息，请单击此处。


Commander 脚本命令选项

使用此对话框可以确定应将 Commander 脚本的 %BTW% 命令发送到哪个 BarTender 命令处理器。

单击设置可以显示 BarTender 命令处理器设置对话框。


Commander 变量

Commander 允许在 BarTender、操作系统和 Commander 脚本命令行中使用变量。这些变量在执行任务时将被替换。

变量可用于以下任何位置：

  • 格式名称

  • 打印机名称

  • 文本文件名

  • IDoc 名称

  • ODBC 用户名

  • ODBC 口令

  • 其它命令参数（在 BarTender 命令选项对话框中的 常规选项卡上）

  • 在操作系统命令行中

注意：如果您不想变量被替换，请另外添加一组尖括号。例如，如果确实不想替换 <Time>，则使用 <<Time>>。处理后，<<Time>> 将替换为 <Time> 而不会替换为实际时间。

变量如下：

变量 | 定义
<Trigger Contents> | 将替换为触发器文件的内容，或者，如果使用电子邮件触发器，则替换为邮件的正文。该变量将先于任何其它变量进行计算，因此可以使用此触发器中的其它任何变量。 注意：在所有 Commander 脚本命令行中均自动使用该变量。
<Trigger File Name> | 将替换为触发器文件的完整路径和文件名。（另请参见以下注释。）
<Trigger Base File Name> | 将替换为触发器文件名，不包括其路径或扩展名。（另请参见下面的注释。）
<Trigger File Path> | 替换为触发器文件的路径。不包括文件名或扩展名。（另请参见下面的注释。）
<Time> | 将替换为触发任务的时间并采用 [h]h:mm:ss xM 的格式。（小时数字中不显示前面的 0）。
<Date> | 将替换为触发任务的日期并采用 [m]m/[d]d/yyyy 的格式。（月或天数字中不显示前面的 0）。
<E-mail Subject> | 将替换为电子邮件的整个主题行。（仅适用于电子邮件触发器。）

注意：如果使用电子邮件触发器，但没有选中任务选项对话框中触发器选项卡上的保存到文件选项，则变量 <Trigger File Name>、<Trigger Base File Name> 和 <Trigger File Path> 将替换为空白。


运行 Commander

运行 Commander 任务列表：

  1. 通过单击打开按钮或从文件菜单中选择打开，打开一个任务列表。

  2. 突出显示每项要执行的任务，并从任务菜单中选择启用，以启用相应的任务。

  3. 单击开始检测按钮或从工具菜单中选择开始检测，启动触发器检测。

将开始对所启用的任务的每个触发器同时进行监视。对于每项任务，Commander 将根据在任务选项对话框的触发器选项卡中的设置进行监视。


Commander 使用示例

将触发器用作数据库的示例

对于邮购公司而言，每次记录一份订单时，都需要打印一个包含相关销售记录数据的标签。销售应用程序将生成一个以逗号定界的文本文件，并将该文件保存到已设置 Commander 进行监视的目录中。Commander 检测该文件，并指示 BarTender 读取该文件和打印标签。以下是实施这一方案的步骤：

设置样本数据文件

  1. 选择用于保存触发器文件的目录。这就是 Commander 所要监视的目录。在本例中，该目录为 C:\Shipping\NewOrders。
  2. 创建或获取一个样本文件。在本例中，我们将在记事本中创建一个文件，文件名为 order.txt，其中包含一行以逗号定界的数据（如下所示）：

Around the Town,Jerome Davis,购买者,1220 Governor Sq.,Hadden,Alberta,WA1 1DP,加拿大,(171) 555-7788,(171) 555-6750

  3. 将样本文件保存到您在步骤 1 中选择的目录中。

设计标签格式

  1. 在 BarTender 中，从文件菜单中选择新建。与往常一样设计您的标签，选择打印机、卷等。有关详细信息，请参见 BarTender 帮助。
  2. 单击数据库设置按钮。
  3. 在数据库设置向导中，单击下一步。
  4. 选择文本文件，然后单击下一步。
  5. 输入所创建的样本文件的完整路径和文件名，然后单击下一步。
  6. 选择逗号作为定界类型，然后单击下一步。
  7. 当提示您输入有关文本文件标题信息时，选择否，然后单击完成以打开数据库设置对话框。
  8. 单击确定返回 BarTender 主屏幕。
  9. 在标签上创建一个文本对象，并双击该对象，打开修改所选条形码对象对话框。
  10. 单击数据源选项卡，并将来源下拉列表设置为数据库。
  11. 在使用字段下拉列表上，选择使用字段下拉列表中的“字段 2”，因为在此样本中，第二个字段包含购买者的姓名。
  12. 将“购买者姓名”作为样本数据输入，单击确定关闭该对话框。
  13. 如果还需要其它的文本对象，只需返回步骤 9，对应于每种情况，将对象分配到数据库中的相应字段。
  14. 选择文件菜单中的保存按钮，使用名称 NewOrderAddress.btw 保存该标签格式。
  15. 将样本数据库文件 orders.txt 从 Commander 要扫描的目录中移出。
  16. 关闭 BarTender。

创建 Commander 任务

  1. 在 Commander 中，从文件菜单中选择新建。
  2. 从任务菜单中选择添加，以打开任务选项对话框。
  3. 输入“每个订单”作为任务名称，然后从触发器下拉列表中选择文件。
  4. 单击触发器选项卡，并在要扫描的文件夹框中输入 Commander 将要监视的目录路径。该目录也就是您在上面设置样本数据文件的步骤 1 中所使用的目录。
  5. 在要查找的文件框中，输入“orders.txt”或只输入“*.txt”。（请勿输入引号。）
  6. 将检测响应设置为重命名文件，而非删除文件，原因在于，如果 Commander 删除了文件，BarTender 就无法将该文件用作它的数据库。
  7. 将新扩展名设置为“old”（不带引号）。该扩展名不能与在要查找的文件中指定的扩展名相同。
  8. 单击命令选项卡，并在命令类型列的第一行中，从下拉列表中选择 BarTender。
  9. 单击该行结尾处的 … 按钮，打开 BarTender 命令选项对话框。注意：在命令参数框中，最初只有一个 /P 参数。该参数指示 BarTender 进行打印。
  10. 单击格式选项卡，然后选择文件单选按钮。接着输入 NewOrderAddress.btw 的路径和文件名。请注意：命令参数框中已添加了一个 /AF= 参数，为 BarTender 标识应该打印的标签格式。
  11. 单击文本文件选项卡，启用文本文件复选框，但保留默认值：Commander 变量 <触发器文件名>。/D=<触发器文件名> 参数已添加到命令参数框中，指示 BarTender 应将此触发器文件用作其数据库。
  12. 启用完成后删除文件复选框，指示 BarTender 应在读取文件后将其删除。
  13. 在 BarTender 命令选项对话框中，单击确定。
  14. 在任务选项对话框中，单击确定。
  15. 在文件菜单中，选择保存，使用名称 NewOrderAddress.tl 保存该格式。

开始检测

  1. 从检测菜单中选择开始检测。
  2. 将样本文件 orders.txt 重新复制到 Commander 所监视的目录中。

    Commander 将执行以下操作：

    • 检测该文件，
    • 将其重命名为 orders.old，并且
    • 启动 BarTender。

    Bartender 将执行以下操作：

    • 打开 NewOrderAddress.btw，
    • 读取 orders.old 中的数据，
    • 打印标签，并且
    • 随后删除 orders.old。


Commander 使用示例 2

Commander 脚本使用示例

由于众多不同的用户通过网络输入发票数据，因此公司需要打印背涂粘胶的发票。每个用户对于共享驱动器均具有访问权限。但是，根据用户和要开票的产品不同，需要提供具有不同格式的发票。此外，不同的部门分别使用自己的打印机。

在这种情况下，开票应用程序可以针对每张发票创建一个文本文件，其中包含相关数据和指示 BarTender 执行以下操作的 Commander 脚本：

  • 打开特定发票的 *.btw 文件。

  • 使用触发器文件作为数据文件（从第 3 行开始），

  • 打印到特定的打印机，并且

  • 完成操作后删除触发器文件。

以下是实施这一方案的步骤：

设置样本数据文件

  1. 选择用于保存触发器文件的目录。这就是 Commander 所要监视的目录。在本例中，该目录为 C:\InvoiceServer\CommanderWatch。
  2. 对于每类发票，创建或获取一个样本文件，其中数据的组织方式和定界方式与真实的数据文件完全相同。在本例中，我们假定有两个部门需要打印发票。对于第一个部门，使用记事本创建一个文件并命名为 invoice1.txt，其中包含一行以逗号定界的数据（如下所示）。其中唯一的硬回车位于记录结尾处。

Around the Town,Jerome Davis,购买者,1220 Governor Sq.,Hadden,Alberta,WA1 1DP,加拿大,(171) 555-7788,(171) 555-6750

  3. 对于第二个部门，使用记事本创建一个文件并命名为 invoice2.txt，其中包含一行以引号和逗号定界的数据（如下所示）。其中唯一的硬回车位于记录结尾处。

"Far Fetched Imports","Jerry Bom","manager","3320 Happy St.","Incident","Washington","98887","USA","(444) 555-7788","(444) 555-6750"

  4. 将样本文件保存到您在步骤 1 中选择的目录下。

设计标签格式

  1. 在 BarTender 中，从文件菜单中选择新建。与往常一样设计您的标签，选择打印机、卷等。有关详细信息，请参见 BarTender 帮助。
  2. 单击数据库设置按钮。
  3. 在数据库设置向导中，单击下一步。
  4. 选择文本文件，然后单击下一步。
  5. 输入 invoice1.txt 的完整路径和文件名，然后单击下一步。
  6. 选择逗号作为定界类型，然后单击下一步。
  7. 当提示您输入有关文本文件标题信息时，选择否，然后单击完成以打开数据库设置对话框。
  8. 单击确定返回 BarTender 主屏幕。
  9. 在标签上创建一个文本对象，并双击该对象，打开修改所选条形码对象对话框。
  10. 单击数据源选项卡，并将来源下拉列表设置为数据库。
  11. 在使用字段下拉列表上，选择使用字段下拉列表中的“字段 2”，因为在此样本中，第二个字段包含购买者的姓名。
  12. 将“购买者姓名”作为样本数据输入，单击确定关闭该对话框。
  13. 如果还需要其它的文本对象，只需返回步骤 9，对应于每种情况，将对象分配到数据库中的相应字段。
  14. 选择文件菜单中的保存按钮，使用名称 HardwareInvoice.btw 保存该标签格式。
  15. 重复步骤 1 至 14。这次使用 invoice2.txt 作为数据库，将定界类型设置为引号和逗号，将标签格式另存为 SoftwareInvoice.btw。
  16. 将这两个样本数据库文件从 Commander 将要扫描的目录中移出。
  17. 关闭 BarTender。

创建 Commander 任务

  1. 在 Commander 中，从文件菜单中选择新建。
  2. 从任务菜单中选择添加，以打开任务选项对话框。
  3. 输入“发票”作为任务名称，然后在触发器下拉列表中选择文件。
  4. 单击触发器选项卡，并在要扫描的文件夹框中输入 Commander 将要监视的目录路径。该目录也就是您在上面设置样本数据文件的步骤 1 中所使用的目录。
  5. 在要查找的文件框中，输入“*.txt”。（请勿输入引号。）
  6. 将检测响应设置为重命名文件，而非删除文件，原因在于，如果 Commander 删除了文件，BarTender 就无法将该文件用作它的数据库。
  7. 将新扩展名设置为“old”（不带引号）。该扩展名不能与在要查找的文件中指定的扩展名相同。
  8. 单击命令选项卡，并在命令类型列的第一行中，从下拉列表中选择 Commander 脚本。
  9. 在任务选项对话框中，单击确定。
  10. 在文件菜单中，选择保存，使用名称 VariantInvoices.tl 保存该格式。

创建样本触发器文件

  1. 打开第一个样本数据库文件 invoice1.txt，在文件的开始部分添加以下两行。（唯一的硬回车应紧随“%END%”前后。）

%BTW% /AF=c:\command\command.btw /D=<触发器文件名> /PRN="EasyCoder F4 (203 dpi)" /R=3 /P /DD
%END%

因此，整个文件现在包含的内容如下：

BTW% /AF=c:\command\HardwareInvoice.btw /D=<触发器文件名> /PRN="EasyCoder F4 (203 dpi)" /R=3 /P /DD
%END%
Around the Town,Jerome Davis,Buyer,1220 Governor Sq.,Hadden,Alberta,WA1 1DP,Canada,(171) 555-7788,(171) 555-6750

“%BTW%”是一个 Commander 脚本命令，指示 Commander 启动 BarTender，并使用其后的字符串作为 BarTender 命令行。“%END%”指示 Commander 命令行已结束，后面的内容为数据。

当然，如果您的打印机的名称不同于 EasyCoder F4 (203 dpi)，则必须在命令行中替换为您的打印机名，并且必须将 c:\command\ 替换为保存 *.btw 文件的路径。（如果路径中存在空格，则必须使用引号将整个 /AF= 参数值引起来。）但是，不应将 <触发器文件名> 替换为 invoice1.txt。Commander 会将 <触发器文件名> 视为自己的变量，并自动将其替换为最新的触发器文件名，然后将参数传递给 BarTender。/R=3 指示 BarTender 将触发器文件中的第三行作为数据记录。/P 指示 BarTender 打印标签，而 /DD 指示它在读取触发器文件后删除该文件。

  2. 打开第二个样本数据库文件 invoice2.txt，并向文件的开始部分添加行，添加行后的文件如下所示。

%BTW% /AF=c:\command\SoftwareInvoice.btw /D=<触发器文件名> /PRN="Datamax 4400" /R=3 /P /DD
%END%
"Far Fetched Imports","Jerry Bom","manager","3320 Happy St.","Incident","Washington","98887","USA","(444) 555-7788","(444) 555-6750"

注意：本示例假定打印 SoftwareInvoice.btw 的打印机与打印 HardwareInvoice.btw 的打印机不同。如前一个样本触发器文件所示，应视需要更改此处显示的路径和打印机名。

开始检测

  1. 从检测菜单中选择开始检测。
  2. 将样本文件 invoice1.txt 重新复制到 Commander 所监视的目录中。

    Commander 将执行以下操作：

    • 检测该文件，
    • 将其重命名为 invoice1.old，并且
    • 启动 BarTender。

    Bartender 将执行以下操作：

    • 打开 HardwareInvoice.btw，
    • 读取 invoice1.old 中的数据，
    • 打印标签，并且
    • 随后删除 invoice1.old。

  3. 将样本文件 invoice2.txt 重新复制到 Commander 所监视的目录中。

    Commander 将执行以下操作：

    • 检测该文件，
    • 将其重命名为 invoice2.old，并且
    • 启动 BarTender。

    Bartender 将执行以下操作：

    • 打开 SoftwareInvoice.btw，
    • 读取 invoice2.old 中的数据，
    • 打印标签，并且
    • 随后删除 invoice2.old。

现在，您可以使用不同的开票应用程序自动在 Commander 所监视的目录中创建名为 *.txt 的文件。在本例中，文件的开始部分应当是 Commander 脚本和数据。每次在目录中创建了此类文件后，Bartender 都会将在触发器文件中指定的标签格式打印到在该文件中指定的打印机上。


Commander 作为服务概述

Commander 除了可作为应用程序运行之外，如果它安装在运行 Windows 2000、XP 或 2003 的计算机上，则还可以作为一项操作系统服务。与其它任何服务一样，可以在 Commander 应用程序内或通过操作系统的服务对话框来手动启动和停止运行该服务。此外，与其它服务一样，可以将其配置为随计算机引导和操作系统加载而自动启动。对于后一项配置，任何用户均无需登录计算机。

如果 Commander 作为服务运行，则可以关闭用户界面，而不会停止该服务。

可以通过 Windows 服务对话框来配置Commander 服务。


启动 Commander 服务

若要启动 Commander 服务，请执行以下操作：

  • 自动，加载操作系统时：

使用 Windows 服务对话框将该服务的启动类型设置为自动。

  • 手动，使用 Windows 服务对话框：

在 Windows 2000 和 2003 中

注意：如果 Windows 2003 的界面已配置为使用 Windows XP 风格，请使用以下针对 Windows XP 的说明。

打开开始菜单，依次选择设置、控制面板、管理工具和服务图标。突出显示 Commander 服务，然后单击工具栏上的 [image] 按钮。

在 Windows XP 中

注意：如果开始菜单已更改为“经典开始菜单”，则使用上文中有关 Windows 2000 的说明。

打开开始菜单，选择控制面板，然后选择性能和维护。打开管理工具，然后打开服务图标。突出显示 Commander 服务，然后单击工具栏上的 [image] 按钮。

注意：启动服务和启动检测在逻辑上是截然不同的。如果服务的检测启动选项设置为停止，则启动服务不会导致 Commander 实际执行任何操作。同样，如果将检测启动选项设置为启动，也并不表示加载操作系统时 Commander 将立即开始检测：还必须将启动类型设置为自动。


停止或禁用 Commander 服务

停止 Commander 服务

可以采用多种方式停止 Commander 服务：

在 Windows 2000 和 2003 中

注意：如果 Windows 2003 的界面已配置为使用 Windows XP 风格，请使用以下针对 Windows XP 的说明。

打开开始菜单，选择设置，选择控制面板、管理工具，然后选择服务图标。突出显示 Commander 服务，然后单击工具栏上的 [image] 按钮。

在 Windows XP 中

注意：如果开始菜单已更改为“经典开始菜单”，则使用上文中有关 Windows 2000 的说明。

打开开始菜单，选择控制面板，然后选择性能和维护。打开管理工具，然后打开服务图标。突出显示 Commander 服务，然后单击工具栏上的 [image] 按钮。


禁用和重新启用 Commander 服务

禁用该服务将停止该服务，并防止任何应用程序重新启动该服务。必须用户介入才能更改禁用状态。

可以采用多种方式禁用 Commander 服务。

在 Windows 2000/2003 中：

注意：如果 Windows 2003 Server 的界面已配置为 Windows XP 风格，请使用下文有关 Windows XP 的说明。

打开开始菜单，选择设置，选择控制面板、管理工具，然后选择服务图标。双击 Commander 服务，单击常规选项卡，将启动类型设置为已禁用。

在 Windows XP 中

注意：如果开始菜单已更改为“经典开始菜单”，则使用上文中有关 Windows 2000 的说明。

打开开始菜单，选择控制面板，然后选择性能和维护。打开管理工具，然后打开服务图标。双击 Commander 服务，单击常规选项卡，将启动类型设置为已禁用。

通过使用上面的方式将启动类型重新设置为自动或手动，可以重新启用此服务。


Commander 服务对磁盘和网络打印机的访问权限

当 Commander 作为一项服务运行，并且没有用户登录时，在默认情况下，Commander 将在“系统”帐户下运行。系统帐户存在一定限制，无法访问其他用户帐户可用的资源。

网络打印机

系统帐户不具备访问网络打印机的权限。若要访问网络打印机，必须指定其它帐户来运行 Commander ，并且这一帐户必须具有访问网络打印机的权限。

此外，必须使用以下步骤将网络打印机安装为本地打印机。

  1. 打开开始菜单，选择设置，然后选择打印机。双击添加打印机以启动“添加打印机向导”。（有关使用该向导的详细信息，请参见 Windows 文档。）

  2. 当向导提示您选择本地或网络打印机时，请选择本地。

  3. 当向导提示您选择端口时，请单击创建新端口，然后从下拉列表中选择 Local Port。

  4. 当提示输入端口名称时，请输入 \\<服务器名>\<打印机共享名>。

Note: You must use a Universal Naming Convention (UNC) path. Do not use mapped drive letters.

文件夹写权限

在监视文件时，Commander 需要拥有所要监视的文件夹的写权限。系统帐户可能不具备写权限，具体取决于该文件夹的安全设置。若要解决这一问题，您可以更改文件夹的安全设置，也可以指定对该文件夹具有写权限的其它帐户来运行 Commander。

另请参见：

为 Commander 服务指定用户帐户


为 Commander 服务指定用户帐户

注意：本主题介绍如何配置 Commander 服务使用默认帐户（本地系统帐户）之外的其它帐户。其目的是为了限制在 Commander 运行时能够进行的配置更改类型。有关详细信息，请单击此处。

若要为 Commander 指定用户帐户，请执行以下操作：

  1. 创建用户帐户，如“CommanderService”，并将用户口令设置为“永不过期”。

  2.

    1. 打开开始菜单，依次选择设置、控制面板、管理工具和本地安全策略图标。
    2. 在本地安全设置对话框中，依次双击本地策略和用户权利指派。
    3. 在策略列表中双击作为服务登录，然后在本地安全策略设置对话框中单击添加用户或组。
    4. 浏览并突出显示在第 1 步中创建的用户，单击添加，然后单击确定。在本地安全策略设置对话框中再次单击确定。

  3. 配置 Commander 服务，以作为在第 1 步中创建的用户进行登录：

在 Windows 2000 和 2003 中

注意：如果 Windows 2003 的界面已配置为使用 Windows XP 风格，请使用以下针对 Windows XP 的说明。

打开开始菜单，选择设置，选择控制面板、管理工具，然后选择服务图标。双击 Commander 服务，单击登录选项卡。单击此帐户。输入在第 1 步中创建的用户及为该用户指定的口令。

在 Windows XP 中

注意：如果开始菜单已更改为“经典开始菜单”，则使用上文中有关 Windows 2000 的说明。

打开开始菜单，依次选择控制面板、性能和维护、管理工具和服务图标。双击 Commander 服务，单击登录选项卡。单击此帐户。输入在第 1 步中创建的用户及为该用户指定的口令。


使用 Windows“服务”对话框控制服务

通过 Windows 操作系统控制服务

使用 Windows 服务对话框可以执行以下操作：

  • 启动和停止 Commander 服务。

  • 可以配置服务的启动状态。

  • 可以确定服务响应失败的方式。

  • 可以配置服务使用网络打印机。

有关打开和使用此对话框的说明，请单击下面相应操作系统的名称。

  • Windows 2000 和 2003

  • Windows XP


Windows 2000“服务”对话框

在 Windows 2000/2003 中运行 Commander 服务

注意：如果 Windows 2003 Server 的界面已配置为 Windows XP 风格，请使用 Windows XP 的说明。（如果已配置为使用“经典开始菜单”，则下面的说明也适用于 Windows XP。）

若要在 Windows 2000/2003 中显示服务对话框，请打开开始菜单，选择设置，然后选择控制面板。双击管理工具图标，然后双击服务图标。

双击服务列表中的 Commander 服务，打开 Commander 服务属性对话框。其中包含以下选项卡：

常规

登录

恢复

依存关系


Windows XP“服务”对话框

在 Windows XP 中运行 Commander 服务

注意：如果 Windows XP 已配置为使用“经典开始菜单”，请使用适用于 Windows 2000 的相关说明。（如果已配置为使用 Windows XP 风格的界面，则下面的说明也适用于 Windows 2003。）

在 Windows XP 中显示服务对话框：

打开开始菜单，选择控制面板，然后选择性能和维护。双击管理工具图标，然后双击服务图标。

双击服务列表中的 Commander 服务，打开 Commander 服务属性对话框。其中包含以下选项卡：

常规

登录

恢复

依存关系


增强性能概述

通过运行 BarTender 的多个实例（也称作进程），且每个实例同时执行不同的任务，可以提高 Commander 运行 BarTender 命令的速度。此外，可以使用不同的命令参数集来启动 BarTender 的不同实例，这样，您就可以将每个任务分配给命令行参数最适合于该任务的 BarTender 实例。例如，可以让 BarTender 的一个实例预先加载某项任务稍后将打印的指定格式。还可以分配很少触发的任务来启动 BarTender 的某个实例，然后在任务完成后立即关闭实例。

任务中的每个命令都可以指定一个命令处理器执行该任务。命令处理器的主要职责是预先加载格式。如果某个特定命令处理器负担过重，则可以为其分配多个 BarTender 进程。

对于每个命令处理器，可以执行以下操作：

  • 设置它将启动的 BarTender 进程数。

  • 设置 BarTender 启动时间。

  • 预先加载格式并使用其它命令行参数。

  • 确定 BarTender 在桌面上是否可见。

示例：

公司有一个名为“Standard”的命令处理器，该处理器使用五个 BarTender 实例，每个实例均采用以下命令行参数：使实例打开一个适用于所有新装运方式的标签格式，并登录到 ODBC 数据库。公司的第二个命令处理器名为“RepairReturns”，该处理器使用一个 BarTender 实例，其命令行参数使 BarTender 打开一个标签格式（该标签格式用在向货主发运已修好产品的包装上）。最后，第三个命令处理器名为“Refunds”，该处理器定义为启动一个 BarTender 实例，打印信封，然后立即关闭该实例。该处理器被分配给一个一周仅触发数次的任务。

可以使用 BarTender 命令处理器设置对话框来配置这些命令处理器。从工具菜单中选择 BarTender 命令处理器设置，可以打开该对话框。


“BarTender 命令处理器设置”对话框

全部显示 全部隐藏

使用此对话框（从检测菜单中打开）可以配置 BarTender 命令处理器。

注意：如果 Commander 作为一项服务运行，则该对话框将仅在服务已配置为满足特定条件时才打开。

处理器列表

该框包含 BarTender 所有命令处理器的列表。此框下面的工具栏包含以下按钮：

  • 新建。用于在列表中添加新的命令处理器。

  • 删除。用于从列表中删除命令处理器（不能撤消）。

  • 剪切。用于将命令处理器移动到剪贴板。

  • 复制。用于将命令处理器复制到剪贴板。

  • 粘贴。用于将命令处理器从剪贴板粘贴至列表中。

  • 上箭头。用于在列表中上移突出显示的命令处理器。

  • 下箭头。用于在列表中下移突出显示的命令处理器。

有关每个选项卡上的各个项的详细信息，请单击选项卡名称：

“常规”选项卡

常规选项

  • 名称。用于输入/编辑处理器的名称。

  • 持续时间。选择检测开始，直至检测停止，可让由此处理器创建的 BarTender 实例在不执行任务时仍然保持运行状态。选择单个命令，可让由此处理器创建的任何 BarTender 实例在完成打开实例的任务后立即退出。

  • 进程数。输入与此处理器关联的 BarTender 实例的数量。

  • 启动命令。用于组合当启动与此处理器关联的 BarTender 的每个实例时要使用的命令行参数。单击字段结尾处的“. . .”按钮可以打开 BarTender 命令选项对话框。

  • 可见。如果希望与此处理器关联的 BarTender 实例在 Windows 桌面上可见，则选中此框。

“登录”选项卡

此选项卡仅限于 Windows 2000、XP 和 2003 平台，可用于指定当此命令处理器启动 BarTender 时应使用的特定 Windows 用户帐户。如果运行 Commander 的用户不具备 BarTender 执行任务所需的所有网络权限或系统权限，则此选项将很有用。例如，如果将 Commander 作为一项服务运行，而默认情况下它运行于本地系统帐户下，则该帐户可能无权访问所需的网络目录和打印机。

单击使用帐户运行 BarTender 可以打开此功能。

登录设置

  • 用户

    • 。输入 Windows 用户名。

  • 口令。输入用户的口令。

  • 域。输入用户帐户的域名。

注意：您还必须配置 Windows DCOM，以使 Commander 能够在此对话框中所用的用户名下运行 BarTender。有关详细信息，请单击此处。


“消息设置”对话框

全部显示 全部隐藏

使用此对话框可以配置 Commander 处理信息、警告和错误消息的方式。

此对话框上有两个选项卡：单击恢复为默认设置按钮可将这两个选项卡上的设置恢复为默认值。更改将立即显示，但只有在单击确定按钮后才会实际生效。如果按恢复为默认设置后单击取消，则不会恢复为默认设置。

“消息”选项卡

使用此选项卡可以确定将要显示或记录的消息，以及应用程序响应这些消息的方式。

  • 顶部的网格通过以下各列列出了应用程序中可以显示的消息：

  • #。消息的唯一 ID 号。

  • 严重级别。消息的严重级别，从提示信息、警告到错误依次递增。

  • 类型。标识消息的类别。（例如打印机、数据库）

  • 对消息的默认响应。应用程序在自动模式下运行时如何响应消息的当前设置。

  • 消息目标。显示消息的位置。

  • 消息内容窗口。显示当前突出显示的消息的内容。

  • 消息目标。选择显示消息的位置：

  • 对话框：消息将显示在屏幕上。

  • 日志文件：（仅适用于已在日志文件选项卡上启用消息记录的情况。）消息将显示在日志文件中。

  • 2000/XP/2003 事件日志：消息将被发送到操作系统的事件日志。

  • 对消息的默认响应。有些消息要求获得响应（例如单击确定或取消），因此，如果不能向用户显示消息供其选择响应方式（例如，对话框已经关闭），则应用程序就必须自动进行响应。这里显示对当前突出显示的消息的可能响应。选择您希望应用程序始终自动做出的响应。

“日志文件”选项卡

使用此选项卡可以配置将消息记录到文件中的方式。选择启用日志记录可以激活此选项卡的功能。

  • 日志文件文件夹。输入保存日志文件的目录。

  • 组织。选择有关如何创建和命名日志文件的选项：

  • 一个文件。应用程序将所有消息都记录到同一个文件中。

  • 按日期。应用程序将按当前日期命名日志文件，并且每天都使用一个新的日志文件。

  • 输出类型。选择日志文件的格式：

  • 制表符定界。使用制表符分隔所记录的消息。

  • 逗号定界。使用逗号分隔所记录的消息。

  • 引号和逗号定界。将所记录的消息用引号括起来并使用逗号分隔。

  • Encoding. Select the encoding to use for the log files. Your options are:

    • Unicode

    • Unicode (Big Endian)

    • UTF-8

    • 使用系统默认值

    • 阿拉伯语 (1256)

    • 波罗的语 (1257)

    • 中欧字符 (1250)

    • 简体中文 (GB-2312, 936)

    • 繁体中文 (Korea, Big 5, 950)

    • 西里尔字母 (1251)

    • 希腊语 (1253)

    • 希伯来语 (1255)

    • 韩语 (Hangul, 949)

    • 韩语 (Johab, 949)

    • 日语 (SHIFT-JIS, 932)

    • 泰语 (874)

    • 土耳其语 (1254)

    • 美国、西欧 (ANSI, 1252)

    • 越南语 (1258)

  • 日志文件按钮：

  • 查看。单击可浏览到日志文件。

  • 查看最后一项。单击可打开最新的日志文件。

  • 全部删除。单击可删除所有日志文件。

“电子邮件”选项卡

使用此选项卡可以指定 Commander 消息的电子邮件副本的接收者和通过电子邮件发送的消息的结构。

单击启用电子邮件可以激活此选项卡的功能。

  • 邮件系统。此框标识 Commander 在发送电子邮件时要使用的邮件/邮件传送系统。除非在此框中更改为其它系统，否则将使用当前登录到该计算机上的用户的默认邮件系统。单击设置可配置将要使用的电子邮件配置文件的详细信息。

    • 如果已选择 Internet Mail (SMTP) 作为邮件/邮件传送系统，则单击设置后，将打开 Internet 邮件设置对话框。

    • 如果选择 Windows Messaging (MAPI) 作为邮件/邮件传送系统，则单击设置后，将打开 Windows Messaging 设置对话框。

  • 收件人。如果使用的是 Internet Mail (SMTP)，请键入一个或多个主要收件人地址（以分号分隔）。如果使用的是 Windows Messaging (MAPI)，请单击选择按钮打开电子邮件地址簿，然后选择收件人。

  • 抄送。如果使用的是 Internet Mail (SMTP)，请键入一个或多个次要收件人地址（以分号分隔）。如果使用的是 Windows Messaging (MAPI)，请单击选择按钮打开电子邮件地址簿，然后选择收件人。

  • 输出类型。从下拉列表中选择要发送的消息文件的格式。可用的选项有：

    • 文本报告。邮件的各个部分将按以下顺序单行显示：日期、时间、邮件编号、邮件类型、邮件类别、邮件响应和邮件正文。

    • 制表符定界。使用制表符分隔邮件的各个部分。

    • 逗号定界。使用逗号分隔邮件的各个部分。

    • 引号和逗号定界。将邮件的各个部分用引号括起来并使用逗号分隔。

单击发送测试邮件按钮可以测试邮件是否抵达正确的收件人，以及是否按所选的输出格式结构化。


任务日志设置

使用此对话框（从工具菜单中打开）可以配置 Commander 活动的日志记录设置。

注意：如果 Commander 作为一项服务运行，则该对话框将仅在服务已配置为满足特定条件时才打开。

  • 记录到文件复选框。如果选中此框，则可以打开日志记录功能并输入日志文件的路径和文件名。（单击此处查看是否必须使用完整的 UNC 路径。）

  • Encoding. Select the character set of the text file if it is different from the default. For example, you might need to do this if you are using a language other than the default for your version of Windows. Your options are

  • Unicode

  • Unicode (Big Endian)

  • UTF-8

  • 使用系统默认值

  • 阿拉伯语 (1256)

  • 波罗的语 (1257)

  • 中欧字符 (1250)

  • 简体中文 (GB-2312, 936)

  • 繁体中文 (Korea, Big 5, 950)

  • 西里尔字母 (1251)

  • 希腊语 (1253)

  • 希伯来语 (1255)

  • 韩语 (Hangul, 949)

  • 韩语 (Johab, 949)

  • 日语 (SHIFT-JIS, 932)

  • 泰语 (874)

  • 土耳其语 (1254)

  • 美国、西欧 (ANSI, 1252)

  • 越南语 (1258)

  • 任务名称复选框。如果希望日志中包括任务名称，则选中此框。

  • 执行时间/日期复选框。如果希望日志中包括每个任务执行的日期和时间，则选中此框。

  • 采取的操作复选框。如果希望日志包括所采取的操作，则选中此框。

  • 错误复选框。如果希望记录全部错误，则选中此框。


常规选项

全部显示 全部隐藏

使用此对话框可以设置有关 Commander 的语言、启动状态、最小化图标位置以及是作为服务还是作为应用程序运行的各项首选设置。有关每个选项卡的详细信息，请单击其名称：

常规

  • 语言下拉列表。选择希望 Commander 在其菜单和对话框中使用的语言。

  • 最小化位置。设置 Commander 图标最小化的所在位置，可位于任务栏或系统任务栏上。

启动

  • 任务列表。配置 Commander 使用新的空白任务列表、指定任务列表或最近使用的任务列表启动。

  • 名称。如果在任务列表下拉列表中选择了打开指定的任务列表，则输入该任务列表的路径和名称。（单击此处查看是否必须使用完整的 UNC 路径。）

  • 检测。配置 Commander 启动时打开检测、关闭检测或沿用 Commander 上次关闭时的状态。

  • 窗口状态。配置 Commander 启动时最小化或采用上次关闭时的状态。

服务

  • 运行方式。选择 Commander 是作为服务还是作为应用程序运行。

  • 启动类型。选择 Commander 服务的启动类型。


“管理设置”对话框

使用此对话框可以标识和编辑所需的消息文件，并设置任务列表目录的路径。

若要标识文件，请突出显示该文件，单击选择位置，然后浏览至文件。

若要编辑文件，请突出显示该文件，然后单击编辑类型。

若要返回到默认设置，请单击重置为默认设置。

另请参见：

“消息设置”对话框


使用命令行参数启动 Commander

可以将 Commander 应用程序或服务配置为启动时自动打开检测功能和特定的任务列表。

命令行的语法是：

cmdr.exe [参数] [<Task_List_Path_&_Filename>]

可用参数有：

/START

立即开始检测。不区分大小写。

/MIN[=TaskBar|SystemTray]

启动时将用户界面最小化到任务栏或系统任务栏上。或者，指定运行时是否将用户界面最小化到任务栏或系统任务栏上。

/MAX

Commander 运行时保持最大化状态。

/NOSPLASH

使 Commander 启动时不显示其启动屏幕。

<Task_List_Path_&_Filename>

让 Commander 立即打开指定的任务列表。

示例：

cmdr.exe /START C:\Commander\tasks.tl

（单击此处查看是否必须使用完整的 UNC 路径。）


Commander 工具栏

Commander 工具栏上包括以下按钮。有关详细信息，请单击按钮名称或下图上的任何按钮。通过从视图菜单中选择工具栏，可以隐藏或取消隐藏工具栏。

新建

打开

保存

删除

剪切

复制

粘贴

开始检测

停止检测

添加

属性

运行 BarTender


新建

使用新建菜单项和新建按钮，可以开始空白任务列表。


打开

使用打开菜单项和打开按钮，可以显示一个对话框，从中可以打开现有的任务列表。


保存

使用保存菜单项和保存按钮可以保存当前任务列表。

注意：如果是第一次保存某个任务列表，则将打开另存为对话框。


另存为

使用另存为菜单项可以打开一个对话框，从中可以更改任务列表的名称和指定保存位置。


最近使用过的文件

最近打开的任务列表的列表。单击其中的任何文件可以重新打开。


退出

单击该项可退出 Commander。系统将提示您是否保存对当前任务列表所做的更改。


剪切

使用剪切菜单项和剪切按钮，可以将任务从任务列表移到剪贴板上。


复制

使用复制菜单项和复制按钮，可以将任务从任务列表复制到剪贴板上。


粘贴

使用粘贴菜单项和粘贴按钮，可以将任务从剪贴板复制到当前的任务列表。


删除

使用删除菜单项和工具栏上的删除按钮（以及键盘上的 DELETE 键），可以从任务列表中删除当前突出显示的任务。


工具栏

隐藏和显示 Commander 工具栏。


状态栏

隐藏和显示 Commander 状态栏。


启用

启用当前突出显示的任务。


添加

使用添加菜单项和添加按钮可以打开任务选项对话框，从中可以为当前任务列表创建新任务。

注意：如果 Commander 作为一项服务运行，则该对话框将仅在服务已配置为满足特定条件时才打开。


属性

使用属性菜单项和属性按钮，可以打开任务选项对话框，从中可以修改当前突出显示的任务的属性。

注意：如果 Commander 作为一项服务运行，则该对话框将仅在服务已配置为满足特定条件时才打开。


开始检测

使用开始检测菜单项和开始检测按钮，可以促使 Commander 开始检测触发器。


停止检测

使用停止检测菜单项和停止检测按钮，可以促使 Commander 停止检测触发器。


BarTender 命令处理器设置

打开 BarTender 命令处理器设置对话框。

注意：如果 Commander 作为一项服务运行，则该对话框将仅在服务已配置为满足特定条件时才打开。


显示所有正在运行的 BarTender

在桌面上显示所有正在运行的 BarTender 实例。

另请参见：

BarTender 性能增强


隐藏所有正在运行的 BarTender

隐藏所有正在运行的 BarTender 实例。

另请参见：

BarTender 性能增强

显示所有正在运行的 BarTender


BarTender

运行 BarTender

使用运行 BarTender 菜单项和运行 BarTender 按钮可以启动 BarTender。


消息设置

打开消息设置对话框。


“任务日志设置”菜单项

任务日志设置

打开任务日志设置对话框。

注意：如果 Commander 作为一项服务运行，则该对话框将仅在服务已配置为满足特定条件时才打开。


“常规选项”菜单项

常规选项

打开常规选项对话框。


管理设置

显示管理设置对话框。


帮助主题

打开 Commander 联机帮助。


技术支持菜单项

技术支持

使用技术支持可以打开 BarTender 联机帮助，其中提供有关如何获取技术支持的主题。


在线注册

通过在线注册，可以访问 Seagull 的 Web 站点，在此可以注册新的 BarTender。


万维网上的 Seagull

通过万维网上的 Seagull，可以访问 Seagull 的 Web 站点，在此可以找到有关 BarTender 的信息，并下载其它打印机驱动程序。


激活此软件

激活此软件或激活向导

使用这些命令可以启动激活向导。如果之前从未激活过软件，此命令为激活此软件。否则，此命令为激活向导。


激活帮助

使用激活帮助可以打开有关软件激活的常见问题解答。


关于 Commander

打开一个显示 Commander 版本信息的窗口。


在 Windows 中访问 BarTender

在 Windows 中向 Commander 授予访问 BarTender 的权限

如果希望 Commander 在运行 BarTender 时使用的用户帐户与 Commander 自身使用的用户帐户不同，则必须在 BarTender 命令处理器设置对话框的登录选项卡中对 Commander 进行相应的配置，同时还必须使用以下步骤对配置 Windows DCOM：

在 Windows 2000 中

1. 打开开始菜单，然后选择运行。

2. 输入 dcomcnfg，然后单击确定。

3. 在打开的对话框中，单击应用程序选项卡，然后双击 BarTender 格式。

4. 在 BarTender 格式属性对话框中，单击安全性选项卡。

5. 启用使用自定义访问权限，然后单击编辑按钮。

6. 在访问权限对话框中，单击“添加”，添加 Commander 运行 BarTender 时应使用的用户或组。

7. 然后，以相反顺序依次单击每个对话框中的确定，然后重新启动计算机。

在 Windows XP/2003 中

1. 打开开始菜单，选择控制面板，然后选择性能和维护。（如果计算机使用“经典开始菜单”，则打开开始菜单，选择设置，然后选择控制面板。）

2. 双击管理工具，然后双击组件服务。

3. 在组件服务对话框中，双击组件服务图标，然后依次双击计算机、我的电脑以及 DCOM Config。

4. 右键单击 BarTender 格式后，选择属性。

5. 在 BarTender 格式属性对话框中，单击安全性选项卡。

6. 启用访问权限部分的自定义，然后单击编辑按钮。

7. 在访问权限对话框中，单击添加，添加 Commander 运行 BarTender 时应使用的用户或组。

8. 单击确定两次退出对话框，然后关闭组件服务和管理工具对话框。

9. 重新启动计算机。


Commander 服务属性：“依存关系”选项卡

使用此选项卡可以查看 Commander 服务所依赖的各项服务。有关详细信息，请参见 Windows 2000/XP/2003 文档。


Commander 服务属性：“常规”选项卡

使用此选项卡可以启动、停止、暂停和继续该服务，以及设置其启动类型和启动参数。

  • 显示名称和描述文本框。根据需要进行更改。

  • 启动类型。设置 Commander 服务的启动类型，然后单击应用。

  • 根据需要，使用启动和停止按钮。（如果将启动类型设置为已禁用，则将禁用上述按钮。)运行 Commander 时，不能使用暂停和继续按钮。

  • 启动参数。将此框留空。Commander 不使用任何启动参数。


Commander 服务属性：“登录”选项卡

使用此选项卡可以确定该服务是只登录到计算机，还是要登录到网络。若要向该服务授予访问网络打印机的权限，则要求服务登录到网络。

若要使用非默认本地系统帐户的其它帐户，请单击此帐户，然后在所显示的框中输入用户名（如“CommanderService”）和口令（两次）。该帐户应当拥有 Commander 服务所需的访问所有网络打印机的权限。

注意：如果不使用默认的本地系统帐户，则当您在运行 Commander 的过程中需要更改配置时，将受到某些限制。有关详细信息，请单击此处。

在硬件配置文件列表中，至少必须对于一个配置文件启用此服务。


Commander 服务属性：“恢复”选项卡

使用此选项卡可以确定 Commander 服务响应失败的方式。有关详细信息，请参见 Windows 2000/XP/2003 文档。


连接到 Commander 服务

如果该项的当前状态未设置为已禁用，则启动 Commander 服务。


“Internet 邮件设置（用于电子邮件触发器）”对话框

全部显示 全部隐藏

注意：使用此对话框可以对 Internet 邮件系统进行设置，以便向 Commander 发送电子邮件触发器。这一对话框并不用来为 Commander 处理消息而设置 Internet 邮件系统。对于后一个主题，请参见“Internet 邮件设置（用于消息处理）”对话框。

单击任务选项对话框的触发器选项卡上的设置按钮可以打开此对话框。（仅当指定“电子邮件”作为触发器类型时才显示该按钮。）

此对话框上包含以下选项卡：

接收 (POP3)

  • 邮件服务器。用于指定接收邮件服务器的名称（如 mail.mycompany.com）。

  • 用户名。用于指定 Commander 应该用来接收电子邮件触发器的邮件系统用户名。

  • 口令。用于指定用户的口令。

发送 (SMTP)

  • 邮件服务器。用于指定发送邮件服务器的名称（如 smtp.mycompany.com）。

  • 要求身份验证。如果发送邮件服务器要求登录，则选中此框以启用登录设置。

  • 使用接收的 (POP3) 设置。选择此选项后，可以使用在接收 (POP3) 选项卡上使用的相同登录设置。

  • 指定登录设置。如果 Commander 转发电子邮件时使用的用户名不同于接收电子邮件时使用的用户名，则选择此选项。

  • 用户。用于指定 Commander 应该用来转发电子邮件消息的邮件系统用户名。

  • 口令。用于指定用户的口令。

高级

  • TCP/IP 通信端口。键入接收邮件服务器和发送邮件服务器所用的端口号。

  • 超时。设置应用程序在断定无法连接到邮件服务器之前，尝试发送电子邮件的时间。

单击测试按钮可确保应用程序能够与邮件服务器通信。


“Internet 邮件设置（用于消息处理）”对话框

注意：使用此对话框可以设置 Internet 邮件系统以处理消息。此对话框并不用于设置 Internet 邮件系统来向 Commander 发送电子邮件触发器。对于后一个主题，请参见“Internet 邮件设置（用于电子邮件触发器）”对话框。

如果选择 Internet Mail (SMTP) 作为邮件系统并单击消息设置对话框的电子邮件选项卡上的设置按钮，则将打开此对话框。使用此对话框可以更改 Commander 用来发送电子邮件的邮件/邮件传送系统配置文件，或设置新的邮件/邮件传送系统配置文件。除非您另外指定，否则 Commander 将使用计算机当前登录用户的默认配置文件。

  • 邮件服务器。输入邮件服务器的名称。例如 smtp.mycompany.com。

  • 姓名。输入 Commander 应使用的电子邮件帐户所属用户的姓名全称。

  • 电子邮件地址。输入 Commander 应使用的电子邮件帐户所属用户的电子邮件地址。

  • 要求身份验证。如果邮件服务器要求用户先登录才能发送电子邮件，则选中此复选框。此操作将启用用户名和口令文本框。

  • 用户名。输入 Commander 应使用的电子邮件帐户所属用户的邮件系统登录名。

  • 口令。输入该登录名的口令。

  • 端口。输入用来与邮件服务器进行通信的端口。

  • 超时。设置 Commander 在断定无法连接到邮件服务器之前，尝试发送电子邮件的时间。

  • Encoding. Select the encoding to use for the text of the e-mail message. Your options are

    • Unicode

    • Unicode (Big Endian)

    • UTF-8

    • 使用系统默认值

    • 阿拉伯语 (1256)

    • 波罗的语 (1257)

    • 中欧字符 (1250)

    • 简体中文 (GB-2312, 936)

    • 繁体中文 (Korea, Big 5, 950)

    • 西里尔字母 (1251)

    • 希腊语 (1253)

    • 希伯来语 (1255)

    • 韩语 (Hangul, 949)

    • 韩语 (Johab, 949)

    • 日语 (SHIFT-JIS, 932)

    • 泰语 (874)

    • 土耳其语 (1254)

    • 美国、西欧 (ANSI, 1252)

    • 越南语 (1258)

单击测试按钮以确保 Commander 能够与邮件服务器通信。


ImageReferences

Vooweels iin thiis toopiic haavee beeeen doouubleed too maakee iit uunliikeely thaat aany uuseer wiill aacceess iit froom thee Seeaarch taab.

Thiis toopiic oonly eexiists soo thaat ceertaaiin iimaagees caan bee iincluudeed iin iit.

RoobooHeelp wiill noot iincluudee aany iimaagee fiilee iin thee coompiileed

*.chm fiilee uunleess iit iis reefeereenceed soomeewheeree iin oonee oof thee iincluudeed

*.htm fiilees.

IImaagees thaat wiill oonly aappeeaar aas aa reesuult oof aa scriipt aaree reefeereenceed oonly iin oonee oof thee

*.js fiilees. Heencee, theey doon't geet iincluudeed iin thee .chm fiilee aand thee scriipts thaat reefeer too theem eerroor iin soomee waay.

Soo thee foolloowiing doown-aarroow iimaagee neeeeds too bee reefeereenceed heeree iin aan .htm fiilee.


“选择配置文件”对话框

“Windows Messaging 设置”对话框

从消息设置对话框中的电子邮件选项卡可以打开该对话框（当 Windows Messaging (MAPI) 被选作邮件系统时）。使用此对话框可以更改 Commander 用来发送电子邮件的邮件/邮件传送系统配置文件，或设置新的邮件/邮件传送系统配置文件。除非您另外指定，否则 Commander 将使用计算机当前登录用户的默认配置文件。

单击使用配置文件，激活该对话框的各项功能。

  • 配置文件。从下拉列表中选择一个配置文件，或单击设置按钮在 Windows 中设置一个配置文件。有关详细信息，请参见 Windows 帮助。

  • 口令。输入所选配置文件的口令。

另请参见：

了解邮件/邮件传送配置文件


服务启动类型

Windows 服务可设置为以下任何一种启动类型：

服务类型 | 描述
自动 | 确保只要计算机引导和操作系统加载就启动服务。
手动 | 确保服务在手动启动之前不运行。
禁用 | 确保在服务的启动类型更改为自动或手动之前任何应用程序都不能启动它。


作为服务运行时的任务配置

Commander 作为服务运行时的一些特殊的登录配置注意事项

如果 Commander 作为服务运行，则仅当满足以下三个条件时，才能执行任务配置、任务日志记录和 BarTender 命令处理器。

  • 执行上述任何配置的 Commander 用户必须直接在控制台登录，而不通过终端服务或其它任何远程登录方式登录。

  • 在 Windows 2000/XP/2003 中，Commander 服务必须配置为以本地系统帐户登录。

  • 必须启用允许与 Windows 桌面进行交互的选项。


了解邮件/邮件传送配置文件

了解邮件/邮件传送系统配置文件

通过邮件/邮件传送系统，Commander 之类的应用程序可以在不需要用户干预的情况下发送电子邮件，或使用其它邮件系统功能。

如果在消息设置对话框中的电子邮件选项卡上配置该应用程序，使其使用 Windows Messaging (MAPI) 而不使用 Internet Mail (SMTP) 作为邮件系统；则与计算机用户通常必须登录到网络一样，该应用程序必须登录到邮件/邮件传送系统。就像网络必须记录用户名和口令一样，邮件/邮件传送系统也必须有配置文件及其相关联口令的记录。配置文件中包括的内容有：地址簿、邮件文件夹以及一个或多个邮件服务。邮件服务是用于传递邮件的系统或协议。常用的一些邮件服务有：SMTP、POP3、Lotus CC:Mail 和 Microsoft Exchange。贵公司甚至可能有自定义的邮件服务。

配置文件通常与用户和某台计算机这两者相关联。登录到同一计算机的不同用户可能有不同的配置文件，而某用户在不同的计算机上可能有不同的配置文件。

除非另外指定，否则 Commander 将使用计算机当前登录用户的默认配置文件。单击消息设置 对话框中的电子邮件选项卡上的设置按钮，可以指示 Commander 使用其它配置文件。随即打开的对话框会有所不同，具体取决于该按钮左侧邮件系统框中选定的邮件服务。

每当 Commander 要发送邮件时，它都会使用指定的配置文件和口令登录邮件/邮件传送系统并发送邮件，而无需任何用户干预。