简介

BarTender 利用单个的对话框和菜单选项来控制创建、设计和打印标签时所涉及的各个方面。您随时都可以通过按键盘上的 F1 键或单击相应对话框中的帮助按钮来参考 BarTender 的帮助系统，该帮助系统的内容很全面。

关于 BarTender 的帮助系统

该帮助系统分为以下几个部分：

  • 设置 BarTender。介绍如何执行特定的管理任务和配置任务。

  • 了解标签格式。介绍如何打开和保存标签格式、页面设置选项以及查看选项。

  • 创建标签格式上的对象。介绍如何创建和排列标签格式。

  • 修改对象。介绍如何指定标签格式的数据源以及如何修改标签对象。

  • 从数据库读取数据。介绍如何配置 BarTender，使其读取各种数据文件，其中包括 BarTender 如何使用 ODBC（开放数据库互连）、OLE DB、SAP IDoc 和文本数据源来读取现有的任何数据库和电子表格中的标签数据。另外，还介绍了如何执行表连接和数据库查询。

  • 打印标签格式。介绍如何指定打印机、可用的打印选项以及如何打印标签。它还介绍了打印时的记录选择以及如何读懂“同样标签的份数”或“序列标签数”。

  • Visual Basic 脚本。介绍如何创建将在打印时在 BarTender 的内部脚本引擎中执行的脚本。

  • 自动执行 BarTender 各部分。介绍自动执行 BarTender 功能的方法。

  • 条形码符号体系参考。概述了符号体系的特点，并提供了条形码符号体系表以及有关各符号体系的详细帮助主题。

  • 界面参考。介绍 BarTender 的主要菜单、工具栏、工具箱、键盘快捷方式和上下文菜单（右键单击即可打开）。


使用联机帮助

全部显示 全部隐藏

本帮助右侧窗口中始终包括最近查看过的主题。

左侧有 5 个选项卡：

  • 目录。帮助目录。浏览找到任一主题，然后双击将其打开。

  • 索引。帮助索引。其中包括您最可能查找的词。单击任何一个词。如果该词仅与一个主题相关，右侧将显示该主题。如果该词与多个主题相关，则列出这些主题。请单击所需的主题。

  • 搜索。一个全文搜索实用程序。有关此选项卡的使用方法，请参见以下内容。

  • 收藏夹。您最常查看的帮助主题的列表。要将某帮助主题添加到该列表中，请打开相应的主题，然后打开收藏夹选项卡，再单击选项卡底部的添加按钮。

  • 词汇表。词汇表包含标签和条形码行业的重要术语的定义。

顶部的按钮栏上有以下按钮：

  • 隐藏/显示。切换左侧窗格的可见性。

  • 定位。显示您当前打开的主题在目录中的位置。（有些主题未包含在目录中。）

  • 后退。再次打开您查看的上一个主题。

  • 前进。返回到您按后退按钮时打开的主题。

  • 打印。打印当前主题。

  • 选项。 单击它可以查看该菜单上的选项：

    • 隐藏选项卡/显示选项卡。与隐藏/显示按钮的功能一样（参见上文）。

    • 后退。与后退按钮的功能一样（参见上文）。

    • 前进。与前进按钮的功能一样（参见上文）。

    • 主页。打开本帮助的首页。

    • 停止。取消打开本帮助中的 Internet 网页。

    • 刷新。再次打开本帮助中当前显示的页。

    • 1 Seagull。与 Seagull 按钮的功能一样（参见下文）。

    • 2 跳转。与跳转按钮的功能一样（参见下文）。

    • Internet 选项。打开 Windows 和 Internet Explorer 的“Internet 选项”对话框。

    • 打印。与打印按钮的功能一样（参见上文）。

    • 搜索突出显示启用/禁用。启用和禁用与搜索选项卡一起使用的一项功能（参见上文）。当该功能启用时，如果您使用搜索选项卡查找某帮助主题，则在从搜索选项卡打开的任何主题中，都将突出显示您搜索的术语。

  • Seagull。打开 Seagull Scientific 的 Web 主页。

  • 跳转。打开一页，在此，您可以输入特定帮助主题的文件名，立即打开该主题。通常，此功能仅在 Seagull Scientific 技术支持部门的的指导下使用。

使用“搜索”选项卡

如果要查找 BarTender 某重要问题的所有相关主题，则索引选项卡中可能会列出该词。如果在那里找不到它，或从逻辑上来说需要进行更复杂的搜索，可以使用搜索选项卡。

简单搜索

使用搜索选项卡的最简单方法是在选项卡顶部的文本框中键入所需词，然后单击列出主题。所有包含该词的主题都将显示在该选项卡上较大的文本框中。要打开其中任一主题，仅需单击它，然后单击显示，或双击该主题。

注意：那些包含该词的相近语法变化形式的主题也将列出。例如，如果搜索词为“water”，则除包含“water”的主题外,还将列出包含“watering”和“watered”的主题。不过，不会查找以“water”开头但实际并非单词“water”的语法变化形式的词，如“waterfall”。请参见下面的使用通配符搜索。

缩小搜索范围

要将搜索范围缩小到仅包含所有词的主题，仅需键入一个以上的单词并在词之间留空格。例如，要查找有关从标签格式中删除文本对象的主题，可以在文本框中输入“删除文本对象”（不加引号）。

扩大搜索范围

要将搜索范围扩大到包含两个词中任何一个（或三个或三个以上词中至少一个）的主题，必须在词与词之间输入逻辑字符“OR”（有时称作布尔值“OR”）。要输入布尔词，请单击文本框右侧的小按钮。按钮上有一个指向右侧的箭头。布尔词下拉列表随即展开。单击 OR。例如，如果要查看与删除有关的主题，但不清楚帮助中使用的词是“删除”还是“去除”，可以输入“删除 OR 去除”作为搜索词。这样，就会列出包含这两个词中任何一个的主题。

排除特定主题

要排除包含某些词的主题，请在搜索词后加上布尔词 NOT，并在其后面输入相关的词。例如，如果要查找所有提到数据库的主题，但不查找有关 SAP IDoc 的主题，可以使用“database NOT IDoc”作为搜索词。

使用密切相关的词获取主题

如果要查找包含两个（或更多）密切相关词的主题，可以在词之间加上布尔词 NEAR。例如，如果搜索“删除文本”，那么生成的列表中会包含只是碰巧有“删除”和“文本”两个词而并非真与删除文本有关的主题。但如果搜索“删除 NEAR 文本”，则生成的主题列表将缩短，所有主题都极可能至少与删除文本部分相关。

注意：要查找确切的多词短语，请将其用引号括起来。例如，在包括引号的情况下，使用 "删除文本" 将仅查找包含该确切短语的主题。这样找到的结果可能会太狭窄：例如，有些主题可能包含有关删除文本的信息，但其中没有与搜索短语完全一样的短语。

复杂布尔搜索

您可以在搜索术语中使用括号，将布尔表达式嵌套在其它布尔表达式中（最大深度可达五层）。例如，使用“文本 AND (删除 OR 去除)”将查找所有包含词“文本”且至少包含“删除”和“去除”两个词之一的主题。

注意：虽然 AND 是下拉列表中的一个布尔运算符，但该运算符并非完全必要。搜索功能会将词之间的空格解释为 AND。因此，“文本 (删除 OR 去除)”等价于“文本 AND (删除 OR 去除)”。

注意：如果您在搜索表达式中使用多个布尔运算符，但未使用括号，则搜索功能认为：除了第一个和最后一个搜索词之外，您希望在所有搜索词后添加右括号（在表达式的开头是一串左括号）。于是，“文本 AND 删除 OR 去除”将被解释为“(删除 AND 文本) OR 去除”，而“文本 AND 删除 OR 去除 NOT IDoc”则被解释为“((文本 AND 删除) OR 去除) NOT IDoc”。

使用通配符搜索

搜索时可以使用标准的 Windows 通配符“*”和“?”。“?”作为单个字符或数字的占位符。“*”表示一串字符和数字的占位符。搜索“water?”（不带引号）将找到包含“waters”的主题，而搜索“water*”（不带引号）将找到包含“waterfall”和“waterproof”的主题。

其它缩小或扩大搜索范围的方法

在搜索选项卡的底部有一些复选框，使用它们可以打开或关闭特定的搜索功能。

在上次结果中搜索。选中该选项后，每次搜索都将忽略那些在上次搜索中未找到的主题。

匹配相近的词。选中该选项后，搜索结果中将包含与搜索词相近的词的主题，即使主题中并不包含搜索词本身。

仅搜索标题。选中该选项后，将仅列出其标题与搜索表达式匹配的主题。


ChsGlossary

词汇表

2 位补充

可以添加到 UPC 或 EAN 条形码尾部的补充条形码。请参见“条形码”、“UPC”和“EAN”。

5 位补充

可以添加到 UPC 或 EAN 条形码尾部的补充条形码。请参见“条形码”、“UPC”和“EAN”。

Australia Post 4-State Customer Code

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

Aztec Code

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

CC-A、CC-B 和 CC-C

一些符号体系的名称。CC 是“复合组件”的缩写。请参见“符号体系”和“复合条形码”。

Codabar

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

Code 128

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

Code 3-of-9

Code 39 的另一个名称。

Code 39 - Full ASCII

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

Code 39 - Regular

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

Code 93

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

Code One

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

dBase

IBM 开发的数据库程序。

DOS 命令

磁盘操作系统 (DOS) 能识别的命令。例如，“copy”和“print”。

EAN

European Article Numbering（欧洲物品编码）的缩写。符号体系系列。请参见“符号体系”。

FNC1 前缀

FNC 是功能字符集的名称。FNC1 是该字符集的第一个成员。如果用在条形码开头处，则称为“FNC1 前缀”，表示条形码符合特定的标准。

HASP

Hardware Against Software Piracy（防软件盗版硬件）的缩写。HASP 是 Aladdin Knowledge Systems, Ltd. 的注册商标。它是 BarTender 使用的加密锁类型（也称为“加密狗”）。

HP (PCL) 打印机

Hewlett-Packard (HP) 制造的打印机，它使用 HP 公司开发的打印机语言：打印机控制语言 (PCL)。

IDoc

SAP R/3 软件系统使用的一种数据文件。有关详细信息，请参见帮助主题“了解 IDocs”。

Interleaved 2 of 5

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

Intermec

一家标签打印机制造商。

JAN

Japanese Article Numbering（日本物品编码）的缩写。符号体系系列。请参见“符号体系”。

KIX 4-State Customer Code

一种符号体系的名称。（KIX 是荷兰语短语“Klant Index”的缩写。）请参见“符号体系”。

Maxicode

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

MicroPDF417

一种符号体系的名称。（PDF，当后面跟有“417”时，是 Portable Data File（可移植数据文件），而不是 Portable Document Format（可移植文档格式）的缩写。）请参见“符号体系”。

MSI Plessey

一种符号体系的名称。（MSI 是 Marketing Systems, Inc. 的缩写。）请参见“符号体系”。

ODBC

Open Data Base Connectivity（开放数据库互连）的缩写。一个用于在不同制造商开发的应用程序之间交换数据的协议。

OLE DB

一个用于在不同制造商开发的应用程序之间交换数据的协议。该术语不再是缩写。

PDF417

一种符号体系的名称。（PDF，当后面跟有“417”时，是 Portable Data File（可移植数据文件），而不是 Portable Document Format（可移植文档格式）的缩写。）请参见“符号体系”。

QR Code

一种符号体系的名称。QR 是“Quick Response”（快速响应）的缩写。请参见“符号体系”。

RFID

Radio Frequency Identification（射频识别）的缩写。

Royal Mail 4-State Customer Code

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

RSS

Reduced Space Symbology（缩小面积的符号体系）的缩写。请参见“符号体系”。

RSS Expanded

特定符号体系系列的名称。请参见“RSS”和“符号体系”。

RSS Limited

一种符号体系的名称。请参见“RSS”和“符号体系”。

RSS-14

特定符号体系系列的名称。请参见“RSS”和“符号体系”。

SAP

“Systems, Applications, and Products in Data Processing”（数据处理过程中的系统、应用程序和产品）的缩写。此术语是德国 SAP Aktiengesellschaft 公司注册的商标。

SQL

“Structured Query Language”（结构化查询语言）的缩写。一种用于编写数据库查询的语言。

SSCC

“Serial Shipping Container Code”（系列货运包装箱代码）的缩写。该缩写出现在某些符号体系的名称中。请参见“符号体系”。

Telepen

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

UCC

“Uniform Code Council”（统一编码委员会）的缩写。一个推广条形码通用国际标准的组织。该缩写出现在某些符号体系的名称中。请参见“符号体系”。

UCC/EAN FNC1

一种符号体系的名称。请参见“符号体系”、“EAN”、“UCC”和“FNC1”。

UCC/EAN-128

一种符号体系的名称。请参见“符号体系”、“EAN”和“UCC”。

UPC

“Universal Product Code”（通用产品编码）的缩写。符号体系系列。请参见“符号体系”。

US Postnet

符号体系系列的名称。US 是“United States”（美国）的缩写，Postnet 是将“postal”和“network”组合在一起创造的无意义的词。请参见“符号体系”。

Visual Basic 脚本

一种编程语言。

WYSIWYG

英语短语“what you see is what you get”（所见即所得）的缩写。通常用作形容词。它表明编辑软件或设计软件具备如下功能：设计的对象在屏幕上的外观与打印出来的外观一样。示例：“BarTender 具有 WYSIWYG 的标签编辑功能。”

安全栏

请参见“保护符”。

保护符

条形码中超长的线条。也称为“安全栏”。

保护框

与条形码的主要线条垂直的线条（或者围绕条形码形成一个矩形框的线条）。

标签参考点

标签上作为 XY 坐标系（用于定位对象）的中心的点。请参见帮助主题“了解参考点”。[与“对象参考点”相对。]

标签对象

可包括在标签格式中的任何类型的对象。例如，文本框或条形码。请参见“标签格式”和“对象”。

标签格式

标签的模板。

补充

加在条形码末尾处的 2 位或 5 位数字。

参考点

用于定位标签上的对象的点。请参见帮助主题“了解参考点”。

重复段

可在特定 SAP IDoc 中多次出现的段。请参见“IDoc”、“SAP”和“段”。

重复段规则

决定 BarTender 如何处理 SAP IDoc 中出现多次的段中的数据的规则。请参见“IDoc”、“SAP”和“段”。另请参见帮助主题“‘重复段规则’窗口”。

打印机代码模板

主要采用打印机语言编写的文件。不过，打印机代码模板与真正的打印机语言不同，因为它添加了一些标记。这其中的一些标记是标识文件中的重要位置的结构标记，例如，每行的开始和结束。其它一些标记是用作占位符的数据标记，这些标记在打印时将被实际数据所取代。

打印时

打印标签的时间或接近时间。此词用于强调在标签打印时而不是标签创建时发生的事情。示例：“标签数据也可以在打印时输入，以响应预定义的提示。”

定界

使用某些指定为分隔符的字符来分隔文件中的不同数据项的过程。例如，在以逗号定界的名称文件中，各名称之间用逗号分隔（分界）。

段（用在 IDocs 中）

当用在 SAP IDocs 中时，段指数据字段集。请参见“IDoc”、“主段”和“SAP”。

堆栈式符号体系

一种将条形码分为多行且行与行之间均有分隔符的符号体系。

对象

此词有时用在 Seagull 文档中，通常指可以插在标签格式上的事物类型：条形码、文本区、线条、方框和图形图像。

对象参考点

对象上正好位于定位坐标系的 X 轴坐标和 Y 轴坐标的点。请参见帮助主题“了解参考点”。[与“标签参考点”相对。]

符号体系

条形码符号体系是在条形码中将字符数据转换成宽窄条形码和空格等模式的编码方案。符号体系有许多种。注意：在 symbology 这个字中，字母“b”后没有“i”。其词根为“symbol”，而不是“symbiosis”。请参见“条形码”。

复合条形码

包含一维部分和二维部分的条形码。

复位

其含义与“归位”类似，但“复位”指稳定递减的值回到起始点。请参见“归位（用作动词）”。

格式

在 Seagull 文档中，当上下文表明此词的指“标签格式”时，它具有特殊的含义。请参见本词汇表中的“标签格式”。

归位（用作动词）

在达到最大值后回到起始值（通常为零）。“他汽车上的里程表达到 999,999 公里后将归位。”注意：此复合词的分词和时态是将词分为两部分并对词的前半部分进行变形：即“rolled over”和“rolling over”，而不是“rollovered”和“rollovering”。

归位（用作名词）

稳定递增的值回到起始点的事件。“里程表归位了，公共汽车上的每个人都欢呼起来。”

归位（用作形容词）

归位的或与归位有关的。“BarTender 中的归位选项提供了多种选择。”请参见帮助主题“归位”。

脚本助理

帮助开发 Visual Basic 脚本的软件程序。请参见“Visual Basic 脚本”。

校验位

有时，数字的最后一位是通过将数学函数运用到数字中的所有其它位生成的。无论数字是用数值的形式还是用条形码的形式表达的，都可以这么做。读取该数字的人或软件程序可以再运用该函数来验证其结果是否等于最后一位。如果再运用公式后得到的结果不等于最后一位，则读取该数字的人或程序就知道该数字已被篡改。按照这种方式生成的最后一位称为“校验位”。因此，校验位是用于检查数字是否被篡改的位。请参见“校验位类型”。

校验位类型

校验位是由特定的数学函数生成的。每个函数定义不同的校验位类型。例如，一种校验位可通过以下方式来生成：对数字的所有其它位求和，再除以10，得到的余数就是校验位。另一种是将这些位相乘，然后除以 10，得到的余数就是校验位。请参见“校验位”。

截断

从文字或数字的末尾去掉一些字符或数位的过程。

连接

在查询数据库时，连接指合并两个数据库表。

连结

将两个或两个以上原本单独的字母、数字、字符、象形文字或其它符号字符串合并为一个字符串。

连结

进行连结的过程。请参见“连结”。

路由器

连接两个计算机网络或一个大型网络的两部分的硬件设备。

密度

对条形码而言，它指给定长度（比如说一英寸）的条形码中的线条个数。线条越多，条形码越密。

命令行参数

在面向字符的用户界面中启动程序时为程序提供的少量信息。参数在命令行中输入，紧随启动程序的命令之后。例如，如果在命令行中输入了以下内容，则其中“bartend”为启动程序的命令，而“/PRNTYPE=laser”为命令行参数：“bartend /PRNTYPE=laser”

事件脚本

由 BarTender 中的事件触发的 Visual Basic 脚本。例如，可以将脚本设置为每次打印作业完成时运行。请参见“Visual Basic 脚本”。

收发器

一种可以传输和接收无线电信号的设备。

数据矩阵

一种符号体系的名称。请参见“符号体系”部分中该名称的主题。另请参见本词汇表中的“符号体系”。

填充

填充是指在数字和/或字母字符串的一端添加字符，使字符串符合某种最短长度要求。“他通过在末尾添加三个‘x’来填充姓名‘Johnson’。”该术语的含义类似“连结”，但“填充”意味着添加的字符都无意义。请参见“连结”。

填充字符

用于填充数字字符串或其它字符串的字符。如果在“Bob”末尾添加三个“R”来填充它 (BobRRR)，则“R”就是填充字符。请参见“填充”。

条形码

一组平行线条，它们以某种符号体系（条形码语言）来表示文字或数字。您可以将条形码视为符号体系中的“文字”或“数字”。请参见“符号体系”。

文本对象

请参见“对象”。

向导

在软件应用程序中，向导是指引导用户完成某些过程的一系列屏幕。

序列标签

依次递增每个标签上的编号而生成的一系列标签。按照这种方法生成的标签，编号都不相同，但每个编号都在指定的范围内。这一系列标签中的标签都不相同。

旋转点

对象旋转时将围绕其转动的点。

掩码

合并成单个变量的一个或多个变量（类型可能不同）的序列。例如，如果“n”是表示一位数的变量，“p”是表示标点符号的变量，则“nnpppn”就是可用由两个数字、三个标点符号和另一个数字组成的任何序列替换的掩码。

异频雷达收发机

一种仅在被预定义的信号激活后才能广播的收发器。请参见本词汇表中的“收发器”。

圆弧文本

PDF 一行沿曲线边缘弯曲的文本。

占位符

占位符是变量的一种。当正确的字符未知或因某种原因而不显示时，占位符会临时出现在字符串中。它用于确保字符串的长度不会因缺少正确字符而受到影响。当正确的字符已知并可显示时，占位符将被该字符所取代。BarTender 在某些标签对象中使用占位符来使对象的外观尽量接近设计标签时的外观。从标签格式打印某特定标签时，标签上的占位符将被其相关数据所取代。请参见“标签格式”和“标签对象”。

指示符位

标识号中指定包装级别的数位。

智能标签

其中包含微小的异频雷达收发机的标签。请参见“异频雷达收发机”。

终止字符

有关其定义，请参见帮助主题“终止字符…”。

主段

请参见帮助主题“主段”。另请参见本词汇表中的“段”。


应用程序设置概述

BarTender 设置概述

BarTender 在安装之后立即就能使用，但您可能想要或需要更改某些配置设置。

  • 日志文件设置。通过此对话框可以配置每项打印作业的详细日志，以便跟踪标签生产过程。

    •

  • IDoc 定义设置。使用此对话框可以配置 BarTender 如何处理 IDoc 定义文件。

    •

  • 消息设置。使用此对话框可以配置 BarTender 如何处理信息、警告和错误消息。

  • 打印机代码模板设置。使用此对话框可以配置导出打印机代码模板时使用的打印系统。

    •

  • 常规选项。使用此对话框可以配置有关 BarTender 用户界面的某些细节。

  • 管理设置。使用该对话框可以配置某些具有特殊用途的 BarTender 文件和目录。


“日志文件设置”对话框

全部显示 全部隐藏

注意：此对话框仅适用于 BarTender 企业版。

通过日志文件设置对话框可以记录每个打印作业，以便跟踪标签的生产。您可以使用这些选项指定：

  • 保存日志文件的位置

  • BarTender 是将数据附加到一个日志文件中，还是分别为每个打印作业创建一个日志文件

  • 是以 HTML 格式，还是以文本格式保存日志文件

  • 日志文件包含哪些信息

下面介绍了日志文件设置对话框上的各个选项。

  • 日志打印作业。用于启用日志文件设置对话框中的选项。

  • 样本日志文件。根据当前的“日志文件设置”设置显示样本日志文件的外观。

设置选项

  • 日志文件文件夹。用于指定保存日志文件的文件夹。（使用浏览按钮定位文件夹，并在日志文件文件夹选项中输入路径。）

  • 组织。用于指定是将日志文件附加到某个现有文件之后，还是将它们保存在单独的文件中。

  • 输出类型。用于指定是应将日志文件保存为 HTML 文件（可使用 Web 浏览器查看），还是保存为（简单的）文本文件。

  • Encoding. Select the character set of the log file if it is different from the default. For example, you might need to do this if you are using a language other than the default for your version of Windows. Your options are

  • Unicode

  • Unicode (Big Endian)

  • UTF-8

  • 使用系统默认值

  • 阿拉伯语 (1256)

  • 波罗的语 (1257)

  • 中欧字符 (1250)

  • 简体中文 (GB-2312, 936)

  • 繁体中文 (Korea, Big 5, 950)

  • 西里尔字母 (1251)

  • 希腊语 (1253)

  • 希伯来语 (1255)

  • 韩语 (Hangul, 949)

  • 韩语 (Johab, 1361)

  • 日语 (SHIFT-JIS, 932)

  • 泰语 (874)

  • 土耳其语 (1254)

  • 美国、西欧 (ANSI, 1252)

  • 越南语 (1258)

  • 查看。用于在记事本（文本文件）或 Web 浏览器（HTML 文件）中打开以前生成的日志文件。

  • 查看最后一项。用于打开最后一个打印作业所创建的最后一个日志文件。

  • 全部删除。用于删除在日志文件文件夹选项中指定的文件夹中的所有 .txt 文件和 .htm 文件。

    • 警告：这将删除所有这些类型的文件。如果在指定文件夹中还有属于这些类型的其它文件，请不要使用此选项来删除它们。而应使用“我的电脑”或 Windows 资源管理器。

    标题、每个标签和脚注选项

    使用标题、每个标签和脚注选项卡上的选项，可以指定要存储在日志文件中的信息。例如，您可能需要记录每个标签的打印时间。为此，可启用每个标签选项卡上的开始时间设置。

    • 要记录的子串。（每个标签）用于指定是否应将标签对象中包含的数据与日志文件中的数据放在一起。

    另请参见：

    访问“日志文件设置”对话框


“IDoc 定义设置”对话框

注意：此对话框仅适用于 BarTender 企业版。

使用此屏幕可将 IDoc 类型定义链接到语法分析器文件，因此您不必单独将每个 IDoc 链接到语法分析器文件。

在添加/删除 IDoc 类型定义窗口的左侧是当前可用于 BarTender 的 IDoc 类型定义的列表：

  • 名称字段包含该类型所使用的名称。（请参见“IDoc 类型定义”窗口。）

  • 类型字段包含 SAP AG（或者，如果该类型是在具体业务中定义的自定义类型，则为创建者）赋予该类型的名称。

  • 版本字段标识该类型的版本。

  • 默认 IDoc 文件字段包含指向默认 IDoc 文件的路径。

在此屏幕上，您可以执行以下操作：

  • 通过单击新建按钮，向可用于 BarTender 的 IDoc 类型中添加新的 IDoc 类型。

  • 通过突出显示 IDoc 类型并单击修改，修改 BarTender 使用该 IDoc 类型的方式。

  • 通过突出显示 IDoc 类型并单击删除，从可用于 BarTender 的 IDoc 类型中删除该类型。

另请参见：

了解 IDoc

分析器文件


“消息设置”对话框

使用此对话框可以配置 BarTender 处理信息、警告和错误消息的方式。

此对话框上有三个选项卡：使用恢复为默认设置按钮，可以在按确定按钮后，将所有选项卡上的设置恢复为默认设置。如果按恢复为默认设置后单击取消，则不会恢复为默认设置。

  • 消息选项卡。使用此选项卡可以确定要显示或记录的消息以及 BarTender 响应这些消息的方式。

  • 日志文件选项卡。使用此选项卡可以配置将消息记录到文件中的方式。

  • 电子邮件选项卡。使用此选项卡可以配置通过电子邮件发送消息的方式和收件人。


“打印机代码模板设置”对话框

全部显示 全部隐藏

注意：此功能仅适用于 BarTender 企业版。

BarTender 附带有预定义的打印系统。但并不要求您必须使用这些打印系统。您可以使用打印机代码模板设置对话框创建自己的自定义打印系统。可以定义任意数量的系统。所定义的每个新系统都将添加到文件 | 导出打印机代码模板菜单以供选择。

注意：有关打印系统的详细信息，请参见了解打印机代码模板。

打印系统列表

这是所有可用打印系统的列表。

列表下方是用于维护该打印系统列表的按钮：

按钮 | 用途
 | 新建打印系统。向列表中插入新的打印系统。
 | 删除打印系统。删除所选的打印系统。
 | 剪切打印系统。删除所选打印系统，但将该打印系统的副本放入 BarTender 的剪贴板。
 | 复制打印系统。将所选的打印系统复制到 BarTender 的剪贴板中。
 | 粘贴打印系统。将当前位于剪贴板中的打印系统副本粘贴到列表中。
 | 上移打印系统。将所选打印系统在列表中上移一个位置。
 | 下移打印系统。将所选打印系统在列表中下移一个位置。

注意：所有这些命令还可以通过在列表中的任何地方右键单击来进行访问。

名称框包含所选打印系统的名称。

“定界符”选项卡

定界符选项卡用于配置打印机代码模板定界符。对打印机代码模板进行分析的打印系统将使用这些定界符，并且打印系统在进行打印之前将替换这些定界符。

下表列出了可插入到打印机代码模板中的每种定界符类型。

  • 属性。此列提供了有关每种定界符的简短说明（通常按照定界符类型在打印机代码模板中的位置）。

  • 值。此列中的单元格提供各个定界符的值。此值将被插入到模板文件中，因此必须使用符合打印系统要求的值。例如，如果打印系统要求打印机代码模板中的各行都以定界符 {SL} 开头、以定界符 {EL} 结尾，则应输入“{SL}”（不带引号）作为行首定界符名称，并输入“{EL}”作为行尾定界符名称。

    • 使用标题和脚注定界符可以分别指定打印系统要求在模板文件的开头和结尾找到的字符（如果有）。

    • 使用行首和行尾定界符可以分别指定打印系统要求在模板文件的每一行开头和结尾找到的字符（如果有）。

    • 使用起始字段定界符和结尾字段定界符可以设置紧随模板字段名称前后的字符（或一组字符）。有关模板字段的详细信息，请参见更多选项对话框中的常规选项卡的帮助。

    • 使用起始打印代码和结尾打印代码可以指定打印系统要求在打印机语言代码段的开头和结尾找到的字符（如果有）。

  • … 按钮。打开定界符值对话框，从中可以输入定界符值。

“替换表”选项卡

使用此选项卡可以解决在打印机语言与所使用的模板字段语法之间可能发生的冲突。例如，如果您要用作起始字段定界符的字符（如“&”）已用于打印机语言中，则需要在打印机的语言代码中出现该字符的位置临时替换该字符。否则，打印系统会将此字符的每个实例都解释为模板字段的开头。打印系统在生成完全用打印机语言编写的打印机文件之前，最后一步是取消这一临时替换。

在替换列中，输入应被替换的字符。在替换为列中，输入替换字符。必须选择打印系统能够理解的替换字符串。继续上面的示例，如果打印系统要求任何不是模板字段开头的“&”字符之前必须为“<(>”，且其后必须为“<)>”，则“&”的替换字符串必须为“<(>&<)>”。

在创建打印机代码模板后，替换框中的任何字符都将被替换为框中的字符所替代，但 BarTender 将只在打印机代码和模板字段名称中搜索可替换字符。根据定义，结构定界符与打印系统所要求的语法兼容，因此不会将它们当作可替换字符。起始/结尾字段定界符也不会被当作可替换字符。

最多可以使用十个替换对。

若要删除替换对，请突出显示相应的替换对，然后单击删除。

单击全部删除可删除所有替换对。

Printer Tab

The Printer tab allows filtering of print systems by printer language and/or printer manufacturer so that only print systems that are compatible with the current printer are listed in the Export Printer Code Template menu.

  • Supported Printer Languages. A parameter that with the specified Printer Languages filters what printer languages are supported by the selected print system. The options are all printer languages available; only the printer languages specified; or all except the printer languages specified.

  • Printer Languages. The list of printer languages, specified by three-letter codes. The button displays a list of currently supported language codes. Multiple entries are separated by semicolons. New languages not listed but supported by updated Seagull Scientific drivers can be added by entering the appropriate code in this box.

  • Supported Printer Manufacturers. A parameter that with the specified Printer Manufacturers filters for printer manufacturers. The options are all manufacturers; specified manufacturer only; or all except a specified manufacturer.

  • Printer Manufacturers. The list of printer manufacturers. The button displays a list of supported printer manufacturers that can be selected, or a user-specified name can be entered. Multiple entries are separated by semicolons.

  • Driver Parameters. Additional parameters that are rarely needed may be entered here. Seagull Scientific technical support will provide guidance if such parameters are required.

Output Tab

The Output tab determines what options will be available, and sets default values for controls in the Export Printer Code Template dialog. In addition, the default location and/or extension of the exported files can be set here.

  • Separate Format and Data Files. Printer Code Templates can be exported in one file or in separate format and data files. This option can be set so that it is Optional, Required, or Disabled in the Export Printer Code Template dialog.

    • Optional: The dialog will permit either All in One File or Separate Format and Data Files to be selected.

    • Required: Only Separate Format and Data Files will be available.

    • Disabled: Separate Format and Data Files will be unavailable.

  • Printer Code Only for Format File. When Separate Format and Data Files is available as an option the format file can be set to only contain printer code. This option can be set so that it is Optional, Required, or Disabled in the Export Printer Code Template dialog.

    • Optional: The Printer Code Only checkbox is enabled and can be checked.

    • Required: The Printer Code Only checkbox is checked and cannot be changed.

    • Disabled: The Printer Code Only checkbox is unchecked and cannot be changed.

  • Default Directory. Default directory for printer code template file(s). If no path is specified in the Export Printer Code Template the default printer template path is used. If the Default Directory is specified here the export path textbox will be blank in the Export Printer Code Template and the Browse button will open the file browser to the specified default value.

  • Default Extension. The default extension added to the printer code template file(s) exported. If no extension is specified in the Export Printer Code Template dialog the default .prn is used.

Performance Tab

Seagull printer drivers permit certain printer capabilities to be utilized in the printer code template to optimize performance. Each of the three settings on this tab -- Allow Static Graphics, Allow Static Objects, and Allow Variable Data Optimization -- can be individually set to control the allowed behavior to Optional/Required/Disabled. Selecting Optional for a setting will display it as enabled and checked in Export Printer Code Template | Options | Performance; Required will display it as disabled and checked, and Disabled will display it as disabled and unchecked. If the option is not supported by the current printer, it will show as unchecked and disabled.

  • Allow Static Graphics. Raster-type graphic objects that do not change from label to label can be stored at the printer, including TrueType fonts.

  • Allow Static Objects. ALL objects that remain constant from label to label are stored at the printer. In addition to raster graphics, this includes printer fonts, bar codes, imported graphics, and TrueType fonts.

  • Allow Variable Data Optimization. The label formatting specifications (object positions, symbols, fonts, etc.) are stored at the printer so that only object data needs to be transmitted and merged for a specific label.

“常规”选项卡

Encoding. Select the encoding to be used on the templates of the print system. The default value is Windows' System Default.

Visible in File Export Menu. When checked the print system appears in the sub-menu of Export Printer Code Template on the File menu.

File Export Intended For Use With FTP. If checked, the PCT Export file is intended for FTP transport.

Printer Code Modifier. Each print system can have printer code modification actions or scripts associated with it that can replace, insert, or delete specified data in the printer code. The actions and scripts can be created and modified with the following buttons:

  • Action List... button. Brings up the Action List setup dialog for printer code modification.

  • Visual Basic Script... button. Brings up the VB Script assistant.

另请参见：

了解打印机代码模板

导出到打印机代码模板

打印机代码导出选项

打印机代码验证


常规选项

“常规选项”对话框

全部显示 全部隐藏

通过选择工具菜单上的常规选项，可以打开常规选项对话框，从中可以指定有关 BarTender 如何运行的详细信息。

注意：单击此链接可获取有关许可证管理选项卡的帮助。（仅限企业版。）

“常规”选项卡

语言

使用语言选项可以指定 BarTender 显示其菜单和对话框所使用的语言。如果下拉列表中没有您要用来显示 BarTender 的语言，可以使用 BarTender 的安装程序安装一些其它语言。

保存选项

  • 将格式另存为。用于指定保存标签格式所应采用的 BarTender 版本格式。格式可以保存为早期的 5.40 版本。

  • 保存为旧格式时警告。用于启用或禁用在试图将标签另存为旧格式时显示的弹出警告消息框。

其它选项

  • 从工具栏直接打印。用于指定在单击主工具栏上的打印按钮后，在将格式发送到打印机之前，不显示打印对话框。

  • 总是使用高级数据源对话框。用于指定应始终在“高级”模式下显示修改所选对象选项卡式对话框中的数据源属性页。

  • 使用透明效果。用于启用某些可以简化标签格式设计的视觉效果。（此选项仅适用于计算机的显示设置设为 24 位彩色或更高的情况。该选项不适用于 Windows 95 或 Windows NT。）

  • 最小化位置。用于指定在 BarTender 最小化后，BarTender 的图标是否显示在系统任务栏或任务栏中。

应用程序启动

  • 操作。用于指定 BarTender 启动时的行为方式。从滚动式下拉列表中选择一个选项。

“新建格式”选项卡

使用此选项卡上的选项，可以确定当您选择文件菜单中的新建或单击主工具栏上的新建按钮时，BarTender 将如何响应。

  • 运行向导。启动新建标签格式向导。

  • 立即，空白格式。将立即创建一个新的带有默认形状和大小设置的空白标签格式。

  • 基于现有格式启动。将创建一个新的标签格式，该格式最初与您在格式框中输入的现有格式完全相同。然后，可以根据需要编辑该格式。


“管理设置”对话框

使用该对话框可以配置某些具有特殊用途的 BarTender 文件和目录。以下是这些文件和目录的说明。

若要标识文件或更改文件位置，请突出显示该文件，单击选择位置，然后浏览到该文件或目录。

若要编辑可编辑的文件，请突出显示该文件，然后单击编辑类型。

若要返回到默认设置，请单击重置为默认设置。

  • 背景图片目录。在您浏览要作为标签格式背景的图片时，该目录是默认打开的。请使用页面设置对话框的背景选项卡。

  • 自定义打印系统。在导出打印机代码模板时，您既可以使用预定义的分隔符和数据字段名称系统（如 SAPScript-ITF），也可以自己创建一套或多套系统。这些系统称为自定义打印系统，存储这些系统的文件位置标识在此处。您不能直接编辑该文件，但可以更改其位置。若要创建/更改自定义的打印系统，请从工具菜单打开打印机代码模板设置。

    •

  • 自定义卷文件。在安装 BarTender 时，已对几乎所有主要标签卷制造商的大多数卷类型的大小和布局进行了定义。如果您创建了自己的卷定义，这些卷定义将存储在 Custom.stk 文件中。您不能直接编辑该文件，但可以更改其位置。若要创建自定义卷，请从文件菜单或主工具栏打开页面设置对话框，然后使用卷选项卡。

  • 标签格式目录。该目录是保存您创建的标签格式的地方（如果您没有在另存为对话框中浏览到其它目录）。

  • 许可证管理。（仅限支持许可证的 BarTender 版本。）在常规选项对话框的许可证管理选项卡上进行的设置存储在许可证管理配置文件 BTLM.ini 中。您可以使用编辑类型按钮直接打开该对话框。

    •

  • 消息。您在消息设置对话框上所做的更改将存储在扩展名为 *.btm 的文件中。您可以设置该文件的位置和/或使用编辑类型按钮来打开消息设置对话框。

  • 图片目录。当您浏览到要添加到标签格式的图片时，该目录是默认打开的。

  • SAP IDoc 类型定义。您在 IDoc 定义设置对话框上所进行的设置将存储在扩展名为 *.itd 的文件中。您可以更改该文件的位置，也可以使用编辑类型按钮来直接打开对话框。

    •

  • 工具箱组件目录。在您为标签创建可重复使用的自定义的组件时，这些组件存储在此处标识的目录中。

另请参见：

“消息设置”对话框

SAP IDoc 定义文件

页面设置的卷选项

工具箱

了解打印机代码模板


登录到应用程序

“登录”对话框

输入编辑标签格式所需的口令，然后单击确定。


“口令设置”对话框

若要设置口令来保护编辑标签格式的权限，请输入原口令（如果有），然后输入新口令两次。如果希望在启动 BarTender 时自动显示登录提示，则选中对应于该选项的复选框。单击确定。


了解标签格式

全部显示 全部隐藏

标签通常用于以某种方式标记和识别对象或将对象分类。制作标签的材料有多种，包括纸张、布匹、塑料或金属。标签可以永久附着在对象上（如食品店中出售的盒装牛奶上印刷的 UPC 条形码），也可以很容易地从对象上剥离（如百货公司出售的衣服上悬挂的标签）。

创建标签的过程非常简单。利用鼠标、工具栏和菜单栏，您可以设计出带条形码、图片和文本的标签。标签视图区域上放置的这种对象的集合称为标签格式。

注意：请记住，在创建新标签时，如果要打印标签格式，不必首先保存该标签格式。BarTender 将打印标签视图区域中显示的所有内容。不过，建议您最好保存标签格式，以备将来打印相似标签之需。

设计简单标签

所有 BarTender 菜单的设置和对话框参数都是根据其最常用的设置预置的。这些设置称为“默认”设置，有了这些设置，开始使用 BarTender 时就可以得心应手。

在开始新建标签格式时，标签的外观受到默认设置的影响。默认设置是在您没有具体指定的情况下 BarTender 自动使用的选项或设置。默认设置有两种类型。一种类型决定要使用的打印机以及标签的尺寸和方位。另一种类型影响标签格式上放置的对象（如条形码和文本）的初始外观。

打印机默认设置

无论与标签格式一起保存的打印机设置如何，在开始新建标签格式时，BarTender 都将自动将您选择的打印机作为默认 Windows 打印机。这样，页面设置中的标签设置格式将自动遵循默认打印机的默认设置。例如，您处理的标签被设置为在热感打印机上打印，但您的默认打印机是一台激光打印机。在开始新建标签时，将根据激光打印机的默认纸张尺寸和边距设置来决定新标签的大小。如果要将标签设置为在其它打印机上打印，您可以在打印对话框中更改打印机的设置。

标签对象默认设置

在将对象插入到标签格式中时，对象的外观受 BarTender 的默认设置的影响。如果希望新建的对象显示不同的外观，您可以逐标签地修改默认设置，以便更符合您的需要。

使用 BarTender 提供的标签格式

创建标签格式的过程可以非常轻松简单。但为了帮助您完成任务，BarTender 还是提供了多种常用标签格式。您可以根据自己的需要轻松地自定义这些预先设计的标签格式。这些预先定义的标签格式位于 BarTender 安装目录的 Samples 子目录下。

注意：您还可以使用 BarTender 来设计和打印圆形和椭圆形标签。


开始新建标签格式

文件菜单中的新建命令用于创建新的标签格式。根据您在常规选项对话框中所做的选择，该命令将执行以下操作之一：

  • 使用默认卷和大小属性，创建新的空白标签格式

  • 创建现有标签格式的副本

  • 启动新建标签格式向导。该向导将指导您完成选择打印机和设置标签卷的过程。完成向导后，新标签将打开。如果在您运行向导时，标签视图屏幕上已有标签格式，BarTender 将打开一个新的标签格式窗口，从而不会影响当前窗口。

您可以使用窗口菜单上的打开窗口列表来访问其它打开的标签格式窗口。

BarTender 工具栏上的新建按钮 [image] 与新建命令的作用相当。

另请参见：

打开标签格式

了解标签格式

“常规选项”对话框


页面设置选项

页面设置

全部显示 全部隐藏

页面设置对话框中包含可以控制标签卷配置的选项。

预览窗口显示当前的页面布局和目前正在使用页面设置选项进行的更改。

向导按钮可以启动新建标签格式向导。该向导将帮助您逐步完成选择打印机、配置卷和创建新格式的整个过程。

下面介绍了页面设置对话框中每个选项卡上的选项。

卷选项

  • 类别。从下拉列表中选择标签卷的制造商。如果没有列出该制造商，则单击保存按钮，然后添加该制造商。

  • 卷名。从列表中选择标签卷。如果没有列出该卷，则单击保存按钮，然后添加该卷。

  • 保存按钮。单击此按钮可以打开一个对话框，从中可以添加制造商和卷类型。

  • 删除按钮。单击此按钮可以删除当前所选的卷类型。如果您删除的卷类型是唯一一个针对给定制造商列出的卷类型，则也将删除该制造商。

纸张选项

  • 纸张大小。用于指定打印机要使用的纸张大小。当且仅当当前打印机支持用户定义的纸张大小时，列表上才会显示“用户定义大小”选项。

  • （纸张）宽度。在大小选项设置为“用户定义大小”时，用于为打印机所使用的纸张指定自定义宽度。如果当前打印机不支持用户定义的纸张大小，则禁用此选项。

注意：如果标签卷的支架比标签宽，则在此输入支架的宽度，并使用布局选项卡上的右边距和左边距框调整宽度差异。

  • （纸张）高度。在大小选项设置为“用户定义大小”时，用于为打印机所使用的纸张指定自定义高度。如果当前打印机不支持用户定义的纸张大小，则禁用此选项。

  • Paper Tray. Specifies the source if multiple trays are available on the current printer. This option is only visible and available for page printers.

  • 方向。用于为页面指定“纵向”或“横向”方向。

  • Mirror Image. (Available on only some thermal printers.) Used to print a mirror image of the label: the left and right margins are swapped. To swap the top and bottom margins combine Mirror Image with Landscape orientation.

  • Negative. (Available on only some thermal printers.) Used to reverse which pixels are printed, so printed text and bar codes become white on a black background.

布局选项

布局

  • 行数。用于指定页面上的标签行数。

  • 列数。用于指定页面上的标签列数。

边距

  • 上边距。用于指定页面的上边缘与标签第一行的顶部之间的距离。

  • 下边距。用于指定页面的下边缘与标签最后一行的底部之间的距离。

  • 左边距。用于指定页面的左边缘与标签第一列的左边缘之间的距离。

  • 右边距。用于指定页面的右边缘与标签最后一列的右边缘之间的距离。

标签大小

  • （标签）宽度。在已启用手动设置选项的情况下，用于指定标签的宽度。

  • （标签）高度。在已启用手动设置选项的情况下，用于指定标签的高度。

  • 手动设置。用于指定您希望手动设置标签的高度和宽度，而不由 BarTender 根据所选的卷和页面设置对话框中的其它设置自动计算高度和宽度。

注意：如果标签之间有间隙，请在设置标签大小之前参见以下主题：调整包含间隙的标签。

形状选项

  • 形状。用于指定标签的常规形状。

注意：如果希望使用圆形标签，则选择椭圆形，然后启用标签大小选项卡上的手动设置，并在高度和宽度框中输入直径。

  • 选项。此部分显示的选项可用于指定所选形状的属性。所选形状不同，显示的选项也有所不同。

  • 孔。用于指定椭圆形标签中心位置将有一个孔。

  • 直径。用于指定标签中心位置的孔的大小。

  • 打印边框。用于指定打印标签时将打印标签周围的边框，无论标签是圆形还是矩形。

Media Handling Options

These settings permit driver-supported devices such as cutters and label-taken sensors to be utilized in a print job. These actions are triggered by options set by the user. See Media Handling for additional information.

  • Action. Used to specify the media handling action. The default is set to Use Driver's Settings.

    • Use Driver's Settings. No action is taken unless the driver itself has been configured to do so.

    • Page Break. No additional labels are printed on the current page, and any subsequent labels are printed on a new page. If the format has only one label per page no action is taken.

    • Pause. Printer will wait for user input before printing any subsequent labels.

    • Wait for Label Taken Sensor. Printer will wait until the label-taken sensor is activated before printing any subsequent labels.

    • Cut. Label stock is cut.

    • Cut and Pause. Label stock is cut, and printer will wait for user input before printing any subsequent labels.

  • Driver Settings .... This button brings up the printer driver's Property dialog, allowing the user to select and configure Media Handling options.

  • Occurrence. Used to specify when the selected media handling action will take place. Some options will not be available in all editions of BarTender. This option is not available if Use Driver's Settings is selected.

    • At End of Print Job. The selected action will be performed at the end of the print job.

    • After Every Page. The selected action will be performed at the end of each page. If the format has only one label per page this action will take place after every label.

    • After Every Record. The selected action will be performed after all labels associated with a given database record have been printed.

    • After Identical Copies. The selected action will be performed after all identical copies of a label have been printed.

    • After Data Change. The selected action will be performed after the specified data item has changed. See Data Item Types for the data types that can be selected.

    • After Specified Number of Labels. The selected action will be performed after the specified number of labels. The Number of Labels textbox will be available to set the value at which the selected action will occur.

    • Data Item Types. If After Data Change is selected, the Data Item Types option is visible and allows the data type and the value (Data Item) to be specified.

      • Database Field. A database field name in a database used in the label format.

      • Named Substring. Any named substring used in the label format.

      • Label Object String. Any string associated with an object used in the label format.

    • Ignore Case checkbox. If selected, the comparison between values of the specified data item will ignore differences in case. This checkbox will only be visible if After Data Change is selected.

Note: Some thermal printers do not support all Media Handling actions and the Action dropdown will show only the actions supported by the printer. Page printers will only have Use Driver's Settings and Page Break options

打印顺序选项

这些选项仅适用于所打印的标签的每“页”包含多个标签的情况，如模切激光打印机标签或喷墨打印机标签。

  • 起始边角。用于指定将作为第一个标签打印的边角标签。

  • 首选方向。用于指定打印标签时要采用的方向。水平表示将逐行打印标签。（根据起始边角的不同，将从左到右或从右到左打印各行标签。）垂直表示将逐列打印标签。（根据起始边角的不同，将从上到下或从下到上打印各列标签。）

  • 打印时提示起始标签号。用于在打印作业开始时显示一个提示，以允许用户定义要第一个打印的标签。当您需要在一张已部分使用的标签页上开始打印时，此选项尤其有用。您在提示中输入的值不会实际显示在标签上。该值只是指示标签页上起始标签的位置（假设您已经为起始边角和首选方向设置了值）。使用对话框上的预览窗格可以确定应使用的标签号。

  • 跟踪起始标签号。用于跟踪在已部分使用的标签页上，哪个标签应成为下一个打印作业中的第一个标签。如果启用了此选项，BarTender 将在打印作业之间记住，已部分使用的标签页上的哪个标签是上一个打印作业的最后一个标签。

背景

  • 图片子选项卡。用于设置标签格式的背景图片。

  • 颜色子选项卡。用于设置标签格式的彩色背景。

另请参见：

创建圆形标签


方向

使用方向选项，可以指定打印机是按“横向”还是“纵向”打印标签。在出版行业中，“纵向”一直都是指打印纸张的长大于宽，而“横向”则指纸张的宽大于长。不过，在标签打印行业中，这些术语有着不同的含义。很简单，“纵向”是指打印的页面或标签不相对于纸张的运动方向旋转，而“横向”则是指打印的页面或标签旋转了 90 度。

例如，在下图中，两张标签的高和宽都相同。二者之间唯一的差别是，右侧的标签已旋转成了“横向”。

重要提示：通过 Windows“控制面板”中的打印机设置对话框，也能使用打印机的方向选项来更改页面或标签的方向。


页边距

边距

使用这四个边距选项可以指定标签卷的页边距。

注意：大多数激光打印机和其它“页面”打印机不能在页面周边的一定狭窄区域内打印，您应该了解这一点。这个“不可打印区域”因打印机而异。例如，Hewlett-Packard 兼容激光打印机不能打印距页面边缘 0.200 英寸左右的区域。因此，只是将边距更改为零并不意味着能一直向右打印到纸张边缘。

如果启用查看选项对话框中的显示不可打印区域选项，则 BarTender 将显示浅淡的虚线来指示标签不可打印区域的边框。有关此选项的详细信息，请务必阅读有关显示不可打印区域选项的帮助主题。

上边距

上边距选项指定页面的上边缘与标签第一行顶部之间的距离。

下边距

下边距选项指定页面上标签最后一行的底部与纸张的底部边缘之间的距离。

左边距

左边距选项指定页面的左边缘与标签第一列左边缘之间的距离。

右边距

右边距选项指定页面的右边缘与标签最后一列的右边缘之间的距离。


图片子选项卡

背景图片子选项卡

使用此子选项卡（位于页面设置对话框的背景选项卡上）可以为标签格式设置背景图片。

  • 来源。选择内嵌式图片或链接式图片来启用某图片背景。如果选择内嵌式图片，则会在 BarTender 标签格式文件中保存该图片的副本。如果选择链接式图片，则该图片仍为一个单独的文件，而只在标签格式文件中添加到该图片文件的路径。

  • 选择图片。单击此按钮可以浏览并选择图片文件。（仅当您嵌入图片时，此按钮才可用。）

  • 文件名。输入该图片文件的路径，或使用浏览按钮定位到该文件。（仅当您链接图片时，该框和该按钮才可用。）

  • 大小调整方法。从以下选项中选择：

    • 原始大小。BarTender 将使用原始大小的图片。

    • 页面宽度。图片将根据需要收缩或扩展，以确保其宽度与标签宽度相符。BarTender 将保持图片的高宽比。

    • 页面高度。图片将根据需要收缩或扩展，以确保其高度与标签高度相符。BarTender 将保持图片的高宽比。

    • 伸展。图片将根据需要收缩或扩展，以确保其符合标签的尺寸。

      注意：如果有悬垂值，则图片的尺寸与标签尺寸不可能完全相符。

  • 透明度。使用滑块或文本框中的箭头设置透明度，值范围为 0 到 100%。该值越大，图片就越透明。如果采用部分透明的背景图片，可以在打印出来的标签上看到背景色（如果有）或物理卷自身的颜色。

    •

  • 旋转。输入所需的图像旋转度数。

  • 不打印。使用此选项可以指定应不打印背景图片。

  • 不显示在打印预览中。使用此选项可以指定背景图片不应在打印预览中出现。

  • 悬垂标签。输入背景图片应超出标签尺寸的距离。如果标签卷在打印机中移过时会滑动很少的距离，则此选项会很有用。

  • 错误处理。打开一个对话框，利用它指示 BarTender 打印时若找不到图片文件应如何处理。 （仅当链接图片时才启用。）

另请参见：

背景色


颜色子选项卡

背景色子选项卡

使用此子选项卡（位于页面设置对话框的背景选项卡上）可以设置标签格式的背景色。

  • 背景色。使用此选项可以选择所需颜色。

  • 不打印。使用此选项可以指定应不打印背景色。

  • 不显示在打印预览中。使用此选项可以指定背景色不应在打印预览中出现。

  • 悬垂标签。输入有颜色的背景应超出标签尺寸的距离。如果标签卷在打印机中移过时会滑动很少的距离，则此选项会很有用。

另请参见：

背景图片


调整包含间隙的标签

全部显示 全部隐藏

当您的标签卷在每行标签之间有间隙（很小的空间）时，例如在感热打印机和某些其它连续形式的打印机上使用的卷，您需要打印的实际标签大小将稍小于禁用手动设置时计算的大小。

如果您希望纸张大小和实际标签大小之间的差异在屏幕上的标签视图区域中被正确计算，则必须启用手动设置选项并且设置自己的标签尺寸。因为 BarTender 根据页面设置对话框上的所有其它设置确定其标签高度和宽度自动设置，所以我们建议采用以下过程。此过程使 BarTender 可以向您提供与所需大小非常相近的标签大小设置。在 BarTender 执行了大多数工作后，您只需对其中一项或两项设置进行很少的调整。

为包含间隙的标签卷指定标签高度和宽度：

重要提示！在执行第 5 步之前不要启用手动设置选项。

  1. 单击文件菜单上的页面设置选项可以打开页面设置对话框。

  2. 使用纸张选项卡上的各个选项指定纸张的大小和方位。（如果在纸张大小选项所显示的下拉列表中不包括您所需的纸张大小，则单击列表末尾的“用户定义大小”设置，然后在纸张宽度和纸张高度选项中键入适当的值。）

  3. 在边距选项卡上的四个选项中键入四个适当的边距值。

  4. 在布局选项卡上输入行数和列数。

  5. 现在，通过单击手动设置选项一次以给该复选框加复选标记，启用该选项。

  6. 如果您按照上述过程执行，则 BarTender 现在将显示与您所需设置非常接近的标签宽度和高度设置。选择以下一项或全部两项：

  • 如果在您的标签卷上的各行之间有间隙，则降低标签高度设置以匹配标签的实际高度。

和/或

  • 如果在您的标签卷上的各列之间有间隙，则降低标签宽度设置以匹配标签的实际宽度。

  7. 单击确定按钮。


使用应用程序提供的标签格式

使用 BarTender 提供的标签格式

BarTender 允许您完全控制标签格式的外观。不过，因为从头开始创建格式可能会非常耗时，所以 BarTender 中附带了多种标准标签格式。建议您首先检查这些附带的标签格式，然后再从头开始创建标签，因为其中某一标签可能完全符合您对标签的要求。或者，如果其中一个标签很接近但并不完全相符，您可以对它进行修改，而不必从头开始。

注意：将提供的标签格式加载到标签视图区域是了解 BarTender 的性能的快捷方法。在您加载了某一格式后，可以检查各种对话框设置以确定哪些标签特性可用。使用 BarTender 的打开命令可以加载和查看任何提供的标签格式。


创建圆形标签

创建圆形标签：

  1. 选择正确的打印机。（有关详细信息，请参见选择打印机。）

  2. 通过单击主工具栏上的页面设置按钮或文件菜单中的页面设置选项以显示页面设置对话框，访问页面设置对话框。（您还可以双击标签视图区域上的任何空白位置。）

  3. 单击形状选项卡以显示形状选项。

  4. 选择椭圆。

  5. 单击布局选项卡。

  6. 单击手动设置选项以启用高度和宽度选项。

  7. 将所需圆形直径输入高度和宽度选项。

如果您需要指定边距、纸张大小、方向、行、列或其它卷设置值，请参见页面设置对话框。


打印预览

从文件菜单中选择打印预览命令，或在主工具栏中单击打印预览按钮 [image] ，可以将 BarTender 切换到打印预览模式。（如果已处于打印预览模式下，上述操作将切换回主 BarTender 屏幕。）在这种模式下，您可以查看打印作业在打印后的外观。

此视图提供了一个特殊的工具栏：

按钮 | 用途
 | 打印。单击该按钮可以打印标签。
 | 关闭。单击该按钮可以返回到标签设计视图或提示设计视图下，即打开打印预览模式之前所处的模式。
 | 多页。单击该按钮可以查看多页打印作业。
 | 放大。单击该按钮可以使光标变为放大光标。在预览图像的任何地方单击可以放大图像。您也可以按住鼠标左键来选择要放大的区域。
 | 缩小。单击该按钮可以使光标变为缩小光标。在预览图像的任何地方单击可以缩小图像。
 | 调整到窗口大小。单击该按钮将撤消已执行的放大或缩小操作的影响并使图像返回到默认大小。
 | 页面工具。使用 [image] 和 [image] 按钮（或使用 TAB 和 SHIFT-TAB 键）可以在打印作业中翻页。使用 [image] 和 [image] 按钮则可以分别直接跳到打印作业的第一页和最后一页。若要直接转至某一页，请在文本框中输入相应的页码。

注意：通过打印对话框，您还可以对一个标签执行测试打印。


打开现有的标签格式

  1. 单击文件打开按钮 [image] 或选择文件菜单中的打开命令，显示文件打开对话框。

  2. 选择显示在文件类型选项中的格式类型。如果使用默认设置“BarTender 格式文件 (*.btw)”，则显示可用的标签格式。

  3. 在文件打开对话框的查看选项区域中，选择以下设置之一。

  • 预览。（默认设置。）查看要加载的标签的“所见即所得”缩略视图。

或

  • 说明。查看以前随标签格式一起保存的说明。

  4. 在查找范围字段，单击包含该标签格式的驱动器。然后，在查找范围字段正下方的列表框中，双击包含该标签格式的文件夹名称。继续双击，直到打开包含所需文件的子文件夹。

  5. 单击所需标签格式的名称，使其突出显示。（注意：在从可用文件列表中选择标签格式时，如果将光标停放在其名称上一秒钟以上，BarTender 将在查看选项区域中显示当前突出显示的标签格式的缩略图，或显示以前随之一起保存的说明。）

  6. 单击打开按钮。

快捷方式：若要打开最近使用过的标签格式，只需在文件菜单底部最近使用过的文件列表中单击相应的名称即可。

另请参见：

“打开”命令

说明


保存标签格式

有三个命令可用来保存当前加载的标签格式：保存和另存为，在某些情况下，还可使用打印对话框选项选项卡中的打印到文件选项。保存命令用来将修改保存到现有文件中，而另存为命令则用来保存新创建的文件。打印到文件选项用来以打印机使用的特殊语言保存文件。

将修改保存到现有文件：

从文件菜单中选择保存命令。这将保存当前加载的标签格式，而且所用文件名仍是打开它时的文件名。

保存一个新的标签格式：

  1. 单击文件保存按钮 [image] 或从文件菜单中选择另存为命令，显示文件保存对话框。

  2. 在文件保存对话框底部的文件类型选项中指定所需的文件类型。使用默认设置“BarTender 格式文件 (*.btw)”，可将文件另存为一个标签格式。

  3. 在保存位置字段中，单击包含所需文件夹的驱动器。在保存位置字段下的列表框中，双击文件夹名称，直至打开要用来保存该标签格式的子文件夹。

  4. 如果要为该标签格式指定一个新文件名，请在文件名字段中键入一个新名称。如果不需要更改标签格式的名称，则可跳过步骤 5 保存该标签格式。

  5. 编辑完文件名字段后，单击保存按钮保存该标签格式。

以打印机使用的语言保存标签格式：

从文件菜单中选择打印命令。单击打印对话框上的选项选项卡，然后单击打印到文件复选框。在打印对话框上完成设置并按下打印之后，系统将提示您为采用打印机语言的标签选择路径和文件名。

另请参见：

保存命令

另存为命令

打印到文件选项


使用其它名称保存标签格式

另存为

文件菜单中的另存为命令用于命名并保存新创建的标签格式，或使用新名称保存现有格式的副本而原始标签格式保持不变。

“保存文件”对话框

选择了另存为命令后，BarTender 将显示保存文件对话框。下面概要介绍了“保存文件”的各个选项：

  • 保存位置。用于显示可用驱动器的名称。当前指定的驱动器显示在列表的顶部。所选驱动器的内容将列在保存位置选项的正下方。

  • 文件名。用于指定要保存的标签格式的名称。

  • 保存类型。用于指定标签格式将被保存为的 BarTender 版本。

在阅读保存文件所遵循的步骤之前，您需要首先了解以下部分中讨论的文件命名惯例。

命名标签格式

在使用另存为命令保存现有格式时，您可以选择是指定新格式名还是使用现有格式名。

如果不再需要原有格式规格时，您可以使用现有文件名来保存所做的更改。

如果需要保留原有标签格式规格的副本，则可以使用新文件名来保存对标签格式所做的更改。

过程：

保存标签格式

将标签格式另存为以前版本格式

另请参见：

保存标签格式

保存全部打开的标签格式


保存全部打开的标签格式

全部保存

全部保存命令用于保存 BarTender 中当前打开的所有格式。要保存的格式类型不同，该命令的功能会有所区别：

  • 如果格式是新建的（从未保存过），系统将提示您使用另存为对话框保存该格式。

  • 如果格式最初是使用 BarTender 的以前版本创建的，您将收到警告，提示您一旦在当前版本中保存了该格式，将无法再将其加载到以前版本的 BarTender 中。

  • 如果该格式曾经在当前版本中保存过，BarTender 将只是将其保存到磁盘。在这种情况下，不会显示消息对话框。

另请参见：

使用其它名称保存标签格式

保存标签格式


将标签格式另存为以前版本格式

可以将标签格式另存为最早为 5.40 版的早期版本格式。这可以通过以下步骤来实现：

  1. 单击文件菜单。

  2. 单击另存为。

  3. 单击保存类型下拉框以选择标签格式要另存为的版本号。

  4. 单击保存。

重要提示：如果将标签格式另存为旧版本格式，而标签启用了以前版本中所不具有的对象或功能，则您将失去该标签格式中的这些对象和功能。如果存在这种情况，则当您尝试保存标签时，将在保存前弹出一个对话框以提醒您这些后果，这样，您便可以最终选择保存为旧版本、当前版本还是取消此决定。建议您在将格式保存在旧版本中之前先将其保存在当前版本中，这样，您便获得了标签的一个备份副本，以备将来需要时使用。

设置保存格式时使用的默认版本号

BarTender 允许您设置默认的标签格式另存版本。这可以通过常规选项对话框设置，并且可以通过以下步骤实现：

  1. 单击工具。

  2. 单击常规选项。

  3. 单击 Save Formats As（将格式另存为）下拉框，然后选择需要的版本号。

  4. 单击确定。

禁用当另存为旧格式时弹出的警告消息

将标签另存为旧格式时，如果标签中启用了旧版本所不支持的功能或对象，将弹出一条警告消息，通知您如果继续保存，这些对象和功能将丢失。可以通过以下步骤来禁用此消息。

  1. 单击工具。

  2. 单击常规选项。

  3. 取消选中保存为旧格式时警告。

  4. 单击确定。


打印到文件

使用打印对话框中的打印到文件选项，您可以将标签打印到某一文件，而不是直接打印到打印机。（您也可以使用 Windows 控制面板将您的打印机连接到某一文件，不过使用上述选项会更快捷。）在以下情况下适合于将您的标签打印到一个文件：

  • 保存打印输出数据以便在以后打印您的标签。

  • 从其它计算机打印您的标签。

  • 出于不同目的查看或编辑打印输出数据。

在选择了打印到文件选项后，BarTender 将在打印时显示打印到文件对话框，您可以从中指定打印数据的路径和文件名。

有关如何在以后打印文件的信息，请参见 DOS COPY 和 PRINT 命令。


“查看”菜单

使用查看菜单中的选项可以更改标签在屏幕上显示的大小和位置以及是否从标签设计模式切换到提示设计模式。不过，这些选项不会改变标签的实际内容，它们只改变标签的显示大小和位置。您还可以使用查看菜单访问查看选项对话框，其中包含标尺、网格和缩放倍数设置。

重要的查看功能：“查找标签”按钮

在使用 BarTender 的滚动工具时，尤其是在还同时使用查看菜单中的缩放命令时，如果滚动标签，可能会将其完全滚出标签视图区域，造成标签从视野中消失。如果发生了这种情况，BarTender 将在顶部标尺的右侧显示查找标签按钮。单击该按钮，可以使 BarTender 自动查找标签并将其置于视图区域的中心处。在提示设计视图模式下，也提供了类似的功能。

有关查看菜单选项的详细信息，请单击以下相应的菜单名称。

  • 标签设计视图。用于设计和查看标签格式（此为默认选项）。

  • 提示设计视图。用于设计自定义打印时提示对话框。

  • 工具栏。用于显示或隐藏可用工具栏。

  • 放大。用于根据当前指定的缩放倍数百分比放大标签视图区域局部。

  • 缩小。用于根据当前指定的缩放倍数百分比取消缩小标签视图区域局部。

  • 实际大小。用于将标签图像调整到 Windows 默认缩放倍数时的标签视图区域大小。

  • 调整到窗口大小。用于将标签图像调整到整个标签视图区域大小。

  • 查看选项。用于指定 BarTender 的标尺和网格参数。使用该选项还可以控制放大和缩小命令将使用的缩放倍数。


了解 RFID

文本标签或条形码标签仅在标签和人或读取器之间没有障碍物的情况下才有用。如果不满足该条件，可使用 RFID（Radio Frequency Identification，射频识别）来替代或补充普通的标签识别系统。RFID 系统使用非常小的异频雷达收发机 来广播标识数据。需要识别的每个项都附带有自己的可编程异频雷达收发机，每个异频雷达收发机都广播不同的标识号。这些标识号由一个特殊的无线电收发器 （称作“询问器”）读取。异频雷达收发机不连续广播其数据：而是等待询问器广播标识请求。异频雷达收发机和询问器将交换确认信号，然后异频雷达收发机将向询问器广播其数据。

异频雷达收发机很小，可以放在纸标签的夹层中。这些标签包含有与异频雷达收发机中编码的信息相同或附在其后的文本或条形码，可以打印出来。这类标签通常称作“智能标签”、“标记”或“RFID 卡”。

许多打印机制造商现在生产的打印机都有 RFID 功能，可以在将数据打印到智能标签上的同时，将数据编码到标签的异频雷达收发机中。您可以将 BarTender 标签设计为可在这些打印机上打印，主要步骤如下：

  1. 在打印机驱动程序中创建一个或多个 RFID 字体。

  2. 将一个文本对象放到标签格式上，将其配置为使用 RFID 字体。该对象将保存要被编码的数据，不会打印。

  3. 可与往常一样设计格式的可打印部分。


创建对象

创建标签格式上的对象

在您要向标签上添加条形码、文本或不同图形对象时，可有几种选择。您可以：

  • 单击主 工具栏上的相应按钮，然后单击该标签。

  • 从创建菜单上选择相应的命令，然后单击该标签。

  • 将所需类型的对象从工具箱的默认对象窗格拖到标签上。

  • 将以前创建和配置的对象（或对象组）从工具箱的组件窗格拖到标签上。

  • 将数据源类型从工具箱的数据源窗格拖放到标签上。

  • 将以前使用的数据库字段或现有的指定子串从工具箱的数据源窗格拖到标签上。

在已将某一对象插到标签上后，使用修改对话框中的选项调整其外观和属性。

对象默认设置

默认设置是在您没有具体指定的情况下 BarTender 自动使用的选项或设置。每次您执行新建命令时，BarTender 都会清除标签视图区域并自动将菜单和对话框选项重置为其内置的默认设置。不过，可以使用修改菜单中的默认对象选项修改这些默认设置（并用标签格式保存它们）。如果您要修改该默认设置，请参见修改内置默认设置。

另请参见：

了解标签格式


绘制方框

请使用最符合您工作习惯的方法：

使用工具箱：

  1. 将方框从工具箱的默认对象窗格中，拖到标签上需要方框的大致位置。

  2. 使用手柄调整方框的尺寸和位置或旋转方框。

  3. 双击该对象，打开修改所选方框对话框以配置方框的属性。

使用主工具栏或“创建”菜单：

  1. 单击主工具栏上的创建方框按钮 [image] 。（或从创建菜单中选择方框。）您的鼠标光标将呈现方框光标形状。

  2. 将光标移到标签视图区域中要放置方框一角的那一点。

  3. 单击并按住鼠标左键，将光标拖到起始角的对角。（沿着光标将勾勒出一个淡淡的虚线方框，使您可以知道正在创建的方框的大小。）

  4. 释放鼠标按钮，该对象随即显示。

  5. 使用手柄调整方框的尺寸和位置或旋转方框。

  6. 双击该对象，打开修改所选方框对话框以配置方框的属性。

另请参见：

创建标签对象


Drawing an Ellipse

Use the method that fits best with your working style:

Note: To create a circle, hold down the Shift key when placing the object on the label.

With the Toolbox:

  1. Drag-and-drop an ellipse from the Default Objects pane of the Toolbox to the approximate location on the label where you want the ellipse.

  2. Use the handles to adjust the ellipse's dimensions and location or to rotate it.

  3. Double-click the object to open the Modify Selected Ellipse dialog to configure the ellipse's properties.

With the Main Toolbar or the Create Menu:

  1. Click on the Create Ellipse button [image] on the Main toolbar. (Or select Ellipse from the Create menu.) Your mouse cursor will assume the shape of the ellipse mouse cursor.

  2. Move the cursor to the point in the label viewing area where you want to position one end of your ellipse.

  3. Click the left mouse button and hold it down while you drag the cursor to the corner diagonally opposite the corner from which you began. (An ellipse made of lightly dashed lines will stretch along with the cursor so that you know the size of the ellipse you are creating.)

  4. Release the mouse button and the object appears.

  5. Use the handles to adjust the ellipse's dimensions and location or to rotate it.

  6. Double-click the object to open the Modify Selected Ellipse dialog to configure the ellipse's properties.

See Also:

Creating Label Objects


绘制线条

请使用最符合您工作习惯的方法：

使用工具箱：

  1. 将线条从工具箱的默认对象窗格中拖放到标签上需要线条的大致位置。

  2. 使用手柄调整线条的尺寸和位置或旋转线条。

  3. 双击该对象，打开修改所选线条对话框以配置线条的属性。

使用主工具栏或“创建”菜单：

  1. 单击主工具栏上的创建线条按钮 [image] 。（或从创建菜单中选择线条。）您的鼠标光标将呈现线条光标形状。

  2. 将光标移到标签视图区域中您希望的线条起始位置。

  3. 单击并按住鼠标左键，将光标拖到您希望的线条结束位置。

  4. 释放鼠标按钮，该对象随即显示。

  5. 使用手柄调整线条的尺寸和位置或旋转线条。

  6. 双击该对象，打开修改所选线条对话框以配置线条的属性。

另请参见：

创建标签对象


将图片导入标签格式中

注意：如果您需要的是标准提醒符号、警告符号或危险材料符号，则可能不必导入图片。在 BarTender 所附带的特殊符号字体中提供大多数此类符号。此外，这些“字体”中还包括包装、纺织品保养、电气材料以及工业车间使用的一些符号。

您可以导入以下任何一种类型的图片：BMP、DXF、EPS、GIF、IMG、JPG、PCD、PCX、PNG、TGA、TIF、WPG 和 WMF。这些格式中，最后一种不能旋转。

将图片放到标签上的方法有多种：

使用工具箱：

  1. 将图片从工具箱的默认对象窗格中拖放到标签上需要图片的大致位置。样本图片将放到您的标签上。

  2. 使用手柄调整线条的尺寸和位置或旋转线条。

  3. 双击新放置的样本图片，显示修改所选图片对话框。继续完成下面的导入方法部分。

使用主工具栏或“创建”菜单：

  1. 单击主工具栏上的创建图片按钮 [image] 。（或从创建菜单中选择图片。）您的鼠标光标将呈现创建图片按钮形状。

  2. 将鼠标光标移到标签视图区域中您要放置图片的位置，然后单击鼠标左键。样本图片将放到您的标签上。

  3. 使用手柄调整图片的尺寸和位置或旋转图片。

  4. 双击新放置的样本图片，显示修改所选图片对话框。继续完成下面的导入方法部分。

导入方法

BarTender 提供了三种方案，供您将图片导入标签格式中。如果您知道需要使用哪个方案，请选择以下相应的操作过程：

  • 嵌入图片。

  • 链接外部图片。

  • 从数据文件读取图片。

如果您不确定应使用哪种方案，请参见“帮助”主题导入图片的可选项。

注意：从工具箱的数据源窗格中，您也可以通过一个步骤插入图片并为其分配数据源类型。

注意：从组件窗格，可以向标签添加以前创建的图片对象。

另请参见：

创建标签对象


创建条形码

请使用最符合您工作习惯的方法：

使用工具箱：

  1. 将条形码从工具箱的默认对象窗格中拖放到标签上需要该对象的大致位置。

  2. 使用手柄调整条形码的尺寸和位置或旋转条形码。

  3. 双击该对象，打开修改所选条形码对象对话框以配置条形码的属性。

使用主工具栏或“创建”菜单：

  1. 单击主工具栏上的创建条形码按钮 [image] 。（或从创建菜单中选择条形码。）

  2. 将光标移到标签视图区域。请注意，当指针越过标尺进入标签视图区域后，其形状会变为工具栏中相应按钮上的图形。这表明现在可以创建条形码了。

  3. 对准标签视图区域中条形码中心将要位于的地方单击。标签上随即出现一个条形码。

  4. 使用手柄调整条形码的尺寸和位置或旋转条形码。

  5. 双击该对象，打开修改所选条形码对象对话框以配置条形码的属性。

注意：从工具箱的数据源窗格中，您也可以通过一个步骤创建一个条形码并为其分配数据源类型。

注意：从组件窗格，可以向标签添加以前创建的条形码。

另请参见：

创建标签对象


创建文本对象

请使用最符合您工作习惯的方法：

使用工具箱：

  1. 将文本对象从工具箱的默认对象窗格中拖放到标签上需要该对象的大致位置。（右键单击该对象并从上下文菜单中选择编辑，以便可以编辑文本。）

  2. 编辑完毕后，在对象外单击，或按 Shift+Enter 组合键恢复箭头光标并接受所做的修改。

  3. 再次单击对象，使用手柄调整文本对象的尺寸和位置或旋转文本对象。

  4. 右键单击该对象，从下拉菜单中选择属性，打开修改所选文本对象对话框，在此您可以配置文本对象的属性。

使用主工具栏或“创建”菜单：

  1. 单击主工具栏上的创建文本按钮 [image] 。（或从创建菜单中选择文本。）

  2. 将光标移到标签视图区域。请注意，当指针越过标尺进入标签视图区域后，其形状会变为工具栏中相应按钮上的图形。这表明现在可以创建文本对象了。

  3. 对准标签视图区域中对象中心将要位于的地方单击。标签上随即出现一个文本对象。（右键单击该对象并从上下文菜单中选择编辑，以便可以编辑文本。）

  4. 编辑完毕后，在对象外单击，或按 Shift+Enter 组合键恢复箭头光标并接受所做的修改。

  5. 再次单击对象，使用手柄调整文本对象的尺寸和位置或旋转文本对象。

  6. 右键单击该对象，从下拉菜单中选择属性，打开修改所选文本对象对话框，在此您可以配置文本对象的属性。

注意：从工具箱的数据源窗格中，您也可以通过一个步骤创建一个文本对象并为其分配数据源类型。

注意：从组件窗格，可以向标签添加以前创建的文本对象。

另请参见：

创建标签对象


Creating an RFID Object

Use the method that fits best with your working style. Regardless of the method you use, be sure to first select an RFID-capable printer.

With the Toolbox:

Drag-and-drop a standard RFID object from the from the Standard RFID pane of the Toolbox.

With the Main Toolbar or the Create Menu:

  1. Click on the Create RFID [image] button on the Main toolbar. (Or select RFID from the Create menu.)

  2. Use the Modify Selected RFID Object dialog, which opens automatically to configure the object's properties. The options available depend on the current printer.

Note: You can also drag an RFID object from the Default Objects pane of the Toolbox to the label format. Double-click the object to open the Modify Selected RFID Object dialog to configure the object's properties.

Note: You can add to a label a previously created RFID object from the Components pane.

Note: If the current printer does not support the RFID tag type which the RFID object is originally configured to use, or the current printer does not support RFID at all, then the RFID object will appear with a red spot with an "X" on it. Place the cursor over the red spot to see a message that identifies the problem.

See Also:

Creating Label Objects

Understanding RFID


复制对象

使用“单击和拖曳”的方法：

  1. 按住键盘上的 Ctrl 键。

  2. 在按住 Ctrl 键的同时，单击并按住鼠标左键。对象四周将出现一条虚线。

  3. 将鼠标光标拖到标签上要放置该对象副本的位置。

  4. 释放鼠标按钮。如果希望新对象与标签上下两边的距离与原始对象完全相同，或左右两边距离与原始对象完全相同，请同时按住 Shift 键和 Ctrl 键。这样，可确保新对象只能放在原始对象的正上下方或左右方，防止有任何偏移。

使用“剪贴板”方法：

  1. 单击要复制的对象。

  2. 单击主工具栏上的复制按钮 [image] 。BarTender 将复制所选对象并将其副本存储在 Windows 剪贴板中。

  3. 单击主工具栏上的粘贴按钮 [image] 。BarTender 将把对象副本从剪贴板粘贴到标签视图区域的左上角。

  4. 将指针光标放在粘贴的对象上，“单击并拖曳”到标签上的所需位置。

注意：使用工具箱的组件窗格，也可以存储并再次使用对象和对象组。

另请参见：

“复制”命令

移动对象


将打印时提示与条形码对象或文本对象相关联

创建打印时提示

有时会直到打印时才知道标签上需要哪些数据。例如，当某个文本对象或条形码对象表示一个包裹的最终重量时就会出现这种情况。在这些情况下，就需要创建一个提示。这样，在打印时会显示该提示，要求用户在响应框中输入所需的数据。有关打印时提示功能的概述，请参见了解打印时提示。

创建提示的基本步骤如下：

  1. 双击相应的文本对象或条形码对象，打开修改所选 … 对象对话框。

  2. 单击数据源选项卡。

  3. 单击更多选项按钮，打开更多数据源选项对话框。

  4. 依次单击提示选项卡和打印时提示复选框，然后根据需要配置对话框上的其它设置。

  5. 依次单击关闭和确定，返回 BarTender 主屏幕。

  6. 按 F8 键切换到提示设计视图。单击工具栏上的提示设计按钮或选择查看菜单中的提示设计视图也可实现此操作。一个简单的提示设计窗口随即显示，其右侧是一个响应框，左侧则是该响应框的标题。

  7. 双击该标题，打开修改所选对象对话框，然后根据需要更改标题的属性。

  8. 双击该响应框，打开修改所选对象对话框，然后根据需要更改响应框的属性。

  9. 使用设计工具修改提示并向其添加对象。

注意：从来没有多个提示与某个给定标签格式相关联的情况，但可以将多个文本对象或条形码对象设置为打印时提示。只须重复第 1 步到第 6 步即可。每次完成第 6 步后，都会新增一个响应框和标题。


“排列”菜单

排列菜单选项可执行以下两种功能：

  • 将多个对象并入一个可作为单个对象移动的组。

  • 提供多种将对象相对于另一个对象放置的高级方式。

一般情况下，基本的鼠标移动已足以在标签上组织和放置对象。不过，有时可能需要更高级功能来控制标签的布局，排列菜单即提供了这些功能。

下面概述了排列菜单选项。有关各个选项的详细信息，请单击以下相应的菜单名称。

  • 前移。用于将对象移到与之重叠的所有其它对象的前面。

  • 后移。用于将对象移到与之重叠的所有其它对象的后面。

  • 编组。用于将两个或多个对象并为一个组，以便能够同时挪动或修改该组中的所有对象。

  • 解除编组。用于拆分一组结合在一起的对象。

  • 对齐。用于将所选对象组织成行或列，以及调整对象间的水平和垂直间距。

  • 旋转。用于旋转标签上的单个对象和对象组。


前移/后移

使用排列菜单中的前移和后移命令，可以将所选对象移到标签上与之重叠的其它对象的前面或后面。

通过重叠标签上的不同对象，可以创建出具有独特图形和其它特殊效果的标签。不过，重叠对象会使标签的编辑变得复杂，因为选择位于上方的对象总是要比选择下方的对象更容易一些。此外，对象与对象的上下放置顺序也必须正确，这样才能在打印时获得满意的效果。

示例

上例使用了 BarTender 的多种功能。若要获得上述效果，请执行以下步骤。

  1. 将条形码放在标签格式上。

  2. 双击条形码，打开修改所选条形码对象页。

  3. 单击条形码选项卡。

  4. 单击颜色，从调色板中选择白色。

  5. 切换到字体选项卡。

  6. 单击颜色，从调色板中选择白色。

  7. 单击确定，返回标签格式。您将只能看到条形码周围的手柄。

  8. 在主工具栏上单击创建方框按钮，并使用光标围绕条形码画一个方框。

  9. 单击工具栏上的选择按钮。

  10. 双击刚创建的方框，打开“方框”属性页。

  11. 选中填充方框内部复选框。

  12. 单击确定，返回标签格式。您将看到一个黑色的方框。

  13. 在菜单栏上单击排列，然后选择后移。您的条形码将按照与上例中相反的顺序显示。您可以根据需要调整方框的大小或条形码。


将对象编组

编组

使用排列菜单中的编组命令，可以将标签视图区域中的两个或多个对象编成一个组。将多个个体对象并入一组后，只需单击组中的任一对象就能选中整个组。对象组还可以有某些组中对象共享的属性。对于这些属性，修改一次，就能修改组中所有对象的属性。

例如，可以用鼠标移动整组对象，却不会更改组中相互关联的各个体对象的位置。再比如，如果某组中的某些对象是条形码，则一次就能更改该组中所有条形码的符号体系或密度。

重要提示：在以上两个示例中，使用 Shift 键或选择光标执行块选而暂时组合成的对象组可以采用同样的方法修改。

将多个对象并入一个组：

1. 使用以下方法之一选择要合并的对象。

  • 按住 Shift 键，同时单击要选择的对象，一次一个。

或

  • 使用选择光标选择要编入该组中的对象。

2. 选择编组命令。

将各个体对象并入一组后，无论您是单击的哪一个对象来暂时选中该组，该对象都将成为该组的所选主对象。所选主对象总是很容易辨认，它上显示的手柄是实心的，而组中其它对象的手柄则是空心的。

修改某组中的对象时，所选主对象的修改方法有两种：使用修改所选对象选项卡式对话框将所选主对象作为单个对象进行修改，使用修改所选组选项卡式对话框将所选主对象作为该组的一部分进行修改。组中的非主对象只能作为组的一部分进行修改。不过，随时可以指定其它对象作为组的主对象，只须单击要指定为新的主对象的对象即可。


解除（拆分）对象组

解除编组

排列菜单中的解除编组命令用于拆分一组结合的对象。对象被解除编组之后，您一次可以选中一个个体对象。

将一组拆分成若干个个体对象：

  1. 单击组中的一个对象，选中要拆分的组。

  2. 单击解除编组命令。


旋转对象

旋转

使用旋转对话框中的选项，可以围绕任何单个对象（或一组对象）的中心点旋转该对象（或组）。

您可以选择方向（顺时针或逆时针）和角。对于线条、框和图片，可以从下拉列表中选择常用的度数，也可输入一个精确到十分之一度 (0.1) 的度数。对于所有其它类型的对象，则必须从下拉列表中选择 0°、90°、180° 或 270°。

也可以使用排列工具栏上的旋转按钮，将当前突出显示的对象旋转 1°、90°（顺时针或逆时针）或 180°。

如果希望围绕某个点而不是对象自己的中心点来旋转该对象，则可以使用修改所选 … 对象对话框中的位置选项卡。

注意：一种快速旋转对象的方法是使用主工具栏上的旋转工具。


使用指针工具选择一组对象

选择命令（指针工具）还可用于选择一组对象。该功能通常与排列菜单中的编组命令结合使用，后者用于将所选对象组合为一个组以便操作。

要选择一组对象，可以定义一个完全囊括了所需对象的矩形。（任何未完全处于矩形边框内的对象都不会选择。）

选择一组对象：

  1. 单击主工具栏上的选择按钮。

  2. 确定要选择标签视图区域中的哪些对象。

  3. 在标签视图区域中，将鼠标指针移至所需对象组四个角之一的外侧，然后按住鼠标左键。

  4. 按住鼠标左键，将光标从待选对象组的起始角一直拖到对角。（注意，移动鼠标时，随着鼠标的移动会出现一个细虚线框。）

  5. 当所需的全部对象都囊括在边框内后，松开鼠标按钮。

取消对所选对象的选择：

单击标签视图区域的空白处，或单击某个未选中的对象。

选择不相邻的对象

BarTender 还允许您同时选择多个不相邻的对象。为此，请激活选择命令，然后按住 Shift 键，同时单击要选择的每个对象。

采用同样的方法，还可以用 Shift 键从一组所选对象中删除对象。选择了该组后，按住 Shift 键，然后使用指针工具单击要取消选择的每个对象。

另请参见：

“选择”命令

“全选”命令


对齐组中的对象

对齐

对齐对话框包含的选项可用于对您选择的标签对象执行两种不同类型的位置调整。

对齐方式：

使多个对象排成行或列。为此，只需将一组所选对象的水平对齐值和垂直对齐值设为同一个值。

间距：

一组中多个对象之间的等间距。

大多数“对齐”选项明确用来将两个或更多的标签对象彼此对齐。因此，除非在标签上选中了两个或更多的对象，否则，其中的大多数选项都会被禁用（灰显）。标签中央选项就是一个特例，它可用于对单个标签对象进行操作。

为了能够单独控制标签上各对象的水平和垂直对齐方式，因而针对对齐和间距类别提供了单独的控制选项。以下各部分讲述了这些控制选项：

水平对齐设置

垂直对齐设置


水平对齐设置

在以下描述中，切记，所选主对象始终很容易辨认。因为它的手柄是实心的，而同一组中其它对象的手柄却是空心的。而且，您熟悉了对齐命令后，可能会发现：使用位于标签视图区域下侧的排列工具栏中的快捷按钮更加方便。

按钮 | 用途
 | 不变。（默认设置。）由于每个水平对齐选项都可不考虑垂直对齐选项单独设置（反之亦然），因此，可以使用不变选项使一个方向的标签对象的位置保持不变，而只调整另一个方向的对象的对齐方式。
 | 左对齐。将两个或两个以上所选对象的左侧与所选主对象的左侧对齐。此外，所有所选对象的“Horizontal Position”（水平位置）方法都将设置为“Left Alignment”（左对齐），不管在请求执行对齐操作之前这些对象是如何设置的，都是如此。
 | 中心对齐。将两个或两个以上所选对象的中心与所选主对象的中心对齐。此外，所有所选对象的“Horizontal Position”（水平位置）方法都将设置为“Center Alignment”（中心对齐），不管在请求执行对齐操作之前这些对象是如何设置的，都是如此。
 | 右对齐。将两个或两个以上所选对象的右侧与所选主对象的右侧对齐。此外，所有所选对象的“Horizontal Position”（水平位置）方法都将设置为“Right Alignment”（右对齐），不管在请求执行对齐操作之前这些对象是如何设置的，都是如此。
 | 标签中央。尽管听起来可能相似，但此选项与中心对齐选项并不相同。此选项不是将所选对象与所选主对象的中心对齐，而是与标签自身的中心对齐。如果只选择了一个对象，则其水平中心将与标签的水平中心对齐。如果选择了多个对象，则将这些对象作为一组进行水平移动，使它们的公共中心与标签的水平中心对齐。最后，与前三个水平对齐选项不同的是，此选项不会更改所选对象的“Horizontal Position”（水平位置）方法（在位置对话框中指定）。
 | 等间距。与要求选中一个或两个对象的其它对齐选项不同，此选项要求最少选择三个对象。系统将对所选对象彼此间的相对位置进行分析，最接近标签左右两侧的两个对象的位置保持不变。然后，调整位于这两个对象之间的对象的位置，使从左到右所有所选对象彼此间的距离都相等。所有位置调整都是相对于所选对象的左右两侧执行的，而各对象的“Horizontal Position”（水平位置）方法（在位置对话框中指定）都保持不变。

另请参见：

垂直对齐设置


垂直对齐设置

在以下描述中，切记，所选主对象始终很容易辨认。因为它的句柄是实心的，而同一组中其它对象的句柄却是空心的。而且，您熟悉了对齐命令后，可能会发现：使用位于标签视图区域下侧的排列工具栏中的快捷按钮更加方便。

按钮 | 用途
 | 不变。（默认设置。）由于每个水平对齐选项都可不考虑垂直对齐选项单独设置（反之亦然），因此，可以使用不变选项使一个方向的标签对象的位置保持不变，而只调整另一个方向的对象的对齐方式。
 | 上对齐。将两个或两个以上所选对象的上端与所选主对象的上端对齐。此外，所有所选对象的“Vertical Position”（水平位置）方法都将设置为“Top Alignment”（顶部对齐），不管在请求执行对齐操作之前这些对象是如何设置的，都是如此。
 | 中心对齐。将两个或两个以上所选对象的中心与所选主对象的中心对齐。此外，所有所选对象的“Vertical Position”（水平位置）方法都将设置为“Center Alignment”（中心对齐），不管在请求执行对齐操作之前这些对象是如何设置的，都是如此。
 | 下对齐。将两个或两个以上所选对象的底部与所选主对象的底部对齐。此外，所有所选对象的“Vertical Position”（水平位置）方法都将设置为“Bottom Alignment”（底部对齐），不管在请求执行对齐操作之前这些对象是如何设置的，都是如此。
 | 标签中央。尽管听起来可能相似，但此选项与中心对齐选项并不相同。此选项不是将所选对象与所选主对象的中心对齐，而是与标签自身的中心对齐。如果只选择了一个对象，则其垂直中心将与标签的垂直中心对齐。如果选择了多个对象，则将这些对象作为一组进行垂直移动，使它们的公共中心与标签的垂直中心对齐。最后，与前三个垂直对齐选项不同的是，此选项不会更改所选对象的“Vertical Position”（垂直位置）方法（在位置对话框中指定）。
 | 等间距。与要求选中一个或两个对象的其它对齐选项不同，此选项要求最少选择三个对象。系统将对所选对象彼此间的相对位置进行分析，最接近标签上下两侧的两个对象的位置保持不变。然后，调整位于这两个对象之间的对象的位置，使从上到下所有所选对象彼此间的距离都相等。所有位置调整都是相对于所选对象的上下两侧执行的，而各对象的“Vertical Position”（垂直位置）方法（在位置对话框中指定）都保持不变。

另请参见：

水平对齐设置


修改对象

通过使用修改菜单和修改选项卡式对话框中的选项，可以根据需要调整标签上对象的外观。使用修改对话框还可以指定条形码和文本对象的数据源。

修改选项既可以应用于单个对象，也可以应用于对象组。但是，由于只有一部分修改选项与给定的任何对象或对象组有关，因此在任何指定时间显示的对话框都可能包含若干个被禁用（灰显）的选项。此外，有些修改对话框中还包含动态区域，这些区域中所显示的选项因对话框中其它选项的设置而异。


“数据源”属性页

全部显示 全部隐藏

若要查看该属性页，请通过双击对象来打开修改所选 … 对象对话框。然后，单击数据源选项卡。

在使用条形码和文本对象时，通过数据源属性页上的选项可以指定打印标签所使用的数据是通过键盘键入、从外部数据文件读取，还是从其它可能的来源获取的。在使用数据源 图片时，通过数据源属性页可以指定外部数据文件中包含要读取的图片名称的字段。

使用数据源属性页上的来源选项可以指定创建条形码或文本对象所需的信息类型以及导入数据源图片所需的字段。您可以从以下来源中选择：

  • 屏幕数据。直接键入标签格式的数据。

  • 数据库字段。从数据库连接设置对话框中指定的数据库读取的数据。

  • Visual Basic 脚本。从用户定义的 Visual Basic 脚本读取的数据。

  • 日期。从计算机或打印机的日期设置读取的数据。

  • 时间。从计算机或打印机的时间设置读取的数据。

  • Printer Code Template Field. Use this source if the field will be used only when the label format is exported to a Printer Code Template.

  • Label Object String. String data is read from another label object.

各数据源都有自己的一组选项。数据源属性页包含了一个动态区域，而不是同时显示不同数据源的所有选项（不管是否需要这些选项） 该动态区域会根据您指定的数据源来只显示与其有关的选项。

使用“新建子串向导”按钮 [image] 可以打开数据格式向导。该向导可用于指导您完成配置文本或条形码对象的数据结构的过程。

有关可用选项的详细信息，请参阅基本和高级数据源选项中的相应主题。

基本和高级选项

数据源属性页在标签对象中提供两种处理数据的模式：

  • 基本。用于仅要求一个数据源的标签对象。

  • 高级。用于将多个来源的数据结合起来供一个标签对象使用或将某个数据源的数据在多个标签对象之间共享。

在第一次访问数据源属性页时，BarTender 将以基本模式显示该属性页，其中包含您可能需要的所有选项。高级模式只不过是基本模式的扩展版本，它为需要更复杂数据来源的用户提供更完善的数据处理功能。

注意：与其它修改属性页不同，数据源选项一次只能应用于一个对象，而不能应用于一组对象。

过程：

显示数据源属性页


显示数据源属性页

双击要修改的对象，然后单击数据源选项卡以显示数据源属性页。


基本和高级数据源选项

全部显示 全部隐藏

由于大多数标签对象都使用单一数据源，因此，数据源属性页的基本选项包含了大多数用户在处理大多数标签对象时需要使用的所有选项。不过，利用高级选项，您可以设计出更复杂的标签对象。

永久基本数据源选项

在第一次访问数据源属性页时，您将看到基本选项。基本模式和高级模式中都提供这些选项。有关详细信息，请单击以下相应的选项名称。

  • 来源。用于指定在打印标签上替换对象的屏幕数据的数据是来自外部数据文件、日期、时间还是来自 Visual Basic 脚本输出。

  • “新建子串向导”按钮 [image] 。用于打开数据格式向导。该向导可用于指导您完成配置文本或条形码对象的数据结构的过程。当您在基本模式和高级模式之间切换时，该按钮的位置也会发生变化。

  • 更多选项。用于访问更多数据源选项对话框上的序列化、打印时提示、数据有效性以及各种其它选项。

  • 基本/高级。用于在基本模式和高级模式之间进行切换。

永久高级选项

高级选项是基本选项的扩展版本。利用这些附加的选项，您可以从多个数据源读取数据（使用数据子串）并与其它标签对象共享数据。

  • 子串列表。用于查看和编辑（如果可以编辑）包含多个子串的条形码和文本对象的数据。

  • “共享/名称”子选项卡。用于指定子串的数据是否被其它子串共享或被某一脚本引用。

  • “字体”子选项卡。包含有关数据字段中所使用字体的信息和一个按钮，使用该按钮可以打开字体属性页。（在 BarTender 的 Ultra-Lite 版和基本版中，该子选项卡不可用。）

  • 样本。用于显示所选对象的合并子串样本。

动态选项

在选择数据源时，某些可用选项会发生变化，只有那些与指定数据源相关的选项才会显示出来。这些发生变化的选项称为动态选项，它们位于动态区域中，而动态区域就在来源选项的正下方。在基本模式下，该区域的标题为选项；而在高级模式下，BarTender 将其显示在一个子选项卡上，其名称与所选数据源的名称相同。

  • 屏幕数据/样本数据/默认响应。用于输入作为对象默认内容的词或数字，或在启用对象提示的情况下用于输入默认响应。

  • 字符助理。“字符助理”显示在屏幕数据/样本数据/默认响应文本框的右侧，以如下按钮形式出现：

  • 字段名。用于指定使用数据库的哪个字段作为对象的数据源。

  • 带编辑按钮的类型下拉框。该下拉框用于选择要使用的 Visual Basic 脚本的类型。使用编辑按钮可以打开脚本助理。

  • 日期格式。用于选择日期对象的格式。

  • 时间格式。用于选择时间对象的格式。

  • 偏移。选中该选项可以启用以当前日期/时间为基准偏移日期/时间的功能。然后，您可以使用该复选框右侧的文本框来设置偏移的时间长度。

另请参见：

合并不同的数据源


决定是使用基本模式还是高级模式

在确定是需要使用基本选项还是高级数据源选项时，需要考虑两个重要事项：

  1. 已为所选对象指定的数据子串的数量。

  2. 是否所有这些子串都需要使用更高级的选项来操作。

数据子串是为某个条形码对象或文本对象分配的数据字符的集合，打印该对象时将打印出来。此数据可能包括屏幕数据、数据库数据、提示数据、Visual Basic 脚本中的数据、日期或时间。通常只有条形码对象和文本对象需要从单个子串接收其数据，但有时标签对象也需要从多个子串接收其数据。

以下段落简要介绍了这两个选项分别应在何时使用。

使用基本源选项

需要创建使用单个数据子串的条形码对象和文本对象，而且该子串不需要使用更高级的选项来操作时。

使用高级数据源选项

需要创建使用多个数据子串的条形码对象和文本对象时，或需要在对象或子串之间共享数据时。

在基本和高级模式之间切换视图：

使用基本/高级按钮可以在查看基本模式和高级模式之间进行切换。


屏幕数据

数据源属性页和修改屏幕数据对话框上的屏幕数据选项用于输入数据，这些数据将显示在标签视图区域并打印在当前所选对象的标签上。对于新创建的对象，BarTender 的默认“来源”设置始终是屏幕数据。如果未指定使用来自其它类型的数据源的数据，那么，在打印时，BarTender 也将使用屏幕数据来打印条形码对象或文本对象。

要输入屏幕数据，只需直接在屏幕数据选项中输入所需数据。


数据库选项

在当前指定的子串使用数据库字段作为其数据源时，数据源属性页的动态区域将显示指定的数据库选项。

如果在一个打印作业中需要打印多个标签，而每个标签的数据各不相同，则数据库字段是首选数据来源。

由于这种数据通常会因标签而异，因此标签视图区域不会显示文件中的数据，而只是显示样本数据区域中的文本。通过单击数据库连接设置对话框上的浏览选项卡，可以预先查看数据。

以下段落概要介绍了数据源选项。

  • 字段名。用于指定将在打印时替换当前指定子串的样本数据的数据库字段。

  • 样本数据。用于指定将显示在标签视图区域中的数据。在打印时，标签上的该样本数据将被数据源文件中的数据替换。

  • 数据库连接设置按钮。作为另一种通过文件菜单访问数据库连接设置对话框的方法。

另请参见：

合并不同的数据源

设置标签对象以从数据源文件读取数据


Visual Basic 脚本选项

作为数据源的 Visual Basic 脚本

到目前为止，修改所选…对象对话框中数据源选项卡上的 Visual Basic 脚本数据源是 BarTender 提供的所有数据源中最高级的一个。当您需要生成文本对象或条形码对象的最终数据时，如果没有别的办法，只能通过处理来自一个其它数据源或数据源组合的数据来达成的化，这是最常用的方法。

注意：Visual Basic 脚本还有许多高级用途，这些用途实际上根本不涉及数据的来源。当您将脚本用于这些高级用途时，应将对象的数据源设置为屏幕数据、数据库或系统日期/时间。然后，单击更多选项按钮，打开更多数据源选项对话框。单击“VB 脚本”选项卡，使用它来启用和编写脚本。

下面概述了 Visual Basic 脚本选项。在使用这些选项之前，请先查阅主题了解 BarTender 中的 Visual Basic 脚本。

  • 类型。用于指定要使用的 Visual Basic 脚本的类型。根据您的需要和技术知识，有三种不同级别的 Visual Basic 脚本。

  • 编辑。用于访问脚本助理，它可帮助您编写和存储脚本。它还提供了一系列有关 Visual Basic 和 Visual Basic 脚本的帮助。


日期选项

在您将所选数据子串的来源设置为“日期”后，数据源属性页的动态区域将显示相应的选项。在基本数据源属性页上，选项将显示在标题为选项的属性页区域中。在高级数据源属性页上，选项将显示在日期选项卡中。

  • 日期格式。用于指定日期的格式。（如果选中了如下所示的用户打印机的时钟复选框，可用选项将随打印机的设置而变化。）

  • 偏移。用于通过输入正值或负值来指定过去或将来的日期。正值指定将来的日期（滞后日期）；负值指定过去的日期（提前日期）。

  • 单位。用于选择偏移的时间单位。

  • 使用打印机的时钟。用于指定使用打印机的时钟而不是计算机的系统时钟。

如果打印机支持不同语言的时间表达形式，请从打印机的前面板上选择所需语言。若要使用打印机的时钟，您必须在字体选项卡上选择一种基于设备的字体。如果时间对象是较大文本或条形码对象的子串，则较大对象中的所有子串都必须使用相同的（基于设备的）字体。如果要使用打印机的时钟，则不必参阅 VB 脚本中的时间对象。

  • 时钟选项。打开打印机时钟选项对话框。

示例：

假定当前日期为 1997 年 1 月 19 日。您需要打印一个标签，该标签的条形码对象将显示日期 1996 年 12 月 28 日。将条形码放在标签上后，双击该条形码，以显示修改所选条形码选项卡式对话框。再次单击数据源选项卡，显示数据源属性页。使用来源选项，选择“日期”作为数据源。通过单击复选框启用偏移选项，然后在“天”数据输入框中输入数字“-22”。单击确定按钮。标签上条形码编码后的日期将显示 12/28/96。

另请参见：

时间选项

合并不同的数据源


时间选项

在您将所选数据子串的来源设置为“时间”后，数据源属性页的动态区域将显示相应的选项。在基本数据源属性页上，选项将显示在标题为选项的属性页区域中。在高级数据源属性页上，选项将显示在时间选项卡中。

  • 时间格式。用于指定时间是使用 12 小时（上午/下午）格式还是 24 小时格式。（如果选中了如下所示的用户打印机的时钟复选框，可用选项将随打印机的设置而变化。）

  • 偏移。用于通过在“小时”和/或“分钟”数据输入框中输入正值或负值来指定过去或将来的时间。正值指定将来的时间；负值指定过去的时间。

  • 使用打印机的时钟。用于指定使用打印机的时钟而不是计算机的系统时钟。

如果打印机支持不同语言的时间表达形式，请从打印机的前面板上选择所需语言。若要使用打印机的时钟，您必须在字体选项卡上选择一种基于设备的字体。如果时间对象是较大文本或条形码对象的子串，则较大对象中的所有子串都必须使用相同的（基于设备的）字体。如果要使用打印机的时钟，则不必参阅 VB 脚本中的时间对象。

  • 时钟选项。打开打印机时钟选项对话框。

另请参见：

日期选项

合并不同的数据源


启用打印时提示

当您为某对象启用打印时提示后，BarTender 会自动创建一个用户提示和响应框并将它们放置在一个提示对话框上。在打印作业开始时，该提示对话框将在打印向导中显示所有使用“打印时提示”创建的用户提示和响应框，供用户输入所需数据。

  • 用户提示。提示对话框上显示的消息，它要求用户输入数据。

  • 响应框。提示对话框上显示的数据输入框，用户可以在此输入响应。

启用打印时提示：

  1. 双击要在打印时为其输入数据的对象。BarTender 将显示修改所选 … 对象对话框。

  2. 单击数据源选项卡显示数据源属性页。

  3. 单击更多选项按钮，然后选择提示选项卡，以便显示打印时提示选项选项。

  4. 单击打印时提示框启用提示选项和响应选项。

请参见下一节：

编辑用户提示


提示

全部显示 全部隐藏

如果直到打印时尚不了解标签所需的信息，则可以使用提示选项，指示 BarTender 在打印作业开始时请求对象的数据。例如，假定您需要一个标准的发货标签，其中包括包装重量，但在打印作业开始前又无法知道包装重量。

通过单击更多选项按钮并选择提示选项卡，可以将所选标签对象设置为在打印作业开始时发出提示。在顶部显示提示属性页后，选中打印时提示框，并根据需要设置选项。

使用提示选项可以定义 BarTender 请求信息的方式。有关详细信息，请单击下面相应的选项。

提示选项

  • 打印时用户提示。用于输入在打印作业开始时，在提示对话框上显示的提醒用户键入数据的文本。

  • 提示频率。用于指定是只在打印作业开始时请求一次对象的提示数据，还是针对每个记录请求对象的提示数据。

响应选项

  • 默认响应。此消息显示默认响应的源。

  • 只读。用于指定默认响应仅供显示而不能进行编辑。

  • 打印后更新默认响应。用于指定为响应打印时提示而输入的最后一个响应将显示为新的默认响应。

  • 视回车符为制表符。用于指定当按 ENTER 键时光标将移到下一个响应框内。

  • 出现制表符时跳过数据输入框。用于指定在为响应提示而输入数据时自动跳过响应框。

注意：在此对话框上有一个图钉按钮 [image] 。当此按钮处于下陷状态 [image] 时，即使您将焦点切换到其它窗口，该对话框仍将保持打开状态。

另请参见：

了解打印时提示

了解查询提示


有效性

使用有效性选项可以强制数据遵循特定的规则。虽然有效性选项可用于不同的数据源，但通常只在从数据源文件中接收数据或根据提示输入数据时才使用它们。例如，在开始打印作业提示您输入数据时，您可能希望去掉多余的数据或添加特殊的字符。

下面概要介绍了各个有效性选项。有关其它信息，请单击以下相应的选项名称。

  • 允许的字符。用来指定将接受的字符类型。

  • 字符。在允许的字符选项设置为“自定义”的情况下，用于指定将接受的字符。

  • 选择样本掩码在允许的字符选项设置为“由‘输入掩码’设置”的情况下，从已有的几个样本输入掩码中选择一个。

  • 输入掩码。在允许的字符选项设置为“由‘输入掩码’设置”的情况下，用于创建和/或显示要强制数据遵循的模板。

  • 测试。用来显示在输入掩码数据输入框中指定的数据模板示例，并允许您输入数据来测试数据模板是否正常工作。

  • 占位符。用来指定将在测试区域中和提示对话框的响应框中显示为占位符的字符。

  • 打印实际字符。用来指定在输入掩码数据输入框中输入的数据模板将显示在标签视图区域中，并打印到标签上。

  • 从右向左填充字符用来指定从右向左输入数据。

  • 转换为大写。用来将字母数据转换为大写。

  • 转换为小写。用来将字母数据转换为小写。

  • 当数据有效性失败时警告。用来指定当数据中出现无效字符时，将显示一条消息。您可以删除无效字符并继续或取消打印作业。

注意：在此对话框上有一个图钉按钮 [image] 。当此按钮处于下陷状态 [image] 时，即使您将焦点切换到其它窗口，该对话框仍将保持打开状态。


截短

从数据源文件读取数据时，有时您可能不希望将整个数据文件字段读入标签对象。例如，某个数据文件字段在您所需的数据前面或后面带有空格。（这可能是由于从一种数据库格式转换为另一种数据库格式，或从数据库转换为文本文件而导致的。）由于 BarTender 不知道这些空格是否必要，因此，在打印时会将它们作为数据处理。这可能会增加条形码的大小并导致其它问题。

使用截短属性页上的选项，可以指定要保留或要删除的字符。下面介绍了这些选项。

  • 删除左侧空格。用于删除数据多余的前导空格。

  • 删除右侧空格。用于删除数据多余的尾随空格。

  • 丢弃左侧字符。用于从数据文件字段的左侧删除指定数量的字符。

  • 丢弃字符数。用于指定要从数据文件字段的左侧删除的字符数。

  • 丢弃右侧字符。用于从数据文件字段的右侧删除指定数量的字符。

  • 丢弃字符数。用于指定要从数据文件字段的右侧删除的字符数。

  • 保留左侧字符。用来保留数据文件字段左侧指定数量的字符。

  • 保留字符数。用来指定数据文件字段左侧要保留的字符数。

  • 保留右侧字符。用来保留数据文件字段右侧指定数量的字符。

  • 保留字符数。用来指定数据文件字段右侧要保留的字符数。

  • 从值中去除 .0。用来从数据文件字段的右侧删除 (.0)。

注意：在此对话框上有一个图钉按钮 [image] 。当此按钮处于下陷状态 [image] 时，即使您将焦点切换到其它窗口，该对话框仍将保持打开状态。


下限

有时，从数据文件的字段中读取的数据所包含的字符数会少于要在给定条形码对象或文本对象上打印的字符数。在这种情况下，使用下限属性页（位于使用修改所选 … 对象对话框上的更多选项按钮打开的更多数据源选项对话框中）上的选项，可以指定如何处理这些字段中包含的数据。

下面介绍了各个下限选项。

  • 需要最小字符数。用于启用下限选项。

  • 最小字符数。用于指定要从数据文件中读取的最小字符数。

  • 填充方式。用于指定当字段数据少于所需的最小字符数时，是在数据的左侧还是右侧插入额外字符。

  • 填充字符。用于指定填充时要使用的字符。

  • 当字符数不足时警告。用于指定如果打印时读取的数据少于所需的最小字符数，BarTender 将发出警告。

注意：在此对话框上有一个图钉按钮 [image] 。当此按钮处于下陷状态 [image] 时，即使您将焦点切换到其它窗口，该对话框仍将保持打开状态。


上限

有时，从数据文件的字段中读取的数据所包含的字符数会超过要在给定条形码对象或文本对象上打印的字符数。在这种情况下，使用上限属性页上的选项，可以限制最大字符数，并指定在打印时，如果输入的数据超过上限，则发出警告。

下面介绍了各个上限选项。

  • 限制最大字符数。用于启用上限选项。

  • 最大字符数。用于指定允许的最大字符数。

  • 当超过上限时警告。用于指定如果打印时字符数超过允许的最大字符数，BarTender 将发出警告。

注意：在此对话框上有一个图钉按钮 [image] 。当此按钮处于下陷状态 [image] 时，即使您将焦点切换到其它窗口，该对话框仍将保持打开状态。


序列化选项

序列化

有时，您可能会发现在打印输出标签时，必须自动递增或递减一个或多个数据子串。单击更多选项按钮并单击“序列化”选项卡即可实现此操作。在显示了“序列化”属性页后，选中序列化，并根据需要设置选项。

使用序列化选项，可以精确地指定对所选数据子串进行序列化的方式。

  • 类型。指定用来对子串数据进行序列化的字符集。

  • 顺序。如果已对类型选项选择了“自定义”设置，则可以键入要用来对子串数据进行序列化的自定义字符集。对于所有其它类型设置，顺序选项仅供显示。

  • 递增/递减。指定是递增还是递减子串数据。（还可指定更改数据的程度和频率。）

  • 归位。启用归位检测并指定最大值、最小值和重置值。

  • 保留子串长度。指定在发生归位或复位时是否保留子串的长度。

  • 序列化同样标签份数。指定应对标签完全相同的副本进行子串数据序列化。

  • 打印后更新子串。指定在每个打印作业后应将子串数据更新为其新值。

注意：在此对话框上有一个图钉按钮 [image] 。当此按钮处于下陷状态 [image] 时，即使您将焦点切换到其它窗口，该对话框仍将保持打开状态。

另请参见：

序列化数据

设置一个计数字段


“常规”选项卡

常规

使用更多数据源选项对话框的常规选项卡上的选项可以执行以下操作：

  • 不打印空的文本对象或条形码对象（或对象内的子串）。

  • 指定是否将条形码中的字符（或条形码内的子串）显示为条形码的供人识读字符。

  • 指定日志文件中是包含文本对象中的数据，还是条形码对象中的数据。

    •

  • 指定在导出打印机代码模板时如何处理子串。

    •

下面简要介绍这些选项。

打印机代码模板字段：

使用选项卡的这一部分，可以指定在将标签格式导出到打印机代码模板时，应如何给子串赋予模板字段名称。有关本主题的详细信息，请参见了解打印机代码模板。

  • 来源。用于确定 BarTender 将赋给打印机模板字段的名称。可用的选项有：

    • 自动。BarTender 在导出时将决定要使用的打印机模板字段名称。如果存在与子串关联的提示，它将选择提示文本。否则，将选择数据库字段名称。

    • 提示文本。使用链接到子串的提示文本。

    • 数据库字段名。使用链接到子串的数据库字段名称。

    • 共享子串名称。使用共享子串名称。

    • 屏幕数据。使用子串的屏幕数据。

    • 自定义。使用在下面的名称框中输入的自定义名称。

    • 无。根本不会在打印机代码模板中插入任何字段名称。

  • 名称。显示当前名称（如果有）。

  • 添加字段定界符。选中此框后，可以使用在 打印机代码模板设置对话框的定界符选项卡上选择的字段定界符，将模板字段名称分隔起来。

可见性：

  • 不打印，如果子串为空。用于指定当下一个（或上一个）子串为空时，在打印作业中忽略所选子串的内容。如果条形码对象或文本对象只包含一个字符串，则此选项无效。

  • 用作供人识读字符时可见。用于指定是否将当前指定的子串数据显示为条形码的供人识读字符。

日志文件选项：

  • 记录子串。用于指定日志文件中是否包含此子串的数据。如果启用此选项，并且日志文件设置对话框的每个标签选项卡上的要记录的子串选项设置为“已选择”，则日志文件中将包括该对象的数据。选中此选项后，您可以在日志文件中包含任意数量的子串。

注意：在此对话框上有一个图钉按钮 [image] 。当此按钮处于下陷状态 [image] 时，即使您将焦点切换到其它窗口，该对话框仍将保持打开状态。


子串列表

子串列表（仅适用于高级模式）

在大多数情况下，标签格式中的对象均使用单个数据源。然而，有时您可能希望将来自两个或多个数据源的信息放入一个条形码或文本对象中。通过连接（附加）多个数据子串以便作为单个字符串输出，可以实现这一点。（有时，这也称为字符串“连结”。）

将子串列表选项与选项卡式数据源选项结合使用，可以为使用多个子串的对象定义数据子串的类型和顺序。要访问此选项，请双击该对象，以打开修改所选 . . . 对象对话框。单击数据源选项卡，然后单击高级按钮。子串列表位于选项卡的左侧。

以下主题包含有关了解和使用子串列表的重要信息。如果您不熟悉 BarTender，请务必阅读以下所有主题。

另请参见：

了解子串列表

生成子串列表

重新配置子串列表

子串列表选项快捷菜单

子串连结示例

合并不同的数据源


了解子串列表

子串列表有两个主要用途：

  • 显示数据源的结构。使用子串列表，您可以清楚直观地掌握标签对象中的子串数量以及用于每个子串的数据源。列表中每个条目的左侧都有一个小型图标，它表示用于每个字符串的数据类型。每个条目的右侧是当前为该子串指定的样本数据。

  • 编辑数据源的结构。使用子串列表，您还可以很轻松地编辑单个子串的内容并更改子串的使用顺序。每次当您用鼠标单击列表中的子串或使用向上和向下箭头键更改突出显示的子串的位置时，将在列表右侧的子串框中显示新突出显示的子串的重要特性。这样，您就可以轻松快捷地查看和编辑每个数据子串的现有配置了。

另请参见：

生成子串列表

重新配置子串列表

子串连结示例


生成子串列表

在第一次显示给定标签对象的高级数据源对话框时，子串列表将为所选对象只显示一个子串。该子串数据的样本数据将显示在对话框顶部的一个单元格中，而不是显示在对话框的空白部分。如果所选对象要使用屏幕数据，子串列表将显示当前屏幕数据选项中显示的所有数据。同样，如果所选对象要使用输入文件数据，子串列表将显示样本数据选项中当前显示的所有数据，其它数据类型则依此类推。

一个条形码或文本对象的可以加在一起的子串总数和最大字符数仅受标签上可以容纳的数据字符数限制。

有多种方法可以将新数据子串添加到子串列表中：

  • 单击列表末尾的空单元格。通过单击子串列表末尾的空矩形，您可以在现有子串列表的末尾添加新的子串。这样做之后，右侧的动态数据区域将变为指示您正在添加新的子串。然后，仅需单击所需的来源类型即可。

  • 单击子串列表底部的“新建”按钮。在子串列表选项的底部有一排按钮，使用这些按钮可以创建、编辑和重新配置多个子串。最左侧的按钮是新建按钮，单击该按钮后，右侧的动态数据区域将变为指示正在添加新子串。使用新建按钮可以在现有子串列表的任何地方插入新子串，而不会如前面方法所述被限制为在列表末尾添加新子串。

  • 单击位于子串列表的右上角的“新建子串向导”按钮 [image] 。执行该操作可以打开一个菜单，您可以从中选择所需的数据格式向导的类型（如应用标识符）。完成向导后，将插入新的子串。

另请参见：

了解子串列表

重新配置子串列表

子串连结示例


重新配置子串列表

在创建并定义了子串列表后，您可能需要将某些子串重新排序或将其全部删除。您可以使用子串列表底部的工具栏轻松快捷地进行更改。

下面概述了每个按钮的用途。

按钮 | 用途
 | 新建子串。在所选对象的子串列表中插入新子串。
 | 删除子串。将所选子串从所选对象的数据子串列表删除。
 | 剪切子串。将所选子串从所选对象的数据子串列表删除并在 BarTender 的剪贴板中保存该子串的副本。
 | 复制子串。将所选子串复制到 BarTender 的剪贴板中。
 | 粘贴子串。将当前剪贴板中的子串副本粘贴到数据子串列表中。
 | 上移子串。将所选子串在子串列表中的位置上移一位。
 | 下移子串。将所选子串在子串列表中的位置下移一位。

重要提示：所有这些命令都可以通过一个 BarTender 快捷菜单来访问，如下面的第一个另请参见主题所述。

另请参见：

子串列表选项快捷菜单

了解子串列表

生成子串列表

子串连结示例


子串列表选项快捷菜单

子串列表快捷菜单

为包含多个子串的对象编辑数据时所用命令的快捷菜单。该菜单中的每个命令都与子串列表选项底部子工具栏中的一个按钮相对应。“子串列表”选项位于修改所选 … 对象对话框数据源选项卡上的高级视图中（单击该选项卡上高级按钮可以打开）。若要显示该快捷菜单，请右键单击子串列表区域中的任意位置。这样，您可以使用它来创建一个新条目，剪切、复制和粘贴条目，删除条目以及更改条目的顺序。


子串连结示例

使用子串连结可以将多个数据子串组合成单个字符串。

字符串连结的典型示例是将地址中的 CITY、STATE 和 ZIP 字段组合到单个字段中。由于连结功能通过这种方式来组合字段，因此城市的名称可以是很长的数据字符串 (South San Francisco)，也可以是很短的字符串 (Troy) — 并且在这两种情况下，CITY 与 STATE 数据字段之间的间隔是相同的。

下面的两行未使用连结功能，因此，为了弥补较长的城市名称，放置州字段的位置离城市字段的起始处必须有相当长的距离。这就使 Troy 地址行很难看。

South San Francisco, | CA | 90001
Troy, | MI | 40001

然而，接下来的两行就使用了连结功能，其中指定城市字段后面紧跟一个逗号和一个空格，而州字段后紧跟两个空格。请注意，此时 Troy 地址行的外观得到明显改善。

South San Francisco, CA 90001

Troy, MI 40001

在上例中，子串 #1 为 CITY，子串 #2 为单个逗号和空格，子串 #3 为 STATE，子串 #4 为两个空格，而子串 #5 为 ZIP。


合并不同的数据源

有时，您可能会发现将来自数据源文件的数据与屏幕数据或提示数据组合起来使用会有助于解决问题。例如，假定有一个数据字符串，它在所有打印标签上都完全不变显示（如贵公司的名称）。要打印这样的标签，一种方法是在数据源文件的所有行上都重复该文本，如下所示：

"NY","00123","Wrenches","Acme Scientific"

"LA","32014","Oranges","Acme Scientific"

"PA","43444","Bells","Acme Scientific"

不过，最有效率的方法是一次性地将公司名称指定为屏幕数据，而不是在数据源文件的所有行上重复该文本。由于公司名称字段不会随标签而改变，因此在使用这种方法时，将不必为每一要打印的标签重复从数据文件读取该字段。若要进行这种更改，请在数据库连接设置对话框的查询选项卡上单击“查询提示”按钮，显示查询提示对话框。接下来，指定屏幕数据作为来源。最后，在屏幕数据选项中键入公司名称并选择“确定”。

在执行了上述示例中的更改后，数据源文件中的第四个字段将保留为空白：

"NY","00123","Wrenches",""

"LA","32014","Oranges",""

"PA","43444","Bells",""

或完全被省略：

"NY","00123","Wrenches"

"LA","32014","Oranges"

"PA","43444","Bells"


共享/名称选项（仅适用于高级模式）

单击共享/名称子选项卡将显示数据源属性页（在修改所选 … 对象对话框中）的高级视图上的共享/名称选项。使用“共享/名称”选项可以指定一个子串的数据是否与另一个子串共享。“共享/名称”选项可应用于任何数据子串，并且使用方式相同，而不管指定了何种数据源类型。

下面概括介绍了“共享/名称”选项。有关详细信息，请单击以下选项名称。

  • 名称。用于指定当前指定的数据子串与另一个子串共享数据，或指定当前子串来源于另一个子串。也可用于命名共享子串。


“条形码”属性页

全部显示 全部隐藏

使用条形码属性页上的选项可以指定标签上打印的条形码的准确外观。显示条形码属性页最简单的方法是双击要修改的条形码。

条形码属性页中包含一个名为符号体系特殊选项的动态区域，该区域将根据所选的条形码符号体系显示不同的选项。例如，如果将符号体系设置为“Interleaved 2-of-5”（交插二五），将只有一个特定于符号体系的选项，该选项显示为校验位。然而，如果将符号体系选项设置为“Code 128”，则特定于符号体系的区域还将显示 UCC/EAN-128 和代码集选项。

注意：如果选择了包含不同符号体系的条形码的组，条形码和供人识读属性页的符号体系特殊选项区域将为空。

下面概要介绍了各个条形码选项。有关这些选项的详细信息，请单击以下相应的选项名称。

条形码选项

  • 符号体系。用于指定条形码的符号体系（条形码语言）。

  • 颜色。用于指定标签上条形码条的颜色。

  • 打印方法。用于打开指定如何在感热打印机上打印条形码的对话框。

尺寸

  • X 尺寸。用于指定最窄宽度单位，通常，这是最窄条或间距的宽度。单一 X 尺寸的宽度有时也称作“模数”。X 尺寸值取决于所选打印机的分辨率的高低。（适用于除 US Postnet 以外的所有符号体系。）

  • 长宽比。用于指定条形码的宽窄元素比例。（如果符号体系不允许选择比例，则该框将被禁用。）

  • 密度。用于指定条形码的各条的宽度和间距。（适用于除 US Postnet 以外的所有符号体系。）

  • 高度。用于指定条形码的高度。

符号体系特殊选项

该对话框区域中所显示的信息将根据所选的符号体系而定。

Australia Post 4-State Customer Code

  • 格式控制代码。用于确定应采用哪一种 Australian Post 格式控制代码。

  • 保持规格。用于确定条形码是否应保持要求的规格。如果未选中该选项，将可以手动调整条形码的大小。

  • 生成数据源模板。用于使 BarTender 自动通过基于所选模式的数据生成模板。

  • 纠错是必需的。

Aztec Code

  • 纠错。用于指定 98 个纠错级别中的一个。

  • 数据层。用于设置数据层数（1 到 32），或让 BarTender 根据数据相应地设置数据层数（自动）。

  • 定位图形。用于指定 BarTender 是否会根据数据大小来决定条形码是使用 Aztec 压缩结构还是使用 Aztec 完整结构。只有当数据层设置为“4”时，用户才能进行这一选择。

  • 黑底白字。用于反白显示条形码，这样在打印时，将在黑色背景上打印白色的条形码。

Codabar

  • 起始字符。用于指定使用 a – d 四个字母中哪一个作为 Codabar 条形码的起始字符。

  • 终止字符。用于指定使用 a – d 四个字母中哪一个作为 Codabar 条形码的终止字符。

Code 39 — Full ASCII

  • 起始字符。用于指定是否使用起始字符。

  • 终止字符。用于指定是否使用终止字符。

  • 校验位。用于指定是否在条形码中添加校验位。

  • 校验位类型。用于指定要添加到 Code 39 条形码的校验位的类型。

注意：其它校验位类型是作为 VB 脚本函数提供的。有关如何完成此操作的示例，可以查阅 VBScriptedBarCodes.btw 中的样本标签格式。您可以使用内置函数来计算多种标准校验位。您还可以使用 VB 脚本来编写自己的校验位算法。

Code 39 — Regular

  • 起始字符。用于指定是否使用起始字符。

  • 终止字符。用于指定是否使用终止字符。

  • 校验位。用于指定是否在条形码中添加校验位。

  • 校验位类型。用于指定要添加到 Code 39 条形码的校验位的类型。

注意：其它校验位类型是作为 VB 脚本函数提供的。有关如何完成此操作的示例，可以查阅 VBScriptedBarCodes.btw 中的样本标签格式。您可以使用内置函数来计算多种标准校验位。您还可以使用 VB 脚本来编写自己的校验位算法。

Code 93

  • 该条形码没有标准选项。有一个必需的校验位。

Code 128

  • 有一个必需的校验位。

  • UCC/EAN-128。用于指定条形码是否采用称为 UCC/EAN-128 的 Code 128 条形码的特殊类型。此特殊类型在供人识读文本中包含 FNC1 字符、应用标识符、校验位以及额外的空格和括号。启用该选项后，BarTender 会尝试将条形码的第一位与某一 UCC/EAN 应用标识符进行匹配。这些位可以是进入 BarTender 的数据流的一部分，您也可以将条形码配置为具有多个子串，并用第一个子串表示应用标识符。若要自动执行构建条形码的过程，请单击应用标识符数据源向导按钮（请参见以下各项）。

  • 代码集。用于指定使用三个 Code 128 字符集（Code A, Code B, Code C, Auto, Auto A, Manual）中的哪一个来打印 Code 128 条形码。

  • 应用标识符数据源向导。单击该选项可以启动一个向导，通过它，您可以在条形码中添加应用标识符、构建条形码数据并配置其在供人识读文本中的外观。

Code One

  • 版本。用于选择某一支持的 Code One 大小。

  • UCC/EAN FNC1 前缀。用于指定 Code One 条形码中的第一个字符是否应为 UCC/EAN FNC1 字符。

Composite (EAN.UCC)

在使用复合条形码之前，请首先查阅此处的复合条形码简介。

  • 类型。用于选择复合符号体系类型。除 UCC/EAN-128 之外，对于所有符号体系而言，二维组件始终是 CC-A/CC-B。BarTender 会在打印时自动根据数据大小选择 CC-A 或 CC-B。

  • 分隔符高度。用于设置一维组件和二维组件之间以及堆栈式一维组件的各行之间分隔符区域中行的高度。（根据符号体系的规格，分隔符区域可以由多个这样的行构成。）

  • 段/行。（仅限 RSS Expanded Stacked。）用于设置各行的段数。段是条形码的最小可读部分，它由一个数据字符和一个定位图形构成。

  • 一维行高。用于设置一维组件的行高。

  • 二维行高。用于设置二维组件的行高。

  • 保持 EAN.UCC 规格。用于确保保持大小参数为 EAN.UCC 复合规格。

  • 将应用标识符规格应用到辅助数据。用于指示 BarTender 根据用于应用标识的 EAN.UCC 格式设置规则解释辅助数据（二维部分）。这样，将在要求的应用标识符字段中添加校验位。

  • 将应用标识符规格应用到主数据。用于指示 BarTender 根据用于应用标识的 EAN.UCC 格式设置规则解释主数据（一维部分）。这样，将在要求的应用标识符字段中添加校验位。将使用供人识读选项卡上的 UCC/EAN 模板下拉列表设置供人识读数据的格式。对于某些一维符号体系，不能取消选中该框。

  • 复合数据源向导。用于打开可用于构建复合条形码数据的向导。

数据矩阵

  • 符号类型。用于指定要使用的纠错的类型和级别。

  • 字符集。用于指定数据的允许使用的字符。

  • 使用前缀。用于在条形码上添加前缀。

  • 形状。Used to specify the bar code size dimensions。

  • 黑底白字。用于反白显示条形码，这样在打印时，将在黑色背景上打印白色的条形码。

EAN/JAN-8

  • 有一个必需的校验位。

  • 保护符。用于指定 UPC 保护符的长度。

  • UPC 补充选项。用于访问附加 UPC 补充条形码并控制其外观所使用的选项。

EAN/JAN-13

  • 有一个必需的校验位。

  • 保护符。用于指定 UPC 保护符的长度。

  • UPC 补充选项。用于访问附加 UPC 补充条形码并控制其外观所使用的选项。

EAN/JAN/UPC 2-digit Supplemental

  • 该条形码没有标准选项。有一个必需的校验位。

EAN/JAN/UPC 5-digit Supplemental

  • 该条形码没有标准选项。有一个必需的校验位。

Japanese Post 4-State Customer Code

  • There is a mandatory Check Digit.

  • Highest Priority. Used to change the priority value from the default standard priority.

  • Hold to Specifications. Used to determine if the bar code should remain within the required specification. If this is not checked, the bar code can be sized manually.

  • Generate Data Source Template. Used to have BarTender automatically generate a template with data based on the mode selected.

Interleaved 2-of-5

  • 校验位。用于指定是否在条形码中添加校验位。

  • 保护框。用于指定在条形码上是否有非打印区域和/或保护框及其宽度。

KIX 4-State Customer Code

  • 保持规格。用于确定条形码是否应保持要求的规格。如果未选中该选项，将可以手动调整条形码的大小。

  • 生成数据源模板。用于使 BarTender 自动通过基于所选模式的数据生成模板。

MaxiCode

  • 模式。用于指定一个 MaxiCode 支持的模式。

  • 保持规格。用于确定条形码是否应保持要求的规格。如果未选中该选项，将可以手动调整条形码的大小。

  • 生成数据源模板。用于使 BarTender 自动通过基于所选模式的数据生成模板。

MicroPDF417

  • 行高。用于指定 PDF417 和 MicroPDF417 条形码中各行的高度。

  • 行。用于指定 MicroPDF417 条形码的棋盘数据区域中的行数。

  • 列。用于指定 PDF417 和 MicroPDF417 条形码的棋盘数据区域中的列数。

MSI Plessey

  • 校验位。用于指定是否在条形码中添加辅助校验位。（特殊 MOD 10 校验位是必需的。）

PDF417

  • 纠错级别。用于指定 PDF417 条形码九个纠错级别中的一个。

  • 截短。用于指定打印 PDF417 条形码的缩减版本以便节省标签上的空间。

  • 行高。用于指定 PDF417 和 MicroPDF417 条形码中各行的高度。

  • 列。用于指定 PDF417 和 MicroPDF417 条形码的棋盘数据区域中的列数。

QR Code

  • 模型。用于指定 QR Code 条形码是模型 1 还是模型 2。

  • 掩码。用于指定使用哪种类型的掩码来提高 QR Code 条形码的可读性。

  • 起始模式。用于指定在 QR Code 条形码的开头使用哪个字符集。

  • 纠错。用于指定 QR Code 条形码应使用的纠错程度。

Royal Mail 4-State Customer Code

  • 有一个必需的校验位。

  • 保持规格。用于确定条形码是否应保持要求的规格。如果未选中该选项，将可以手动调整条形码的大小。

  • 生成数据源模板。用于使 BarTender 自动通过基于所选模式的数据生成模板。

RSS

  • 类型。用于选择特定的 RSS 符号体系类型。

  • 分隔符高度。用于设置堆栈式条形码的各行之间分隔符区域中每一行的高度。（根据符号体系的规格，分隔符区域可以由多个这样的行构成。）

  • 段/行。（仅限 RSS Expanded Stacked。）用于设置各行的段数。段是条形码的最小可读部分，它由一个数据字符和一个定位图形构成。

  • 行高。用于设置行高。

  • 应用应用标识符规格。用于指示 BarTender 应根据用于应用标识的 EAN.UCC 格式设置规则解释数据。这样，将在要求的应用标识符字段中添加校验位。将使用供人识读选项卡上的 UCC/EAN 模板下拉列表设置供人识读数据的格式。

  • 保持 EAN.UCC 规格。用于确保保持大小参数为 EAN.UCC 复合规格。

  • RSS 数据源向导。用于启动一个向导，该向导将指导您完成配置用于 RSS 条形码的数据的过程。

Telepen

  • 类型。用于选择字母数字或数字。字母数字类型允许每英寸最多 8 个字符/数字。而数字类型允许每英寸最多 16 个数字。

  • 起始字符。用于指定起始字符。

  • 终止字符。用于指定终止字符。

  • 有一个必需的校验位。

UCC/EAN128

  • UCC/EAN 128 的选项与 Code 128 的选项大体相同（如上所述），只是 UCC/EAN-128 选项总是启用。

UPC-A

  • 有一个必需的校验位。

  • 保护符。用于指定 UPC 保护符的长度。

  • UPC 补充选项。用于访问附加 UPC 补充条形码并控制其外观所使用的选项。

UPC-E

  • 有一个必需的校验位。

  • 保护符。用于指定 UPC 保护符的长度。

  • 数字系统。用于指定条形码的第一个字符是零还是一。

  • 数据格式。这用来标示或者 6 个数字或者 11 个数字。

  • UPC 补充选项。用于访问附加 UPC 补充条形码并控制其外观所使用的选项。

US POSTNET (Zip, Zip + 4, & DPBC)

  • 有一个必需的校验位。

  • 保持规格。用于确定条形码是否应保持要求的规格。如果未选中该选项，将可以手动调整条形码的大小。


条形码的符号体系

符号体系

使用条形码属性页上的符号体系选项可以指定条形码的符号体系。条形码符号体系是在条形码中将字符数据转换成宽窄条形码和空格等模式的编码方案。就像人们能够以不同的语言进行交流一样，BarTender 也能够以不同的符号体系输出条形码。

若要选择符号体系，只需单击所选符号体系右侧的向下箭头，即可显示符号体系列表。再一次单击，以选择您需要的符号体系。

另请参见：

符号体系表


X 尺寸

（除 US Postnet 之外的所有符号体系均可启用该选项。）

使用条形码属性页上的 X 尺寸选项可以指定条形码中的最基本元素 — 最窄元素的宽度。该窄元素的宽度称为条形码的 X 尺寸。连同条形码的宽窄元素比一起，X 尺寸是确定条形码密度的因素之一。减小条形码的 X 尺寸值可以提高其密度，而增大 X 尺寸值可以降低其密度。

示例：

假设您在 300 dpi Hewlett-Packard LaserJet II 打印机上打印 Code 39 条形码（其比例选项设置为“自动”）。您能够指定的最小 X 尺寸值是 5.0 mil。当 X 尺寸值为 5.0 mil 时，条形码的密度为 12.5 cpi，这是您能够指定的最大密度设置。

另一方面，您能够指定的最大 X 尺寸值是 168.3 mil，则相应的密度是 .416 cpi（能够指定的最小密度设置）。


条形码的比例

比例

（这是符号体系特定的选项，仅适用于以下符号体系：Code 39 — Full ASCII；Code 39 — Regular、Codabar、Interleaved 2-of-5 和 MSI Plessey。）

条形码的宽窄元素比例定义了条形码中宽元素与窄元素的宽度之间的比例。条形码属性页上的比例选项的默认设置为“自动”，这一设置允许 BarTender 选择它认为最佳的任何比例（在激光打印机上为 2.5 比 1，在点阵打印机上为 3.0 比 1）。但是，您可以指定从 2.0 比 1 到 3.0 比 1 的任何比例，递增量为十分之一。


条形码的密度

密度

全部显示 全部隐藏

（除 US Postnet 之外的所有符号体系均可启用该选项。）

条形码的密度是指每英寸可编码的字符数。控制条形码密度的一个因素是其符号体系。不同的符号体系要求不同的条和间隔数来表示同一信息。条形码的密度还受宽窄条和间隔粗细程度的影响。条和间隔越窄，打印条形码所需的空间越小，而用每英寸字符数表示的条形码密度就越高。

随着条形码字符密度的增加，打印条形码所需的空间将减小，从而使条形码消息占用的空间更小。虽然这是我们所希望出现的情况，但如果密度增加得太高，条形码的可读性将降低，其原因如下所示：

扫描设备的光学器件精度有限，无法正确检测条形码的细微的线条和间隔。

打印设备的打印公差精度有限，无法在较高密度设置的情况下打印出清晰的条来。

更改条形码的密度

您可以使用 BarTender 通过两种方法更改条形码的密度。一种方法是使用条形码对象的手柄和鼠标。另一种方法是使用条形码属性页上的密度选项。

鼠标方法：

  1. 单击要修改的条形码。

  2. 将指针光标放在条形码的左侧或右侧手柄之一上，单击并按住鼠标左键。

  3. 继续按住鼠标左键并拖动选定的手柄，直到条形码达到所需的密度。

  4. 松开鼠标键。

菜单方法：

  1. 双击要修改的条形码。这时，将显示修改所选条形码选项卡式对话框。

  2. 单击条形码属性页上的密度选项。

  3. 单击向上或向下控制箭头，直到编辑框中显示所需的密度值。

  4. 单击确定按钮。

高密度条形码限制

当在点阵或激光打印机上打印高密度条形码时，请记住，您需要使用高分辨率的光学扫描仪来读取条形码。由于各种原因（例如，点阵打印机头已老化或激光打印机出现墨粉污点），可能导致条之间的白色窄间隔太窄，从而使中低分辨率的光学扫描仪无法检测出来。另外，激光打印机打印出的线条也可能会太细，超出光学扫描仪的光学分辨能力。因此，如果您计划打印高密度的条形码，建议您使用高分辨率的光学扫描仪。

低密度条形码和照片复制

使用低密度点阵条形码可以生成高质量的照相制版作品。如果以照相缩版方式缩小低密度条形码，点阵打印机中的单独点将消失，从而使其呈现使用高质量激光打印机打印的效果。

密度和 US Postnet 符号体系

如果指定了 US Postnet 符号体系，BarTender 将不允许您为条形码指定密度设置。此时，BarTender 将根据其高度自动确定条形码的密度。


条形码的高度

全部显示 全部隐藏

使用条形码属性页上的高度选项可以指定条形码中条的长度（即条形码顶边到底边的长度）。

最高条形码中条的长度不能超过页的全高。

最短条形码中条的长度不能小于 .001"。

更改条形码的高度

您可以使用 BarTender 通过两种方法更改条形码的高度，这两种方法与更改条形码密度所使用的方法类似。

鼠标方法：

  1. 单击要修改的条形码。

  2. 将指针光标放在条形码顶部或底部手柄上，单击并按住鼠标左键。

  3. 继续按住鼠标左键并拖动选定的手柄，直到条形码达到所需的高度。

  4. 松开鼠标键。

菜单方法：

  1. 双击要修改的条形码对象。这时，将显示修改所选条形码选项卡式对话框。

  2. 单击条形码属性页上的高度选项。

  3. 在编辑框中键入所需的高度值。

  4. 选择确定按钮。

指定短条形码的用户提示

如果要使用接触式扫描仪（如条形码读入器），请不要指定过短的条形码。如果条形码的条太短，将很难使用接触式扫描仪扫描，这是因为大多数人都无法在整个扫描过程中保持手部稳定，使扫描在条形码的边界内进行。如果要使用非接触式扫描仪（如移动光束扫描激光枪），将不会遇到此类问题。

高度和 US Postnet 符号体系

在为条形码指定了 US Postnet 符号体系后，高度选项的默认值将被设置为 0.125"（八分之一英寸）。对于 US Postnet 条形码中的长条来说，这是合适的高度。除非您需要打印较大的 US Postnet 条形码，然后通过照片缩版以缩小到适当的大小，否则，建议您不要修改该默认值。


“供人识读”属性页

全部显示 全部隐藏

条形码中的编码字符通常也会以供人识读的形式显示在条形码的下方。这样，如果条形码读取器不能正确读取数据（或未安装），数据输入人员就可以阅读供人识读字符，并使用键盘向计算机中输入信息。使用供人识读属性页上的选项，可以确切指定如何将这些供人识读字符随条形码一起打印（或是否打印这些字符）。

与条形码属性页相似，供人识读属性页也包含一个动态区域，该区域根据所选的条形码符号体系不同而显示不同的选项。有关供人识读选项的详细信息，请单击以下相应的选项名称。

供人识读选项

  • 可见性。用于指定条形码的供人识读字符是否可见。

  • 方位。用于指定是在条形码的上方还是下方打印供人识读字符。

  • 对齐方式。指定相对于条形码放置供人识读字符时使用的水平对齐方法。

  • 垂直偏移。用于指定供人识读字符与条形码之间的垂直距离。

  • 水平偏移。与对齐方式选项结合使用，以指定供人识读字符相对于条形码的水平位置。

  • 字符模板。用于指定条形码的供人识读文本中不属于要扫描的条形码数据字符串之列的额外字符。

符号体系特殊选项

  • 隐藏校验位。用于指定校验位（如果已启用校验位计算）是否随供人识读字符一起显示。（仅适用于 Code 39 — Full ASCII、Code 39 — Regular、Code 93、Code 128、Interleaved 2-of-5、UPC-A、UPC-E、EAN-8、EAN-13、MSI Plessey 和 Telepen。）

  • 隐藏纠错位。用于指定纠错位是否随供人识读字符一起显示。（仅适用于 Australian Post 4-State Customer Code。）

  • 拆分 UPC 数字。用于指定是否将 UPC-A 条形码中的前面和后面若干个供人识读数字与其它数字分隔开来。（仅适用于 UPC-A。）

  • 收缩 UPC 拆分数字。用于指定拆分后的 UPC 条形码中的前后若干个数字的打印格式是否小于其它供人识读字符。（仅适用于 UPC-A 和 UPC-E。）

  • Code 39 转换。用于指定是否用供人识读的字符显示 Full ASCII 条形码中文本字符的双字符表示法。（仅适用于 Code 39 — Full ASCII。）

  • 显示起始/终止字符。用于指定起始字符和终止字符的供人识读版本是否将随条形码消息一起打印。 （仅适用于 Code 39 - Full ASCII、Code 39 - Regular、Codabar 和 Telepen。）

  • UCC/EAN 模板。用于指定条形码的供人识读文本中的额外空格和圆括号配置。 （仅适用于 Code 128、RSS 和 Composite。）

  • 显示。用于指定 Composite 条形码中的供人识读部分。如果选择两者均可见，则二维组件中的数据将在一维组件的数据所在行的下面一行中单独显示。（仅适用于 Composite。）


供人识读字符的可见性

可见性

使用供人识读属性页上的可见性选项，可以选择是否在显示条形码的同时显示供人识读字符。下面将介绍三种可见性设置。

  • 完全。这是 BarTender 中默认的可见性选项设置，它指定供人识读字符随条形码一同显示。

  • 无。指定供人识读字符不随条形码一同显示。

  • 由数据源选项设置。指定供人识读字符是否可见由更多数据源选项对话框中常规选项卡上的用作供人识读字符时可见选项决定。要打开“更多数据源选项”对话框，请单击数据源属性页上的更多选项按钮。

尽管大多数条形码都是在启用了显示供人识读字符选项的情况下打印的，但有些情况下，不显示供人识读字符会更好。不显示供人识读字符的主要原因之一是能对已添加的数据起到安全保护作用。以用于考勤的员工 ID 卡为例。如果没有供人识读字符，一般人很难进入计算机，更别说手动输入信息甚至破坏数据库了。


供人识读字符的位置

使用供人识读属性页上的位置选项可以将供人识读字符放到条形码的下方或上方。供人识读字符的位置的默认设置是“条形码下方”。


供人识读字符的对齐方式

对齐方式

供人识读属性页上的对齐方式选项为您提供了四种对齐与条形码关联的供人识读文本字符的方法：左对齐、右对齐、居中和栏密度/等间距。

  • 左。供人识读字符打印时紧密相连，文本字符串中第一个字符的左侧与条形码中第一个条码的左侧完全对齐。

  • 右。供人识读字符打印时紧密相连，文本字符串中最后一个字符的右侧与条形码中最后一个条码的右侧完全对齐。

  • 居中。（默认设置。）供人识读字符打印时紧密相连，并且位于条形码两个边缘的正中间。

  • 栏密度。根据条形码的密度确定供人识读字符之间的间距。在条形码消息中，每个供人识读字符的左侧均与每个条形码字符的开始字符的左侧完全对齐。如果栏密度为可用选项，则等间距选项将不可用。

  • 等间距。沿着条形码的宽度等间距放置供人识读字符。供人识读字符的左侧和右侧分别与条形码的左侧和右侧完全对齐。如果等间距为可用选项，则栏密度选项将不可用。

注意：如果选中字符模板选项，或者使用的是 Australian Post 4-State 条形码而未选中隐藏纠错位选项，则对齐方式选项中的可用选项是等间距，而不是栏密度。


供人识别字符相对于条形码的垂直偏移

垂直偏移

供人识读属性页上的垂直偏移选项指定了供人识读字符与条形码之间的垂直距离。


供人识别字符相对于条形码的水平偏移

水平偏移

供人识读属性页上的水平偏移选项可以与对齐方式选项一起使用，以调整供人识读字符相对于条形码的水平位置。例如，您可能希望将文本字符串中第一个字符的左侧稍微向右移或向左移，而不是直接与条形码中第一个码的左侧对齐。

该选项的默认设置是 0.00 英寸。然而，您也可以输入正值（将字符向右移）或负值（将字符向左移）。


供人识读文本中的额外空格

条形码标签越来越需要在条形码的供人识读文本中打印额外字符，但这些字符并非待扫描的条形码的组成部分。例如，有些大型零售商店所需的 UCC-128 装运箱标签上使用的 Code 128 条形码要求在供人识读文本中加入额外的空格和圆括号。这些字符并非条形码的组成部分，因此条形码阅读器不会将它们读入计算机中。使用供人识读属性页上的字符模板选项可以指定这些额外字符及其在数据字符串中的位置。下图显示了标签可能需要的数据类型的简单示例（本例中为商店中商品的价格）。

条形码包括数字数据字符串“1099”。

字符模板选项中的每个问号均表示实际条形码数据字符串中的一个字符。$ 符号和小数点表示将出现在供人识读字符（而非条形码）中的额外数据。


隐藏供人识读字符中的校验位

隐藏校验位

（这是符号体系特定的选项，仅适用于以下符号体系：Code 39 — Full ASCII；Code 39 — Regular、Interleaved 2-of-5、UPC-A、UPC-E、EAN-8 和 EAN-13。）

使用供人识读属性页上的隐藏校验位选项，可以选择是否显示条形码的供人识读字符中的校验位。该选项的默认设置是隐藏校验位，因此，在正常情况下，供人识读的校验位字符不会与其它的供人识读字符一起显示。如果您希望校验位与其它供人识读字符一起显示，只需单击该复选框以取消激活该选项。

有关校验位的详细信息，请务必阅读校验位选项的帮助主题。


隐藏供人识读字符中的纠错位

隐藏纠错位

（这是符号体系特定的选项，仅适用于 Australian Post 4-State Customer Code。）

使用供人识读属性页上的隐藏纠错位选项，可以选择是否显示条形码的供人识读字符中的纠错位。如果您想隐藏纠错位，请单击此复选框。


拆分 UPC-A 第一位和最后一位供人识读字符

UPC 数字

（这是符号体系特有的选项，仅可为 UPC-A 启用。）

UPC-A 是一种十二位数的代码。第一位是“数字系统数字”，最后一位是“校验位”，中间十位数则包含实际的产品代码。之所以采用这种约定，是为了将第一位和最后一位与中间十位分隔或“拆分”开。不过，有些用户倾向于使用一种连续的十二位供人识读代码。

默认情况下，供人识读属性页上的拆分 UPC 数字选项是启用的，即指示 BarTender 自动将第一位和最后一位与中间十位拆分开。如果希望将供人识读字符作为一个连续代码打印出来，请单击此复选框，清除其中的“X”，禁用该选项。


转换 ASCII 字符的双字符表示法

Code 39 转换

（这是符号体系特定的选项，只为 Code 39 — Full ASCII 启用。）

使用供人识读属性页上的 Code 39 转换选项，可以指定是否用供人识读的字符显示 Full ASCII 条形码中文本字符的双字符表示法。

Code 39 — Full ASCII 和 Code 39 — Regular 符号体系的字符集中都包含同一个条形码字符集（共 43 个字符）。但是，为了能表示所有 128 个定界文本字符，Code 39 — Full ASCII 符号体系使用由该字符集中的 43 个字符构成的特殊双字符组合。除非您另行指定，否则 BarTender 在打印 Code 39 — Full ASCII 条形码的供人识读字符时，会自动将这种双字符组合转换为其表示的单个定界字符。

示例：

为了能用 Code 39 — Full ASCII 符号体系来将问号“?”编成条形码，BarTender 使用了双字符组合“%J”。在打印供人识读字符时，Code 39 转换选项的默认设置会指示 BarTender 将这种双字符组合自动转换成问号“?”。不过，如果因您取消选中了该选项而使 Code 39 转换的默认设置发生了更改，则条形码的供人识读字符中显示的就是百分比符号“%”和大写字母“J”。


显示供人识读字符中的起始和终止字符

显示起始/终止字符

（这是符号体系特定的选项，仅适用于以下符号体系：Code 39 — Full ASCII、Code 39 — Regular 和 Codabar。）

使用供人识读属性页上的显示起始/终止字符选项，可以指定是否在 Code 39 和 Codabar 条形码的供人识读字符中显示起始和终止字符。

对于 Code 39 — Full ASCII 和 Code 39 — Regular

普遍使用星号作为 Code 39 的起始和终止字符（二者实际上是同一个字符）。有些用户希望在供人识读字符中显示它们，有些用户则希望只显示条形码消息的数据部分。显示星号的唯一一个真正的好处是可以快速直观地确定使用的是否 Code 39。如果用户既要打印 Code 39，又要打印另一种条形码符号体系，那他会发现这一功能很有用。

BarTender 的默认设置是不打印 Code 39 — Full ASCII 或 Code 39 — Regular 条形码的起始和终止字符。如果确实希望起始和终止字符的供人识读表示符随条形码一起打印，请单击该复选框激活此选项。

对于 Codabar

由于在默认情况下 BarTender 禁用该选项（复选框中没有“X”字样），所以，在通常情况下，起始和终止字符不会随 Codabar 条形码中的其它供人识读字符一起打印出来。如果希望 BarTender 在打印 Codabar 条形码的同时还打印起始和终止字符，只需单击复选框激活此选项。


UCC/EAN 模板

有些大型零售商店所需的装运箱标签上使用的 UCC/EAN-128 条形码经常要求在供人识读文本中加入额外的空格和圆括号。某些 RSS 符号体系也使用这种特殊的格式。根据具体要求，这些额外字符的位置可以有所不同。UCC/EAN 模板选项的默认设置（“圆括号和空格”）规定的是这些额外字符的最常用配置。BarTender 还提供了其它一些设置供您选择。

设置 | 供人识读字符串样本
圆括号和空格（默认设置） | (00) 1 2345678 912345678 9
仅圆括号 | (00)123456789123456789
圆括号、空格和分隔符 | (00) 1 23 45678 912345678 9
无。当您的应用指定不在供人识读字符串中添加其它字符时，请选择该设置。当您需要在供人识读字符串中添加字符且该选项的任何其它设置中未指定这些字符时，也可以选择该设置。之后，您就可以使用 BarTender 的标准字符模板选项来添加这些附加字符了。 | 00123456789123456789

注意：供人识读字符串中额外圆括号和空格的位置可能会与所示样本中的稍有不同，具体取决于条形码上的应用标识符和数据字段。


打印方法选项

使用打印方法选项对话框中的选项，可以指定在使用感热打印机时如何打印条形码。单击修改所选条形码对象对话框的条形码选项卡上的打印方法按钮，可以打开该对话框。仅当 Seagull Scientific, Inc. 提供的 Windows 感热打印机驱动程序被指定为活动打印机驱动程序时，该按钮才可用。几乎在任何情况下，默认设置均为最佳设置，因而一般不必更改此选项。

  • 打印机控制的条形码和供人识读文本。使用打印机内置的条形码和文本功能，以最高的速度打印条形码。

  • BarTender 控制的条形码和供人识读文本。虽然该设置可为条形码和供人识读文本提供最佳的所见即所得打印，但会降低标签打印的速度（有时非常明显，特别是在使用串口的情况下）。这是由于条形码将转换为位图，并以位图形式传递给打印机，而不是使用打印机内置的条形码功能。

  • 打印机控制的条形码和文本由 BarTender 控制。使用打印机内置的条形码功能高速打印条形码，但您仍然可以选择最好的字体来打印供人识读文本。（默认设置。）


编辑文本对象

编辑文本对象的最佳方法取决于它是否包含多个子串。

如果对象不包含多个子串 …

单击主工具栏上的编辑按钮 [image] ，然后就像对待 Windows 中的任何文本框一样单击要编辑和设置格式的文本对象。（对于复杂的文本格式，包括添加制表位、自动调整文本框的大小等，通过单击主工具栏上的选择按钮 [image] 更改为箭头光标。右键单击文本对象，并从下拉菜单中选择属性以打开修改所选文本对象对话框。根据需要使用字体和文本选项卡。您还可以更改数据源选项卡上的内容。）

注意：如果文本对象已被旋转或伸展，则在该对象处于编辑模式时将出现它的临时水平和未伸展的副本。这使您在编辑时可以更容易地看到执行情况。在您退出编辑模式（通过在对象外的地方单击，或者按下 ESC 或 SHIFT+ENTER 键）后该临时副本将消失，并且所做更改将保存到旋转或伸展后的对象中。

如果对象包含多个子串 …

  1. 如果光标已不是一个箭头，则单击主工具栏上的选择按钮 [image] 。

  2. 右键单击文本对象，并从下拉菜单中选择属性以打开修改所选文本对象对话框。

  3. 打开数据源选项卡。

  4. 单击高级按钮。

  5. 在子串列表上突出显示您要更改的子串。

  6. 在屏幕数据子选项卡更改文本。

注意：如果您单击主工具栏上的编辑按钮 [image] ，然后单击包含多个子串的文本对象，则修改屏幕数据对话框将打开。


添加特殊字符

有时，您可能希望在标签中添加特殊字符，如注册符号或版权符号。若要将不在键盘上的特殊符号放入文本对象中，必须使用 Windows 附带的字符映射表附件将其复制到剪贴板中，然后将其粘贴到文本对象中。

注意：如果您要在标签中添加某些复杂的符号，如标准提醒、警告和危险材料符号；或者要添加标准电气、包装、纺织品或工业工作场所符号，可能会在 BarTender 附带的某个特殊符号字体中找到您需要的复杂符号。这些复杂符号未包含在字符映射表附件中。

若要添加特殊字符，请执行以下步骤：

  1. 单击开始按钮。

  2. 定位到字符映射表。它就在附件下或附件的某个子菜单中。

  3. 滚动查看可用字体列表并选择所需字体。

  4. 双击需要的特殊符号。

  5. 单击复制将副本放入剪贴板中。

  6. 单击关闭并返回 BarTender。

  7. 或者将符号直接粘贴到标签中，从而创建一个新的对象；或者双击相应的文本对象，然后使用 Ctrl-V 组合键将符号粘贴到所需文本对象中。

重要提示：常用特殊符号位于大多数可读字符集中（例如，在 Arial、Times New Roman 和其它字符集中可以找到版权符号和注册符号），并且可以放入使用相同字体的常用文本对象中。但是，如果您使用某个符号集（如 Wingdings 或 Symbols；或者 BarTender 附带的某个特殊符号字体）中的特殊符号，则需要将该符号放入文本对象内的单独子串中，因为一个子串无法支持多种字体。如果您使用的是感热打印机，并且文本对象设置为代之以最匹配的打印机字体，将需要对特殊符号使用 TrueType 字体；否则，将代之以最匹配的符号。


特殊符号字体

全部显示 全部隐藏

BarTender 提供 Seagull Scientific, Inc. 的几种特殊 True Type 符号字体，使您只需键入字母或数字，而不必导入或链接到图形文件，就能在标签上放置某些复杂的符号。由于这些符号是字体字符，而不是图像，所以您可以像对待其它 True Type 字体一样，将它们放大或缩小。

若要将这些符号之一放在您的标签，请创建一个文本对象，在选择字体时选择所需的特殊字体，然后按表示该符号的按键。根据需要调整字体大小。

注意：当为使用这些字体之一的文本对象打开修改所选文本对象对话框的数据源选项卡时，屏幕数据框将显示字母而非特殊符号本身。这样是为了让您能够核实键入的字母，因为如果在屏幕数据框中显示符号，会因太小而看不清楚。

单击下面的字体名称，打开包含字体符号以及相应按键的表。

Seagull ADR

ADR（European Agreement Concerning the International Carriage of Dangerous Goods by Road，国际危险货物陆路运输的欧洲协议）

Seagull 电气

Seagull 紧急情况

Seagull 危险材料

Seagull 徽标

Seagull 包装

Seagull 油漆

Seagull 废品回收

Seagull 风险用语

Seagull 纺织品保养

Seagull 警告


“字体”属性页

全部显示 全部隐藏

使用字体属性页上的选项可以设置标签上打印文本的格式，包括条形码的供人识读字符的大多数特性。随 Windows 提供的所有 TrueType 字体均适用于 BarTender。其中包括 Arial（类似于 Helvetica）、Courier New、各种样式的 Times New Roman、Symbol 以及其它字体。此外，BarTender 还提供了两种最适合光学字符识别的 True Type 字体（OCR-A 和 OCR-B），以及多种表示特殊符号的 True Type“字体”，包括标准提醒、警告和危险材料符号，以及包装、电气、纺织品和工业工作场所符号。

TrueType 字体是完全可伸缩的，这意味着您可以随意指定文本大小。它是一种特别简单易用的系统，因为屏幕上所显示的始终与打印时所输出的完全相同。而且，使用 TrueType 时，若要更换新打印机，不必重新选择或安装新型字体。您可以随意更换打印机（甚至可以互换点阵打印机与激光打印机），而无须调整字体类型规格。

可以从修改所选条形码对象或修改所选文本对象选项卡式对话框中显示字体属性页。

有关字体选项的详细信息，请单击以下相应的选项名称。

字体选项

  • 字体。用于指定标签上文本的字体集。若要按类型（基于打印机、True Type 等等）对字体排序，请单击对话框底部附近的按类型对字体排序复选框。

  • 字体样式。用于指定是在标签上打印常规文本、粗体文本还是斜体文本。

  • 字体大小。用于指定标签上文本的字体大小。

  • 替换最匹配的打印字体。用于指定 BarTender 将所选的 TrueType 字体替换为感热打印机内置的一种字体。（仅适用于感热打印机。）

文本效果选项

  • 删除线。用于指定是否在标签上打印删除线文本。

  • 下划线。用于指定是否将在标签上打印下划线文本。

  • 黑底白字。用于指定是否在标签上打印颜色反转文本。

  • 比例。用于指定压缩或伸展文本对象的程度。

注意：如果启用自动调整大小选项，则文本属性页的自动调整大小子选项卡上的最大比例值将覆盖此值。

  • 颜色。用于指定文本对象的颜色和条形码对象的供人识读字符的颜色。

脚本选项

从下拉列表中选择所需的脚本。脚本是一种规则或一系列密切相关的规则。

另请参见：

添加特殊字符

特殊符号字体


文本字体集

字体

字体属性页上的字体选项用于指定当前选中的文本对象或子串将使用的字体集。字体“集”是字体的一个相关组，通常有不同的大小。

Windows 附带的可供 BarTender 使用的一些字体包括 Arial、Courier New、Symbol 和 Times New Roman。您的 Windows 系统上可能安装了其它字体，这些字体也可供 BarTender 使用。

BarTender 包括 Seagull Scientific, Inc. 提供的两种字体 OCR-A 和 OCR-B，它们常用于条形码标签上。此外，BarTender 还包含多种 Seagull Scientific 提供的 特殊符号“字体”，这些字体常用在标签上，不论标签是否使用条形码。它们包括标准提醒符号、警告符号和危险材料符号，以及工业车间、电气、包装和纺织品保养中使用的符号。

注意：您可以使用 BarTender 来创建 RFID 字体。如果在字体选项中使用这类字体，则文本对象不会打印出来。而是将该对象中的数据编码为 RFID“智能标签”。有关详细信息，请单击此处。


字体样式

通过使用字体属性页上的字体样式选项，可以为标签上的文本指定常规、斜体、粗体或粗斜体等字体样式。


文本的大小

使用字体属性页上的字体大小选项可以为所选条形码对象或文本对象指定文本的字体大小。字体大小选项由一个有滚动条的列表框组成，以便您可以快速更改文本的指定大小。可以指定整字体大小和半字体大小。但不能指定其它分数的字体大小。

您还可以使用鼠标来更改文本对象的字体大小。单击选中相应的文本对象后，再次单击该对象的一个手柄，然后按住鼠标键拖动该手柄，直到文本达到所需的大小。此时，随着光标移动将出现一个淡淡的虚线框，它表示文本的新大小。当文本对象的虚线框显示为所需的大小时，松开鼠标按钮，BarTender 将以文本的新大小刷新文本。


替换最匹配的打印字体

注意：该选项只有在使用感热打印机进行打印时才可用。

Windows TrueType 字体技术使得感热打印机可以打印以前只有在 PostScript 激光打印机上才可用的设计人员字体。但是，在感热打印机上，TrueType 字体通常是作为图形来操作和打印的，而图形的下载和打印速度可能非常慢，而在通过串行端口进行打印时，这种情况尤其突出。

提高打印机速度

启用替换最匹配的打印字体选项后，选定的 TrueType 字体将在打印时被与其最为接近的内置打印机字体替换。根据标签格式复杂程度的不同，这可能会大大提高标签的打印速度，尤其是目标文本因标签不同而变化的情况下，这种改善会更为突出。

第一次开始设计标签时，如果已选定了感热打印机，那么您创建的任何文本字段都将自动设置为打印机的内置字体。在这种情况下，字体替换将不会起作用。但是，如果在您开始设计标签时选择的是激光打印机或另一个品牌的感热打印机，那么除非您启用了字体替换，否则文本将以 TrueType 字体打印出来。因此，TrueType 字体替换功能使得您可以单独设计一种标签样式，并在多个品牌的感热打印机上高速打印该标签，而不必分别针对每一种特定的打印机设计该标签。

打印时 TrueType 字体警告

如果标签格式上的一个或多个对象设置为使用 TrueType 字体进行打印，那么在打印作业开始时，您会收到 TrueType 字体警告。TrueType 字体通常作为图形来操作和打印，而图形的下载和打印速度可能非常慢。使用此对话框中的设置可以指定 TrueType 字体在打印时是否被与其最为接近的内置打印机字体替换。根据标签格式复杂程度的不同，这可能会大大提高标签的打印速度，尤其是目标文本因标签不同而变化的情况下，这种改善会更为突出。


给文本加删除线

使用字体属性页上的删除线选项可以指定标签上的文本对象在打印出来时是否在文本上带删除线。这样，您便可以在显示文本的同时，指示该文本可能在将来的某个时间从标签格式中删除。


带下划线的文本

使用字体属性页上的下划线选项可以指定是否对标签上特定对象的文本加下划线。


黑色背景上的白色字符

黑底白字

通过使用字体属性页上的黑底白字选项，可以指定是否以相反的样式（黑色背景上的白色字符）显示和打印标签上特定对象的文本。


比例

要拉伸只包含一行数据的文本对象，最简单的方法就是在屏幕上使用鼠标和文本对象的手柄。在屏幕上拉伸文本对象后，可以使用字体属性页上的比例选项，确切地查看一下与正常情况相比文本对象的变形程度。

您还可以在比例选项中直接输入值，指定水平压缩或拉伸文本对象的系数。所有文本对象的默认设置为 100%。但是，您可以根据需要加大或减小此数字。如果数字大于 100，则将拉伸文本；如果数字小于 100，则会压缩文本。

重要提示：

当使用鼠标或比例选项拉伸文本对象时，切记以下几点。

  • 在 BarTender 中可以拉伸 TrueType 和 PostScript 字体。但不能拉伸设备字体，如感热打印机或热传输打印机中内置的字体。

  • 当您指定一个比例值时，只是输入一个大概值。Windows 将向您提供现有的最接近的拉伸值。

  • 对于段落文本对象，不可以使用屏幕手柄来拉伸文本。但可以使用手柄来加大和减小段落本身的宽度。要压缩或拉伸段落中实际文本的大小，必须使用字体属性页上的比例选项。


标签的文本属性页

文本属性页

在不改变默认文本对象的情况下，如果在 BarTender 中创建文本，则将生成单行文本对象。但是，只要将文本放到标签上，就可以赋予各种不同的格式特性，包括将多行文本换行成为段落，或将一行文本弯曲成圆弧形状。

注意：此处提到的格式特性是指文本正文的整体形状，而不是指字体本身的特性，如粗体、斜体、字体字样和字号。有关后者的详细信息，请参见字体属性页。

文本属性页上的选项随您指定的文本类型不同而有所不同。有关可用选项的说明，请单击下面相应的类型。

类型

  • 单行 。指定对象的文本显示为一行。

  • 段落。指定当数据量超过一行时，对象的文本将换行成为多行。

  • 圆弧（仅限 TrueType）。指定对象的文本将弯曲成圆弧形状。


单行文本

当在文本属性页上为类型指定单行时，对于所显示的选项将有两个子选项卡。

  • 使用自动调整大小子选项卡可以指定是否应动态调整行的大小，以便恰好放入文本对象的手柄所标记的矩形中，相关信息详见自动调整大小以适合于矩形。

  • 使用制表位子选项卡可以在文本中设置制表位。


自动调整单行文本的大小

此功能位于修改所选文本对象对话框的文本选项卡的自动调整大小子选项卡中。在文本对象上出现的数据在长度上变化很大，但必须始终适合每一标签上的某个区域时，该功能会很有用。这可以通过以下一种或全部方法实现。

  • BarTender 将会在打印标签时增减数据的字号，以使其适合于在矩形（由对象的手柄标记）内显示。

  • BarTender 将压缩或伸展每一字符的水平宽度，这样在打印标签时数据就适合在矩形中打印出来。默认情况下，这并不更改文本的高度（字体大小）。

单击自动调整大小可启用此功能。

  • 使用最小和最大字体大小选项可以确保数据的大小始终足以适合阅读，但又永远不会过大。如果字体必须始终保持固定大小（高度），则将这两项设置为相同值。

注意：在此处设置的值将会覆盖在字体属性页上设置的字体大小。

  • 使用最小和最大比例选项可以确保数据永远不会被压缩或伸展到无法阅读的大小。如果字母相对于字体大小必须保持其标准宽度，则将这两个值设置为 100%。

注意：如果文本对象数据过长，压缩到设定的最小大小限制值也无法完全放置于矩形内，则会将其截断。

注意：在此处设置的值将会覆盖在字体属性页上设置的比例值。

  • 使用 Horizontal Alignment（水平对齐）选项可以选择文本是沿矩形的左侧对齐、右侧对齐还是居中对齐。

  • 使用 Vertical Alignment（垂直对齐）选项可以选择文本是沿矩形的顶部对齐、底部对齐还是垂直居中对齐。


设置制表位

使用制表位子选项卡可以为文本对象设置制表位。

选择制表位将启用此功能。

  • 默认制表位。此处设置的值决定了各制表位之间以及边距与第一个制表位之间的距离。

  • 自定义。使用此框可以在默认制表位之外添加更多的制表位。

若要添加制表位，请在该框中输入一个值，然后单击设置。

若要删除某个制表位，请突出显示该制表位，然后单击删除。

若要删除所有自定义制表位，请单击全部删除。


段落文本

当在文本属性页上为类型指定段落时，使用显示的选项可以指定段落的对齐方式、宽度、制表位以及行间距，并且可以启用可选的自动调整大小功能。

还可以将段落文本功能与 BarTender 的其它功能结合起来使用。例如，段落文本的一个非常常见的用途是从某个地址记录中提取各个字段，并将这些字段组合成一段以便打印在地址标签上。通过将这些字段组合成一个段落，并使用更多数据源选项对话框的常规选项卡上的不打印，如果选项，可以避免当地址记录中包含空字段时在标签上打印空行和空格。有关如何进行此项操作的更多信息，请参见不打印子串。

如果将段落选定为文本类型，文本属性页上将出现下列子选项卡。有关其中各个选项的更多信息，请单击相应的子选项卡名称。

  • 常规。用于设置段落的对齐方式、宽度和缩进。

  • 自动调整大小。用于启用和配置自动调整大小功能。

  • 制表位。用于配置段落中的制表位。

  • 间距。用于指定段落的行间距以及段落上下的额外前导行。

子选项卡下面的窗口示例显示了所选选项的效果。


常规段落选项

使用常规子选项卡可以设置段落的对齐方式、宽度和缩进。页面底部的样本会显示您选择的选项将产生的结果。

  • 对齐方式选项用于指定段落中文本的对齐方式是左对齐、居中、右对齐或两端对齐。子选项卡的下面显示了样本。

  • 段落宽度。更改所选段落宽度的最简单方法是用鼠标拖动所选段落的左手柄或右手柄。不过，您也可以使用此“段落宽度”选项。段落的默认宽度设置为两英寸，不过您可以在 0 到 60 英寸（如果您使用的是公制单位，则为 0 到 152.4 厘米）的范围内指定任意宽度。

  • 缩进。在此，您可以选择（无）、首行或悬挂。对于后两个选项，需要在右侧的框中输入值。


自动调整段落大小

此功能位于修改所选文本对象对话框的文本属性页的自动调整大小子选项卡中。在段落文本对象上出现的数据在长度上变化很大，但必须始终适合每一标签上的某个区域时，该功能会很有用。BarTender 将会在打印标签时增减数据的字号，以使其适合于在矩形（由对象的手柄标记）内显示。

单击自动调整大小可启用此功能。

  • 使用最小和最大字体大小选项可以确保数据的大小始终足以适合阅读，但又永远不会过大。如果字体必须始终保持固定大小（高度），则将这两项设置为相同值。

注意：如果即使文本对象数据以最小字体大小显示，也无法完全放置于矩形内，则会将其截断。

注意：在此处设置的值将会覆盖在字体属性页上设置的字体大小。

  • 使用 Vertical Alignment（垂直对齐）选项可以选择文本是沿矩形的顶部对齐、底部对齐还是垂直居中对齐。


段落行距

行距

使用间距子选项卡，可以指定段落中行与行之间的垂直间距，以及段落前后额外的前导行（如果有的话）的行数。

  • 行距。默认设置为单行，不过，您可以指定两倍、三倍或自定义。如果选择“自定义”，请在右侧框中输入您希望的行与行之间的间距。

  • 段前。用于在段落前添加额外的前导行，以行或某度量单位计。

  • 段后。用于在段落后添加额外的前导行，以行或某度量单位计。

注意：段落与段落之间的距离将为段前值与段后值之和。


圆弧文本

当在文本属性页上为类型选项指定圆弧时，使用显示的选项可以指定弯曲的文本将如何显示在标签上。

下面概要介绍了各个圆弧选项。有关更多信息，请单击相应的选项名称。

  • 参考点。用于指定文本将自动根据文本与标签中心的距离弯曲，还是根据文本与将随同对象一起移动的某个点的距离弯曲。

  • 半径。用于通过指定参考点与文本的距离来调整曲率。

  • 参考角。用于围绕参考点旋转文本。

  • 方向。用于指定文本将顺时针显示（文本底部正对中心）还是逆时针显示（文本底部逆对中心）。

  • 对齐方式。用于指定对象中的文本将放置在对象的左边缘或右边缘，还是在左边缘与右边缘之间居中放置。


参考点

参考点选项指定圆弧文本将围绕其弯曲的基准点，并且是度量半径选项的起点。文本的曲率由文本与参考点的距离（半径）决定。文本与参考点距离越近，曲率越大。

  • 使用标签中央。指定将从标签的中心开始度量半径。

  • 使用位置页标。指定将从随同对象一起移动的点开始度量半径。该点是通过使用鼠标移动对象来指定的，或者也可以使用该对话框的位置选项卡上的选项来指定某个点。


半径

半径选项确定了圆弧的参考点与文本之间的距离。它还确定了圆弧的曲率。半径越小，文本将与参考点越接近，并且曲率越大。


参考角

使用参考角选项可以围绕参考点旋转圆弧文本。


方向

使用方向选项可以指定文本将正对参考点还是逆对参考点。

  • 顺时针。指定文本的底部将正对参考点。

  • 逆时针。指定文本的底部将逆对参考点。


对齐方式

将圆弧文本放置在标签上时，“半径”和“参考角”选项定义一条从参考点延伸至文本的假想线。使用对齐方式选项可以指定文本相对于这条假想的半径线的对齐方式。

  • 左。指定文本的左边缘将从假想的半径线的外侧端开始。

  • 中。指定文本将在假想的半径线的外侧端居中（默认设置）。

  • 右。指定文本的右边缘将在假想的半径线的外侧端终止。

下图显示了相对于假想线而言的对齐方式设置。


RFID Property Page

Show All Hide All

The RFID property page can be used to modify the properties of the RFID object.

Options on the RFID property page are summarized below.

Note: Options not supported by the current printer will be grayed or not present at all.

  • Tag Type. Used to select the RFID tag type. All tag types supported by the current printer are listed.

  • Printer RFID Properties. Used to open the printer driver's RFID properties dialog.

Data Location

Use these options to specify what part of the transponder should be programmed at print-time and whether the programming will be protected from later reprogramming.

  • Segment. Used to specify which segment of the RFID tag the printer should program at print-time. The options you see will depend on what is supported by the printer and the tag type. See the specification of the tag type for details on the different segments. Segments not programmed at print-time can be programmed at some other time.

  • Start Block. Used to specify the block in the tag where the printer will begin writing information. A block is a set of bits, typically eight. Some tag types reserve certain blocks, so it is necessary to specify the block at which the printer should begin. BarTender will suggest a starting block. You should change this only if you are thoroughly familiar with the specifications of your tag type.

  • Write Protect Blocks. Used to ensure that the RFID object's data cannot be changed after the printer has programmed it. Not all tag types support this feature.

Data Format

Use these options to specify how data will be encoded.

  • Type. Used to specify the data format type. The choices that appear on the list will vary depending on the tag type.

Note: Whenever the data format type is changed, the pattern of substrings in the Substring List is changed to match the selected type.

Table of Current Format Types

This table lists the current data format types. See below for how you can support new EPC data formats released since BarTender's release.

Format

Required Data

Remarks

SGTIN-64 and SGTIN-96

Filter Value;Company Prefix;Item Reference;Serial Number

Some 96-bit formats have fields that vary in length depending on a parameter called the "partition value." The driver calculates the required partition value automatically based on the provided company prefix; it should not be provided in the data.

SSCC-64 and SSCC-96

Filter Value;Company Prefix;Serial Reference

SGLN-64 and SGLN-96

Filter Value;Company Prefix;Location Reference;Serial Number

GRAI-64 and GRAI-96

Filter Value;Company Prefix;Asset Type;Serial Number

GIAI-64 and GIAI-96

Filter Value;Company Prefix;Individual Asset Reference

GID-96

General Manager Number;Object Class;Serial Number

DOD/UID-64 and DOD/UID-96

Filter Value;CAGE;Serial Number

For DOD formats, the CAGE ignores the current encoding and expects data to be supplied as ASCII text.

To support future EPC formats, you can select Custom to create a formatting scheme in the Scheme box that appears. A scheme is a string that expresses the sizes (and sometimes the data) of the fields in the data stream. Field sizes are measured in bits and fields are separated with semicolons. If the data for a particular field should always be the same when initially programmed, then a colon should follow the field size and the mandatory data should follow the colon. For example, "8:8;10;32" describes a three-field scheme. The first field, the header, is 8 bits long and has an immediate value 8 (this is a specification requirement and cannot be set by the user). The second field has 10 bits and the last has 32 bits, both values that can be set by the user.

Once you have created a custom scheme, use the Advanced view of the Data Sources tab to create substrings for every field that has variable data. Do not create a substring for any fields with constant data. Constant data includes the header and partition fields and BarTender will insert data into these fields automatically. In the first example above, you would not create a substring for the first field because the ":8" tells BarTender that it is a constant field that always contains "8".

  • Input. Used, with a custom data format type, to determine how the printer driver will process the data before it programs it to the RFID tag. The options available will vary by printer. They may include any of these:

    • Hexadecimal. The printer driver will treat the character data as hexadecimal numbers and convert them to binary numbers.

    • Decimal. The printer driver will treat the character data as decimal numbers and convert them to binary numbers.

    • Binary. The printer driver will treat the character data as a series of "0"s and "1"s, each expressed with a whole character, and convert them to binary numbers, so that each "0" and "1" is expressed with a single bit.

  • Text Encoding. Used to specify what writing system BarTender should convert the data into before it sends it to the printer.

See Also:

Understanding RFID


图片属性页

全部显示 全部隐藏

图片属性页包含多个选项，通过这些选项，您可以选择要导入的图片及导入方式，调整图片大小以适合标签，以及确定 BarTender 在打印时找不到原始图片文件的情况下将如何响应。(BarTender 支持以下图片类型：BMP、DXF、EPS、GIF、IMG、JPG、PCD、PCX、PNG、TGA、TIF、WPG 和 WMF。这些格式中，最后一种不能旋转。）

当您初次使用导入图片按钮将图片插入到标签格式时，BarTender 最初将插入默认的图片，即导入图片按钮的副本。此默认图片只是充当标签格式上的占位符。直到您双击该默认图片，并使用图片属性页为此图片对象分配一个有效的图片文件后，才会出现可打印的图片。

若要调整图片的位置，可以使用鼠标或位置属性页上的选项。

图片源选项

  • 类型。用于指定 BarTender 如何将图片导入到标签格式中。使用此选项，您可以嵌入或链接图片，也可以从外部数据文件读取图片。

下面列出的选项位于图片属性页的动态区域 中，并将根据您选择的类型而显示或隐藏。在每个选项后面列出了各个选项所适用的源类型。

  • 选择图片。用于指定要插入到标签格式中的图片文件（仅限内嵌式图片和链接式图片）。

  • 文件名。用于指定要导入到标签格式中的图片的路径和文件名（仅限链接式图片）。

  • 默认路径。用于指定存储外部数据库中所引用图片的文件夹（仅限数据源图片）。

  • 选择路径。使用鼠标指定默认路径，而不使用默认路径选项来键入默认路径（仅限数据源图片）。

图片尺寸选项

  • 大小调整方式。用于确定是否可以在标签视图区域中调整图片的大小，以及在可调整大小的情况下如何调整图片大小。

  • 保持长宽比。用于启用或禁用按比例调整大小的功能。

  • 高度和宽度。按原始图片大小的百分比调整图片大小，或使用精确的高度和宽度度量值。

打印时错误处理方法选项

  • 如果图片未找到。确定在预期的文件夹中找不到链接式图片或数据源图片时，BarTender 将如何处理标签。

Effects

  • Mirror Horizontal If checked, flips the picture about a horizontal axis.

  • Mirror Vertical If checked, flips the picture about a vertical axis.

步骤：

将图片导入标签格式中


导入图片的三种不同方式

使用图片属性页上的图片源类型选项，可以通过三种不同的方式将图片导入到标签格式中。内嵌式图片是通常最易使用，但有些情况下，另两个选项之一可能更适合您的需要。(BarTender 支持以下图片类型：BMP、DXF、EPS、GIF、IMG、JPG、PCD、PCX、PNG、TGA、TIF、WPG 和 WMF。这些格式中，最后一种不能旋转。）

注意：如果您需要的是标准提醒符号、警告符号或危险材料符号，则可能不必导入图片。在 BarTender 所附带的特殊符号字体中提供大多数此类符号。在这些“字体”中还包括用于包装、纺织品、电气材料和工业场所的符号。

图片源类型：

  • 内嵌式图片

由于内嵌式图片成了标签格式的永久组成部分，所以即使原始图片文件被移动、删除或重命名，标签格式中的图片也仍不变。这是最易用也最常用的图片源类型。嵌入图片。

  • 链接式图片

采用链接式图片时，BarTender 仅存储图片文件的路径和名称，而不存储实际的图片。当您打印标签格式时，BarTender 将自动更新打开的副本。因此，如果图片文件经常要更改，链接是一种省时的嵌入图片的方式。链接外部图片。

  • 数据源图片

使用数据源图片，BarTender 可以通过引用数据源文件中的字段来打印各种图片。例如，假定您有一个数据库，您经常要为其中有些部分打印标签，如果指定该数据库中的某字段引用图片文件，然后从 BarTender 引用该字段，那么您就可以给数据库中的每条记录打印每个标签的不同的图片。从数据文件读取图片。有关如何设置数据库的信息，请参见正确设置数据库。

注意：与内嵌式图片不同，当图片为链接式或数据源图片时，BarTender 会查找存储在特定位置的图片文件。对于链接式图片，如果原始图片文件已改变，BarTender 将更新标签视图区域中显示的图片，随后还会更新打印在标签上的图片。但如果原始图片文件被移动、删除或重命名，BarTender 就找不到它，图片也就变为空白。对于数据源图片，BarTender 会在数据库中搜索被引用的图片文件。对于这两种类型的图片，如果 BarTender 找不到图片文件，它会向您发出警告。有关其它信息，请参见处理找不到的图片。


嵌入图片

注意：如果您需要的是标准提醒符号、警告符号或危险材料符号，则可能不必嵌入图片。在 BarTender 所附带的特殊符号字体中提供大多数此类符号。在这些“字体”中还包括用于包装、纺织品、电气材料和工业场所的符号。

注意：此过程假定您已将默认图片放置于标签格式上并且访问了修改所选图片对话框。

  1. 保持将类型选项设置为内嵌式图片，按下选择图片按钮以显示选择图片对话框。

  2. 文件类型选项的默认设置“所有图像文件”将指示 BarTender 显示可用于当前指定目录的所有图片文件。

  3. 如果需要，您可以通过单击“所有图像文件”右侧的箭头以打开可用图片文件类型下拉列表，将图片列表限制为特定的图片文件类型。然后选择所需的图片类型。

  4. 如果该图片文件名尚未列在查找范围选项正下方的框中，并且当前磁盘驱动器盘符不正确，则使用查找范围选项以选择其它磁盘驱动器。接下来，在查找范围选项下的列表中，在包含图片文件的文件夹名称上双击。继续双击，直到打开包含所需图片文件的子文件夹。

  5. 在您要导入的图片文件的名称上双击。BarTender 使您自动返回选择图片对话框。

  6. 单击确定将关闭该对话框并可以查看标签上导入的图片。

  7. 在将图片放置于标签视图区域后，可以使用鼠标或位置属性页上的选项根据需要确定图片的位置。

过程：

将图片导入标签格式中

另请参见：

创建标签对象

特殊符号字体


链接图片

注意：如果您需要的是标准提醒符号、警告符号或危险材料符号，则可能不必链接图片。在 BarTender 所附带的特殊符号字体中提供大多数此类符号。在这些“字体”中还包括用于包装、纺织品、电气材料和工业场所的符号。

注意：此过程假定您已将默认图片放置于标签格式上并且访问了修改所选图片对话框。

  1. 单击“内嵌式图片”右侧的箭头，然后从下拉列表中选择“链接式图片”。这时，选择图片按钮将移到右侧，而文件名文本框在该按钮的左侧显示。

  2. 键入图片文件的路径和名称，或单击选择图片按钮。

  3. 在选择图片对话框中，如果使用文件类型选项的默认设置“所有图像文件”，BarTender 将显示当前指定目录中的所有可用图片文件。要在特定图片文件格式列表中查看或选择文件格式，请单击“所有图像文件”右侧的下箭头，然后从下拉列表中选择文件格式。

  4. 在查找范围字段，单击包含该图片文件的驱动器。然后，在查找范围字段正下方的列表框中，双击包含该图片文件的文件夹名称。继续双击，直到打开包含所需图片文件的子文件夹。

  5. 在您要导入的图片文件的名称上双击。

  6. BarTender 使您自动返回选择图片对话框。单击确定关闭该对话框，然后查看标签上的所选图片。

过程：

将图片导入标签格式中

另请参见：

“创建”菜单

特殊符号字体


从数据文件读取图片

注意：此过程假定您已将默认图片放置于标签格式上并且访问了修改所选图片对话框。

  1. 单击“内嵌式图片”右侧的箭头，然后从下拉列表中选择“数据源图片”。请注意数据源属性页的新选项卡。选择路径按钮取代了选择图片按钮，而且默认路径文本框在该按钮的左侧显示。

  2. 单击选择路径按钮来访问 Browse Folder（浏览文件夹）对话框。双击包含所需图片文件的驱动器、文件夹和子文件夹的名称。

  3. 单击确定按钮，返回到修改所选图片对话框。您也可以直接输入路径，而不必访问 Browse Folder（浏览文件夹）对话框，其方法是在默认路径文本框中键入路径。之后，默认路径文本框中就将显示您所键入的路径。

  4. 选择数据源选项卡，以显示数据源属性页。

  5. 单击来源右侧的箭头，以展开一个显示数据源选项的下拉列表。

  6. 选择数据库字段来读取存储在 ODBC 或 OLE DB 数据源、SAP IDoc 或文本数据文件中的文本。如果您已经使用数据库连接设置对话框来确定所要使用的数据文件，您将看到字段名选项。否则，您将看到使用数据文件字段 #选项。有关如何设置数据源文件的信息，请参见“帮助”中的主题数据库连接设置。

  7. 单击字段名右侧的向下箭头展开一个下拉列表，然后选择包含图片文件引用的字段。

  8. 选择确定。标签格式仍将显示默认图片。

  9. 从文件菜单中选择打印，以便使用数据文件信息设置要打印的标签格式。

  10. 在打印对话框中，选择记录选择下面的选项使用数据库。

  11. 单击关闭返回到标签格式，或单击打印来打印标签。

过程：

将图片导入标签格式中

另请参见：

正确设置数据库

创建标签对象


使用粘贴命令导入位图

使用粘贴命令从其它程序导入位图

重要提示：将图片导入标签格式的首选方法是使用创建图形图片按钮从文件导入图片。

位图是由单独的点组成的图像或图片。已经制订了许多具体的位图标准，以允许位图从一个程序传递到另一个程序。除了其它功能外，粘贴命令还可用于将在其它 Windows 程序中创建的位图放置于标签视图区域中。例如，您可以通过添加公司徽标或特殊绘图，使您的标签个性化。（BarTender 支持以下图片类型：BMP、DXF、EPS、GIF、IMG、JPG、PCD、PCX、PNG、TGA、TIF、WPG 和 WMF。这些格式中，最后一种不能旋转。）

将位图粘贴到标签视图区域：

  1. 运行已用于（或要用于）创建您的位图图像的 Windows 程序。

  2. 加载或创建图像。

  3. 选择图像并将其复制到剪贴板中。

  4. 退出程序或将程序最小化。

  5. 运行 BarTender 并打开您要向其中添加位图图像的标签格式。

  6. 单击编辑菜单中的粘贴命令，或单击主工具栏中的粘贴按钮。BarTender 会将位图粘贴到标签视图区域中。

注意：如果在下拉编辑菜单时 BarTender 的粘贴命令未启用，则用于创建位图并将其复制到 Windows 剪贴板的程序没有使用 BarTender 支持的剪贴板格式。在此情况下，将位图图像从您的程序导出到 BarTender 的创建图形图片功能支持的图形文件类型，然后使用同一功能将它导入到 BarTender。


选择图片

选择图片按钮仅可用于内嵌式图片和链接式图片，可帮助您找到和导入图片文件。（BarTender 支持以下图片类型：BMP、DXF、EPS、GIF、IMG、JPG、PCD、PCX、PNG、TGA、TIF、WPG 和 WMF。这些格式中，最后一种不能旋转。）选择选择图片按钮后将显示选择图片对话框，您可以使用该对话框来搜索所需的图片文件。


文件名

通过文件名数据输入框（仅链接的图片有此框），无须访问选择图片对话框既可输入所需图片文件的驱动器、文件夹和文件名。

要指定使用的文件名，只须在提供的数据输入框中键入路径和文件名。

如果需要查找图片文件的位置，可单击选择图片按钮，显示选择图片对话框。


默认路径

默认路径数据输入框只能用于数据源图片，通过此框可以告诉 BarTender 外部数据源中引用的图片文件的位置。您可以将此信息键入默认路径数据输入框中，或者使用选择路径按钮。

另请参见：

正确设置数据库


选择路径

选择路径按钮仅仅在数据源图片上可用，它帮助您找到存储数据文件中所引用的图片文件的驱动器和文件夹。当选择选择路径按钮时，将显示 Browse for Folder（浏览文件夹）对话框，在该对话框中，可以使用鼠标输入路径。

选择路径：

  1. 单击选择路径按钮显示 Browse for Folder（浏览文件夹）对话框。

  2. 双击相应的驱动器以显示该驱动器上可用的文件夹列表。

  3. 双击文件夹。

  4. 如果文件夹包含子文件夹，则继续双击，直到存储图片文件的文件夹打开。

  5. 选择了必要的路径后，单击确定返回图片属性页。图片文件的路径将出现在默认路径中。

另请参见：

正确设置数据库


调整图片大小

大小调整方式

使用图片属性页上的大小调整方式选项，可以确定是否能够调整图片大小以及怎样调整图片大小。

单击图片以选中它，请注意图片每侧和边角上显示的大小调整手柄。根据您在图片属性页上的图片尺寸选项中所做的选择，您可以访问部分或全部的大小调整手柄。

如果手柄是实心的，则可以抓住并拖动它，以便按比例调整图片大小或伸展图片。如果手柄是空心的，则无法用它来调整图片大小。

  • 原始大小。与图片文件中图像的高度和宽度保持相同的大小。

  • 原始大小的百分比。按原始大小的百分比调整图片大小。

  • 调整到方框大小。强制将图片大小调整到确切的尺寸。

另请参见：

保持长宽比

图片属性页


原始大小

原始大小可以使图片大小与从图片文件中导入的原始图像的大小保持一致。选中该项后，将无法以任何方式更改图片的大小。若要启用大小调整功能，请将此项更改为原始大小的百分比或调整到方框大小大小调整方法。


原始大小的百分比

使用原始大小的百分比可以按图片原始大小的百分比来增大或减小图片的大小。可以使用鼠标调整图片的大小，也可以在高度和宽度数据输入框中输入百分比。


调整到方框大小

调整到方框大小可以扩大或缩小图片，以强制图片在设定的区域内打印。在使用数据源图片时，该功能尤其有用。由于通过数据库链接到 BarTender 的图片大小各异，因此，调整到方框大小可以确保从数据库导入的图片仅以预设的大小进行打印，以适合标签的大小，而不是以原始大小打印。

可以使用鼠标调整图片的大小，也可以在高度和宽度数据输入框中输入实际值。


保持长宽比

保持长宽比可启用或禁用按比例调整大小的功能。

如果启用…

仅可使用图片上的边角手柄，而限制您使用鼠标按比例调整图片大小。还可以使用图片属性页上的高度和宽度按比例调整大小。由于大小是成比例的，因此您对高度所做的任何更改都将自动更改宽度中的值，反之亦然。

如果禁用…

图片上的所有手柄均可用，您可以根据需要使用鼠标来调整图片大小和伸展图片。也可以使用图片属性页上的高度和宽度来调整图片大小和伸展图片。


图片的高度和宽度

高度和宽度

高度和宽度用于按精确的尺寸或原始图片的百分比调整图片的大小。这里有两个数据输入框用于输入确切的高度和宽度，还有两个数据输入框用于输入百分比。根据所选的大小调整方式，BarTender 将启用或禁用部分或全部高度和宽度数据输入框。

大小调整方式 | 高度和宽度数据输入框
原始大小 | 禁用全部高度和宽度数据输入框。
原始大小的百分比 | BarTender 将启用高度和宽度的百分比数据输入框。
调整到方框大小 | BarTender 将启用高度和宽度的尺寸输入框。


处理找不到的图片

在链接图片或从外部数据文件导入图片时，BarTender 将查找硬盘或软盘上存储的图片文件。如果 BarTender 找不到打印时所需的文件，可以使用图片属性页上的打印时错误处理方法选项，指示 BarTender 如何处理该打印作业。

收到错误消息的原因：

  • 未指定有效的图片文件。

  • BarTender 在预期的位置找不到链接式图片文件或数据源式图片文件。

打印时错误处理方法选项：

  • 总是终止打印作业。指示 BarTender 在找不到图片文件时不打印标签。

  • 终止打印作业前总是询问。指示 BarTender 在找不到图片文件时发出通知。

  • 不终止打印作业。指示 BarTender 在找不到图片文件时继续打印。

另请参见：

正确设置数据库


Property Page

Box and Ellipse Property Pages

The Box or Ellipse property page can be used to modify the dimensions and other properties of the object.

Property page options are summarized below. For additional information, click on the appropriate option name below.

General

  • Width. Used to specify and/or display the horizontal dimension of the object.

  • Height. Used to specify and/or display the vertical dimension of the object.

  • Line Thickness. Used to specify the thickness of the lines that make up the object.

  • Line Color. Used to specify the color of the lines that make up the object.

  • Fill Color. Used to specify the fill color of the object.

Specific to Boxes

  • Corner Radius. Used to set the degree of rounding for the corners of a box.

Specific to Ellipses

  • Circle. Used to constrain height and width to form a circle.


Height

The easiest way to specify the height of a box, ellipse, (or a group box in Prompt Design) is to use your mouse. However, you can also specify height by entering a value into the Height option on the Box, Ellipse or Group Box property page. Both methods are described below.

Mouse Method:

(For greatest accuracy, make sure the Snap option in the View Options dialog is enabled.)

  1. Click on the object whose height you want to change.

  2. Position the pointer cursor over one of the object's top or bottom handles and click and hold down your left mouse button.

  3. Holding down your left mouse button, drag the selected handle until the object is the desired height.

  4. Release the mouse button.

Note: You can adjust both height and width at the same time using a corner handle. It is also possible to lock the aspect ratio by holding down the Shift key while resizing an object in the design area.

If you need to specify an exact height or the height of the object falls between the specified snap points of the ruler, you can enter an exact value into the Height option on the Box, Ellipse or Group Box property page using the following method.

Property Page Method:

  1. Double-click on the box whose height you want to change to display the Modify Selected Box or Modify Selected Ellipse tabbed dialog.

  2. Select the Height option on the appropriate property page.

  3. Type the desired height into the edit box.

  4. Click the OK button.

Note: When specifying the height of objects on your labels, if you specify a height that causes the object to extend out of the label viewing area only the portion of the object that is within the boundaries of your label will print.


Width

The easiest way to specify the width of a box or ellipse (or a group box in Prompt Design) is to use your mouse. However, you can also specify the width by entering a value into the Width option on the Box, Ellipse, or Group Box property page. Both methods are described below.

Mouse Method:

(For greatest accuracy, make sure the Snap option in the View Options dialog has been enabled.)

  1. Click on the object whose width you want to change.

  2. Position the pointer cursor over one of the object's left or right side handles and click and hold down your left mouse button.

  3. Continuing to hold down your left mouse button, drag the selected handle until the object is the desired height.

  4. Release the mouse button.

Note: You can adjust both height and width at the same time using a corner handle. It is also possible to lock the aspect ratio by holding down the Shift key while resizing an object in the design area.

If you need to specify an exact width or the width of the object falls between the specified snap points of the ruler, you can enter an exact value into the Width option on the Box, Ellipse, or Group Box property page using the following method.

Property Page Method:

  1. Double-click on the object whose width you want to change to display the Modify Selected Box or Modify Selected Ellipse tabbed dialog.

  2. Click the Width option on the appropriate property page.

  3. Type the desired box width into the edit box.

  4. Click the OK button.

Note: When specifying the width of objects on your labels, if you specify a width that causes the object to extend out of the label viewing area, only the portion of the object that is within the boundaries of your label will print.


线宽

The Line Thickness options on the Line, Box, and Ellipse property pages are used to specify the width of the lines on your label.

  • 默认设置为 .020 英寸。

  • 最小宽度为 .001 英寸。

  • 最大宽度为 14.0 英寸。


圆角半径

如果为圆角半径输入一个正数值，方框的角可以呈圆形。该值越大，方框的角就越圆。


Fill Interior

Interior of Box

The Fill Interior option on the Box or Ellipse property page is used to fill the currently specified object with a solid color. Black is the default solid color. However, you can use the Color dialog to change the object to any of the available colors.


更改对象的颜色

使用颜色控制可以指定标签上对象的颜色。例如，您可以使用修改所选方框对象对话框的默认选项卡来通过颜色控制更改方框的颜色。您还可以使用页面设置对话框背景选项卡上的背景色框来更改标签的背景色。

使用彩色条形码的注意事项：条形码扫描仪在读取条形码时，无法读取用大多数颜色打印的条形码，不过可以读取用黑色打印的条形码。因此，除非出于装饰需要，否则，建议您不要指定彩色条形码。

设置颜色：

  1. 单击颜色框中的箭头。如果标准颜色中有适合您需要的颜色，请单击该颜色即可。如果没有，请继续执行以下步骤。

  2. Click More Colors to display the Color selection menu.

  3. Click on one of the basic or custom colors shown in the menu to select it, or click Define Custom Colors to expand the menu and create a new custom color.

  4. 单击确定。

另请参见：

创建自定义颜色。介绍如何创建自定义的颜色。


Circle

The Circle option on the Ellipse property page is used to create a circle by setting the height and width to the same value. It is also possible to create a circle by holding down the Shift key while resizing or adding an ellipse object in the design area.


线条（标签上）属性页

修改所选线条对话框中的线条属性页可用于指定线条的端点位置，还可用来修改线条的长度、粗细程度以及颜色。

以下概述了线条属性页上的各个选项：

  • 点 1 和点 2 的 X 和 Y 坐标。用于指定线条的端点位置，该位置相对于标签的参考点（原点），而不是线条的参考点。标签参考点在高级位置设置对话框中设置。线条的参考点在修改所选线条对话框中的位置属性页上设置。不必使用本页的 XY 坐标即可确定线条的放置位置。如果愿意，可以使用位置属性页上线条的参考点坐标。

重要提示：标签参考点不同于对象参考点。有关两者之间的差别信息，请单击此处。

有关其余选项的详细信息，请单击以下相应的名称。

  • 长度。用于指定和/或显示线条的两个端点之间的距离。

  • 线宽。用于指定线条的粗细程度。

  • 颜色。用于指定线条的颜色。


线条的长度

指定线条长度的最简单方法是使用鼠标。然而，您也可以通过在线条属性页上的长度选项中输入值来指定线条的长度。下面将介绍这两种方法。

鼠标方法：

（为了获得最高的准确度，请确保启用查看选项对话框中的对齐选项。）

  1. 单击要更改其长度的线条。

  2. 将指针光标放在线条两端的其中一个手柄上，然后单击并按住鼠标左键。

  3. 继续按住鼠标左键并拖动选定的手柄，直到线条达到所需的长度。

  4. 松开鼠标键。

如果您需要指定线条的确切长度或线条位于标尺的指定对齐点之间的长度，则可以使用以下方法，在线条属性页上的长度选项中输入确切的值。

菜单方法：

  1. 双击要更改其长度的线条，以显示修改所选线条选项卡式对话框。

  2. 单击线条属性页上的长度选项。

  3. 在编辑框中键入所需的线条长度。

  4. 单击确定按钮。

在指定标签上的线条长度时，请记住，如果您指定的线条长度导致线条超出了标签视图区域，则只会打印线条在标签边界内的部分。


移动对象

移动（重新定位）对象

使用鼠标拖动对象，或在位置属性页的相应选项中输入值，可以移动对象。

注意：对象或对象组还可以在原地或围绕标签上的某个指定点旋转。

使用鼠标移动对象：

  1. 将指针光标放在要移动的对象上，然后单击并按住鼠标左键。

  2. 继续按住鼠标左键，将对象拖到所需的新位置。（在将对象拖过标签视图区域时，随着光标移动会在对象四周出现一个虚线框。）

  3. 当对象框位于所需的新位置时，释放鼠标按钮，BarTender 将在新位置重新绘制该对象。如果希望将对象移动到一侧，但与标签上下两侧的距离保持不变，或要将其上下移动，但与标签左右两侧的距离保持不变，请在拖动的同时按住 Shift 键。这可防止偏移。

使用“位置”属性页移动对象：

  1. 双击要移动的对象。该操作可选中该对象并自动显示该对象的选项卡式对话框。单击位置选项卡，显示位置属性页。

  2. 如果需要，更改对象的默认参考点“左上”。然后以标签参考点为原点，输入对象的参考点的 X 和 Y 轴坐标值。（您也可以根据需要单击高级按钮打开高级定位设置对话框来更改标签的参考点。（另请参见了解参考点。）

  3. 单击确定按钮。BarTender 将把对象移动到新指定的位置。

另请参见：

位置

了解参考点

对象的旋转


旋转对象

既可以就地旋转对象，也可以围绕标签中指定的某个点旋转对象。旋转可以通过以下几种方法来实现：

  • 使用鼠标。

  • 使用修改所选 … 对象对话框中的位置选项卡的旋转部分。

  • 使用旋转对话框。（此方法只能用于就地旋转对象。）


使用“位置”属性页确定对象的位置

当您需要指定某对象的确切位置坐标时，必须使用位置属性页。当位置坐标位于标尺的指定对齐点之间时，位置属性页上的选项尤其有用。当您想检查当前选定对象的确切位置时，也可以显示位置属性页。

位置

  • X 坐标：可用于指定对象参考点与标签参考点之间的距离（左或右）。如果对象参考点在标签参考点的左侧，则为负数。有关详细信息，请参见了解参考点。

  • Y 坐标：可用于指定对象参考点与标签参考点之间的距离（上或下）。如果对象参考点在标签参考点的上方，则为负数。有关详细信息，请参见了解参考点。

  • 对象参考点。用于选择对象的参考点。可用的选项有：

    • 对象的左上角

    • 对象的顶部居中

    • 对象的右上角

    • 对象的中部居左侧

    • 对象的中心

    • 对象的中部居右侧

    • 对象的左下角

    • 对象的底部居中

    • 对象的右下角

  • 高级按钮：使用该按钮可以打开高级位置设置对话框，从中可以选择标签的参考点。

旋转

  • 角。用于指定对象应围绕旋转点旋转的度数。对于线条、框和图片，可以从下拉列表中选择常用的度数，也可输入一个精确到十分之一度 (0.1) 的度数。对于所有其它类型的对象，则必须从下拉列表中选择 90°、180° 或 270°。

  • 高级按钮：使用此按钮可以打开高级旋转设置对话框，从中可以选择标签的旋转点。

注意：您还可以使用鼠标旋转对象，或使用排列菜单中的旋转对话框旋转对象。

另请参见：

了解参考点


常规属性页

常规属性页上的选项可用于指定标签格式上不应打印的对象。您还可以插入有关某个对象的详细说明。

以下概述了常规属性页上的各个选项：有关详细信息，请单击相应的选项名称。

  • 不打印对象。用于指定不应打印的标签对象。

  • 不显示在打印预览中。用于指定不应出现在打印预览中的标签对象。

  • 此对象的说明。用于指定标签对象的说明。


不打印对象

“不打印对象”和“不显示在打印预览中”

有时，标签格式上可能有一些您不想打印的对象，或您可能有一些不想打印的对象，但又希望能在打印预览中看到这些对象。

  • 此时，可使用不打印 [对象] 选项，指定在打印标签时不打印某些对象（或标签背景）。如果以后，您又想打印该对象，只需禁用不打印对象，就能将该对象打印出来。

  • 当您选中不打印对象选项后，系统会自动选中不显示在打印预览中选项，但您可以取消选中它，以便能在打印预览中看到该对象。


此对象的说明

有时，您可能希望为对象输入说明或其它信息，但不希望在标签上打印这些信息。使用此对象的说明选项可以为标签对象输入这类信息。选择标签对象后，输入的任何文本都将显示在状态栏的右侧。


Creating a Custom Color

To create a custom color you need to expand the Color selection menu to display the custom color controls. The expanded Color selection menu uses two color models that can be used to create custom colors. One model allows you to control the actual amount of red, green, and blue in the color that you are creating, while the other model allows you to control the hue, saturation, and luminosity of the color.

To create a custom color:

  1. From inside the Color selection menu, click on the custom color that you want to replace.

  2. Click on the Define Custom Colors button. BarTender will display the expanded Color selection menu.

  3. Enter the desired values into the edit boxes or drag the controls in the color chart and column until the desired color is displayed in the Color/Solid display box.

  4. Click on the Add to Custom Colors command button. The new color will replace the color that you specified in Step 1 and you can now select it in the same manner as any other color.

See Also:

Changing the Color of an Object


修改对象组

如果在标签视图区域中选择一个包含不同对象类型的组，而后单击修改菜单中的所选编组选项，则该组中每个对象类型的所有属性页（“数据源”除外）都会显示出来。由于条形码对象和文本对象的数据源必须按对象修改，即一次只能修改一个对象，因此不会显示数据源属性页，除非该组中只有一个条形码对象或文本对象。该条形码对象或文本对象还必须是所选主对象（组的所选主对象上的手柄是实心的，而不是空心的）。

例如，假定在标签视图区域中选择了一个条形码、一个线条和一个方框（其中条形码是所选主对象）。那么，选择了修改菜单中的所选编组选项后，修改所选对象选项卡式对话框顶部将显示以下选项卡：条形码、供人识读、字体、数据源、线条、方框和位置。

另请参见：

将对象编组

显示所选对象的属性


在标签格式设置会话期间修改默认设置

默认设置

每次您执行新建命令时，都启动新的标签格式并将 BarTender 的菜单选项重置为其内置默认设置。不过，一旦您开始处理新标签格式或现有标签格式后，就可以使用修改菜单中的默认对象选项更改将创建的对象的默认设置。这些修改后的默认设置基于每个标签格式提供，并且它们保存在标签格式中以供将来用于该标签格式中。


从数据库读取数据概述

从数据库读取数据

数据库是与特定主题或用途有关的信息集合，例如打印标签或条形码所需的信息类型。为打印标签或条形码，通常从外部数据文件（例如数据库）读取数据。若要了解外部数据文件和 BarTender 使用它们的方式的更多信息，请参见以下主题：

何时从外部数据文件中读取数据。

BarTender 可以读取的不同类型的数据库。

如何设置 BarTender 以读取数据库。


何时从外部数据文件中读取数据

若要从 BarTender 中打印简单标签，最快捷的方法是通过屏幕数据选项使用直接在标签格式中键入的数据。不过，很多更复杂的标签格式通常要求从数据源文件中读取将打印的部分或全部数据，而不是通过键盘键入数据。例如，在下列情况下，最好使用单独的数据文件。

  • 有多个标签要输出，并且某些数据因标签的不同而变化。

  • 需要使用数据库、电子表格或其它程序中的数据打印标签。


不同类型的数据文件

数据文件和数据源可分为几类：

  • OLE DB 数据源。OLE DB 是一项让 Windows 应用程序可以从所有主要数据库格式和电子表格格式中获取数据的技术。

  • ODBC 数据源。ODBC（Open Database Connectivity，开放数据库互连）技术的用途与 OLE DB 的相同，只不过比后者早些，所以与之兼容的数据库类型也少些。

  • SAP R/3 Intermediate Document (IDoc) 文件。SAP IDoc 是一种层次化结构的文本文件，可用来将数据从 SAP R/3 系统传递到 BarTender。

    •

  • 文本文件。已定界的文本文件或字段宽度固定的文本文件。

上面链接的主题详细介绍了这些数据文件类型。


了解 OLE DB

OLE DB 提供程序可以从数据库检索信息，然后将信息传递到请求该数据的应用程序，如 BarTender。每种类型的数据库（如 Oracle、Microsoft Access 等）都需要自己的提供程序。OLE DB 技术的用途与 ODBC 的类似，但比后者新，可与更广泛的专有数据库和数据类型兼容。

许多 OLE DB 提供程序都会在安装 Windows 时一并安装，另外一些可以从数据库供应商处获取。

注意：若要查看您的计算机上有哪些 OLE DB 数据源，请创建一个扩展名为“.udl”的纯文本文件。双击该文件，打开 Windows 数据链接属性对话框。单击提供程序选项卡查看提供程序列表。


了解 ODBC

ODBC 是 Open Data Base Connectivity 的缩写，表示开放数据库互连。ODBC 数据源是一组至少指定以下内容的配置信息：

  • 设计为从特定数据库格式读取数据的 ODBC 驱动程序。

  • 根据数据库格式，包含一个或多个表的目录或文件的名称。

  • 此信息集合的名称。

它是一种允许程序不必理解特定数据库格式的具体细节即可读取来自不同数据源的信息的功能。该功能是通过使用 ODBC 驱动程序实现的。因为有大量可用 ODBC 驱动程序，所以 BarTender 能够读取来自多种不同数据源的数据。这些数据源包括所有的主要数据库和电子表格格式，以及标准定界文本文件或字段宽度固定文本文件之外的文本文件。

通过将添加数据库连接向导 — 类型对话框的类型选项设置为“ODBC 数据源”，BarTender 可以从您具有其 ODBC 驱动程序的任何数据源导入数据。尽管使用命名的 ODBC 数据源并不要求具备 ODBC 或 ODBC 管理器的高级知识，但理解 ODBC 的基本知识可以使您工作起来更顺利。

另请参见：

了解 ODBC 驱动程序

选择已命名 ODBC 数据源

了解 ODBC 数据源管理器

设置特定于数据文件类型的 ODBC 参数


什么是 SAP

什么是 SAP R/3

SAP™ R/3（Systems, Applications, and Products in Data Processing，即数据处理中的系统、应用程序和产品）是位于德国法兰克福的 SAP AG 开发的企业级可自定义工作流程序。它设计用于使大型企业中的所有核心流程自动进行，这些流程包括订单处理、供应链、库存管理、订单实现和客户服务，可供世界各地的中型和大型企业使用。

SAP 成功的关键是其强大的集成功能，这些功能使完全不同的第三方程序和不兼容的数据库可以彼此交换信息。BarTender 使用其中一种名为中间文档 (IDoc) 的集成技术，将您公司的任何与 SAP 连接的数据库中的数据打印到标签上。

SAP 是 SAP Aktiengesellschaft 的商标。


了解 IDoc

IDoc（中间文档）是从与 SAP 连接的程序发送到其它程序的事务型消息，该消息采用文本文件形式。

IDoc 消息的大部分内容由组合成几段的数据字段组成。各段之间彼此具有层次关系。

示例：医生为医院患者所开的药方需要交到医院的药房处。这可以通过从临床程序发送到药房中的程序的 IDoc 来实现。假定 IDoc 具有由四个级别的段构成的层次结构：

患者姓名：Johnson

诊断结果：喉炎

诊断结果：胫骨骨折

就诊类型：入院

药名：可待因

药名：阿米酚

就诊类型：随访

药名：甲氧基甲基萘乙酸

第 1 级：包含保存一次后将保持若干年不变的数据，如患者姓名和住址。

第 2 级：包含在特定疾病过程中保持不变、但因疾病而异的数据，如主治医师和诊断结果。特定的患者可能有多个处于第二级的段。

第 3 级：包含特定就诊过程中保持不变、但因每次就诊而异的数据；如就诊类型（入院或复查）和主治医师。患者可能在一次疾病过程中多次就诊。

第 4 级：包含因药方而异的数据，如开药方的医师、用药和剂量。特定患者的某次特定就诊的药方中可能包含多种药物。

另请参见：

IDoc 类型和段定义

将 IDoc 树转换为平构记录


IDoc 类型和段定义

由于 IDoc 是一种消息，因此发送和接收程序都必须符合这样一条通用惯例：即在给定的 IDoc 中，从哪些位置可以找到各部分数据。迄今为止，SAP AG 已定义了数百种 IDoc 类型以及大量的段类型。

发送程序必须根据这些定义构造给定类型的 IDoc，而接收程序（以此为例）在对 IDoc 进行语法分析时必须符合这些定义。这意味着，确定语法分析器文件是设置 BarTender 来使用 IDoc 中数据的其中一步。

IDoc 类型的名称由六个字母和两个数字组成。SHPMNT01 是包含有关装运消息的 IDoc。SAP 时常修改 IDocs 的定义，名称末尾的两个数字标识了修订的版本号。

段名称可能以三个数字的版本号结尾。例如，E2KNA1M001 是 DEBMAS02（客户控制）IDoc 类型的段。

SAP 所有者可以创建自己的自定义 IDoc 类型和段类型。

由 SAP AG 定义的段名称始终以“E”开头，而自定义设计的段名称始终以“Z”开头。


分析器文件

IDoc 类型的分析器文件包含 BarTender 分析 IDoc 所需要的信息；例如，其中将出现哪些段、哪些段是可重复的、哪些数据字段将出现在每一段中、字段的顺序，以及每个字段的长度。

应在 IDoc 类型定义窗口将分析器文件与特定的 IDoc 类型相关联。


将 IDoc 层次数据转换成平构记录

由于子段中的数据总是与其父段中的数据相关联，因此对于 IDoc 中某树的任何非分支路径，从顶部节点到底部节点这一段都可以被视为一个像面向表的数据库中的记录一样的记录。

以下列数据层次结构为例，为简单起见，其中每一段都只包含一个字段：

患者姓名：张 |  |  |
 | 诊断结果：喉炎 |  |
 | 诊断结果：胫骨骨折 |  |
 |  | 就诊类型：入院 |
 |  |  | 药名：可待因
 |  |  | 药名：阿米酚
 |  | 就诊类型：复查 |
 |  |  | 药名：甲氧基甲基萘乙酸

患者张曾在不同时期接受过针对喉炎和胫骨骨折的治疗。（第一种疾病没有详细的记录。）第一次因骨折去医院就诊时，医生开了可待因和阿米酚两种药品。而第二次，医生开了甲氧基甲基萘乙酸。

胫骨骨折和甲氧基甲基萘乙酸药方的路径可以折叠为如下平构记录：

患者姓名 | 诊断结果 | 就诊 | 药名
张 | 胫骨骨折 | 复查 | 甲氧基甲基萘乙酸

其它两个完整路径则可以折叠为以下记录：

患者姓名 | 诊断结果 | 就诊 | 药名
张 | 胫骨骨折 | 入院 | 可待因
张 | 胫骨骨折 | 入院 | 阿米酚

BarTender 在读取 IDoc 时，会将数据树折叠为平构记录。您将可以从这些记录中选择标签上所需的字段。

另请参见：

主段


主段

对于可能从 IDoc 数据层次结构中生成的每一条记录来说，并非都需要一个标签。您可以配置 BarTender，使其在打印时只选择某些记录，而对于一些从 IDoc 提取数据的标签格式，即使在典型情况下也不要求得到所有可能生成的记录。BarTender 使用“主段”这个概念来帮助您仅生成您需要从 IDoc 生成的记录。

主段的定义如下：就标签需要而言，主段中的数据是我们最看重的数据。BarTender 将为 IDoc 中您指定为“主段”的每一个段各生成一条记录。

以了解 IDoc 帮助页中显示的数据树为例。如果医院需要为所开的每一种药物都生成一个标签，则它可以将“主段”设置为第四级。于是，BarTender 就将生成三条记录：

患者姓名 | 诊断结果 | 就诊 | 药名
张 | 胫骨骨折 | 入院 | 可待因
张 | 胫骨骨折 | 入院 | 阿米酚
张 | 胫骨骨折 | 复查 | 甲氧基甲基萘乙酸

假定医院将患者每次就诊时的文件都分开保管，并希望生成一些标签来供文件夹使用。患者每次就诊时仅需一个标签。在这种情况下，可以将“主段”设置为第三级，而 BarTender 将生成两条记录：

患者姓名 | 诊断结果 | 就诊 | 药名
张 | 胫骨骨折 | 入院 | 可待因、阿米酚
张 | 胫骨骨折 | 复查 | 甲氧基甲基萘乙酸

在第一条记录中，BarTender 包括了“主段”级别之后的“药名”字段，并将该较低级别的段中的所有数据都堆放在一起。（有关详细信息，请参阅“重复段规则”窗口。）

由于 BarTender 将为“主段”的每一个实例生成一条记录，所以可以得出如下有关确定“主段”的经验：

通常在运行从此 IDoc 生成的标签时，我希望为每一个（次）_____________生成一个标签。

在上面的示例中，如果在空白处填写“就诊”，则第三级可能是最佳的“主段”级选择，而如果在空白处填写“药名”，则最好选择第四级。


SAP IDoc 定义文件

SAP IDoc 定义文件是一个列表，其中包含当前可用于 BarTender 的 IDoc 类型，以及当前与各个类型关联的默认 IDoc 文件、别名以及分析器文件。

无论何时添加、修改或删除 IDoc 类型，SAP IDoc 定义文件都会被修改。

BarTender 安装后，将该定义文件设置为 <安装目录>\SAP\default.itd。若要切换到另一个 IDoc 定义文件，请选择工具菜单中的管理设置，然后使用 SAP IDoc 类型定义文件部分中的选择按钮浏览至新文件。

在 BarTender 安装到另一台计算机上后，应更改 SAP IDoc 定义文件，以便与运行 BarTender 的其它计算机使用相同的 SAP IDoc 定义文件。

另请参见：

了解 IDoc

IDoc 类型和段定义


将应用程序设置为从数据库读取数据

将 BarTender 设置为从数据库读取数据

若要将 BarTender 设置为从数据库读取数据，可以使用添加数据库连接向导和数据库连接设置对话框中的选项卡式对话框。添加数据库连接向导用于添加数据库。选项卡式对话框用于修改、浏览、连接、排序数据库、创建 SQL 语句以及创建数据库的别名。通过所有数据库树视图（位于数据库连接设置对话框的左侧），用户可以访问所有可用的数据库、表和字段，进行查看、修改、查询以及 SQL 语句操作。数据库连接设置对话框可以下列方式访问：文件菜单、数据库连接设置按钮 [image] 、修改数据源选项卡或打印对话框。


如何启动“数据库连接设置”对话框

您可以使用以下方法之一显示数据库连接设置对话框。（如果您以前尚未设置数据库，则添加数据库连接向导将打开。）

从“文件”菜单或主工具栏

单击主菜单栏上的文件可以访问文件菜单；然后单击数据库连接设置。或者单击主工具栏上的数据库连接设置按钮 [image] 。

从“打印”对话框

单击主菜单栏上的文件可以访问文件菜单；然后单击打印。从打印对话框中，单击数量选项卡，然后单击数据库连接设置按钮。

从“数据源”选项卡

当数据源属性页上的来源选项被设置为“数据库字段”时，将显示数据库连接设置按钮。单击此按钮可以显示数据库连接设置对话框。

从工具箱的“数据源”窗格

右键单击工具箱的数据源窗格的数据库字段组，从下拉菜单中选择数据库连接设置。


“数据库连接设置”对话框

全部显示 全部隐藏

使用数据库连接设置对话框可以设置一个或多个打印时要读取的数据库。BarTender 将从数据库读取记录并这些数据传递到正确配置的标签对象上。

  • 所有数据库树视图。这是对话框最左侧的区域，它显示数据库、表和字段的视图，该视图具有像树一样的层次。

  • 添加。添加新数据库。使用该命令可以显示添加数据库连接向导。

  • 删除。删除所选数据库或表。

“数据库连接设置”选项卡

这些选项卡的显示取决于在“所有数据库树”中所选的项。根据具体情况，将显示以下一个或多个选项卡：

  • 表。用于在所选 ODBC 数据库中查看、添加或删除表。

  • 查询。指定所选数据库中要打印的记录必须满足的条件。

  • 排序。对所选数据库中的所选字段排序。

  • SQL。用于为所选 ODBC 或 OLE DB 数据源编写自定义 SQL 语句。

  • 主段。用于设置 SAP IDoc 的主段。

    •

  • 选项。指定所选数据库的各种选项。

  • 状态。显示树视图中所选项的状态。

  • 浏览。查看树视图中所选项的记录数据。


添加数据库连接向导

使用添加数据库连接向导可以设置 BarTender 打印标签格式时要从中读取数据的数据库。您始终可以通过单击数据库连接设置对话框上的添加按钮来添加数据库。根据您设置的配置选项不同，所显示的页面也有所差异。完成该向导后，将打开数据库连接设置对话框。

另请参见：

数据库连接设置

了解 ODBC

了解 OLE DB


添加数据库连接向导 - 类型

添加数据库连接向导 — 类型

类型对话框提供了以下数据库选项。

  • Microsoft Access。一个通用的桌面关系型数据库应用程序，BarTender 可以使用 OLE DB 提供程序来读取。提供程序属于中间件，BarTender 可以使用它来读取专有数据库。

  • Microsoft Excel。一个通用的电子表格应用程序，BarTender 可以使用 OLE DB 提供程序来读取。

  • Microsoft SQL Server。一个通用的基于服务器的关系型数据库应用程序，BarTender 可以使用 OLE DB 提供程序来读取。

  • Oracle。

    • 一个通用的基于服务器的关系型数据库应用程序，BarTender 可以使用 OLE DB 提供程序来读取。此选项使用 Microsoft 的提供程序访问 Oracle。如果您更愿意使用 Oracle 的提供程序，请从 Oracle 的网站下载该提供程序，然后选择其它提供程序，并按下一步。

  • 常规 OLE DB 提供程序。具有相应 OLE DB 提供程序的任何数据库应用程序。

  • 通用数据链接 (UDL) 文件。BarTender 与 OLE DB 提供程序进行通信的替代方法。

    • 如果您要使用某个 OLE DB 数据源，但希望将连接信息存储在单独的文件（而不是标签格式文件）中，则可选择此选项。如果还有其它应用程序也要访问同一个 OLE DB 数据源，则此选项非常有用。所有此类应用程序都可以使用同一个 UDL 文件。

  • ODBC 数据源。任何支持 ODBC（Open Database Connectivity，开放数据库互连）的数据库应用程序。ODBC 是一种应用较早的方法，BarTender 通过它可以访问专有数据库。通过 ODBC 或 OLE DB 技术可以访问许多主要的数据库类型。单击下一步，然后在向导中的下一页上选择特定 ODBC 数据库类型。

  • SAP 中间文档 (IDoc) 文件。一种特殊结构的文本文件，可保存来自 SAP R/3 系统中任何来源的数据。

  • 文本文件。此类别包括定界文本文件和具有固定宽度字段的文本文件。

  • IBM Informix. This option will only be visible if the IBM Informix OLE DB Provider is available on your system.

另请参见：

了解 OLE DB

了解 ODBC

了解 SAP IDoc

了解文本文件数据


添加数据库连接向导 - 选择 Access

添加数据库连接向导 — 选择 Access 数据源

使用此对话框可以选择 Access 数据源或 Excel 数据源。可以使用两种方法实现此操作。

  • 方法 1：直接在此对话框中输入所需的信息：

    • 文件名。在框中输入数据库名称，或浏览到该数据库。

    • 用户名和口令。如果数据库要求登录，请在相应的框中键入用户名和口令。

    • 将用户 ID 和口令保存到格式。不能关闭此选项。该选项将用户 ID 和口令与标签格式一起保存。

    • 测试连接。单击此按钮可以验证 BarTender 能否访问数据库。

  • 方法 2：单击高级按钮可以打开 Windows 数据链接属性对话框，在此可以输入数据库和安全信息。有关详细信息，请单击该对话框上的帮助按钮。

另请参见：

了解 OLE DB


添加数据库连接向导 - 选择 Excel

添加数据库连接向导 — 选择 Excel 数据源

使用此对话框可以选择 Excel 数据源。可以使用两种方法实现此操作。

  • 方法 1：直接在此对话框中输入所需的信息：

    • 文件名。在框中输入数据库名称，或浏览到该数据库。

    • 测试连接。单击此按钮可以验证 BarTender 能否访问数据库。

  • 方法 2：单击高级按钮可以打开 Windows 数据链接属性对话框，在此可以输入数据库和安全信息。有关详细信息，请单击该对话框上的帮助按钮。

另请参见：

了解 OLE DB


添加数据库连接向导 - 选择 MS SQL Server

添加数据库连接向导 — 选择 MS SQL Server 数据源

使用此对话框可以选择 Microsoft SQL Server 数据源。可以使用两种方法实现此操作。

  • 方法 1：直接在此对话框中输入所需的信息：

    • 服务器。键入服务器名称。

    • 数据库。键入数据库名称。

    • 使用 Windows NT 集成安全性。如果启用此选项，则只要运行 BarTender 的计算机上的当前用户具有访问服务器和数据库的权限，BarTender 就能够访问该数据库。

    • 使用特定用户名和口令。选择此选项将启用“用户名”和“口令”文本框。

    • 用户名和口令。如果希望 BarTender 登录到数据库，请在这些框中输入用户名和口令。

    • 将用户 ID 和口令保存到格式。选中该选项会将用户 ID 和口令与标签格式一起保存。

    • 测试连接。单击此按钮可以验证 BarTender 能否访问数据库。

  • 方法 2：单击设置按钮可打开 Windows 数据链接属性对话框，在此可以输入数据库和安全信息。有关详细信息，请单击该对话框上的帮助按钮。

另请参见：

了解 OLE DB


添加数据库连接向导 - 选择 Oracle

添加数据库连接向导 — 选择 Oracle 数据源

使用此对话框可以选择 Oracle 数据源。可以使用两种方法实现此操作。

  • 方法 1：直接在此对话框中输入所需的信息：

    • 服务器。键入服务器名称。

    • 使用 Windows NT 集成安全性。如果启用此选项，则只要运行 BarTender 的计算机上的当前用户具有访问服务器和数据库的权限，BarTender 就能够访问该数据库。

    • 使用特定用户名和口令。选择此选项将启用“用户名”和“口令”文本框。

    • 用户名和口令。如果希望 BarTender 登录到数据库，请在这些框中输入用户名和口令。

    • 将用户 ID 和口令保存到格式。选中该选项会将用户 ID 和口令与标签格式一起保存。

    • 测试连接。单击此按钮可以验证 BarTender 能否访问数据库。

  • 方法 2：单击高级按钮可以打开 Windows 数据链接属性对话框，在此可以输入数据库和安全信息。有关详细信息，请单击该对话框上的帮助按钮。

另请参见：

了解 OLE DB


添加数据库连接向导 - 选择常规 OLE DB 提供程序

添加数据库连接向导 — 选择常规 OLE DB 数据源

使用此对话框可以选择 OLE DB 数据源。

  • 提供程序。从列表中选择 OLE DB 提供程序。

  • 连接设置。单击此按钮可打开 Windows 数据链接属性对话框，在此可以输入数据库和安全信息。有关详细信息，请单击该对话框上的帮助按钮。

  • 测试连接。单击此按钮可以验证 BarTender 能否访问数据库。

另请参见：

了解 OLE DB


添加数据库连接向导 - UDL 文件

添加数据库连接向导 — UDL 文件

使用向导中的这一页可以选择或创建一个 UDL（Universal Data Link，通用数据链接）文件，以存储 BarTender 连接到 OLE DB 数据源所需的信息。

  • UDL 文件名。在框中输入 UDL 文件的路径和名称，或浏览到该文件。

  • 新建。单击此按钮可以新建一个 UDL 文件。此时将打开一个 Windows 数据链接属性对话框，在此可以选择提供程序并配置数据库和安全信息。有关详细信息，请单击该对话框上的帮助按钮。单击确定后，将打开一个 Windows 另存为对话框，供您保存 UDL 文件。

  • 编辑。在框中输入一个 UDL 文件后，单击此按钮可编辑该文件。此时将打开 Windows 数据链接属性对话框，在此可以配置数据库和安全信息。有关详细信息，请单击该对话框上的帮助按钮。

另请参见：

了解 OLE DB


添加数据库连接向导 - ODBC 数据源

添加数据库连接向导 — 选择 ODBC 数据源

使用此对话框可以选择或创建 ODBC 数据源。有关选择 ODBC 数据源的信息，另请参见这些分步指导。

  • 类型。选择三种现有数据源类型之一：

    • 用户数据源。只有当前已登录的用户才能访问的本地数据库。

    • 系统数据源。网络上具有所需权限的任何用户都可以访问的本地数据库。

    • 文件数据源。位于网络上任何位置的数据库。

  • 数据源列表或输入 DSN 文件名文本框。如果选择用户数据源或系统数据源作为类型，则将显示数据源列表。单击所需的现有数据库。如果选择文件数据源作为类型，则将显示输入 DSN 文件名文本框。输入数据源的路径和文件名，或单击选择文件按钮，然后浏览到该数据源。

  • ODBC 管理器。单击此按钮可打开 ODBC 管理器，在此可以创建新数据源或修改现有数据源。

  • 表类型。单击它可打开表类型对话框，在此可以指定可用的表类型。

在正确选择或创建 ODBC 数据源后，可以通过指定数据源名称（而不是数据库文件或位置）来访问各个数据库。

另请参见：

设置特定于数据文件类型的 ODBC 参数

了解 ODBC


选择已命名 ODBC 数据源

如果您已创建了命名的 ODBC 数据源，则可以按如下所示选择它：

  1. 从文件菜单中选择数据库连接设置选项。这将显示数据库连接设置对话框。如果您以前尚未为该标签格式指定数据库，则添加数据库连接向导 — 首页也将显示。

  2. 若要显示添加数据库连接向导 — 首页，请单击数据库连接设置对话框上的添加按钮。

  3. 在添加数据库连接向导 — 首页中，单击下一步>。

  4. 从添加数据库连接向导 — 类型对话框中，选择“ODBC 数据源”。然后单击下一步>。

  5. 在添加数据库连接向导 — 选择数据源中，从类型下拉列表中选择三种 ODBC 数据源类型中的一种。

如果您选择文件数据源，则单击选择文件按钮并浏览到 DSN 文件。

如果您选择用户数据源或系统数据源，则从数据源列表中选择一个可用的数据库。

然后单击下一步>。

  6. 从添加数据库连接向导 — 选择表中，指定您要使用的可用表。然后单击下一步>。

  7. 如果您选择了多个表，则需要通过添加数据库连接向导 — 连接对话框连接这些表。

  8. 一旦您选择了表并创建了连接后，单击完成。


了解 ODBC 数据源管理器

在 ODBC Data Source Administrator（ODBC 数据源管理器）对话框中，可以执行以下操作：添加、修改或删除 ODBC 用户数据源；指定数据源文件的位置；指定 OBDC 驱动程序；创建用于跟踪错误的 ODBC 驱动程序调用日志，以及通过相应的选项卡使用连接池。

  • 用户 DSN。存储数据源名称和驱动程序信息。现有的用户数据源将显示在用户数据源列表框中

  • 系统 DSN。添加或删除数据源，或用系统 DSN 设置数据源。这些数据源是计算机本地的，而不是某用户专用的。系统或任何具备权限的用户都可以使用通过系统 DSN 设置的数据源。

  • 文件 DSN。添加或删除数据源，或用文件 DSN 设置数据源。这些是基于文件的数据源，任何用户只要安装了相同的驱动程序而有权访问该数据库，就可以共享这些数据源。这些数据源不必一定是某用户专用的数据源，也不必是计算机的本地数据源。

  • 驱动程序。显示有关已安装的 ODBC 驱动程序的信息。ODBC 驱动程序列表列出了所用计算机上已安装的驱动程序。

  • 跟踪。用于指定 ODBC 驱动程序管理器跟踪 ODBC 功能调用的方式。驱动程序管理器可以持续跟踪调用，即只针对一个连接；可以执行动态跟踪；还允许由自定义跟踪 DLL 执行跟踪。

  • 连接池。用于更改所选驱动程序在使用连接池时的连接重试等待时间以及连接超时时间。还可以启用和禁用性能监视，从而记录连接的统计信息。

  • 关于。提供有关 ODBC 管理器组件的版本信息。

另请参见：

设置特定于数据的 ODBC 参数

选择已命名 ODBC 数据源

修改现有已命名的 ODBC 数据源


数据库连接设置 - 连接表

数据库连接设置 — 连接表

连接表对话框用于在一个表中的字段与另一个表中相同数据类型的字段之间创建关联关系。连接将指示 BarTender 数据关联的方式。

  • 左表。从该下拉菜单中，可以选择要指定的表。

  • 左字段。通过此下拉菜单，可以从“左表”中选择要指定的字段。

  • 运算符。从此下拉菜单中，选择定义左表中的字段与右表中的字段的关联关系的运算符。

  • 右表。从此下拉菜单中，选择要与“左表”中指定的表相关联的表。

  • 右字段。从此下拉菜单中，选择要与“左字段”中指定的字段相关联的字段。

  • 连接类型。选择左表与右表及其相应的字段之间的连接类型。

在添加多个表时，BarTender 将自动创建一个默认内部连接，该内部连接将从所有表中（其中，同名和同类型字段中的值都相等）选择记录。使用 BarTender 可以创建内部连接、左外部连接、右外部连接和完全外部连接。

当第一次打开该对话框时，BarTender 将推测应该在以下列出的各单元格中填入哪些最适合的表名和字段名。如果您进行了更改，但又希望恢复为 BarTender 的原始推测值，请单击生成连接表按钮。


连接类型

使用此对话框，可以选择要执行的连接类型。连接之间的差异与以下情况相关：右表或左表中的记录在相对的表中没有匹配记录。连接类型对话框本身就清楚地说明了连接类型之间的差异。

连接类型

  • 内部连接。

  • 左外部连接。

  • 右外部连接。

  • 完全外部连接。


用于 IDoc 的添加数据库向导

通过添加数据库连接向导，您可以逐步骤完成向可用于 BarTender 的数据库池添加 SAP IDoc 数据库的全部过程。

  1. 在添加数据库连接向导 — 类型窗口中，选择单选按钮 SAP R/3 Intermediate Document (IDoc) File，然后单击下一步>。

  2. 在 添加数据库连接向导 — 选项窗口中，选择用于绘制标签数据的 IDoc 类型和 IDoc 文件。如有必要，可以添加、修改或删除 IDoc 类型。在您完成后，单击下一步>。

  3. 在添加数据库连接向导 — 主段窗口中，选择主段，然后单击下一步>。

  4. 在添加数据库连接向导 — 字段窗口中，选择您要绘制数据的 IDoc 上的字段。如果您选择了重复段上的任何字段，则要为每一此类字段设置重复段规则。

  5. 单击完成。

现在，数据库添加过程即完成，并且将返回到数据库连接设置窗口。在可用于 BarTender 的数据库的树视图中，现在将在所有数据库下有一个称为 SAP 数据库的子数据库。

另请参见：

了解 IDoc


IDoc 的“选项”选项卡

IDoc 的“数据库连接设置选项”选项卡

使用该窗口可以识别 IDoc 类型和特定的 IDoc 文件。

选择 IDoc 类型定义

  • 名称下拉列表。用于选择要使用的 IDoc 类型。

  • 添加/删除。用于添加、修改和删除 IDoc 类型定义。

IDoc 文件（可选）

  • 名称文本框。使用该框可以指定 BarTender 将从中获取数据的特定的 IDoc 文件。（IDoc 文件是从 SAP 系统获取的。）

注意：如果所选 IDoc 类型有与之关联的默认文件，则该文件应该已列在 IDoc 文件文本框中了。您可以更改该文件。

  • 浏览。用于找出 IDoc 文件。

另请参见：

了解 IDoc

主段


“IDoc 类型定义”窗口

使用此窗口可将其它 IDoc 类型定义用于 BarTender 并修改 BarTender 使用 IDoc 类型的方式。

该窗口包含以下元素：

  • 名称文本框。用于设置 IDoc 类型在 BarTender 中使用的名称。

  • 选择语法分析器文件按钮。用于浏览到语法分析器文件。（可从 SAP 系统获取语法分析器文件。）

  • IDoc 类型字段。标识语法分析器文件中包含其信息的 IDoc 类型。

注意：如果语法分析器文件中包含多个 IDoc 类型的分析信息，则该窗口中部的 IDoc 类型字段中将包含一个下拉列表，其中列出语法分析器能够分析的所有类型。请务必选择正确的类型。

  • 段版本下拉列表。用于设置 IDoc 版本。应选择与语法分析器文件的版本相匹配的版本号，或选择列表中最上面的选项<从默认 IDoc 文件提取>。

  • 文件文本框。用于设置或更改与 IDoc 类型关联的默认 IDoc 文件。所选的文件将显示在 IDoc 文件文本框中，该文本框位于 IDoc 的添加数据库连接向导 — 选项窗口和 IDoc 的数据库连接设置选项选项卡上。

另请参见：

了解 IDoc

分析器文件


“主”选项卡

数据库连接设置 —“主段”选项卡

使用该选项卡可以选择主段，它为 BarTender 标识 IDoc 数据中您所关注的重点内容以及应该从 IDoc 文件生成的平构记录的数量。一般来说，将为每条记录生成一个标签。

单击某个段，可以使其成为“主段”。

另请参见：

了解 IDoc

IDoc 类型和段定义

将 IDoc 层次数据转换成平构记录


IDoc 的“字段”选项卡

使用此屏幕可以指定要从中获取标签数据的 IDoc 的特定字段。

  • 段。用于选择包含要从中获取数据的字段的段。

  • 字段。用于选择要从中获取数据的字段。也可以使用添加字段按钮来选择许多字段。

  • 别名。用于设置要在 BarTender 中标识字段的名称。默认情况下使用“字段”列中的条目。

  • 数据类型。用于设置每个字段的数据类型。默认值为“字符”字符串。

  • 重复段规则。如果显示“仅第一段”，则表明该段可重复；因此，在同一个父段下，该段可能出现多次。您必须决定如何处理可重复段上每个字段的规则。单击该单元格，然后单击该单元格中出现的按钮，以打开“重复段规则”窗口，并使用该窗口来设置字段的规则。

注意：无论何时，要删除已选中的某些字段时，可以单击删除字段按钮，突出显示相应的字段，然后单击确定。

另请参见：

了解 IDoc

IDoc 类型和段定义

将 IDoc 层次数据转换成平构记录


“添加字段”窗口

使用此窗口可以从 IDoc 中选择大量字段。单击要添加的每个“段/字段”对。完成后，单击确定。


“删除字段”窗口

使用此窗口可以选择要删除的字段。单击要删除的每个字段。要将它们全部选中，请单击全选按钮。完成后，单击确定。


“重复段规则”窗口

重复段规则 … 窗口

使用此窗口可以确定 BarTender 从重复段（在同一父段下可能多次出现的段）的字段中提取数据时要遵守的规则和条件。

以下是 BarTender 在从某个重复段的所选字段中提取数据时采用的方法：

True 或 False 条件

如果您希望仅当 IDoc 中的数据满足某些条件时 BarTender 才从字段提取数据，则可使用语句编辑器创建 True 或 False 语句。也可以使用布尔运算符“And”和“Or”将两个或两个以上这样的语句组合使用。有关说明，请参见“查询”选项卡。

仅使用第一段

如果您希望数据仅来自符合规则的段第一次出现时显示的字段，则选择此选项。

连结

如果您希望数据来自符合规则的段每一次出现时显示的字段，则选择此选项。这些数据将连结成 BarTender 创建的平构记录上的一个字段。

用空格连结

如果您希望数据来自符合规则的段每一次出现时显示的字段，则选择此选项。这些数据将通过空格连结成 BarTender 创建的平构记录上的一个字段。

另请参见：

了解 IDoc

将 IDoc 层次数据转换成平构记录

“查询”选项卡


文本文件

所有包含标签数据的文本文件都必须通过某种方式来让 BarTender 判断哪个字段属于标签上的某个对象，哪个字段又属于其它对象。为此，可使用定界或固定宽度的数据字段。定界是指使用特殊字符来分隔数据文件中的字段。BarTender 目前支持的文本文件有六种：

有关详细信息，请单击相应的类型。

  • 引号和逗号混用

  • 引号和逗号

  • 逗号

  • 制表符

  • 用户定义的定界符

  • 固定宽度

默认的文本文件定界方式为“引号和逗号混用”。这是一种引号和逗号混用的定界方式。在将数据从数据库或电子表格导出至文本文件时，这是最常用的定界类型。由于该方式既支持引号和逗号混用定界的文件，又支持纯逗号定界的文件，因此大多数定界的文本文件都采用此默认设置。不过，如果您确实需要选择其它定界方式，只须单击设置按钮，即可根据需要更改定界方式。

另请参见：

定界文本文件


添加数据库连接向导 -（文本）文件

添加数据库连接向导 —（文本）文件

使用添加数据库连接向导 — 文件对话框可以指定文本文件的路径及其字符集。

文件位置

可以使用两种方法指定现有文本文件。

方法 1

  1. 在文本文件名字段中键入要从中读取数据的文本文件的路径。

  2. 单击下一步>。

或

方法 2

  1. 单击选择文件按钮。此时将显示指定文本文件对话框。

  2. 从指定文本文件对话框中，使用查找范围下拉文件菜单找到并选择文本文件。

  3. 在找到并选择文本文件后，单击打开。此时，您将返回到添加数据库连接向导 — 文件对话框。

  4. 在添加数据库连接向导 — 文件对话框中，单击下一步>。

查看文件按钮。指定了文本文件后，通过单击查看文件按钮，可以在默认的文本编辑器中显示该文件。

由于 BarTender 的默认文本文件扩展名是 .txt，因此，建议您在命名文本文件时使用 .txt 扩展名。这样，您就不必每次在 BarTender 中请求文本文件时都要指定扩展名了。

代码页

如果要使用的字符集与默认字符集不同，则在所提供的下拉列表中指定文件的字符集。例如，如果要使用的语言不是您所使用的 Windows 版本的默认语言，可能就需要执行此操作。可用的选项有：

  • Unicode

  • Unicode (Big Endian)

  • UTF-8

  • 使用系统默认值

  • 阿拉伯语 (1256)

  • 波罗的语 (1257)

  • 中欧字符 (1250)

  • 简体中文 (GB-2312, 936)

  • 繁体中文 (Korea, Big 5, 950)

  • 西里尔字母 (1251)

  • 希腊语 (1253)

  • 希伯来语 (1255)

  • 韩语 (Hangul, 949)

  • 韩语 (Johab, 949)

  • 日语 (SHIFT-JIS, 1361)

  • 泰语 (874)

  • 土耳其语 (1254)

  • 美国、西欧 (ANSI, 1252)

  • 越南语 (1258)

在指定了文本文件及其字符集后，即可单击下一步>移至添加数据库连接向导 — 定界对话框。

另请参见：

已定界的文本


添加数据库连接向导 - 定界

添加数据库连接向导 — 定界

定界类型。在此字段中，您可以选择六种不同的文本文件定界类型之一。BarTender 读取文本文件，并自动默认使用最可能的定界方法。单击查看文件以通过默认的文本编辑器查看所选文件。

有关详细信息，请单击相应的类型。

  • 引号和逗号混用。此类型与逗号定界以及引号和逗号定界结合使用。

  • 引号和逗号定界。此类型适用于使用引号和逗号分隔各个字段的情况。

  • 逗号定界。此类型适用于通过逗号分隔各个字段的情况。

  • 制表符定界。此类型适用于使用制表符分隔各个字段的情况。

  • 用户定义的定界符。此类型适用于使用用户定义的字符分隔各个字段的情况。

  • 固定宽度。此类型适用于无定界符但每个字段都具有固定宽度的情况。

字段定界符。指定用于分隔数据字段的字符。

在选择了定界类型后，单击下一步 > 将显示添加数据库连接向导 — 字段对话框（或添加数据库连接向导 — 固定宽度对话框）。

另请参见：

使用 dBASE 生成数据文件。


已定界的文本

定界是指使用特殊字符将文本文件中的字段彼此分隔开。


逗号定界

在逗号定界的文本文件中，单个字段之间用逗号分隔。逗号定界文件如下所示：

0543166,Oranges,Perishable

17890,Flower Pots,Breakable

1203768,Apples,Perishable

1029384,Bananas,Perishable

由于文件有四行，因此将打印四张不同的标签，每张标签上三个数据字段。

在第二行的第二个字段中，“Flower”与“Pots”之间有一个空格。逗号定界能识别出字段中数据字符之间的空格。不过，如果单个字段的数据中包含要打印的“前导”和“尾部”空格，则必须使用引号和逗号定界。逗号定界会自动去除所有前导空格和尾部空格。

另请参见：

使用 dBASE 生成数据文件

引号和逗号定界

制表符定界

引号和逗号混用

固定宽度


引号和逗号混用

这是 BarTender 的默认设置，因为它既可用于逗号定界的文件，也可用于引号和逗号混用定界的文件。在标准的已定界 dBASE 文本文件中，数字字段通常用逗号定界，而字符串字段通常用双引号和逗号定界。假定您的 dBASE 程序中每行的第一个字段是数字字段，则保存到该文本文件中的数据如下所示：

0543166,"Oranges","Perishable"

17890,"Flower Pots","Breakable"

1203768,"Apples","Perishable"

1029384,"Bananas","Perishable"

由于文件有四行，因此将打印四张不同的标签，每张标签上三个数据字段。

另请参见：

使用 dBASE 生成数据文件

引号和逗号定界

逗号定界

制表符定界

固定宽度


引号和逗号定界

在引号和逗号定界的文本文件中，单个字段之间用引号和逗号分隔。引号和逗号定界的文件如下所示：

"0543166","Oranges","Perishable"

"17890","Flower Pots","Breakable"

"1203768","Apples","Perishable"

"1029384","Bananas","Perishable"

由于文件有四行，因此将打印四张不同的标签。注意，文件的每一行都包括三个数据字段要打印在每张标签上。每个字段都用引号引起来，字段之间用逗号分隔。例如，第一个标签包含标识号 0543166，该号码很可能将打印为条形码。文本字段“Oranges”和“Perishable”也将打印在同一张标签上。几乎所有数据库、电子表格和字处理软件都可以按照这种格式创建数据文件。

另请参见：

使用 dBASE 生成数据文件

逗号定界

制表符定界

引号和逗号混用

固定宽度


制表符定界

制表符定界使用制表符来分隔字段。制表符定界的文件如下所示：

0543166 | Oranges | Perishable
17890 | Flower Pots | Breakable
1203768 | Apples | Perishable
1029384 | Bananas | Perishable

由于文件有四行，因此将打印四张不同的标签，每张标签上三个数据字段。

另请参见：

使用 dBASE 生成数据文件

引号和逗号定界

逗号定界

引号和逗号混用

固定宽度


固定宽度的字段

所谓字段宽度固定的文本文件，是指从记录开头处起，记录中的每个字段都开始于固定的字符数位置。因此，字段彼此之间不需要任何定界字符来分隔。

下列示例就是字段宽度固定的记录。每个记录中的第一个字段占 8 个字符，第二个字段占 10 个字符，第三个字段占 10 个字符。请注意，在第二个记录中，“Cantaloupe”与“Perishable”之间没有定界符。因为标签格式可设置为始终将第 19 个字符作为第三个字段的起始处，所以不需要定界符。

0543166 Oranges Perishable

17890 CantaloupePerishable

1203768 Apples Perishable

1029384 Bananas Perishable

另请参见：

使用 dBASE 生成数据文件

逗号定界

制表符定界

引号和逗号混用

引号和逗号定界


用户定义的定界符

用户可以使用所需的任何单个字符的定界符来分隔一行中的信息。以下例举了一个使用冒号作为字段定界符的用户定义的定界符文件：

0543166:Oranges:Perishable

17890:Flower Pots:Breakable

1203768:Apples:Perishable

1029384:Bananas:Perishable

由于文件有四行，因此将打印四张不同的标签，每张标签上三个数据字段。


添加数据库连接向导 - 固定宽度

添加数据库连接向导 — 固定宽度

在添加数据库连接向导 — 固定宽度对话框中，用户可以向 BarTender 告知文本文件中的字段数以及每个字段的宽度。

若要添加新字段，请单击插入。

若要删除某个字段，请突出显示该字段，然后单击删除。

若要指定字段的宽度，请在宽度列的相应单元格中键入数字。

若要查看文件，请单击查看文件。

单击下一步>，此时将打开添加数据库连接向导 — 字段对话框。

另请参见：

固定宽度


添加数据库连接向导 - 字段

添加数据库连接向导 — 字段

在添加数据库连接向导 — 字段对话框中，将向用户询问文本文件的第一条记录是否为包含字段名称的“标题”。如果您不确定，则可以选择查看文件按钮来查看文本。在回答“是”或“否”后，单击完成。执行此操作后，将完成数据库连接设置对话框。例如：

记录 1 "ID","TITLE","(Rating)","TYPE"

记录 2 "V124","RAMBO","(R — Restricted)","VHS"

记录 3 "V037","DUMBO","(G — General Audiences)","BETA"

记录 4 "V061","GUNGHO","(PG13 — No One Under 13)","VHS"

上述文本文件中的第一条记录是包含字段名称的“标题”。


数据库连接设置 - 浏览

“浏览”选项卡

使用数据库连接设置对话框可以访问浏览选项卡，在此，您可以查看所有数据库树视图中所选项的数据字段和记录。通过在打印标签之前查看记录，您可以验证是否正确指定了查询或其它记录选择信息。

借助浏览对话框可以执行以下功能：

  • 记录的表视图。显示所有数据库树视图中所选项的相应字段和所选记录。

  • 记录。用于按记录编号查看。

  • 显示全部字段。选中此选项可显示全部字段，不管标签上是否使用了它们。如果取消选中此选项，则只显示要在标签上使用的字段。

  • 刷新按钮。用于刷新网格和显示现有查询提示。


数据库连接设置 - 选择表

“选择表”选项卡

通过数据库连接设置对话框可以打开表选项卡，在此，您可以查看、添加或删除可用表。

  • 可用表列表或输入表名称文本框。

如果表类型对话框中的输入表名称（仅手动输入）未启用（默认设置），您将看到所有可用表的列表。如果启用了输入表名称（仅手动输入），您将看到输入表名称文本框。

  • 要使用的表。要使用的所有表的视图。

  • 添加。从可用表选择要使用的表，或在输入表名称文本框中键入该表的名称，然后单击添加。这样，将在要使用的表中显示该表。

  • 全部添加。将所有表从可用表列表添加到要使用的表中。

  • 删除。将所选表从要使用的表删除。

  • 全部删除。删除要使用的表中的所有表。

  • 表类型。用于选择要从数据源读取的表的类型。

另请参见：

数据库连接设置


数据库连接设置 - 查询

“查询”选项卡

使用查询可以指定将打印哪些记录的搜索条件。您可以在搜索条件中包含多个字段，也可以在字段之间设置任意关系和比较。使用查询选项卡中的设置可以自动生成 SQL 选择语句。BarTender 还允许高级用户使用 SQL 选项卡自定义 SQL 选择语句。

构建查询语句

只需从字段名和比较条件的下拉列表框中进行选择即可构建查询语句。在需要时，您可能还需要键入比较值。SQL 选择语句是在后台构建的，您只需填充查询对话框，而不必关注于它的细节。

当您第一次打开查询对话框时，将显示一个包含若干空白数据填充区的行。单击列标题按钮（即字段、运算符、条件、和/或以及显示“(”或“)”的按钮）将显示一个下拉选择菜单。

  • . 在定义多个查询时指定运算符的优先级。

  • 字段。指定确定是否打印记录所使用的字段。

  • 运算符。选择说明“字段”和“条件”之间所需关系的运算符。

  • 条件。指定与字段值进行比较的值的限制因素。该值既可以是您键入的常数值，也可以从现有值列表中选择。例如，如果要搜索某个部件号，您可以将其值键入字段中或从列表中选择。使用查询提示可以指定打印时的值。

  • . 在定义多个查询时指定运算符的优先级。

  • 和/或。

  • 和。执行两个查询的逻辑与。

  • 或。执行两个查询的逻辑或。

  • 结束。结束查询语句。

查询构建区域下面是以下选项：

  • “全部删除”按钮。单击该按钮可以删除所有查询。

  • 查询提示。单击该选项可以打开查询提示对话框，您可以在其中创建进行以下操作的提示：

    • 在打印时打开，并且

    • 要求用户指定执行查询所需的参数。如果在数据库设置时不清楚构建查询所需的某些参数，而到了打印时才清楚，这时将需要使用该选项。

  • 忽略大小写。如果不想以区分大小写的方式解释查询，请启用该选项。

另请参见：

了解 ODBC

了解 OLE DB

“数据库连接设置”对话框

数据库连接设置 — SQL

了解查询提示


了解数据库索引

索引包含已排序的信息，这些信息来自数据库表。如果没有索引，在查找特定记录时，就需要“逐行搜索”。逐行搜索是指从第一条记录开始搜索，然后一直搜索整个表，直到最后一条记录。逐行搜索非常耗时，具体时间取决于表中的记录数。

通过使用索引，可以根据一种或多种首选的排列顺序，较快地搜索特定的数据和读取数据库记录。例如，为了能够更快、更轻松地找到客户，供应商可以创建和维护一个或多个索引，以便按姓氏、公司名和电话号码对客户表进行排序。创建了这些索引后，用户的数据库程序（和 BarTender）就可以快速找到所需的用户记录。

在 BarTender 中执行按字段搜索、查询或SQL 选项时，正确指定要使用的数据库索引非常重要。这些功能会对整个数据库进行搜索，查找满足特定搜索条件的记录。因此，了解 ODBC 何时自动使用索引、何时不自动使用索引，对用户来说至关重要，因为这会大大影响搜索或查询的速度。

有关详细信息，请参见指定要打印的记录。

另请参见：

指定要使用的索引文件

了解 ODBC


数据库连接设置 - 查询提示

“查询提示”对话框

全部显示 全部隐藏

查询提示用于在打印时填充查询的条件。例如，如果要能够搜索在打印时键入的特定部件号，您可以使用查询对话框从数据库中选择部件号字段，指定等号运算符，然后将条件设置为“查询提示”。这样，将在每次打印时要求您键入部件号，只有那些与该部件号匹配的记录才会打印出来。

查询提示列表

该列表将显示可用的查询提示。列表下面是以下按钮：

按钮 | 用途
 | 新建查询提示。在列表中插入新的查询提示。
 | 删除查询提示。删除所选查询提示。
 | 剪切查询提示。删除所选查询提示的同时将该查询提示的副本保存在 BarTender 的剪贴板中。
 | 复制查询提示。将所选查询提示复制到 BarTender 的剪贴板中。
 | 粘贴查询提示。将剪贴板中当前查询提示的副本粘贴到列表中。
 | 上移查询提示。将所选查询提示在列表中的位置上移一位。
 | 下移查询提示。将所选查询提示在列表中的位置下移一位。

注意：所有这些命令都可以通过在列表中的任何地方右键单击来访问。

查询提示选项

  • 名称。使用该字段可以定义或修改查询提示的名称。

  • 打印时用户提示。输入打印时将显示的文本，以便提示用户输入所需值。

  • 默认响应。默认响应是打印时在查询提示对话框的响应框中显示的文本。

响应选项

  • 打印后更新默认响应。用于指定为响应查询提示而输入的最后一个响应将显示为新的默认响应。

  • 视回车符为制表符。用于指定当按 ENTER 键时光标将移到下一个响应框内。

  • 出现制表符时跳过数据输入框。用于指定在为响应提示而输入数据时自动跳过响应框。

  • 只读。用于指定默认响应仅供显示而不能进行编辑。

  • 更多选项。显示更多查询提示选项对话框。

有关更多数据源选项的信息，请查看以下链接：

有效性

截短

下限

上限


数据库连接设置 - 排序

“排序”选项卡

通过数据库连接设置对话框，可以打开排序选项卡，在此，您可以指定在读取 ODBC 或 OLE DB 数据时打印记录的顺序。

  • 可用字段。可用于排序的字段列表。

  • 排序字段。将按其进行排序的字段列表。

  • 排序方向。定义排序顺序的方向：升序或降序。

  • 添加。从可用字段中选择要使用的字段，然后单击添加。这样，将在排序字段中显示所选字段。（每次只能选择一个字段。）

  • 删除。将所选字段从排序字段移回可用字段中。

  • 全部删除。将排序字段中的所有字段都移回可用字段中。

另请参见：

数据库连接设置

了解 ODBC

了解 OLE DB


数据库连接设置（所有数据库）多数据库连接

“多数据库连接”选项卡（所有数据库）

通过数据库连接设置（所有数据库）可以访问该对话框，在此对话框中，您可以连接多个数据库。连接将指示 BarTender 数据关联的方式。您应该将多数据库连接看作是超级表。为了使多数据库有意义，应该将它们关联起来。

  • 左表。指定所需的左表。

  • 左字段。指定“左表”中要在连接中使用的字段。

  • 运算符。指定定义左表中的字段与右表中的字段之间关系的运算符。

  • 右表。指定所需的右表。

  • 右字段。指定“右表”中要在连接中使用的字段。

  • 连接类型。指定左表与右表及其相应的字段之间的连接类型。

另请参见：

数据库连接设置 — 连接


数据库连接设置 - SQL

SQL 选项卡

SQL 表示“结构化查询语言”，它是一种对数据库进行操作的语言。通过综合运用查询、表和排序选项卡，可以根据用户的设置自动生成 SQL 语句。“使用自定义 SQL 语句”选项是供高级用户使用的，他们了解如何创建自己的 SQL 语句，并且不希望受前端工具（如查询对话框）的妨碍。

重要提示：本帮助主题将概述如何使用 BarTender 的 SQL 选项卡，但不会讲授 SQL 知识。SQL 是一种供数据库程序员使用的高级编程工具。如果您不了解 SQL 的用法，则改用查询、表和排序选项卡。如果您决定从头学习 SQL，建议您购买有关利用 SQL 编程的书籍。

  • 使用自定义 SQL 语句。单击该框可以激活大文本框，您可以在此输入 SQL 语句。

  • 查询提示按钮。用于打开查询提示窗口。

另请参见：

指定要打印的记录

了解 ODBC

了解 OLE DB


数据库连接设置 - OLE DB 选项

数据库连接设置 — OLE DB 选项

通过数据库连接设置 (OLE DB) 对话框，可以访问选项选项卡。

该选项卡可以标识数据源以及与该数据源的连接。对于 SQL Server 和 Oracle 来说，将标识服务器名和数据库名。对于 Microsoft Access 或 Excel 或者 UDL 文件来说，则标识数据库的路径和文件名。对于其它类型的 OLE DB 源，将列出 OLE DB 提供商的名称。

  • 设置。（如果来源为 UDL 文件，则该选项不显示。）使用该按钮可以打开 Windows 数据链接属性对话框，在此，您可以更改与 OLE DB 数据源的连接。有关详细信息，请单击该对话框上的帮助按钮。

注意：如果来源为 UDL 文件，则也提供以下选项：

  • 新建。单击此按钮可以新建一个 UDL 文件。此时将打开一个 Windows 数据链接属性对话框，在此可以选择提供程序并配置数据库和安全信息。有关详细信息，请单击该对话框上的帮助按钮。单击确定后，将打开一个 Windows 另存为对话框，供您保存 UDL 文件。

  • 编辑。单击该按钮可以编辑文件。此时将打开 Windows 数据链接属性对话框，在此可以配置数据库和安全信息。有关详细信息，请单击该对话框上的帮助按钮。

  • 浏览。使用该按钮可以浏览到现有 UDL 文件。

  • 允许重名。如果希望能够打印重复的记录，请选中该选项框。

  • 将用户 ID 和口令保存到格式。选中该选项会将用户 ID 和口令与标签格式一起保存。（对于没有用户 ID 或口令的 OLE DB 数据源，该选项将被禁用。）

  • OLE DB 消息。单击该选项可以打开错误消息对话框，在此，您可以指定要接收的消息和要禁止显示的消息。

另请参见：

了解 OLE DB


数据库连接设置 - ODBC 选项

数据库连接设置 — ODBC 选项

通过数据库连接设置 (ODBC) 对话框，可以访问选项选项卡。

  • 允许重名。如果希望能够打印重复的记录，请选中该选项框。

  • 将用户 ID 和口令保存到格式。选中该选项会将用户 ID 和口令与标签格式一起保存。

  • 设置。打开特定于 ODBC 数据库类型的设置对话框。例如，Microsoft Access 或 Microsoft Excel。

  • ODBC 管理器。打开 ODBC 管理器。

  • ODBC 消息。打开错误消息对话框，在此，您可以指定要接收的消息和要禁止显示的消息。

另请参见：

了解 ODBC


数据库连接设置 - 选项

数据库连接设置 — 文本文件选项

全部显示 全部隐藏

在所有数据库视图中选择了文本文件数据库后，通过数据库连接设置对话框可以访问选项选项卡。

文件

  • 文本文件名。键入所需文本文件数据库的名称和路径。

  • 选择文件。使用该选项可以显示指定数据文件对话框，它可以帮助您找到文本文件。

  • 查看文件。使用默认文本编辑器显示文本文件。

  • 代码页。选择文本文件的字符集（在该字符集不是默认字符集的情况下）。例如，如果要使用的语言不是您所使用的 Windows 版本的默认语言，可能就需要执行此操作。可用的选项有：

  • Unicode

  • Unicode (Big Endian)

  • UTF-8

  • 使用系统默认值

  • 阿拉伯语 (1256)

  • 波罗的语 (1257)

  • 中欧字符 (1250)

  • 简体中文 (GB-2312, 936)

  • 繁体中文 (Korea, Big 5, 950)

  • 西里尔字母 (1251)

  • 希腊语 (1253)

  • 希伯来语 (1255)

  • 韩语 (Hangul, 949)

  • 韩语 (Johab, 1361)

  • 日语 (SHIFT-JIS, 932)

  • 泰语 (874)

  • 土耳其语 (1254)

  • 美国、西欧 (ANSI, 1252)

  • 越南语 (1258)

定界类型

您可以从该字段中选择五种不同文本文件定界类型之一（或选择固定宽度字段）。BarTender 将自动默认使用最可能的定界方法。有关详细信息，请单击相应的类型。

  • 引号和逗号混用。此类型与逗号定界以及引号和逗号定界结合使用。

  • 引号和逗号定界。此类型适用于使用引号和逗号分隔各个字段的情况。

  • 逗号定界。此类型适用于通过逗号分隔各个字段的情况。

  • 制表符定界。此类型适用于使用制表符分隔各个字段的情况。

  • 用户定义的定界符。此类型适用于使用用户定义的字符分隔各个字段的情况。

  • 固定宽度。此类型适用于无定界符但每个字段都具有固定宽度的情况。

字段设置

  • 字段数。BarTender 将默认使用在数据库中找到的字段数。您也可以使用该选项手动增加或减少可用字段的数量。

  • 查找字段数。查找文本文件数据库中的字段数。如果您选择固定宽度作为定界类型，该按钮将不会显示出来。

  • 宽度。打开宽度字段对话框。只有当您选择固定宽度作为定界类型时，该按钮才会显示出来。

  • 第一个记录包含字段名。单击该选项可以指示 BarTender 将文件中的第一条记录解释为字段名。

  • 获取字段名。按该按钮将打开文本文件并从第一条记录中读取字段名。

另请参见：

数据库连接设置


允许重复记录

如果某个查询或 SQL Select 语句得到多个包含要查找的数据的记录，则可以使用允许重名选项来指定是否打印重复的标签。

如果选中了允许重名复选框（默认设置），则将打印查询得到的所有重复的记录数据。如果希望放弃重复的数据，请取消选中此选项。

注意：不选中允许重名选项可能会大大降低整体搜索速度。


数据库连接设置（ODBC 数据库）- 状态

“状态”选项卡（ODBC 数据库或 OLE DB 数据源）

通过数据库连接设置对话框，可以访问状态选项卡。使用该选项卡，可以显示有关所有数据库树视图中所选项（ODBC 数据库或 OLE DB 数据源）的信息。该选项卡将显示以下项。

  • 名称。显示数据库的名称。

  • 别名。显示数据库的别名。

  • 类型。显示数据源的类型是 ODBC 数据源还是 OLE DB 数据源。

  • 数据库类型。显示数据库的类型。

  • 文件/目录。显示数据库所在的“文件/目录”。

  • DSN File. Displays the Data Source Name file selected when the database connection was setup.

  • 别名按钮。单击该按钮可以更改别名。

  • 刷新按钮。重新加载已命名 ODBC 或 OLE DB 数据源的结构和配置。

另请参见：

数据库连接设置


数据库连接设置（SAP IDoc 数据库）- 状态

数据库连接设置（SAP IDoc 数据库）— 状态

通过数据库连接设置对话框，可以访问 IDoc 的状态选项卡。使用该选项卡可以显示有关 IDoc 的信息。这些信息包括：

  • 名称。总是显示“SAP IDoc”。

  • 别名。显示数据库的别名。

  • 类型。显示数据源的类型，此处的类型为 IDoc。

  • 别名按钮。单击该按钮可以更改别名。

另请参见：

数据库连接设置

了解 IDoc


数据库连接设置（文本数据库）- 状态

“状态”选项卡（文本数据库）

通过数据库连接设置对话框，可以访问状态选项卡。使用该选项卡，可以显示有关所有数据库树视图中所选项（文本数据库）的信息。该选项卡将显示以下项。

  • 名称。显示数据库的名称。

  • 别名。显示数据库的别名（如果存在别名）。

  • 类型。显示数据库（文本）的类型。

  • 别名按钮。单击该按钮可以更改别名。

另请参见：

数据库连接设置


数据库连接设置（表）- 状态

“状态”选项卡（表）

通过数据库连接设置对话框，可以访问状态选项卡。使用该选项卡，可以显示有关所有数据库树视图中所选项（表）的信息。该选项卡将显示以下项。

  • 名称。显示表的名称。

  • 别名。显示表的别名（如果存在别名）。

  • 类型。显示数据源的类型，此处的类型为 TABLE。

  • 别名按钮。单击该按钮可以更改别名。

另请参见：

数据库连接设置


数据库连接设置（字段）- 状态

“状态”选项卡（字段）

通过数据库连接设置对话框，可以访问状态选项卡。使用该选项卡，可以显示有关所有数据库树视图中所选项（字段）的信息。该选项卡将显示以下项。

  • 名称。显示字段的名称。

  • 别名。显示字段的别名（如果存在别名）。

  • 类型。显示数据源的类型。

  • 长度。指示字段的最大长度。

  • 别名按钮。单击该按钮可以更改别名。

另请参见：

数据库连接设置


刷新

有时候，在设计标签格式时，您可能需要对指定的 ODBC 数据源进行更改。此更改可能涉及对数据库的结构进行更改，或者涉及对用于读取数据库的 ODBC 驱动程序的配置进行更改。在第一次加载标签格式时将自动检测任何此类更改。但是，如果在格式已被加载的情况下进行了更改，BarTender 将无法自动知道这一情况。

在您在数据库连接设置对话框中执行了任何可能导致重要更改的功能后，单击刷新按钮可以指示 BarTender 重新加载指定 ODBC 数据源的结构和配置。


别名（数据库）

别名按钮出现在数据库连接设置状态选项卡的中间。在您单击别名按钮时将出现编辑别名对话框。


“编辑别名”对话框

单击状态对话框上的别名按钮时，将显示编辑别名对话框。别名是赋予字段、表或数据库的替代名称。当字段或表的名称已改变，而标签对象仍引用原名称时，将需要用到别名。与更改各标签对象中的引用相比，向新名称提供与原名称匹配的别名更快捷。

  • 别名。将别名赋予使用该字段的给定字段、表或数据库。

  • 名称已在使用。显示当前正在使用的所有名称，因此，不要使用这些名称作为别名。

另请参见：

数据库连接设置


打印标签格式

当屏幕标签视图区域中显示的标签格式完全符合您所需的打印输出方式时，就可以使用打印对话框来打印标签了。要显示打印对话框，请单击主工具栏上的打印机按钮，或者从文件菜单中选择打印选项。

重要提示：BarTender 主显示屏的视图区域中显示的某些对象可能不会打印在标签上。只有位于所示标签的边框内的那些对象才会打印出来。使用打印预览功能（如下所示），预览整个打印作业；也可以使用测试打印按钮（如下所示）打印一张标签。

打印对话框是一个选项卡式对话框，其中至少包括打印选项卡和对象打印方法选项卡。根据打印机和打印机驱动程序的不同，也可能有其它选项卡，如性能和打印机高速缓存，供您访问其它选项。

在所有选项卡上完成所需的一切更改后，单击打印按钮。

使用测试打印按钮打印一张标签，并关闭打印对话框。您将不会得到任何提示，即使您已将标签格式上的某个字段设置为“打印时提示”。而是使用该字段的默认数据。如果标签格式上的某个字段设置为序列化，则该字段中显示的数据与一系列标签中第一张上显示的完全相同。

使用预览按钮，打开打印预览功能。

过程：

打印标签

从数据库中读取“同样标签的份数”或“序列标签数”

另请参见：

打印到感热标签打印机

提示页

打印预览


“打印”对话框

“打印”选项卡

全部显示 全部隐藏

使用打印选项卡上的选项，可以指定用来打印标签的打印机，指定同样标签的份数和序列副本的份数，并选择一个或多个其它打印选项。下面简要介绍这些选项。

打印机

使用打印选项卡的这一部分，可以选择用来打印标签的打印机。在名称选项紧下方显示的几行文本显示有关所选打印机的信息。此信息根据所选打印机的属性对话框中的设置不同而自动变化。

  • 名称。用于指定用来打印标签的打印机。（另请参见类型下面的注释。）

  • 文档属性。用于访问当前指定打印机的其它打印机选项。在单击文档属性按钮后设置和保存的任何选项都仅适用于当前的标签格式。

  • 打印机属性。用于访问当前指定打印机的全局打印机选项。在单击打印机属性按钮后设置和保存的任何选项将适用于所有标签格式和其它程序。（也可以通过在 Windows 控制面板中选择“打印机”图标来访问这些选项。有关详细信息，请参见 Windows 文档。）

  • 状态。打印作业的状态。例如，“就绪”表示打印机已准备好执行打印作业。

  • 类型。所选打印机的类型（即 HP LaserJet 1100）。

注意：在加载了某个标签格式后，BarTender 将查找与上次保存该格式时所选打印机完全同名（包括空格和标点符号）的打印机。如果没有找到，它就会查找相同类型的打印机（即相同的制造商和型号）并使用找到的第一台打印机。如果也没有找到相同类型的打印机，它将使用 Windows 默认打印机。

  • 位置。打印机的安装位置或路径。

  • 说明。在 Windows 属性对话框中输入的有关该打印机的任何说明。有关如何更改这些说明的信息，请参见 Windows 帮助。

整个打印选项卡包含两个子选项卡：

“数量”子选项卡

数量子选项卡的功能是指定所打印的标签数。

  • 同样标签的份数。用于指定要打印的每个标签的份数，或一个序列中每个标签的份数（适用于序列化标签）。

  • 选项按钮。用于显示同样标签的份数属性页，从中可以指定三个受支持的选项之一。

  • 序列标签数。用于在序列化标签时指定所需的序列长度。

  • 选项按钮。用于显示序列标签数属性页，从中可以指定两个受支持的选项之一。

  • 记录选择。其中的选项用于指定是否要使用某个数据库，如果是，则指定所要读取和打印的记录。

“选项”子选项卡

使用选项子选项卡上的打印选项，可以记录打印作业，指定自动开始的新打印作业，将打印作业发送到文件而非打印机，以及启用提示等。下面简要介绍这些选项。

  • 日志打印作业。用于启用日志文件设置对话框中的选项。

    •

  • 自动再次打印。用于指定在一个打印作业完成后，自动开始新的打印作业。

  • Enable Printer Code Modifier. Checked by default if Print Code Actions or VB Script modifications are present. Uncheck to prevent scripts or actions from running.

  • 打印到文件。用于将打印作业发送到文件而不是打印机。

  • Show Printer Code at End of Print Job. Opens a text editor that displays the printer code after the print job has finished.

  • 启用提示。用于为启用了“打印时提示”的数据源打开和关闭提示对话框。

  • 刷新数据库。用于重新加载标签格式正在读取的所有数据库的刷新副本。

使用测试打印按钮打印一张标签，并关闭打印对话框。您将不会得到任何提示，即使您已将标签格式上的某个字段设置为“打印时提示”。而是使用该字段的默认数据。如果标签格式上的某个字段设置为序列化，则该字段中显示的数据与一系列标签中第一张上显示的完全相同。

使用预览按钮，打开打印预览功能。


打印机

名称

打印对话框中的名称选项用于指定 BarTender 将打印到哪一打印机。使用该选项可以从安装的所有 Windows 打印机列表中选择一个打印机。默认设置是 Windows 控制面板的打印机对话框中最后指定为默认打印机的打印机。在名称选项正下方的状态行中显示当前打印机的某些最重要设置。

为方便起见，打印机设置被保存为标签格式的一部分。因此，下次您需要打印相同标签时，只需加载格式并打印即可。

注意：在加载了某个标签格式后，BarTender 将查找与上次保存该格式时所选打印机完全同名（包括空格和标点符号）的打印机。如果没有找到，它就会查找相同类型的打印机（即相同的制造商和型号）并使用找到的第一台打印机。如果也没有找到相同类型的打印机，它将使用 Windows 默认打印机。

注意：最好在开始打印标签格式前选择一个打印机，这样可以确保使用正确的打印机规格设置该标签格式。在标签包含条形码对象时尤其应该这样做。用于激光打印机和点阵打印机的不同条形码密度范围可能会影响给定标签的大小。例如，如果所选打印机是激光打印机或点阵打印机，则在将同一条形码放置于标签上时，前者会显得较短。

请参见警告：

执行大型点阵打印作业时需注意的事项

过程：

选择打印机


同样标签的份数

同样标签的份数选项用于在执行打印命令时指定需要多少份同样的标签。例如，如果要将某一张标签打印 25 份，只须在打印对话框上的同样标签的份数编辑框中输入“25”，然后再单击打印按钮。

指定固定份数

对于序列标签

如果已为标签格式上的一个或多个对象启用了序列化，则使用同样标签的份数编辑框，可以指定序列中每个值需要多少同样的标签。

对于使用数据库的标签

如果标签格式要从数据库读取，则可使用此选项指定从数据文件读取的每个记录均打印同样标签的份数。例如，若在同样标签的份数编辑框中输入“25”，则从数据库读取的每个记录都将打印 25 份标签。

指定可变份数

有时，您可能希望从数据文件中读取份数，或在打印时系统提示您输入份数。此时，可使用选项按钮设置要从数据源读取的份数。

注意：使用打印预览功能可预览整个打印作业。


“同样标签的份数”属性页

使用同样标签的份数属性页可以指定是使用打印对话框上的同样标签的份数选项设置标签份数还是使用数据源设置标签份数。

默认设置为“通过‘打印’对话框和‘所选记录’选项进行设置”。不过，为了更加机动灵活，您可以使用数据源选项来指定从数据文件中的字段读取同样标签的份数或在打印时输入同样标签的份数。

请选择以下设置之一：

  • 通过“打印”对话框和“所选记录”选项进行设置。指定将“同样标签的份数”数量应用于指定的记录，但对于其它指定的记录，则通过所选记录选项使用小括号覆盖该值。（默认设置）

  • 通过“打印”对话框进行设置。指定将仅使用打印对话框上的编辑框来设置同样标签的份数。

  • 由数据源设置。显示数据源选项卡，该选项在打印多份标签时可以提供更高的灵活性。在从数据源读取同样标签的份数时，您可以指定是从数据文件中的字段读取该值还是使用打印时提示和输入的数据。


从数据库中读取“同样标签的份数”或“序列标签数”

全部显示 全部隐藏

在标签格式被设置为从数据库读取数据时，您还可为要从数据库读取的每一记录指定副本的数目或序列化标签的数目。例如，在您从数据文件读取同样标签的份数这一数目时，根据与数据文件的每一记录一起读入的字段中存储的数目的不同，同样打印标签的数目也将有所不同。

指定从数据库读取的序列化标签的数目：

  1. 单击打印对话框上序列标签数的选项按钮。

  2. 选择由数据源设置。

  3. 单击数据源选项卡以显示关联的属性页。

  4. 将来源设置为数据库字段。

  5. 在字段名选项中，指定数据文件中包含每一记录的序列长度的字段。

使用文本文件的示例

以下部分假定您具备定界文本文件的基础知识。有关详细信息，请参见定界文本文件。

假定此示例的数据文件包含以下所示的三个记录。此外，假定要打印的标签格式中的对象之一将从每个记录中的第二个字段获取其数据，并且该对象被设置为对数据进行序列化。

"Apples","121","4"

"Oranges","675","2"

"Bananas","501","3"

如果使用上述列出的过程，字段名选项被设置为“Field 3”，BarTender 将为此打印作业打印总共 9 个标签：

四个苹果标签（包含数据 121、122、123、124）

两个桔子标签（包含数据 675 和 676）

三个香蕉标签（包含数据 501、502 和 503）。

您还可以同时从同一文件读取“同样标签的份数”和“序列标签数”。假定一个或多个字段已添加到之前的示例，如下所示：

"Apples","121","4","2"

"Oranges","675","2","0"

"Bananas","501","3","5"

将同样标签的份数设置为从“Field 4”读取。BarTender 将总共输出 23 个标签：

八个苹果标签（两份标签，每个标签都包含从 121 到 124 的数据）

零个桔子标签

十五个香蕉标签（五份标签，每个标签都包含从 501 到 503 的数据）

在使用 ODBC、SAP IDoc 或 OLE DB 提供程序数据源时

在 BarTender 被设置为从 ODBC、SAP IDoc 或 OLE DB 数据源读取数据，而不是从文本文件读取数据时，您将使用字段名称而不是数字指定该字段在多少个要打印的序列化标签上包含数据。


序列标签数

为了打印序列化标签，必须为标签格式上的至少一个对象启用序列化选项。打印对话框中的序列标签数选项用于指定要打印多少连续顺序的标签。

在使用屏幕或提示数据时

在打印其一个或多个对象设置为序列化数据的标签时，打印时输入的数字或屏幕数据字段中输入的数据将确定该序列的起始值。序列标签数字段中输入的数目将确定要打印的标签序列的长度。

例如，如果序列标签数中输入的数字是“3”，将打印三个标签。第一个标签将用屏幕或提示数据指定的起始值打印，并且每个连续标签都将用该序列中的下一个数目打印。

在使用数据库时

在打印从数据库读取的标签时，使用序列标签数选项可为数据库中每一选择的记录打印相同数目的连续标签。

有时候您可能需要更高的灵活性。您可能要设置要从数据库读取的数目或要在打印时提示的数目，而不是打印固定数目的序列化标签。使用选项按钮可以通过数据源选项设置序列化标签的数目。

注意：如果在序列标签数编辑框中输入了某一数字，但没有任何对象设置为要被序列化，则在打印时 BarTender 将闪现消息“没有数据源被设置为序列化”，并且将显示数据源对话框。

注意：使用打印预览功能可预览整个打印作业。


“序列标签数”属性页

使用序列标签数属性页，可以指定是使用打印对话框上的序列标签数选项，还是使用数据源属性页来设置要序列化的标签数。

默认设置是使用打印对话框来设置要序列化的标签数。不过，为灵活起见，您可以使用数据源选项来指定从数据文件中的字段读取要序列化的标签份数，或在打印时输入要序列化的标签份数。

请选择以下设置之一：

  • 通过“打印”对话框进行设置。用于指定将在打印对话框上的编辑框中输入要序列化的标签数。（默认设置）

  • 由数据源设置。用于访问数据源属性页。在从数据源读取序列标签数时，您可以指定是从数据文件中的字段读取该值，还是使用打印时提示您输入的数据。


“打印”对话框 - 记录选择

“打印”对话框 — 记录选择

记录选择用于指定将从所有数据库上读取和打印哪些记录。

  • 使用数据库。指定在打印时是否从“数据库连接设置”中指定的数据库读取。

  • 数据库连接设置。此按钮将显示数据库连接设置对话框。

  • 已查询记录

选择要打印的已查询记录。将提供以下记录选择选项，而与数据文件的类型无关。

  • 全部。指定将打印满足查询条件的所有记录。

  • 仅第一个记录。指定将打印满足查询条件的第一个记录。

  • 选定。对于满足查询条件的记录，只打印其记录号为选择记录对话框中指定的记录号的那些记录。

  • 在打印时选择的。启用打印时记录选择。所有满足查询的记录在打印时均可供选择。

  • 所选记录。指定期望的记录选择。

  • 选择记录。允许从所有查询的记录视图选择一部分记录。


在打印时使用数据库

在一个或多个标签对象被设置为从数据文件读取数据时，您必须使用数据库连接设置对话框指定要使用的数据文件的名称。如果您已经指定了一个数据文件，则使用数据库复选框将被启用。但是，如果您尚未这样做，可以使用数据库连接设置按钮打开数据库连接设置对话框。您还可以通过从主文件菜单中选择数据库连接设置选项，显示该对话框。打开数据库连接设置对话框后，单击添加以启动添加数据库连接向导。


所选记录

使用所选记录字段可以选择要打印的记录。该字段打印对话框和选择记录对话框上都有。使用逗号可以选择一系列记录编号：“1,3,7”；使用连字符可以选择一个记录范围：“1-3”；而将逗号和连字符结合使用则可以选择记录范围和一系列记录：“1-3,7,8”。使用圆括号还可以取代所选记录的同样标签的份数值：“1-3,7,8,9(14),12-40,41-43(14)”。

另请参见：

通过“打印”对话框和“所选记录”进行设置

“打印”对话框 — 记录选择


“选择记录”对话框

选择记录对话框显示已查询的记录的列表。在此对话框中，还可以修改要打印的记录。单击下图中的不同区域，可以了解选择记录对话框中各主要元素的有关信息。

  • 记录。显示当前选定的记录编号。

  • 选择全部记录。选择要读取的现有全部记录。

  • 取消对全部记录的选择。取消选择要读取的现有全部记录。

  • 显示全部字段。选中此选项可显示全部字段，不管标签上是否使用了它们。如果取消选中此选项，则只显示要在标签上使用的字段。

  • 刷新。刷新当前的 SQL 语句。

  • 记录编号列。从记录编号列中，单击相应的记录编号按钮可选择或取消选择要打印的记录。

  • 份数列。选择要打印的记录和打印份数。

  • 记录数据。查看和选择要打印的记录。

  • 所选记录。使用逗号可选择一系列记录编号“1,3,7”；选择记录范围时应采用连字符，如“1-3”；而两者结合使用时，如“1-3,7,8”，则同时选择记录范围和记录系列。

  • 显示记录。选择全部可同时查看选定的和未选定的记录。选择无将不查看记录。

另请参见：

通过“打印”对话框和“所选记录”选项进行设置


记录导航字段

通过在 Record Navigation（记录导航）字段中键入某个记录编号，然后按 Enter 键，可以直接转至该记录。还可以使用前进和后退按钮到达某个记录。


选择全部记录

单击 Select All Records（选择全部记录）按钮将打印所有记录。


取消对全部记录的选择

单击取消对全部记录的选择按钮可取消选择要打印的所有记录。


显示全部字段

选中显示全部字段将显示所有字段，而不考虑标签上是否使用了这些字段。取消选中该选项将只显示要用在标签中的字段。


记录编号列

从记录编号列中，单击相应的记录编号按钮可选择或取消选择要打印的记录。


份数列

份数列可具有以下两种状态之一：

状态 1

选择记录编辑框。在同样标签的份数来源为“通过'打印'对话框和'所选记录'进行设置”时列处于此状态。

在打印对话框的同样标签的份数字段中输入的值是为要打印的每一记录在份数列中出现的默认值。在左侧的示例中，默认值为“25”。替换该默认值：

  1. 双击所选记录的默认值。

  2. 输入该值是为了替换默认值。

或

输入该值是为了替换所选记录字段内括号中的默认值。例如，如果替换的份数对于记录“7”是“29”，则它将在所选记录字段中显示为“7(29)”。

状态 2

选择记录复选框。在同样标签的份数来源为“仅通过'打印'对话框进行设置”或“由数据源设置”时列处于此状态。

选中份数列中的某一记录就是选择要打印该记录。打印对话框上同样标签的份数字段中输入的值就是将打印的每个所选记录的份数。


记录数据

在此区域中查看记录。还可以通过单击记录的某个字段来选择或取消选择打印该记录。


显示记录

选择全部将同时查看选定的和未选定的记录。选择无将不查看记录。


日志打印作业

选择打印对话框上的日志打印作业选项，可以从打印对话框中启用日志文件设置对话框中的选项。通过日志文件设置对话框可以记录每个打印作业，以便跟踪标签的生产。


自动再次打印

在打印作业完成后，BarTender 通常会关闭所有打印时对话框并返回到标签格式。不过，在有些时候您可能希望使用相同的标签格式执行连续的打印作业，而不必手动重新启动打印作业。例如，如果打印的标签格式提示您要在外部文件中搜索数据，则可能有时候您要执行多次搜索以打印若干不同标签。

启用打印对话框中的自动再次打印选项，可以自动重新开始您的打印作业并进行所需任意次数的打印，而不必退出打印模式。在您完成打印后，单击“取消”可以返回标签格式。


启用提示

用于为启用了打印时提示的数据源打开和关闭提示对话框。


响应打印时提示

请求打印作业

如果某个标签的一个或多个标签对象设置为“打印时提示”，则当用户打印该标签时，BarTender 在打印作业开始时显示提示对话框，而不是立即打印标签。但是，根据可能为标签格式设置的其它选项，用户可能在收到提示对话框之前先收到其它打印时提示。这些提示是“打印向导”的一部分，并且对话框标题栏中将显示后接对话框名称的“打印向导”字样。

在提示对话框中输入响应

当提示对话框首次显示时，光标将位于第一个提示的响应数据输入框中，并且将突出显示默认的响应文本。用户既可以接受此数据，也可以继续下一个提示或键入新数据。

在用户已完成在某个响应框中输入数据后，可以使用 Tab 或 Enter 键将光标移至下一个响应框。如果需要返回到前面的提示，可以按 Shift-Tab 组合键后移，或者在相应的响应框中单击鼠标光标。

开始打印

输入完要求的所有数据后，单击打印按钮。

请参见下一节：

了解打印向导


了解打印向导

如果已将标签格式设置为使用下面列出的任一功能，BarTender 将在打印作业开始时显示多个对话框。

  • True-Type 字体警告。用来指定如何处理以下这类打印作业：标签格式中包含使用 True Type 字体的对象。

  • 选择起始标签。用来指定打印作业中应第一个打印的标签。

  • 打印到文件。用来将标签格式打印到文件，而不是将打印作业发送到打印机。

  • 查询提示。用于在打印时提示输入查询条件。

  • 在打印时选择的。用于在打印时选择要从数据库中读取的纪录。


打印向导 - TrueType 字体警告

打印向导 — TrueType 字体警告

如果在感热打印机上打印标签，且一个或多个标签对象被设置为采用 TrueType 字体打印，则将显示 TrueType 字体警告。

TrueType 字体通常作为图形来操作和打印，而图形的下载和打印速度可能非常慢。使用此对话框中的设置可以指定 TrueType 字体在打印时是否被与其最为接近的内置打印机字体替换。根据标签格式复杂程度的不同，这可能会大大提高标签的打印速度，尤其是目标文本因标签不同而变化的情况下，这种改善会更为突出。

从打印向导中继续打印作业：

  1. 单击所需的设置。

  2. 按 ENTER 键或单击下一步。如果没有下一步，则单击打印或提示。单击上一步可返回前一个屏幕。

  3. 请选择以下设置之一：

  • 继续使用 True Type 字体打印。指示 BarTender 继续使用 True Type 字体打印。每次打印标签格式时，BarTender 都将显示该警告对话框，提示您使用 TrueType 字体可能会显著影响打印性能。

  • 忽略关于此格式的警告，继续打印 TrueType 字体。指示 BarTender 使用 TrueType 字体执行此打印作业及后续的所有打印作业。如果选择这一设置，BarTender 对于以后的打印作业将不再显示此警告。

  • 允许打印机字体替换并继续打印。（默认设置。）指示 BarTender 在打印时使用最接近的打印机内置字体替换所选的 TrueType 字体。采用这一设置，打印机将以允许的最高速度输出标签。


选择起始标签

当您打印一页标签时，标签通常从左上角开始打印。不过，有时可能需要指定先打印哪个标签，以便在一张已部分使用的标签页打印。通过页面设置对话框上的打印时提示起始标签号选项，您可以使用选择起始标签对话框来选择起始标签号。

继续打印作业：

  1. 单击相应的标签号。

  2. 按 ENTER 键或单击下一步。如果没有下一步，则单击打印或提示。单击上一步可返回前一个对话框。

注意：使用打印预览功能可预览整个打印作业。


打印向导 - 打印到文件

打印向导 — 打印到文件

使用打印对话框中的打印到文件选项，可以将标签打印到文件，而不直接打印到打印机。（此选项为您使用 Windows 控制面板将打印机连接到文件提供了一个快捷的备选方案。）在以下情况下适合于将您的标签打印到一个文件：

  • 保存打印输出数据以便在以后打印您的标签。

  • 从其它计算机打印您的标签。

  • 出于不同目的查看或编辑打印输出数据。

如果已选中打印到文件选项，BarTender 在打印时将显示打印向导 — 打印到文件对话框。使用此对话框可以指定所打印数据的路径和文件名。

使用打印到文件对话框可以将标签输出到文件，而不直接输出到打印机。

从打印向导中继续打印作业：

  1. 键入标签要打印到的目标路径和文件名。

  2. 按 Enter 键，或单击打印或提示按钮。单击上一步按钮可返回前一个对话框。


了解查询提示

查询提示使您能够在打印时填写查询的条件。例如，如果希望能够搜索打印时键入的特定部件号，可以使用数据库连接设置对话框上的查询选项卡，从数据库中选择相应的部件号字段，指定等号运算符，然后设置查询提示的条件。这样，您每次打印时，系统都会要求您使用打印向导 - 输入查询数据对话框键入部件号，只有那些与该部件号匹配的记录才会打印出来。完成搜索后，将显示打印向导的下一个对话框（若有）。如果找不到匹配的记录，系统将显示一则消息报告这种情况。

注意：如果您希望提示输入将在标签上显示的实际数据，而不是将在打印时执行的 SQL 查询中充当条件的数据，那么请使用 BarTender 的打印时提示功能，而不是查询提示功能。


打印向导 - 在打印时选择的

打印向导 — 在打印时选择的

打印向导 — 在打印时选择的对话框显示已查询的记录的列表。所有满足查询的记录在打印时均可供选择。在此对话框中，还可以修改要打印的记录。有关打印向导 — 在打印时选择的中相关功能的信息，请参见选择记录对话框主题。

从打印向导中继续打印作业：

  1. 选择要打印的记录。

  2. 单击打印或下一步。单击上一步（若可用）可返回前一个对话框。


访问“日志文件设置”对话框

采用以下两种方式之一可以访问日志文件设置对话框：

  • 使用工具菜单上的日志文件设置选项。

  • 在打印对话框上启用日志打印作业选项，并在打印对话框内切换到日志文件选项卡。


样本日志文件

在执行打印作业之前，可以使用样本日志文件区域查看日志文件。该区域显示的内容取决于您在标题、每个标签和脚注选项卡中指定的设置，以及为输出类型选项指定的设置。

示例

  • 如果在输出类型选项中指定了文本格式，则样本区域将显示日志文件中包含的数据。下图显示当输出类型设置为“制表符定界”时的样本日志文件区域。

  • 如果输出类型选项中指定了 HTML，则样本区域将显示 HTML 标记。下图显示当输出类型设置为“HTML 定界”时的样本日志文件区域。


组织

使用组织选项，可以根据四个设置指定日志文件的名称。通过这些设置，您可以将所有打印作业日志附加到一个文件中，或者在不同的文件中保存打印作业日志。下面将介绍这些设置。

  • 一个文件。指定所有打印作业的所有打印作业日志都将附加到单个日志文件中。

  • 按格式文件名。指定将根据标签格式的名称保存日志文件。

  • 按日期。指定根据系统日期将保存所有打印作业日志。

  • 分隔文件。指定将根据标签格式的名称为每一打印作业创建分隔的日志文件。


输出类型

输出类型选项可用于指定日志文件的保存格式。使用文本格式保存的日志文件可以使用记事本、写字板或其它字处理程序查看。使用 HTML 格式保存的日志文件可以使用 Internet 浏览器查看。

日志文件设置对话框顶部的样本日志文件区域将显示日志文件中包含的数据的样本。所显示的样本在很大程度上取决于为输出类型选项指定的设置。

下面介绍输出类型选项的可用设置。

  • 制表符定界。指定用制表符来分隔日志文件中包含的数据。

  • 逗号定界。指定用逗号来分隔日志文件中包含的数据。

  • 引号和逗号定界。指定用引号和逗号来分隔日志文件中包含的数据。

  • HTML 定界。指定日志文件将使用 HTML 格式保存。


标题、每个标签和脚注设置

全部显示 全部隐藏

在您指定 BarTender 将在打印作业期间生成一个日志文件时，可以指定设置以在日志文件中包括某些数据。这些设置位于日志文件设置对话框的标题、每个标签和脚注选项卡中。下表显示了可用设置。大多数设置可用于所有选项卡中；不过，有几个设置只可用于其中一个或两个选项卡中。在每一选项名称后的括号中所示内容是在其上显示该设置的一个或多个选项卡的名称。

日志文件数据选项

  • 最低分隔符行。（脚注） 包括用于标记整个日志条目结束的一行。

  • 数据库文件名。（标题、每个标签和脚注） 包括将从中读取数据的数据库文件名。

  • 日期(长格式)。（标题、每个标签和脚注） 包括含有年和月的当前系统日期；例如 1999 年 1 月 1 日。

  • 日期(短格式)。（标题、每个标签和脚注） 包括当前系统日期的等效数值；例如 1/1/99。

  • 结束日期(长格式)。（脚注） 包括标签作业结束打印时的日期，日期中含有年和月；例如 1999 年 1 月 1 日。

  • 结束日期(短格式)。（脚注） 包括标签作业结束打印时的日期的等效数值；例如 1/1/99。

  • 结束时间。（脚注） 包括标签作业使用区域设置中指定的格式结束打印时的系统时间。

  • 格式名称。（标题、每个标签和脚注） 包括格式的名称。

  • 同样标签的份数。（标题、每个标签和脚注） 包括打印对话框的同样标签的份数选项中指定的数值。

  • 数据库文件名。（标题、每个标签和脚注） 包括在使用数据库打印标签时的数据库文件的名称。

  • 标签列。（标题、每个标签和脚注） 包括标签页上列的数目（根据页面设置对话框的布局选项卡的列选项中指定的设置）。

  • 标签高度。（标题、每个标签和脚注） 包括标签高度（根据页面设置对话框中指定的设置）。

  • 标签号。（每个标签） 包括打印的标签的序列号。

  • 标签行。（标题、每个标签和脚注） 包括标签页上行的数目（根据页面设置对话框的布局选项卡的行选项中指定的设置）。

  • 标签宽度。（标题、每个标签和脚注） 包括标签宽度（根据页面设置对话框中指定的设置）。

  • 日志文件名。（标题、每个标签和脚注） 包括日志文件的名称。

  • 已打印的标签数。（脚注） 包括所打印的标签的总数。

  • 序列标签数。（标题、每个标签和脚注） 包括打印对话框的序列标签数选项中指定的数值。

  • 每个标签字段名。（标题） 包括一行，其字段号或共享名在数据源属性页中指定。

  • 打印机名称。（标题、每个标签和脚注） 包括已用来打印标签的打印机的名称。

  • 分隔符行。（标题、脚注） 在标题下输入一行或在脚注上输入一行，以将文本与每个标签上打印的数据列表分隔开。

  • 开始日期(长格式)。（标题、每个标签和脚注） 包括标签作业开始打印时的日期，日期中含有年和月；例如 1999 年 1 月 1 日。

  • 开始日期(短格式)。（标题、每个标签和脚注） 包括标签作业开始打印时的日期的等效数值；例如 1/1/99。

  • 开始时间。（标题、每个标签和脚注） 包括标签作业使用区域设置中指定的格式开始打印时的系统时间。

  • 时间。（每个标签） 包括使用区域设置中指定的格式打印标签时的系统时间。

  • 最高分隔符行。（标题） 包括用于标记整个日志条目开始的一行。


要记录的子串

有时，您可能希望将标签上各对象包含的数据记录在打印作业过程中生成的日志文件中。通过设置每个标签选项卡上要记录的子串选项，可以指定是不包括子串数据中的任何内容、包括子串数据的所有内容还是只包括某些子串的数据。

下面介绍了要记录的子串选项的可用设置。

  • 无。指定不记录子串中包含的任何数据。

  • 选定。指定只记录那些启用了记录子串选项（位于更多数据源选项对话框的常规属性页上）的子串的数据。

  • 全部。指定应记录子串中包含的所有数据。


对象打印方法

“对象打印方法”选项卡

对象打印方法选项的作用是：当打印机或 Seagull 打印机驱动程序不直接支持某个对象类型时，指定如何在感热打印机上打印对象。

设置

  • 对全部格式使用设置。指定在此对话框上设定的设置将应用于使用任何 Seagull Windows 打印机驱动程序打印的所有格式。

  • 仅对此格式使用设置。用于指定在此对话框上指定的设置将只应用于当前活动的标签格式。

对象

  • TrueType 文本。指定是将 TrueType 字体作为文本输出打印，还是作为位图打印。当打印机不直接支持彩色 TrueType 文本的某种颜色时（例如，打印机支持红色和黄色，但 TrueType 字体为橙色），此选项将影响打印该文本的方式。如果选择位图，则打印机可以抖动（即混合）不同颜色的点，以生成所需颜色的文本。例如，打印机会抖动红色和黄色的点来生成橙色字母。但是，呈抖动后颜色的文本阅读起来会比较费力，尤其是字体较小时。如果选择文本输出，则打印机将以最接近的直接支持的颜色打印文本，因此，打印机将根据橙色的深浅，将橙色文本打印为红色或黄色。

  • 不受支持的一维（或二维）条形码。在打印机或 Seagull 打印机驱动程序不支持一维和二维条形码符号体系的情况下，指定是使用位图还是使用设备线来打印一维和二维条形码。如果将此选项设置为自动，驱动程序将确定最佳的打印方法。

  • Lines, Boxes, and Ellipses. Specifies whether lines, boxes, or ellipses will print using Raster Graphics or using the printer's device settings if they are unsupported by either the printer or the Seagull Scientific printer driver. 如果将此选项设置为自动，驱动程序将确定最佳的打印方法。

使用测试打印按钮打印一张标签，并关闭打印对话框。您将不会得到任何提示，即使您已将标签格式上的某个字段设置为“打印时提示”。而是使用该字段的默认数据。如果标签格式上的某个字段设置为序列化，则该字段中显示的数据与一系列标签中第一张上显示的完全相同。

使用预览按钮，打开打印预览功能。


性能

“性能”选项卡

全部显示 全部隐藏

Seagull Windows 打印机驱动程序

BarTender 的一些杰出功能（以及许多其它 Windows 程序）将导致向打印机发送大量的信息。这意味着，除非打印机得到最佳配置，否则会降低打印速度。默认情况下，BarTender 已配置为尽可能多地利用打印机内置的“高级”图像命令。但是，在某些情况下，需要使用 Seagull Scientific, Inc. 提供的打印机驱动程序（如下所述）来禁用其中的一个或多个此类功能。

设置

  • 对全部格式使用设置。指定在此对话框上设定的设置将应用于使用任何 Seagull Windows 打印机驱动程序打印的所有格式。

  • 仅对此格式使用设置。用于指定在此对话框上指定的设置将只应用于当前活动的标签格式。

Seagull 打印机驱动程序选项

Seagull 打印机驱动程序选项用于指定 BarTender 在使用 Seagull 打印机驱动程序时如何利用内置的打印机功能。

注意：很少将这些选项从默认设置更改为其它设置，而且它们通常只用于解决问题。

  • 使用打印机的静态图形。指定 BarTender 将使用打印机的静态图形功能来存储有关所有位图类型对象的规格，这类对象的打印效果对于每个标签完全相同，包括 TrueType 字体。

  • 使用打印机的静态标签。指定 BarTender 将使用打印机的静态对象功能来存储有关所有对象的规格，这些对象的打印效果对于每个标签完全相同，而不管标签是否为位图。其中包括打印机字体、条形码、导入的图形和 TrueType 字体。

  • 使用打印机的序列。指定 BarTender 在任何适合的情况下使用指定打印机的内置递增功能。

重要提示：切记，TrueType 字体是作为图形（而不是作为下载字体）传送到感热打印机的。由于感热打印机只能递增被处理成字体的数据，因此不能使用打印机内置的序列化功能递增 TrueType 字体。如果希望将标签上的某个对象序列化并利用打印机的序列化功能，则必须使用打印机的内置字体之一。

  • 使用打印机的标签格式。指定 BarTender 将使用打印机的数据合并功能来存储标签的格式规格（对象位置、符号体系、字体等），以便只需传送对象数据。

  • 允许图形高速缓存。指定打印机驱动程序将通过跟踪以前打印的图形来使用打印机中的存储功能。

  • 允许格式高速缓存。指定打印机驱动程序将通过跟踪以前打印的格式来使用打印机中的存储功能。

  • 当使用 TrueType 字体时警告。指定当 BarTender 设置为在感热打印机上打印 TrueType 字体时，应显示相关的提醒消息，即 TrueType 字体可能会对打印速度造成不利影响，尤其是对于使用串行端口的打印机。

注意：有关如何处理一些不常见性能问题的信息，请参见特殊打印机设置文件。

使用测试打印按钮打印一张标签，并关闭打印对话框。您将不会得到任何提示，即使您已将标签格式上的某个字段设置为打印时提示。而是使用该字段的默认数据。如果标签格式上的某个字段设置为序列化，则该字段中的数据将与一系列标签中的第一张标签上显示的数据完全相同。


特殊打印机设置文件

特殊打印机设置文件可以用于对打印机性能的某些方面进行更精确的控制。使用此文件，可以完成以下任务：

  • 在未使用 Seagull Scientific 打印机驱动程序时，将打印机识别为感热打印机。

  • 控制墨水扩散。

  • 将打印机识别为不支持基于打印机复制的打印机。

  • 替换或重命名链接到标签格式的打印机，而不必更改每个格式。

有关详细信息，请参阅 btwprn.ini 文件。该文件位于安装目录中。


刷新高速缓存

在有些情况中，BarTender 可能会认为项已存储于打印机中供以后重复使用，而这些项实际上未被存储。一旦发生此情况，BarTender 可以执行打印作业，但不会将某些项发送到打印机，因为它认为这些项已存储在那里。这会导致标签缺少某些部分，甚至产生空白标签。

刷新 BarTender 的高速缓存信息

对于大多数情况，单击打印对话框的打印机高速缓存选项卡上的立即清除高速缓存按钮，然后按下确定。这将指示 BarTender 假定以前存储在打印机中的所有项都将丢失，导致在随后的打印作业期间所有标签项都被发送到打印机（至少在 BarTender 认为它们被再次存入高速缓存之前）。

网络打印机

如果您使用的是网络打印机，并且您具有使用相同打印机的多个用户，则清除高速缓存的时间可能会很长。在此情况下，您需要禁用打印对话框的性能选项卡的允许图形高速缓存和允许格式高速缓存选项。


打印机高速缓存

全部显示 全部隐藏

由 Seagull Scientific, Inc. 提供的打印机驱动程序与 BarTender 结合使用时，能够将格式和图形存储（或缓存）在打印机中，以供后续打印作业重新使用。这可以显著提高打印作业的处理速度，因为只需发送一次大图形和经常打印的标签格式。

清除高速缓存

BarTender 能够跟踪存储在打印机中的项。不过，有些情况（如打印作业失败或更换打印机）可能会导致 BarTender 认为某些项已存储在打印机中供以后重新使用，但实际上却没有。一旦发生这种情况，BarTender 可以执行打印作业，但不会将某些项发送给打印机，因为它认为这些项已存储在打印机中。这会导致标签缺少某些部分，甚至产生空白标签。因此，建议您定期刷新（清除）打印机的高速缓存。

启用打印机高速缓存

若要打开打印机高速缓存，必须启用打印对话框性能选项卡中的允许图形高速缓存和允许格式高速缓存复选框。

使用该属性页上的选项可以指示 BarTender 按指定的时间间隔定期清除高速缓存。下面简要介绍这些选项。

注意：如果将多台计算机设置为打印到同一台打印机，则高速缓存不会正常工作。因此，对于要打印到一台使用高速缓存的共享打印机上的所有 BarTender 副本，需要禁用打印对话框性能选项卡中的允许图形高速缓存和允许格式高速缓存选项禁用。

自动清除高速缓存

  • 每一个 BarTender 会话期。指定 BarTender 在每个会话的第一个打印作业开始时清除打印机的高速缓存。

  • 每日。指定 BarTender 在每天第一个 BarTender 会话的第一个打印作业开始时清除一次打印机的高速缓存，而不考虑要运行的 BarTender 会话数。

  • 每周。指定 BarTender 在每周第一个 BarTender 会话的第一个打印作业开始时清除一次打印机的高速缓存。

  • 每月。指定 BarTender 在每月第一个 BarTender 会话的第一个打印作业开始时清除一次打印机的高速缓存。

  • 从不。指定 BarTender 不清除打印机的高速缓存，除非明确按下立即清除高速缓存按钮。

立即清除高速缓存。用于清除打印机的高速缓存。

管理高速缓存。用于访问驱动程序的高速缓存选项对话框，以指定使用打印机高速缓存的方式。

使用测试打印按钮打印一张标签，并关闭打印对话框。您将不会得到任何提示，即使您已将标签格式上的某个字段设置为“打印时提示”。而是使用该字段的默认数据。如果标签格式上的某个字段设置为序列化，则该字段中显示的数据与一系列标签中第一张上显示的完全相同。


Print Code Modifier

Printer Code Modifier

The Printer Code Modifier functionality allows modification of print code being sent to a printer or Print Code Template by searching and replacing text. Printer Code Modifier Actions can be constructed and tested on existing print code files, and if the search and replace requirements are more complex VB Scripting can be used in addition.


Print Code Modifier Actions Dialog

Actions List Dialog

Show All Hide All

This dialog permits you to create, modify, and test actions for Printer Code modification.

Actions List

This is a list of all the Printer Code Modifier Actions that will be performed. Each action consists of text to be searched for, directions to insert, replace, or delete that text, and the search method to be used. It is also possible to specify the code page to be used. The actions in the list are performed in the order they appear, and each action makes a complete pass through the print code before continuing with the next action.

Below the list are buttons for maintaining the actions list:

Button | Purpose
 | New Action. Inserts a new action into the list.
 | Delete Action. Deletes the selected action.
 | Cut Action. Deletes the selected action but places a copy of the action into BarTender's clipboard.
 | Copy Action. Copies the selected action into BarTender's clipboard.
 | Paste Action. Pastes a copy of the action currently in the clipboard into the list.
 | Move Action Up. Moves the selected action up one position in the list.
 | Move Action Down. Moves the selected action down one position in the list.

Note: Each of these commands can also be accessed by right-clicking anywhere in the list.

The Actions list can be saved or imported from a file using the buttons below the list itself.

  • Import... Import a saved list of Print Code Modifier actions from a file.

  • Export... Export the list of actions to a file.

    • Action Options

    Options for individual actions can be set separately.

    • Description: Name used to identify the selected action.

    • Action: Action to be performed using the Search Text. Options available are Search and Insert After, Search and Insert Before, Search and Replace, and Search and Delete.

    • Search Text: Text to be searched for in the print code. The arrow button can be clicked to display a list of control characters that can be inserted in the search text field.

    • Replace Text: Text to replace searched text.

    • Encoding: The code page to use with the replacement text. The default is Windows' System Default.

    • Search Method: Options are Literal, where the exact characters entered are searched for, or Wildcard, in which special search characters may be used, e.g.

        Code

        Description

        ?

        Match any single character.

        *

        Match any 0 or more characters.

        $

        Match end of line.

        ^

        Match beginning of line.

        \

        Next character is literal. Escape the next character (if next character would otherwise be interpreted as a wildcard)

        \xNN

        Insert Hexadecimal character, where NN consists of two hexadecimal digits.

    • First Occurrence Only If the checkbox is selected the action will only be performed for the first occurrence of the search text.

    • Test... Clicking this button brings up the Modify File dialog to test the list of actions and confirm they behave as desired. The actions are performed using the content of the specified source file and exported to the destination file.

      • Source File: Location of the print code file to be read.

      • Destination File: Location of the file where the results will be exported to.

      • Automatically Overwrite Destination File If checked, the destination file contents will be replaced if the file already exists.

      • Display Destination File After Modification If checked, the file will be displayed after the search is complete.

      Search Rules

      The following rules apply to wildcard searches:

      • ^ does not match line termination codes (CR/LF) in the input file for insertion, deletion, or replacement.

      • $ does match a CR/LF sequence in the input file for deletion, but not for insertion or replacement.

      • * and ? do not match line termination codes (CR/LF). If the search pattern is to extend over more than one line it must explicitly contain $ characters.

      • The ^ character is only legal as the first character of a search string, unless escaped. In any other location it will be treated as part of the text string.

      • A search string consisting only of a single ^ character is not legal and will be ignored.

      • The $ character is legal anywhere in the search string

      • Two * characters may not be adjacent to each other in the search string, unless one or both are escaped. Only the first * will be interpreted as a wildcard command. Any subsequent * characters will be treated as part of the text string.

      • A search string that ends with a * is not legal. The correct method is to end the search string with a ? character.

      • When processing a Printer Code Template export file (only) the search string will not match any part of a template field tag.

      Examples

      Examples of search strings:

      • ^Cutter$: Looks for a single line that consists only of Cutter.
      • ^Cutter*$: Looks for a line starting with Cutter and matches the entire line.
      • ^*Cutter*$: Looks for any line containing Cutter and matches the entire line.
      • ^Cutter ???*$: Looks for any line containing Cutter<space> and any three or more characters, matching the entire line.
      • Cutter: Searches for Cutter anywhere in the file, matching only those six characters and not the entire line where they are found.


使用脚本助理

VB Scripting can be used in regular print-time operations or with Printer Code Modifier actions. 脚本助理有两个主要用途：

  • 它包含一个较大的脚本编写区域，在该区域中，既可以通过键入方式编写实际脚本，也可以使用脚本助理的表达式构建工具来编写实际脚本。

  • 它提供了引用构建工具和表达式构建工具，可帮助您编写脚本。尽管脚本助理的初衷是为在技术方面不熟练的用户简化脚本设计，但甚至是经验丰富的 Visual Basic 用户也会发现它非常有用。

下面概要介绍脚本助理的选项。有关详细信息，请单击相应的选项名称。

  • 脚本编写区域。根据您打开脚本助理的方式和要创建的 Visual Basic 脚本类型，您在该对话框顶部的这一区域中所看到的内容可能有所不同。

    • Expression . This edit box will be called Expression if the Script Assistant is opened by selecting Visual Basic Script is selected on the Data Sources tab of the Modify Selected … Object dialog and Single-line Expression is selected from the Type dropdown. This is where you enter your single-line expression.

    • Script. The edit box will be called Script if the Script Assistant is opened by selecting Visual Basic Script is selected on the Data Sources tab of the Modify Selected … Object dialog and Multi-line Expression is selected from the Type dropdown or if the Printer Code Modifier Visual Basic Script... button is clicked. The edit box is where you compose your multi-line script.

    • 事件列表。此选项仅适用于事件控制脚本。或者，如果脚本助理是通过更多数据源选项对话框的 VB 脚本选项卡打开的，则可以使用此选项来指定将导致脚本启动的特定事件。（每种事件类型都可以具有自己的脚本。）

  • 样本。在按测试按钮后，将使用样本数据执行脚本，并在此显示输出。

  • 类别。列出 BarTender 和 Visual Basic 中脚本所需使用的组件的类别。突出显示的类别确定了在名称选项中显示的项的列表。

  • 名称。显示当前突出显示的类别项中包含的 Visual Basic 组件的名称。

  • 描述。显示当前在名称选项中突出显示的 Visual Basic 组件的语法和概述信息。有关详细的帮助信息，请单击 Visual Basic 帮助按钮以显示 Microsoft 完整的 Visual Basic 脚本文档，或单击此处获取有关特殊的 BarTender 对象、函数和属性的帮助。

  • 测试。使用样本数据执行脚本，并在样本消息区域中显示输出。

  • 插入。从名称选项中提取突出显示的 Visual Basic 组件，并将其插入到表达式、脚本或事件 <事件名称> 的脚本编辑框中。

  • 帮助。打开此帮助系统。

  • Visual Basic 帮助。显示 Microsoft 完整的 Visual Basic 帮助文档。


执行大型点阵打印作业时需注意的事项

如果要使用点阵打印机打印大量标签，我们建议您在打印过程中检查标签。每打印 1000 张标签至少检查一次标签的质量，这是经验之谈。

确保条形码中条码的黑色适中。当打印机的色带使用时间较长时，条码的颜色会逐渐变淡。虽然有些条形码阅读器能读取“灰色”的条码，但很多阅读器都不行。某些打印机色带在打印了数千张标签后，再打印的条形码很明显就是灰色。

如果要用薄片或其它包覆材料来覆盖条形码，应当使用相应的包覆材料来测试一些条形码。某些薄片（尤其是一些发光的材料）会大大影响阅读速度。用褪色的色带打印出来的条形码更是容易受到高光薄片的影响。

在打印过程中您还需要检查标签，确保打印机的托架未滑动，以保证标签在垂直方向上始终对齐。


DOS COPY 和 PRINT 命令

标签被打印到二进制图形文件。在使用 DOS copy 命令来复制二进制文件时，务必要在命令行中包括 /b 参数。例如，

copy filename.prn /b prn

不建议将 DOS print 命令用于 BarTender 的打印输出文件，因为与 copy 命令不同，print 命令当前不具有用于打印二进制文件的 /b 选项。


了解打印机代码模板

在某些生产情况下，人们使用便携式设备或终端设备来打印标签。在很多情况下，这些便携式设备和终端设备都专用于一项作业（如打印），因而通常不运行 Microsoft Windows 操作系统，也就无法运行 BarTender 之类的标签打印程序包。

这些便携式设备和终端设备通常将打印机代码用于标签，并将代码合并到用户输入信息中，例如批号和过期日期，然后将完成的打印机代码直接发送给打印机。

其它系统可能使用软件打印应用程序，这些程序将用户信息插入标签的打印机代码中。SAP/R3 就是这样一个系统，它使用 SAPScript-ITF 文件。SAPScript-ITF 文件大部分由打印机代码组成，但还有一些附加字段信息用于代替数据输入和系统处理。SAP/R3 系统软件打开由打印机代码和附加字段构成的 SAPScript-ITF 文件，合并用户信息后，再将它发送给打印机。

这些设备、终端以及打印应用程序统称为打印系统。

为了支持不同的打印系统，BarTender 提供了打印机代码模板生成功能。打印机代码模板包含大多数本机打印机代码，但还包含打印系统能够识别并用来合并用户输入信息的已分界字段。

A new capability being supported by some printers is the ability to receive and process XML-formatted print job information. The printer can take a previously stored label format and populate its field data with the information from the XML file for each label. BarTender has built-in Printer Code Template print system support for several XML printers, and custom print systems can be added for other XML capable printers using the Printer Code Template features.

注意：除非您拥有 BarTender 企业版并使用 Seagull Scientific, Inc. 提供的支持打印机代码模板的打印机驱动程序，否则不能使用该功能。

另请参见：

导出到打印机代码模板

打印机代码导出选项

打印机代码模板设置

打印机代码验证


了解 Visual Basic 脚本数据源

了解 BarTender 中的 Visual Basic 脚本

注意：本主题介绍如何将 Visual Basic 脚本与 BarTender 的内部脚本引擎一起使用。并不涉及有关自动化 BarTender 的内容。

脚本的用途

BarTender 的内部脚本功能主要有两种用途：

  • 脚本输出可用作文本对象或条形码对象的数据源。

标签格式上的文本对象和条形码对象可以从多个数据源接收数据，包括键盘、数据源文件以及计算机的时间和日期功能。不过，有时您可能会有一些特殊要求。例如，可能需要从文件读取数据，按照某种特殊方式更改数据，然后可能要采用某种不常见的方式将该数据与其它某些数据组合在一起。BarTender 可以将 Microsoft 的 Visual Basic 脚本用作数据源，这就让您能够以任何可能的方式处理和组合标签对象的数据。

如果这正是您的目的，您必须在修改所选…对象对话框的数据源选项卡上将对象的数据源设置为 Visual Basic 脚本。单击该选项卡上的编辑按钮打开“脚本助理”，您可以在其中创建脚本。

  • 脚本可用于对来自其它一些数据源（如数据库或键盘）的数据执行特殊的确认或其它处理。

有时，在打印之前必须采用某种不常见的方式对数据进行确认或处理。而有时，您可能希望系统上另一个识别 ActiveX 的应用程序以某种受控的方式对 BarTender 中的事件作出反应。例如，可能希望 BarTender 取消同样标签份数超过指定数字的打印作业。

如果这正是您的目的，则必须将对象的数据源设置为屏幕数据、数据库、时间或日期。然后，在修改所选…对象对话框的数据源选项卡上，单击更多选项按钮。在更多数据源选项对话框中，打开 VB 脚本选项卡，启用 VB 脚本，然后单击编辑按钮打开可在其中创建脚本的“脚本助理”。

如何在 BarTender 中使用 Visual Basic 脚本

Visual Basic 脚本是 Microsoft 的 Visual Basic 编程语言的子集。它专用于在现有程序中添加功能，而不是用于编写程序本身。当用作 BarTender 中的数据源时，Visual Basic 脚本可以和一个命令或“函数”一样简单。例如，单行 Visual Basic 脚本可用于在导入的数据字段中添加或删除一个或多个字符。脚本也可能非常复杂，以至它们自身几乎就是程序（尽管它们仍用在其它程序中）。此类脚本可能会测试许多条件，然后根据结果执行一个或可能多个任务。

哪些人应使用 Visual Basic 脚本

虽然 Visual Basic 脚本可以复杂到足以被视为“程序”，但有时证明只一行 Visual Basic 脚本也非常有用。这么简单的脚本用鼠标和 BarTender 的“脚本助理”就可以完成，根本不需要进行传统意义上的“编程”。尽管如此，但脚本编写仍然是“能力型用户”的技术，不是计算机初学者想像的那么简单。无论您的计算机技能水平如何，在着手建立基于脚本的解决方案之前，应始终明白 BarTender 并没有为您的问题提供解决方案。

另请参见：

了解不同类型的 Visual Basic 脚本


Visual Basic 脚本的类型

为使 Visual Basic 脚本能为除编程人员外的更多人使用，脚本的复杂度分为三个级别。有关适合您的脚本类型的详细信息，请单击以下相应的选项。

如果您尚未做过，应当阅读了解 BarTender 中的 Visual Basic 脚本。

  • 单行表达式。这是最简单的脚本，即便是编程经验很少甚或没编过程的人也能编写。

  • 多行脚本。编写多行脚本要求具备较高级的编程知识，不过多行脚本对于自定义控制数据确实能起到独特的作用。

  • 事件控制脚本。采用多行脚本的概念，但不是让 BarTender 决定何时执行脚本，而是允许您指定一个或多个触发脚本执行的“事件”。


脚本编写区域

全部显示 全部隐藏

这个大编辑框位于“脚本助理”的顶部，用于放置 Visual Basic 代码，代码可以是单行表达式，也可以是一个真正的脚本。根据数据源属性页中指定的 Visual Basic 脚本的类型，此编辑框可按以下三种方式之一使用：

当“类型”设置为“单行表达式”时

编辑框的名称将显示为“表达式”。与完整行或多行的真正 Visual Basic 脚本相反，该编辑框只允许您输入单行表达式。单行表达式包含一个或多个函数，且不采用“=”赋值运算符。有关详细信息，请参见单行表达式。

当“类型”设置为“多行脚本”时

编辑框的名称将显示为“脚本”。您可以在该编辑框中输入一行或多行真正的 Visual Basic 脚本。不允许只输入没有正确使用赋值运算符的单行表达式。有关详细信息，请参见多行脚本。

当“类型”设置为“事件控制脚本”时

“多行脚本”设置规定每个对象子串只能有一个脚本。而且，BarTender 会分析脚本和标签格式，并根据预设的规则集自动确定脚本的理想执行次数。相反，“事件控制脚本”能明确设置为在需要响应某特定事件时执行。而且，您可以为一个对象子串指定多个事件控制脚本，每个脚本都为响应不同的事件而执行。有关详细信息，请单击了解多事件脚本的使用。

两个特殊的“事件脚本”

事件列表顶部的“函数和子例程”脚本和“OnAutoSelectedEvent”脚本需要专门讨论。要了解详细信息，请单击两个特殊的事件脚本。

当从“更多数据源选项”对话框打开“脚本助理”时

此时，编写区域中显示的内容与上述“当‘类型’设置为‘事件控制脚本’时”中显示的相同。

另请参见：

事件控制脚本


类别

结合使用类别和名称选项，有助于查找适当的 Visual Basic 语句并将其插入编辑框中。

了解类别

编写 Visual Basic 脚本时，有数百个函数、运算符、常数和其它语言组件可供选择。单击 Visual Basic 帮助按钮，可查看 Microsoft 文档，获得这些组件的完整列表。不过，为便于管理，“脚本助理”中只包括了其中一部分组件。

注意：尽管“脚本助理”中没有列出全部 Visual Basic 组件，但仍可以在脚本中手动键入未列出的组件。

即使组件的数目已减少了很多，但如果在一个列表中显示这些组件，那么要搜索某个 Visual Basic 组件仍很困难且慢，因此，我们将列表分成了几个单独的类别。

选择类别

要选择某类 Visual Basic 语言组件，只须在类别列表中单击所需的项。随后，“脚本助理”中包含的所选类别的组件将显示在类别右侧的名称列表中。

子类别

有时，某类 Visual Basic 语言组件非常大，我们不得不将之再分成多个子类。在类别列表中，如果某类别左侧有加号 [+]，则表明该类别包含子类别。单击该符号或双击相应的类别可将其“展开”，显示子类别。（此时，加号将变成减号 [-]。）然后，可以单击显示的任何子类别，查看关联的名称列表。要“折叠”显示的子类别，只须再次双击主类别或单击减号。

BarTender 对象

BarTender 对象是这些类别之一，其中包含与 BarTender 有关的特殊对象、属性和函数，这些对象没有嵌入 Visual Basic 脚本语言本身内。有关这些对象的帮助信息，请单击此处。


VB 脚本对象、属性和函数的名称

名称

结合使用名称选项和类别选项，有助于查找适当的 Visual Basic 语句并将其插入编辑框中。

名称选项列出了“脚本助理”中当前突出显示的类别的 Visual Basic 组件。无论何时，只要突出显示该列表中的某个组件，名称列表右侧的说明选项中就会显示有关该组件的简要帮助信息。有关详细的帮助信息，或要查找 BarTender “脚本助理”中未列出的 Visual Basic 组件的帮助信息，请单击 Visual Basic 帮助按钮，查看所有 Visual Basic 组件的 Microsoft 帮助信息，或者单击此处，了解特殊的 BarTender 对象、函数和属性的帮助信息。

在脚本编辑框中插入 Visual Basic 代码

找到要查找的指定 Visual Basic 组件后，双击该组件，可以将其插入脚本或表达式编辑框中。单击所需的组件，然后单击“脚本助理”底部的插入按钮，也可以起到同样的效果。

了解“用户定义的”项

大多数 Visual Basic 语言组件都有一个或多个必须由用户定义的项。在编辑框中插入了新的 Visual Basic 组件后，所有此类用户定义的项都将显示在双尖括号中。例如，用于返回文本字符串左半部分的“Left”函数，在插入编辑框中后，将如下所示：

Left("字符串", "长度")

在此例中，两个用户定义的项“字符串”和“长度”，用于告知函数要处理的字符串以及返回的字符长度。您必须在所有此类用户定义的项中输入内容，并删除尖括号，正确完成插入的 Visual Basic 组件。

填写“用户定义的”项。

使用名称选项插入 Visual Basic 组件之后，系统将自动突出显示第一个用户定义的项。您可以使用名称选项插入另一个组件，或使用键盘手动修改，正确替换该用户定义的项。使用名称选项的好处是，修改完第一个用户定义的项后，系统会自动突出显示下一个用户定义的项（如果有）。不过，如果使用键盘替换用户定义的项，使用鼠标或箭头键也可突出显示下一个用户定义的项。


单行表达式

返回假定的数据库字段“PartNumber”中包含的数据。

返回“Length”指定的字符串中最左侧的字符数。

删除字符串右侧的所有尾部空格。

提取表达式或数值并将之设置为价格的形式。

提取字符串中的字符并强行将其转化为大写。

“Left”函数（显示一般的语法，而不是实际数据）。

还是 Left 函数，此次圆括号中的两个参数使用了实际的样本信息。 （请注意函数内的函数。）

仍然是 Left 函数。 请注意函数的函数内的函数。

在此例中，提取了 part number 字段中最左侧的七个字符，并将其附加到 color 字段的内容后。

单行表达式

单行表达式是 BarTender 支持的三种脚本类型中最简单的一种。单行表达式可以执行一些基本任务，例如，删除数据源文件字符串的一部分，或搜索和删除某些字符。单行表达式通常利用某些“函数”和“运算符”的组合。运算符通常（但不一定）对数字数据执行数学运算。函数也可以对数学数据值进行运算，但更常见的情况是用于处理字符集（或“字符串”）。

样本函数

此处显示的所有样本函数都是“字符串”函数，这是 BarTender 中最常用的函数。不过，“脚本助理”中还列出了其它各种函数类型。（圆括号内的尖括号和变量名用于显示函数的“语法”— 它们不是函数本身的部分。您必须用相应的字段名、变量和/或常数代替圆括号内的内容，且不得键入尖括号。）

Field("PartNumber")

Left(<<字符串>>,<<长度>>)

RTrim(<<字符串>>)

FormatCurrency(<<表达式>>)

UCase(<<字符串>>)

样本运算符

  • 算术运算符：+ - * / &

  • 逻辑运算符：< <= <> = > And Mod Not Or

单行表达式示例

所有函数（包括上述样本函数在内）均已是单行表达式。此外，还可以使用运算符将函数组合起来，甚至可以在函数内再使用函数。（以下某些示例假定使用的数据库中包含名为“PartNumber”和“Color”的字段。）

Left(<<字符串>>,<<长度>>)

Left(Field("PartNumber"), 7)

Left(Rtrim(Field("PartNumber")), 7)

Left(Field("PartNumber"), 7) & (Rtrim(Field("Color")))

有关上述函数和 Visual Basic 脚本中所有可用函数的详细说明，请参见说明选项，或在 BarTender“脚本助理”中点击 Visual Basic 帮助按钮。

此外，还可以单击此处，了解“脚本助理”中包含的特殊 BarTender 对象、函数和属性的帮助信息。

另请参见：

在单行表达式中添加条件执行


使用 In-line If (IIF) 函数

单行表达式中的 In-line If (IIF) 函数和条件执行

将条件执行添加到一个或多个函数中的传统做法是使用 If 和 Else 语句。另一种相对简单的替代方法是使用“In-line If”函数（缩写为 IIF）。IIF 函数提供了使用 If 和 Else 语句可获得的大部分功能，又不需要使用多行 Visual Basic 代码。事实上，这是在单行表达式中添加条件执行的唯一方式。此外，它的使用也非常简单，因此许多用户在多行脚本中也尽可能使用该函数，尽管在多行脚本中本可以使用分开的 If 和 Else 语句。

IIF(<ConditionalExpression>,<ExpressionIfTrue>,<ExpressionIfFalse>)

注意：尽管许多计算机语言中都有 IIF 函数，但 Visual Basic 中并没有该函数。因此，BarTender 的制造商创建了“脚本助理”中提供的此函数版本。

请注意，IIF 函数包含三个表达式：

  • 条件表达式。

  • 当条件表达式为 True 时执行的表达式。

  • 当条件表达式为 False 时执行的表达式。

计算 IIF 函数的条件表达式

IIF 函数首先检查条件表达式（函数中的第一项），查看其是 True 还是 False。例如：

  • Quantity > 100

    • 如果名为“Quantity”的变量大于 100，则此条件表达式样本为 True。

  • (Field("PartType") = "Breakable") AND (Field("Price") > 1000)

    • 此条件表达式样本检查正读取的数据文件中名为“PartType”的字段，还会查找同一部件的“Price”字段。此时，如果当前数据文件记录的“PartType”字段为文本“Breakable”，且该部件的“Price”超过 1000，则表达式结果为“True”。

完成 IIF 函数的执行

如果条件表达式为 True，则执行 IIF 函数中的“ExpressionIfTrue”项。如果条件表达式为 False，则执行“ExpressionIfFalse”项。每次执行 IIF 函数时，只能执行这两个表达式中的一个。“ExpressionIfTrue”和“ExpressionIfFalse”表达式可以是任何有效的单行表达式，包括其它（“嵌套的”）IIF 函数。


多行脚本

有时，单行表达式不足以准确地检测数据并计算所需的结果。因此，有时可能需要使用多行脚本。由于多行脚本实际上就是一个简化的 Visual Basic 程序，所以您可以根据需要改进它。

使用多行脚本时设置名为“Value”的变量

通常，BarTender 中的 Visual Basic 脚本已接受了键盘输入的数据或数据源文件中的数据，请按照某种方式更改数据，然后将更改后的数据赋予某条形码或文本对象。要赋此值，脚本中必须有一行以“value =”开头的 Visual Basic 代码（通常在脚本的末尾，但不必一定如此）。等号的右侧是您希望赋予的值。例如：

value = LEFT(Field("part_number"),5)

在此例中，从当前的数据库记录中提取“part_number”字段，然后丢弃前五个字符后的所有字符。将此结果放入保留的变量“value”中，等于给与此数据源关联的条形码或文本对象赋予此值。

所有多行 Visual Basic 脚本的两个重要特征

  • 必须使用赋值运算符

  • 流控制能力

另请参见：

在单行表达式中添加条件执行


必须使用赋值运算符

用于“单行表达式”的 Visual Basic 是 BarTender 的制造商开创的一种简化形式，目的是为了让非编程人员也能使用 Visual Basic。不过，单行表达式仅仅是部分 Visual Basic 行，不能用在多行脚本中。多行脚本要求将任何函数、表达式或其它运算的结果“赋予”某变量。例如：

Value = Trim(Field("part_number")) & Field("price")

在此例中，从当前数据库记录中提取“part_number”字段，删除所有尾部空格，并将该部件的价格附加（或“连结”）在该部件号末尾。然后，将组合而成的数据赋予名为“Value”的变量。


流控制能力

全部显示 全部隐藏

流控制指计算“条件表达式”且仅当条件满足时执行特定操作的能力。可以定义多个操作，但具体执行哪个操作取决于“条件”测试的具体结果。

“If”和“Else”语句

Visual Basic 中最简单的流控制语句是“If”和“Else”语句。以下是一个示例，首先是文字描述：

如果价格超过 $100，则执行一个函数、进行计算或执行其它任务。否则，执行另一个函数、计算或任务。

以下是上述示例的更详细版本，已译成了正确的 Visual Basic 形式：

If Field("price") > $100 Then

message = "请叫经理复核付款。"

Else

message = "正常处理命令。"

End If

在上例中，根据当前数据库中的 price 字段是否超过 $100 设置了不同的“message”变量。

重要提示：为了确定在打印作业过程中运行脚本的最佳时机，以及需要访问的数据文件字段，BarTender 会检查标签设计结构，进行隐式脚本运行测试。除其它因素之外，BarTender 还要考虑何时使用数据库字段和子串共享名称以及如何使用。根据流控制语句，所设条件表达式得到的代码很可能引用 BarTender 在开始打印作业前执行脚本运行测试过程中跳过的字段或共享名称。如果在打印作业过程中条件语句的计算结果不同，以致现在执行而不是跳过这些引用，那么，脚本可能会失败。强制引用字段和共享名称可避免这种可能性。

其它流控制类型

Visual Basic 中还有其它类型的流控制语句。例如，有些“分支”与上面讲述的 If-Else 语句类似，而有些“loop”。请遵循以下操作了解有关流控制语句的详细信息：

  1. 从“脚本助理”或 BarTender 主下拉菜单中，选择 Visual Basic 脚本帮助。

  2. 单击功能信息。

  3. 单击 VBScript 功能。

  4. 查找类别控制流。

  5. 单击您想了解的流控制语句的关键字。


强制引用字段和共享名称

为了确定在打印作业过程中运行脚本的最佳时机，以及需要访问的数据文件字段，BarTender 会检查标签设计结构，进行脚本运行测试。除其它因素之外，BarTender 还要考虑何时使用数据库字段和子串共享名称以及如何使用。

条件语句的执行问题

条件语句会根据条件表达式的计算结果执行不同的代码“分支”。因此，根据计算时的条件，某些代码可能不会执行。如果在 BarTender 进行脚本运行测试的过程中，某字段或共享名称的引用刚好在跳过的代码中，就会产生问题。如果相关的条件语句在打印时的计算结果不同，以致要引用该字段或共享名称，而在前面的运行测试过程中却并没有引用它，那么，脚本就可能无法在最有效的时机运行，甚至还可能失败。

两个不同的强制函数

“脚本助理”包括两个强制脚本引用某数据文件字段或子串共享名称的函数。这两个函数不会更改或分配任何值，而只是强制 BarTender 注意在脚本运行测试过程中可能错过的项。这样可确保 BarTender 建立所有必需的数据字段的链接，还可确保在打印时能执行脚本来响应相应的事件。

要在“脚本助理”中查找以下两个函数，请在类别选项中依次双击函数和声明。然后，在名称选项中双击所需的引用函数和字段或共享名称。最好将引用函数插入脚本的开头处、所有条件语句之前。

强制引用数据文件字段

ReferenceField("字段名称或字段号")

如果标签格式设置为从常规文本文件中读取数据，则应指定字段号。从数据库中读取数据时，应指定字段名称。除非字段名称本身包含在变量中，否则务必在字段名称两边加上引号，例如 ReferenceField("price")。切勿使用尖括号。

强制引用共享数据子串

ReferenceSharedSubString("共享名称")

如果已为标签格式中任何对象的任何子串赋予了某共享名称，则可以如上所示强制引用它们。（除非共享名称包含在变量中，否则务必在它两边加上引号。）


事件控制脚本

全部显示 全部隐藏

事件控制脚本是 BarTender 中一个最高级的功能，只有具备技术知识的人员才能使用该功能。

根据脚本的用途，有的脚本可能偶尔才执行，一个标签作业只执行一次，有的则需要频繁执行，每一个标签就要执行一次。这分别是打印作业中发生的最不频繁和最频繁的“事件”。不过，在这二者之间，还存在多种事件，其发生频率要高于整个作业一次，低于每一个标签一次。

为尽量简化起见，BarTender 通常会检查单行表达式和多行脚本，试着确定脚本的理想执行频率。对于大多数用户和用途而言，这已足够。不过，有时您可能需要更精确地控制并需要明确指出脚本的执行时间。

不同的事件类型

尽管您总是要这么做的可能性很小，但对于 BarTender 支持的每种事件类型，标签上每个对象的每个数据子串仍有可能各有一个脚本。如果您确实要编写事件脚本，那么，只需要为一个特定事件类型以及可能仅为标签上的一个或数个子串编写脚本更为现实。

以下列出了一些最值得注意的事件类型的说明。

  • 当打印作业即将开始时。

  • 当打印作业刚刚完成时。

  • 显示提示对话框前。

  • 在用户按确定以关闭提示对话框后。

  • 在每一个标签上。（会使性能明显降低。）

  • 在每一个新记录上（当从数据源文件读取时）。

  • 当可能发生序列化时。（有关说明，请参见“脚本助理”。）

查看 BarTender 中定义的所有事件名称的列表：

  1. 将脚本类型设置为“事件控制脚本”。

  2. 单击编辑按钮，打开“脚本助理”。

  3. 查看事件列表选项。

有关事件列表的详细信息，请查阅脚本助理帮助中的相应部分。

另请参见：

在单行表达式中添加条件执行


事件列表

注意：仅当类型选项设置为事件控制脚本，或者从更多数据源选项对话框的 VB 脚本选项卡打开“脚本助理”时，“脚本助理”中才显示此列表。

对于大多数标签操作任务而言，将类型选项设置为“多行脚本”就已足够，此时不允许明确的事件控制。但 BarTender 会评估标签格式的结构和脚本的结构，确定脚本的最佳执行次数（或事件）。只有在您需要更精确地控制脚本的执行时间的次数不多时，才使用事件控制脚本。

有关详细信息，请参见事件控制脚本简介。

事件列表如何控制多个脚本？

如果将类型选项设置为多行脚本，则标签对象通常只有一个关联的脚本。不过，如果将类型设置为事件控制脚本，则您在事件列表中单击的每个事件都会有自己单独的脚本显示在编辑框中。有关详细信息，请单击了解多事件脚本的使用。

过程：

创建事件控制脚本

另请参见：

不同类型的事件脚本


创建事件控制脚本

遵循以下操作可创建一个事件控制脚本。

  1. 将数据源属性页上的来源设置为“Visual Basic 脚本”。

  2. 在类型选项中指定事件控制脚本。

  3. 单击编辑按钮，打开“脚本助理”。

  4. 单击事件列表选项中的所需事件。新选事件的脚本将显示在编辑框，同时还会显示该事件的说明。

  5. 在编辑框中键入突出显示的事件的脚本。（如果需要，您可以删除现有的说明。）

  6. 若要为同一个标签对象创建另一个脚本但该脚本要用于不同的事件，请单击事件列表中的所需事件。现有的脚本将被储存，编辑框将显示用于新选事件的脚本。

  7. 根据需要输入新脚本。

另请参见：

事件控制脚本

不同类型的事件脚本

使用脚本助理


了解多事件脚本的使用

在执行打印作业过程中，只有在 BarTender 预先确定的最佳时机才执行单行表达式和常用多行脚本。根据标签格式的结构和脚本的内容，脚本执行的频率可能很小，有时整个标签打印作业中才执行一次，也可能执行的相当频繁，每打印一行标签就执行一次。但有时，您需要更准确地控制脚本的执行时间。

如果标签对象或标签对象子串的 Visual Basic 脚本类型设置为“事件控制脚本”，则脚本编辑框左侧将出现事件列表选项，其中显示多种脚本类型。对于任何标签对象，您都可以为事件列表中的任何事件或所有事件定义脚本。

选择要为之编写脚本的事件

事件列表中每行的项都对应一个单独的脚本。如果要为某个事件编写脚本，只须在事件列表中单击该项。与前一突出显示的项关联的脚本不再显示在脚本编辑框中，取而代之的是与刚突出显示的事件关联的脚本。（请注意，除顶部的一两行注释外，除 OnAutoSelectedEvent 外的所有脚本都完全以空白开头。）现在，您可以将所需的任意行 Visual Basic 脚本插入脚本编辑框中。（别忘了为标签对象赋值，脚本中必须包含以“Value =”开头的一行脚本。）您可以在事件列表中单击任意多个不同的项，为每项定义一个脚本。

事件列表中的不同脚本类型

  • 函数和子例程。这实际上根本不是事件。如果在打开“脚本助理”之前将此选项选作“事件”，“脚本助理”中的编辑框将充当您编写一个或多个独立的 Visual Basic 例程的容器。以后，这些例程将被与真正事件关联的其它脚本调用和使用。有关详细信息，请参见两个特殊的事件脚本。

  • OnAutoSelectedEvent。这实际上根本不是事件。将其选作脚本的“事件”，只意味着您允许 BarTender 的内置智能分析您的脚本并确定在每个打印作业过程中执行脚本的最佳时机。对于单行表达式或多行脚本，此智能始终是打开的，但默认情况下对于事件控制脚本是关闭的。有关详细信息，请参见两个特殊的事件脚本。

  • 常用事件脚本。事件列表中的其余项对应于特定事件。有关详细信息，请参见常用事件脚本。


两个特殊的事件脚本

两个特殊事件

全部显示 全部隐藏

除最上面两个之外，事件列表中的每个事件控制脚本都对应一个极特定的事件。不过，列在最上面的两个事件比较特殊，如下所述：

函数和子例程事件

与函数和子例程事件列表项关联的脚本实际上根本不是事件脚本。您在该脚本中放置的函数和子例程是与同一对象子串关联的所有其它事件脚本都可访问的函数和子例程。您还可以使用函数和子例程脚本来声明其它事件控制脚本需要访问的变量。（这些变量不是完全“全局”变量，因为只有同一对象子串的事件控制脚本能访问它们，与其它子串关联的其它脚本则不能访问这些变量。）以下是经常执行的任务列表以及经常放在函数和子例程脚本中的项：

  • 用户定义的函数和子例程。编程时一种标准的惯用方法是将多处都需要运行的一部分计算机代码放入函数或子例程中。将这些代码放入函数和子例程脚本中，可以从多个脚本多次调用这些代码。

  • 公共变量。要声明某对象子串的所有事件控制脚本都可访问的变量，可以（使用 Visual Basic 的“dim”语句）在函数和子例程脚本中给它们定维。也可以只初始化变量，系统会自动替您给它们定维。（我们之所以使用“公共变量”而不是“全局变量”一词，是因为只有与同一子串对象关联的事件控制脚本才能访问这些变量。有关详细信息，请参见创建真正的全局变量。）

  • 变量初始化。要将变量设置为起始值，只需将类似于以下语句的一行 Visual Basic 代码

VariableName = value

插入函数和子例程脚本中。其中，“VariableName”是要初始化的变量的名称，“value”是变量初始化后的值。由于 Visual Basic 将确定尚未定维的变量并自动为您给它们定维，因此，采用此种初始化方法，您可以省却前面提到的变量定维操作。

  • 其它任何初始化。为了设置其它任何脚本可能需要的任何项而必须运行的其它任何代码，例如，打开或创建日志文件，或许检查文件是否预先已存在。根据您的需要和/或偏好，可以将此代码放在“函数和子例程”脚本中的函数或子例程中，或者仅保存为“裸”代码并按原样插入脚本中。

OnAutoSelectedEvent

当 Visual Basic 脚本的类型被设置为事件控制脚本时，此事件的调用频率等同于类型被设置为“多行脚本”时脚本的调用频率。

使用常用多行脚本时，BarTender 会根据某些预定的规则来分析脚本和标签格式的设计，确定脚本的理想调用次数。其总的目的是，评估标签格式设置其序列化和打印份数选项的方式，然后足够频繁地调用多行脚本，以便根据需要为标签提供新数据，但调用次数不超过必需的次数。相反，当 Visual Basic 脚本的类型设置为事件控制脚本时，您可以明确指定要启动脚本的事件。使用 OnAutoSelectedEvent，您可以编写一个脚本。BarTender 会按照使用常用多行脚本时确定的“理想”次数调用该脚本，即使您可能使用的是与特定事件关联的其它脚本，也是如此。


常用事件脚本

下面列出了可用事件名称。每个事件的右侧都是脚本调用时间的简短概述。（如果要求进一步的论述，还将在列表项的下面显示更多信息。）

  • OnIdenticalCopies：每一个标签。

另请参见性能警告。

  • OnNewRecord：每个新记录（仅输入文件数据）。

有关 OnNewRecord 的更多信息。

  • OnPrePrompt：就在显示提示对话框之前（当使用打印时提示时）。

  • OnPostPrompt：在用户按确定以关闭提示对话框后。

  • OnPrintEnd：当打印作业刚刚完成时。

  • OnPrintStart：当打印作业即将开始时。

  • OnScreenUpdate：每当关联对象的字符串在屏幕上更新时。

有关 OnScreenUpdate 的更多信息。

  • OnSerialize：当可能发生序列化时。

有关 OnSerialize 的更多信息。


自动操作概述

概述

BarTender 可自动执行以下操作：

ActiveX 自动操作 （只能和 BarTender 企业版一起使用）。大多数任务都可通过 ActiveX 自动操作来自动完成。使用编程语言或脚本语言（如 Visual Basic），您可以访问 BarTender 的自动操作对象，使之能够通过编程执行在使用用户界面时需要手动完成的大多数任务。

命令行参数。在 BarTender 启动时，可命令它自动执行某些任务。


使用命令行参数

使用命令行界面

在启动 BarTender 后，通过在 BarTender 的命令行中添加称为参数的特殊代码，可以使某些 BarTender 功能自动执行。在从其它程序运行 BarTender 或者更改 BarTender 的启动设置，以预先加载现有标签格式或自动启动打印作业时，命令行参数最常用。

使用此命令行界面，还可以使 BarTender 在后台运行，从而不必显示 BarTender 窗口或其加载的标签格式。

  • 从其它程序运行 BarTender

  • 更改 BarTender 的启动设置

其它命令行信息

  • 命令行参数的完整列表

  • 指定命令行参数的规则

  • 在文件名中使用空格

另请参见：

访问其它程序创建的数据


指定命令行参数的规则

BarTender 的命令行参数由一个斜杠或空格后跟一个或多个指定所需命令的字母构成，有时斜杠或空格后是一个等号和其它数据。如果命令行中有多个参数，那么参数之间必须用以下任一字符分隔：

  • 空格后跟一个正斜杠（建议）。

  • 正斜杠。

  • 空格。

不管空格和斜杠是否结合使用，参数内都不能有空格，只能在参数之间使用空格。不过，新版 Windows 允许文件夹和文件名中使用空格。有关更多信息，请参见在文件名称中使用空格。

下面给出了多个如何正确分隔命令行参数的合法示例。此外，还列出了多个无效的非法示例。（注意：/F 和 /D 参数用于指定要加载的标签格式和数据文件的名称。）

允许

/F=format_file_name /D=data_file_name

/F=format_file_name/D=data_file_name

F=format_file_name D=data_file_name

不允许

  • 参数内有多余的空格：

/F = format_file_name /D = data_file_name

/F= format_file_name /D= data_file_name

F= format_file_name D= data_file_name

  • 参数间没有分隔符：

    • F=format_file_nameD=data_file_name

    /F=format_file_nameD=data_file_name

另请参见：

使用命令行参数


在文件名称中使用空格

较新的 Windows 版本允许使用包括空格的长文件名。如果用于命令行的任何文件夹名称或文件名称中包含空格，则必须用引号将该路径引起来，或者删除空格并将长名称缩短到 8 个字符。以下是对执行上述两项操作的说明。

使用引号

"C:\Program Files\BarTender\bartend.exe" "/F=C:\BarTender\Samples\Address.btw /X"

在用引号将命令行路径名引起来后，必须将程序命令与文件命令分隔开。

删除空格

/F=C:\Progra~1\BarTen~1CDDesi~1\Samples\Address.btw

您可以通过删除空格并将长名称缩短到 8 个字符，不必使用引号就可以输入引用了具有空格的文件名的命令行参数。为此，请在名称的前 6 个字符后添加发音符号 (~) 和数字。为便于阐明，请注意“使用引号”示例，它的文件夹名称“Program Files”在其中含有一个空格。但在上面的示例中，该空格已被删除，并且“Progra”只是一个单词。

另请参见：

指定命令行参数的规则


从其它应用程序中运行应用程序

从其它程序中运行 BarTender

若要从其它程序中运行 BarTender，您将需要参考其它程序的文档。一个很好的起点就是在其它产品手册非索引中搜索单词“Run”（运行）、“Spawn”（生成）、“Execute”（执行）和 WINEXEC（这是用于加载其它程序的实际 Windows 函数调用）。

在您确定如何从其它程序内运行应用程序时，可以指定所需的命令行以运行 BarTender。有关指定命令行参数的其它信息，请参见指定命令行参数的规则。

从其它程序内运行 BarTender 而不预先加载它

从其它程序内执行 BarTender 的一个方法是在其它程序内的命令行上包括 /P 和 /X 参数。这将启动 BarTender，打印指定的标签作业，并且在完成后退出。

此方法的问题在于，对于任何其它完全独立的 Windows 程序，BarTender 都将用一些时间来从硬盘加载并初始化其本身。这一延迟（取决于您的系统的速度）始终在 1 秒到 10 秒之间，如果您每天只执行几个标签作业则这一延迟通常无关紧要，尤其是在标签作业包含许多标签的情况（因为在该情况下，初始延迟相对并不重要）。但是，如果您需要频繁从其它程序内打印少量标签，则此延迟可能会造成不方便。

预先加载 BarTender 可以避免重复的启动延迟

通过预先加载 BarTender 并使其在后台运行，您可以根据需要从其它程序打印标签，而不必每次都重新加载 BarTender。然后，在您完成后，可发出指示 BarTender 退出的命令。若要预先加载 BarTender，运行一个或多个标签作业，然后在完成后退出，您必须为此分别输入单独的命令行，如下所示：

预先加载标签格式

打印预先加载的格式

指示 BarTender 退出

另请参见：

访问其它程序创建的数据

命令行参数的完整列表

在文件名称中使用空格


在没有启动延迟的情况下打印标签

以下命令行将开始加载 BarTender 的第二个副本，但它将首先确定以前是否已加载其它副本。

c:\btw\bartend.exe /p

（请参见在文件名称中使用空格）

如果您已预先加载了 BarTender，而不是启动了新副本，则此命令行会将其参数传递给已运行的副本并从内存中删除它自己。这将使 BarTender 的第一个副本继续控制程序执行并且可以执行在命令行上指定的功能。因为此进程发生得很快，所以看上去就像指定的参数已直接发送给已在内存中的 BarTender 的副本。

在上面的示例中，只使用了 /p 参数，它指示 BarTender 使用以前加载的标签格式打印数据。但是，您甚至可以指定更多的命令行参数，包括加载不同标签格式的说明和/或可能从特定数据源文件读取数据。您可以继续以此方式打印附加标签作业，将所需的任意数目的命令行从其它程序发送到 BarTender。

接下来：

指示 BarTender 退出

另请参见：

命令行参数概述

指定命令行参数的规则


预先加载应用程序

预先加载 BarTender

在您预先加载 BarTender 时，可以启动它并使它打开现有标签格式。下面的命令行显示您如何这样做。

c:\btw\bartend.exe/f=<格式名称>

（请参见在文件名称中使用空格）

通过这样做，您可以在需要时快速、简便地打印标签格式。但是，因为没有指定任何打印参数，所以 BarTender 将只是保持在内存中并且在您指示它打印之前不执行任何操作。

在您通过此方式预先加载 BarTender 时，我们建议您指示其它程序或 Windows（取决于您的软件开发工具）以最小化运行 BarTender。这会将 BarTender 的屏幕放置于后台，而不显示出来。（不是由 BarTender 来确定是以全屏形式加载还是以图标形式加载。此特性由在其中运行 BarTender 的软件完全控制。）

接下来：

在没有启动延迟的情况下打印标签

另请参见：

命令行参数概述

指定命令行参数的规则


更改应用程序的启动设置

更改 BarTender 的启动设置

在您更改 BarTender 的启动设置时，可以指示 BarTender 在启动时执行某些任务。为此，可以将命令输入 BarTender 的启动命令行，或者将命令输入其它程序。

如果没有额外的命令行参数，在您启动 BarTender 时，它将用新的空标签加载，您可以将该空标签修改为任何所需的格式。不过，您可能需要让 BarTender 用不同大小或形状的空标签格式启动，或者用完全预先设计的标签格式启动。

  • 提供备用启动默认值

  • 使用快捷方式自动加载标签格式、打印和退出

  • 以“只打印”（防篡改模式）模式运行 BarTender

使用列出的过程访问启动命令行，输入特定于您要执行的任务的参数。

重要过程：

访问 BarTender 的启动命令行


提供备用启动默认值

如果将如下示例命令行输入 BarTender 的启动命令行，将导致 BarTender 在启动时打开一个标签格式。

c:\btw\bartend.exe/f=mycustom

（请参见在文件名称中使用空格）

在上面的命令行中，/f= 参数指示 BarTender 自动在启动时加载标签格式 MYCUSTOM.BTW，就像该格式是默认标签格式一样。

过程：

访问 BarTender 的启动命令行

接下来：

标签作业自动执行

另请参见：

指定命令行参数的规则

命令行参数概述


标签作业自动执行

通过使用命令行参数，您可以指示 BarTender 打开标签格式、打印它并退出，而这一切不必在 BarTender 窗口中进行。输入以下命令行将执行这些功能：

c:\btw\bartend.exe/f=partlist /p /x

（请参见在文件名称中使用空格）

在上面的命令行中，/f 参数指示 BarTender 装入名为 PARTLIST.BTW 的标签格式。/p 参数使打印无需用户介入即可自动开始，/x 参数使 BarTender 在打印结束后自动退出。

如果您将上述命令行参数用于其中一个或多个对象设置为打印时提示的标签格式，则会在标签实际打印前收到提示对话框。若要完成打印作业，请将所需的数据输入响应框并单击打印。

过程：

访问 BarTender 的启动命令行

接下来：

以“只打印”模式使用 BarTender

另请参见：

指定命令行参数的规则

命令行参数概述


以“只打印”模式使用应用程序

以“只打印”模式使用 BarTender

使用命令行参数，您可以指示 BarTender 加载、打印或退出标签格式。但是，使用特殊参数，也可以请求 BarTender 显示打印对话框，从中您可以访问同样标签的份数和修改序列份数选项，这样您就可以打印所需数目的标签。

通过输入 BarTender 的启动命令行，如下例所示的命令行参数允许打印，但禁止修改标签设计。一旦您尝试从打印对话框退出后，BarTender 将会完全退出。在此模式下，BarTender 最终将成为“只打印”产品，这将防止用户进行任何设计更改。

c:\btw\bartend.exe/f=partlist /pd /x

（请参见在文件名称中使用空格）

在上面的命令行中，/f 参数指示 BarTender 加载名为 PARTLIST.BTW 的标签格式。/pd 参数意味着打印过程中用户还可以控制打印对话框，并且 /x 参数将导致在打印结束后 BarTender 自动退出。

过程：

访问 BarTender 的启动命令行

另请参见：

指定命令行参数的规则

命令行参数概述


访问其它程序创建的数据

一种非常普遍的情况是：使用由其它程序创建和管理的数据库存储数据，但从 BarTender 内使用该数据打印标签。有三种您可以采取的基本方法。

手动方法（单独运行 BarTender）

一种使用来自外部数据库的数据打印标签的方法是：从其它程序中的数据库向文本文件导出所需的标签数据。这种方法需手动执行，但效果很好。然后，在单独的窗口中运行 BarTender，您可以通过使用数据库连接设置对话框，手动指示 BarTender 将加载和打印哪一数据文件。

部分自动化

一个更为自动化的执行此功能的方法是从其它程序内运行 BarTender。这样，其它程序可以首先创建包含标签数据的文件，然后运行 BarTender 并告诉它从其打印的格式和数据文件。根据命令行参数，可以指示 BarTender 在打印作业结束或仍在进行时退出。

完全自动化

一个完全自动化的方法是，用原始 ODBC 格式保留数据并让 BarTender 直接读取该数据。通过在命令行上将某些参数传递给 BarTender，您可以准确指示 BarTender 直接从数据文件读取哪些数据记录。这是通过 ODBC 管理器执行的。（有关此功能的详细信息，请参见命令行参数概述中的 /W 参数。）

如果您的数据库并非与 ODBC 兼容的数据库，则可以通过使用 OLE DB 提供程序仍以全自动方式获取数据。

第三个全自动的方法会使数据保留在 SAP IDoc 中，并且借助 SAP IDoc 配置文件让 BarTender 直接读取和分析数据。


命令行参数概述

命令行参数参考

全部显示 全部隐藏

您可以使用命令行参数设置 BarTender 在启动后自动具备的功能。命令行的语法是：

bartend.exe [参数]

在“bartend.exe”和第一个参数之间有一个空格，并且所有参数都以正斜杠开头。请参见下面的示例，并且还可以参考指定命令行参数的规则和在文件名称中使用空格。

注意Unless otherwise specified, all command line parameters require Professional edition or better. Help and Register command line options are available in all editions.

Label Format Commands

下表显示了每个可用命令行参数及其功能。

/F=\path\format.btw

指定要装入的标签格式。采用常规的 DOS 文件命名约定。支持使用 * 和 ? 通配符来用于打开多个标签格式。还可以具有多个 /F= 参数。如果未指定任何文件扩展名，则假定采用默认文件扩展名 .BTW。如果在 BarTender 运行时默认工作目录中不包含标签格式，则必须指定标签格式的文件路径。

/FA=\path\format.btw

与 /F= 相似；但是，如果标签格式已由 BarTender 加载，并且在打印作业期间发生了对标签格式的更改，BarTender 在加载新标签格式之前将询问您是否要保存所做更改。

/AF[=\path\format.btw]

/AF 单独使用将指定所有与格式相关的命令（例如 /P 和 /D）都将应用于当前处于活动状态的任何标签格式。/AF=\path\format.btw 与 /F= 相似，但它还指定该标签格式现在是活动标签格式。如果具有多个 /F= 命令或者将通配符用于 /F= 命令，则使用此命令。（通配符不能用于 /AF=，并且只能有一个 /AF=。）

/CLOSE

关闭活动标签格式。

/S

不询问用户即强制保存。

Printing Commands

/P

执行打印作业，保持打印对话框的使用数据库复选框的状态不作改变。如果选中此设置，将按原样使用数据库连接设置对话框中的各种设置，除非这些设置受到其它命令行参数的控制。它将应用于所有打开的标签格式，除非使用了 /AF= 参数。

/PD

与 /P 大体相同，但还显示打印对话框，从而允许用户根据需要对对话框设置进行更改，然后手动启动打印作业。

/QP

将打印对话框的使用数据库复选框的状态强制为已禁用（即“未选中”），这样 BarTender 将不会从任何外部数据源读入任何数据。

/QPD

与 /QP 大体相同，但还显示打印对话框，从而允许用户根据需要对对话框设置进行更改，然后手动启动打印作业。

/FP

将打印对话框的使用数据库复选框的状态强制为已启用（即“选中”），这样将可以从任何正确指定的数据源文件读取数据。

/FPD

与 /FP 大体相同，但还显示打印对话框从而允许用户根据需要对对话框设置进行更改，然后手动启动打印作业。（常用于打印时提示和查询提示。）

/C=n

覆盖每次标签打印的同样标签的份数的当前指定值。

/S=n

覆盖要打印的序列标签数的当前指定值。

/PRN="打印机名称"

(Enterprise Edition or better) 指定要使用的打印机。此参数在任何时候都可以使用，并且将应用于所有已打开的标签格式，除非这些格式之一已被 /AF 参数指定为活动标签格式。

/PRNFILE="打印机文件名"

(Enterprise Edition or better) 指定 BarTender 应打印到文件并且指定应使用的文件名。该参数只应用于活动标签格式。

/PRNMDL="<型号>[, <端口>]"

(Enterprise Edition or better) 设置打印机的型号和（可选）端口。此参数通常在不确定所需打印机是否处于联机状态时用作 /PRN 的替代项。此参数将应用于所有已打开的标签格式，除非这些格式之一已被 /AF 参数指定为活动标签格式。如果该参数与 /PRN 一起使用，则后者优先。如果无法找到用 /PRN 指定的打印机，BarTender 将搜索指定型号的打印机。如果使用 /PRNMDL=<型号> 并且找到了多个正确型号的打印机，则 BarTender 将选择离所缺打印机最近的端口上的打印机。指定 /PRNMDL=<型号>, <端口> 将导致 BarTender 使用指定端口上的该型号的打印机。

/PrintJobName="printer job name"

(Enterprise Edition or better) Sets the visible name for the print job in the spooler.

/Tray="<tray name>"

(Enterprise Edition or better) Specifies the printer's paper tray to print from if multiple trays are available. The "tray name" string is compared to the list of tray names provided by the driver. Matching ignores whitespaces and is case-insensitive. If the specified tray is not available this setting reverts to the default printer tray.

/MediaHandling={option=value;[options=values]}

(Enterprise Edition or better) Sets media handling commands, triggers, and actions. See the BarTender Help topic on Media Handling for more details.

Option | Value
Action | DriverSettings PageBreak Pause WaitForLabelTakenSensor Cut CutAndPause
Occurrence | AtEndOfPrintJob AfterEveryPage AfterEveryRecord AfterAllIdenticalCopies AfterDataChange AfterNumberOfLabels
DataItemType | DatabaseField NamedSubstring NamedObject
DataItemName | (string value)
NumberLabels | (integer value)
IgnoreCase | True/False

Database Connection Commands

/UID="<userID>"

在使用 ODBC 数据源时，可以指定 /UID 和 /PWD 以登录到 ODBC 数据库。该 /UID 和 /PWD 被应用于找到的所有 ODBC 数据库。如果提供了 /UID 但未提供 /PWD，则假定 /PWD 为 ""。在使用 /PWD 的情况下必须使用 /UID。

/PWD=<口令>

在使用 ODBC 数据源时，可以指定 /UID 和 /PWD 以登录到 ODBC 数据库。该 /UID 和 /PWD 被应用于找到的所有 ODBC 数据库。如果提供了 /PWD，则也必须提供 /UID。

/D="<数据文件路径>"

(Enterprise Edition or better) 设置或更改将要使用的文本文件数据库。如果没有与文本文件数据库的连接添加到标签格式上，则向其添加 /D 参数。（BarTender 将假定文件的第一行是包含字段名的标题并且数据文件的定界方法为引号和逗号混用定界。）如果已添加了与一个或多个文本文件数据库的连接，则使用 /D 参数指定的文件将替代第一个文本数据库。（BarTender 将假定新文件与原始文件使用相同的定界方法，并且它将假定只有在原始文件具有此类标题的情况下第一行是字段名称的标题。）/D 参数在没有使用 /AF= 参数的情况下应用于所有打开的标签格式。

/R=<开始记录编号>

(Enterprise Edition or better) 此选项用于在数据库中的特定记录开始打印。在使用查询时，开始记录将用于查询记录的结果中。

/DbTextHeader=<包含字段名称的记录编号>

(Enterprise Edition or better) 此选项用于标识包含字段名称的记录（如果有）。

/?<查询提示名称>="<查询提示值>"

(Enterprise Edition or better) 向指定的查询提示赋值。如果不存在任何匹配项，则忽略该命令。如果未设置标签格式内的查询提示，将用其余未设置的提示显示查询提示对话框。在命令行上支持多个查询提示。只有在指定 /P、/PD、/FP 或 /FPD 时设置查询提示才会生效。

/DD

(Enterprise Edition or better) 导致在打印作业后删除 ASCII 数据文件（如果有一个或多个数据库并且第一个数据库是 ASCII 数据库）。

/W="<where 子句>"

注意(Enterprise Edition or better) ：Where 属性已被废弃，只是为了向后兼容才支持它。使用 /?<查询提示名称> 选项作为备用。

/IDOC="<IDoc 的路径和文件名>"

(Enterprise Edition or better) 指定要使用的 IDoc。

/DIDOC

(Enterprise Edition or better) 导致在第一个数据库是 IDoc 的情况下删除打印作业后的 IDoc。

/ITD=\路径\<SAP 定义文件名>

(Enterprise Edition or better) 指定要使用的 SAP 定义文件。这将更改注册表条目，这样在以后运行 BarTender 时将使用此文件。

License Server Commands

All License Server commands require Enterprise Edition or better.

/LicenseServerAddress=<服务器名|域名|数值 IP 地址|*>

指定网络上将运行 Seagull License Server 的网络地址。您可以使用计算机的名称（例如 MyServer）、域名（例如 Shipping.MyCompany.com）或 IP 地址（例如 10.1.1.32）。

使用“*”（星号）指示 BarTender 应搜索 Seagull License Server。

如果未使用此参数，则 BarTender 将使用 Seagull License Server 的用户界面中指定的默认值。

/LicenseServerAlternateAddress=<服务器名|域名|数值 IP 地址|*>

指定在首选服务器不可用的情况下将使用的备用 Seagull License Server 的地址。有关详细信息，请参见上面的 /LicenseServerAddress。

/LicenseServerPort=<端口>

指定 Seagull License Server 应监视的端口。可能值为 1024 到 65535。如果未使用此参数，则 BarTender 将使用 Seagull License Server 的用户界面中指定的默认值。

/LicenseServerAlternatePort=<端口>

指定如果在首选服务器不可用的情况下使用了备用 Seagull License Server 时，要监视的端口。有关详细信息，请参见上面的 /LicenseServerPort。

/LicenseServerTimeout=<以秒计的时间>

指定 BarTender 将等待多长时间才会放弃查找 Seagull License Server，以秒为单位。如果未使用此参数，则 BarTender 将使用 Seagull License Server 的用户界面中指定的默认值。

/LicenseServerAlternateTimeout=<以秒计的时间>

指定在首选服务器不可用时备用 Seagull License Server 所采用的超时值。有关详细信息，请参见上面的 /LicenseServerTimeout。

Miscellaneous Commands

@<命令文件名>

(Enterprise Edition or better) 因为命令行可能会变得十分长，所以 @ 字符以及后随的 ASCII 文件名会将文件的内容扩展到命令行。

/X

指定在执行了所有请求的功能后，BarTender 将自动退出，但不保存由于已执行的任何命令行操作或已增加的数据值而发生的任何更改。

/XS

指定在执行了所有请求的功能后，BarTender 将在第一次执行对打印作业期间发生的任何更改的无条件保存后自动退出。

/XA

与 /XS 相似，但如果发生了更改，将询问用户是否执行保存。

/RUN

覆盖 BarTender（版本 2.52 和更高版本）的检查已处于内存中的 BarTender 的现有副本的常规过程。此选项而是指示 BarTender 在任何情况下都运行自身，即使这意味着在内存中有 BarTender 的第二个副本。任何其它指定的命令行参数都将由此新加载的 BarTender 副本运行，并且将不传递给以前加载的副本。

/REGISTER

注册 BarTender 的自动化接口。注册通常在安装 BarTender 时进行，但在有些情况下可能需要再次执行注册，例如 BarTender 已从原始安装目录移出的情况下。此参数不能与任何其它参数组合使用。其它任何参数都将被忽略。

/MIN[=Taskbar|SystemTray]

导致 BarTender 以最小化运行。或者，指定它是在任务栏还是系统任务栏中以最小化的形式出现。

/MAX

导致 BarTender 以最大化运行。

/NOSPLASH

导致 BarTender 在启动时不显示其启动屏幕。

/?

/HELP

显示 BarTender 的命令行参数的帮助主题。

BarTender 命令行的示例

bartend.exe /F=c:\Formats\ship.btw /P

加载和打印 ship.btw。

bartend.exe/F=F1.btw /F=F2.btw /F=F3.btw

加载三个标签格式。

bartend.exe/P

打印所有打开的标签格式。

bartend.exe/IDOC="xyz.idoc" /p

使用 IDoc xyz.idoc 打印所有标签格式。

bartend.exe/AF=F2.btw

使标签格式 F2.btw 成为活动标签格式。

bartend.exe/AF /p /c=2 /d="xyz.dat"

使用文本文件 xyz.dat 打印活动标签格式的两个副本。

bartend.exe/F=test.btw /p /LicenseServerAddress=MyServer /LicenseServerPort=5175

打开标签格式 test.btw。连接到端口 5175 上的 MyServer 上的 Seagull License Server。

bartend.exe /MediaHandling="Action=Cut;Occurrence=EndOfPrintJob"

Sets the printer media handling settings to cut the label stock at the end of the print job.

另请参见：

使用命令行参数

从其它程序运行 BarTender


保护框

对于交插二五条形码，可以添加保护框（包含或不包含非打印区域）。

  • 类型。可供选择的选项有：无、顶部/底部或矩形。

  • 粗细。设置保护框的粗细程度。默认值为 3X。

  • 非打印区域。设置非打印区域的粗细程度。默认值为 10X。如果将此值设置为无，则可以得到不包含非打印区域的顶部/底部保护框。（如果选择矩形保护框，则必须包含非打印区域，以便将保护框和条形码区分开来。）


字符集

（这是符号体系特定的选项，仅适用于数据矩阵。）

如果指定的符号类型不是 ECC 200，将启用字符集选项。ECC 200 通过评估数据来自动确定所需的字符集。根据条形码中所含数据的数量和类型，可以通过手动指定字符集来获得最小的条形码。

  • 自动。指定 BarTender 评估条形码的数据并确定最佳字符集。

  • 数字。指定仅将数字视为可接受的数据。

  • 带标点符号的大写字符。指定仅将大写字母和数字（包括标点）视为可接受的数据。

  • 带空格的大写字符数值。指定仅将大写字母和数字（包括空格）视为可接受的数据。

  • 全 128 定界。指定将所有键盘字符（包括大写和小写字母、数字和符号）视为可接受的数据。

  • 全部 256 定界。指定将全部 256 定界字符（包括所有键盘字符和国际定界字符）视为可接受的数据。

数据中的转义符序列

数据矩阵也支持在数据流中使用各种转义符序列。转义符序列以脱字号“^”开头。（使用两个连续的脱字号“^^”可以在数据流中加入一个实际脱字号。）

  • ^X。表示 ASCII 控制字符，其中 X 表示该字符。例如，^G 表示 BEL。

  • ^dnnn。表示 3 位数的 ASCII 十进制代码字，其中 nnn 表示该代码字。

  • ^7nnnnnn。表示 ECI（扩展通道翻译协议）值，其中 nnnnnn 表示 6 位数的 ECI 编码。例如，^7000009 表示 ECI 值 9。ECI 协议值有四种翻译类型：

    • 作为国际字符集（代码页）的标识符

    • 作为无缓冲模式下结构化附加的控制信息

    • 作为加密、压缩或其它一般用途的信息

    • 作为用户定义的信息

  • 其它。

    • ^1。表示 FNC1。在第二个代码字位置，^1 的前面必须是大写或小写字母，或从 01 到 99 的成对数字。

    • ^3。表示阅读器编程。

    • ^5。用作应用标识符的缩写 05 头部。它将被解码为 05 Macro 头部和尾部。

    • ^6。用作应用标识符的缩写 06 头部。它将被解码为 06 Macro 头部和尾部。

当收到不可接受的数据时

由于将生成最小的条形码，因此应该指定与数据最匹配的字符集。不过，如果数据中包含不可接受的字符，当条形码显示在屏幕上时，将在中心处显示一个红色的“X”（如图所示），并且不会打印该条形码。


条形码的校验位

校验位

全部显示 全部隐藏

（这是符号体系特定的选项，对于不支持该功能的符号体系，不启用此选项。）

使用条形码属性页上的校验位选项，可以指定是否在条形码中添加校验位。校验位是一个可选字符，可附加在条形码的末尾以检验错误。

为何使用校验位

虽然使用条形码阅读器自动输入数据的可靠性比使用键盘手动输入数据的可靠性要高出许多倍，但从统计数据来看，前者出现解码错误的可能性永远无法消除。例如，如果用户扫描时突然出现颤动或条形码中出现打印缺陷，都可能会导致发生“替代错误”。由于替代错误会给数据库的完整性带来极其严重的影响，因此我们强烈建议您使用“校验位”。

虽然使用校验位不能完全消除出现替代错误的可能性，但可以大大降低发生这种错误的几率，从而提高数据的完整性。

  • 替代错误。所谓“替代错误”，指的是传送到计算机的条形码消息中的一个或多个字符与条形码的实际编码内容不符。

  • 校验位。条形码末尾附加的额外字符，其值为条形码前面字符的值的和（或加权和）。

校验位工作原理

如果条形码阅读器被配置为查找校验位，则它在扫描包含校验位的条形码时，将再次执行求和运算，这与最初生成校验位时 BarTender 执行的求和运算相同。然后，条形码阅读器将其计算的校验和值与 BarTender 打印的校验位进行比较。如果两个值相符，条形码阅读器将传送条形码消息。如果这两个值不符，则条形码阅读器就会知道发生了错误，而不会传送条形码字符。这时，用户必须重新扫描条形码消息。

校验位的符号体系特定信息

有几种符号体系始终带校验位打印。因此，如果指定当前所选条形码使用这些符号体系，校验位选项为选中状态并灰显。

Codabar 符号体系的规格中不包含校验位选项。因此，如果在标签视图区域中选择了 Codabar 条形码，校验位选项也为灰显状态。

另请参见：

校验位类型


校验位类型

（这是符号体系特定的选项，仅适用于 Code 39 — Full ASCII、Code 39 — Regular。）

使用条形码属性页上的校验位类型选项，可以指定您希望 BarTender 添加到 Code 39 — Full ASCII、Code 39 — Regular 条形码中的校验位的类型。下面将介绍四种设置。

  • MOD 43。（默认设置。）这是打印 Code 39 条形码时最常用的校验位类型。对于数据字符串中包含非数字（字母）字符的 Code 39 条形码而言，这也是生成校验位的唯一设置。当您选择其它校验位类型时，BarTender 将自动忽略条形码数据字符串中的所有字母字符。

  • MSI MOD 10。计算这种校验位使用的校验位公式与 MSI Plessey 符号体系使用的公式相同。只有当条形码数据字符串只包含数字数据时，才选择该设置。

  • UCC MOD 10。计算这种校验位使用的校验位公式与 Interleaved 2-of-5（交插二五）、UPC、EAN 和 UCC/EAN-128 符号体系使用的公式相同。只有当条形码数据字符串只包含数字数据时，才选择该设置。

  • UNISON MOD 10。计算这种校验位时使用 MSI Plessey 校验位公式的一种修改版。只有当条形码数据字符串只包含数字数据时，才选择该设置。

另请参见：

条形码的校验位


Code 128 的代码集

代码集

(This is a symbology-specific option that is only enabled for Code 128.)

This option is available on the Bar Code property page, and has the following values available:

  • Auto: BarTender automatically chooses the most efficient code set with which to begin the bar code and then automatically switches between character sets if necessary. (Default setting.)
  • Auto A: Similar to "Auto" except that BarTender will use code A for any sequence of characters included in both code A and B.
  • Fixed Code Set (A, B, C): The entire barcode will be encoded in the selected code set.
  • Manual: The user must provide all information needed, such as the initial code set and any changes. The supported code set and function control characters are listed below.

    Code

    Description

    ^A

    Switch to code set A.

    ^B

    Switch to code set B.

    ^C

    Switch to code set C.

    ^S

    Shift code set for the next character only (from A to B, or from B to A).

    ^1

    Function code FNC1.

    ^2

    Function code FNC2.

    ^3

    Function code FNC3.

    ^4

    Function code FNC4.

    For further details on characters supported by different code sets see Code 128.


PDF417 的控制列

列

这些符号体系可以使用列变量。

PDF417 中的列

MicroPDF417 中的列


纠错级别

错误检测与纠错

PDF417、QR Code 和 Aztec Code 符号体系可用于对大量信息进行编码，相对于传统的（一维）条形码来说，大量信息在扫描过程中发生解码错误的可能性将增加。相应地，由于校验位仅在扫描过程中检测错误，所以使用校验位这种简单手段是不够的。由于这样将要求尝试再次进行扫描，并且由于 PDF417、QR Code 和 Aztec Code 相当复杂，导致在随后的扫描中出现其它错误的几率很大，所以这些符号体系使用实际的纠错。这一功能是通过在打印符号中添加足够的冗余信息实现的，这样，扫描仪不仅能检测错误的发生，而且还能实际纠错。

注意：有关数据矩阵条形码纠错的信息，请参见符号类型。

此消彼涨：大小与可读性

  • PDF417 支持 9 级纠错，0 为最低级，8 为最高级。当将纠错级别设置为 0 时，只对很少的冗余信息近编码，扫描仪也只能执行最简单的纠错功能。而将纠错级别设置为 8 时，可以纠正重大的扫描问题。

  • Aztec Code 支持 98 级纠错，1% 为最低级，99% 为最高级。（根据 Aztec Code 规格，建议您不要使用低于 5% 或高于 95% 的纠错级别。）百分比表示条形码的数据层中作为校验字符的字符百分比。（实际上，将总是在您设置的百分比级别上再增加三个校验字符。此外，如果最后一个数据层未完全填满，将自动创建附加的校验字符，以确保条形码为完整的方形。）

  • QR Code 支持 4 级纠错，L 为最低级，H 为最高级。这些级别是根据条形码中可在损坏后纠正的代码字百分比定义的。因此，这些百分比与 Aztec Code 中表示纠错级别所使用的百分比相比，在意义上是不同的。这些级别如下所示：

    • L 级：大约可以恢复 7% 的代码字。

    M 级：大约可以恢复 15% 的代码字。

    Q 级：大约可以恢复 25% 的代码字。

    H 级：大约可以恢复 30% 的代码字。

由于随着纠错级别的增加，打印的条形码的大小也将随着增加，这将抵消高纠错级别带来的好处，导致纠错级别越高，条形码越大。

自动确定纠错级别

BarTender 的默认 PDF417 纠错级别为“自动”，它将根据编码为各 PDF417 符号的信息量来自动指定纠错级别。

Aztec Code 的默认纠错级别也是“自动”，但对于 Aztec Code，这意味着纠错级别为 23% 的校验字符加上三个校验字符（再加上填充余下的数据层所需的校验字符）。

如果要在封闭系统（也就是说，您将控制符号的打印和扫描）中使用两种符号体系之一，并且您对打印和读取功能非常有信心，则您可以通过手动指定相对较低的纠错级别（替代“自动”纠错级别），来成功地降低符号的打印大小。另一方面，如果您不能保证打印质量，条形码将受到现场损害性条件的影响，或将有许多人使用各种各样的扫描设备进行工作，即使将导致打印符号较大，您也需要手动指定较高的纠错级别。

自动确定纠错级别不适用于 QR Code。


数据源模板

此选项自动将符号体系的各个字段或选择设置为单独的子串。每个子串都用诸如数据有效性或允许字符数之类的设置正确设置格式，以帮助原始信息符合符号体系的规范。即使新生成的子串与符号体系的规范并不完全相符，所有新生成的子串也都能够被编辑。

警告：如果选择此选项，将删除在此条形码中以前定义的所有子串。

数据源

  • 从文件获取数据（文本文件、ODBC、SAP IDoc 或 OLE DB 提供程序）。使用此选项可以指定此条形码的数据应来自数据源文件。

  • 在打印时提示用户。使用此选项可以指定在打印时是否应提示输入此条形码的数据。

必需的主消息字段（仅限 MaxiCode）

如果您的 MaxiCode 符号被设置为模式 1 或模式 2，则以下字段是必需的。

  • 邮政编码。使用此选项可以指定您的 MaxiCode 符号要求哪一类型的邮政编码。

  • 国家代码和服务级别。它们是 Maxicode 的主消息所必需的，并且不可更改。

可选的第二消息字段（仅限 MaxiCode）

在您的 MaxiCode 符号被设置为模式 1 或模式 2 时，这些字段将可供您使用。它们不是符号体系本身所必需的，因此是可选的。

注意：此选项可用于 MaxiCode、Royal Mail 4-State Customer Code 和 Australian Post 4-State Barcode。


在 UCC/EAN-128 数据字符串中输入功能字符

在将多个应用标识符及其数据字符串共同组合到单个条形码中时，可能需要根据 UCC/EAN 应用标识符主题中介绍的内容，添加一个 FNC1 字符作为两个数据字符串之间的分隔符。有时，应用标识符的规范可能也要求在条形码数据字符串中输入其它功能字符。使用以下步骤将功能字符输入 UCC/EAN-128 数据字符串中。

若要手动将功能字符输入到 UCC/EAN 数据字符串中，请执行以下操作：

  1. 双击要修改的条形码。此时将显示条形码属性页。

  2. 如果尚未执行以下操作，请选择 Code 128 作为条形码的符号体系。

  3. 单击 UCC/EAN-128 选项，以启用 UCC/EAN-128 标准。

  4. 单击所显示的对话框顶部的数据源选项卡，以显示数据源属性页。

  5. 在屏幕数据选项中，键入数据字符串的字符。若要指定功能字符，只需紧随“^”（脱字号）字符后输入功能字符串的相应数字。例如，对 FNC1 字符输入“^1”。

  6. 单击确定按钮完成更改。


格式控制代码

Australia Post 4-State Customer Code 有四种不同的格式。所应用的字段、格式控制代码 (FCC) 以及每个条形码的条数都取决于所选的格式。利用 BarTender，您可以选择一种格式，然后针对该格式生成数据源模板。下面列出了支持的格式选择选项。

  • 标准用户条形码。此种条形码的主要功能是提供发送点信息。“无用户信息”字段即采用此格式。

  • 用户条形码 2 和 3。除增加了自由形式的“客户信息”字段外，这两种格式与标准用户条形码完全相同。在用户条形码 2 中，“用户信息”字段的长度为 16 个条；在用户条形码 3 中，其长度为 32 个条。

  • 回电费已预付条形码。此种条形码的基本格式与标准用户条形码相同，但它使用不同的格式控制代码来指定要使用的回电费已预付服务。

  • 由数据源设置。此选项用于在生成数据源模板之后，指定您自己的格式控制代码。如果未指定格式控制代码，将代之以使用标准用户条形码 11 的代码。


UPC/EAN 的保护符

栏

（这是符号体系特定的选项，仅适用于以下符号体系：UPC-A、UPC-E、EAN-13 和 EAN-8。）

UPC/EAN/JAN 标准包括某些栏在条形码的主体下进行扩展的规范。这些栏称作“不会”栏或“安全”栏。在“标准”全尺寸代码中，条形码主体的高度为 .900 英寸，而保护符可以再扩展 .065 英寸。

如果您的 UPC/EAN/JAN 条形码的高度为其它值，则可能需要调整保护符的悬垂值，使之与其余的条形码及条形码下的供人识读文本保持适当的比例。您可以使用条形码属性页上的保护符选项来完成此操作。


掩码

如果条形码上存在大范围的全亮或全暗模块，或模块的模式与条形码的三个角上的“位置检测模式”相同，则 QR Code 条形码的可读性将有所降低。鉴于这种情况，QR Code 提供了一种类似“掩码”的附加功能，它使用易于读取的条形码来替代难于读取的条形码，而前者可以读取并转换回原始的条形码数据。虽然一共有八种掩码方案，但我们强烈建议您使用默认设置：自动。使用这种设置，BarTender 就可以：(1) 比较所有八种掩码方案将对条形码产生什么影响；(2) 使用可读性最好的掩码，而评估可读性的标准则由 QR Code 的官方规格指定。

当然，您也可以使用 0 到 8 之间的数字来指定具体的掩码方案，或指定无而不使用掩码。


模式 (Maxicode)

MaxiCode 的中心是公牛眼似的三个黑色同心圆，其余部分是 33 个分别有 29 和 30 个六边形元素的相间排列的行。它支持多达 93 个字符的数据。以下概括介绍了四种不同的数据模式。模式 2 和模式 3 需要具有特定的格式才能正常发挥作用；而模式 4 和模式 6 可以包含任何类型的信息。

  • 模式 2：结构化载体信息。用于 UPS 国内货运业务。要使本模式正常发挥作用，需要填写主消息字段。第二消息字段是可选的。单击条形码选项卡上符号体系特殊选项部分中的生成数据源模板按钮，可以让 BarTender 将所有字段作为子串来生成，而且格式正确。

  • 模式 3：结构化载体信息。用于 UPS 国际货运业务。要使本模式正常发挥作用，需要填写主消息字段。第二消息字段是可选的。单击条形码选项卡上符号体系特殊选项部分中的生成数据源模板按钮，可以让 BarTender 将所有字段作为子串来生成，而且格式正确。

  • 模式 4：标准符号。用于生成不限格式的常用条形码。该模式不要求填写任何主消息字段或第二消息字段。

  • 模式 6：读者编程。如果扫描仪可通过扫描条形码来编程，则可以使用模式 6 MaxiCode 符号来编程。有关编程所需的信息和代码，请参阅所用扫描仪附带的文档。


模型

QR Code 有两种版本：模型 1 和模型 2。QR Code 的原始版本模型 1 支持的字符不能像增强版模型 2 支持的一样多。因此，建议所有采用 QR Code 的新应用程序使用模型 2。

每种模型的最小大小和最大大小如下所列。

模型 1。最小为 21 x 21 个模块，最大为 73 x 73 个模块。

模型 2。最小为 21 x 21 个模块，最大为 177 X 177 个模块。


数字系统

（这是符号体系特定的选项，仅适用于 UPC-E。）

UPC-E 符号体系由八位构成。第一位不是 0 就是 1，后面的六位是数据，最后一位是校验位。使用数字系统选项可以指定第一个字符是 0 还是 1。

指定正确的字符数

正常情况下，您提供 UPC-E 条形码的六个中间字符，BarTender 自动在开头添加数字系统位并在计算校验位后将其添加到末尾。但如果您提供的字符多于六个，BarTender 将删除多余的字符。而如果您提供的字符不足六个，BarTender 将在末尾添加零，使数据字符的总数凑足六个。


PDF417 的行高

行高

在 PDF417 和 CC-C 中

在默认情况下，会将 PDF417（和 CC-C）符号中的各行高度设置为三倍的“X 尺寸”值（打印符号中最窄条的宽度）。如果您使用的纠错级别不低于 PDF417 符号规格标准中针对要编码的数据量推荐的最低值，或使用“自动”纠错级别，则默认的三倍行高就足够了。但是，如果您手动指定的纠错级别低于推荐的要编码数据量的纠错级别，则建议将 PDF417 符号的行高增加到大于最小高度。独立 PDF417 的可能高度范围是 1X 到 10X。对于 CC-C，该范围为 3X 到 10X。

在 MicroPDF417 和 CC-B 中

在默认情况下，会将 PDF417（和 CC-B）符号中的各行高度设置为两倍的“X 尺寸”值（打印符号中最窄条的宽度）。您可以将该值最高增加到 10X。独立的 MicroPDF417 的行高最低可以为 1X，但对于 CC-B 来说，最低为 2X。

在 CC-A 中

行高范围是 2X 到 10X。


行

MicroPDF417 符号体系的结构为多个信息行，每一行看上去都像一个非常窄的条形码。已编码的信息看上去有点像不规则的棋盘。另外，还有一到四个行地址模式，每个模式的宽度为 10 个模块。

当行设置为自动时，此棋盘数据区域中的行数和列数将进行调整，以使其总体形状尽可能接近正方形。此外，您还可以指定行数。但是，只可能使用行和列的某些组合。因此，根据在列下拉列表中选择的列数，行下拉列表中的可用行数将有所不同。


Shape

Size

(This is a symbology-specific option that is only enabled for Data Matrix.)

The Data Matrix bar code is made up of columns and rows wherein data is stored. Most Data Matrix bar codes will contain an equal number of columns and rows. However, symbol type ECC 200 allows for some bar codes to have more columns than rows.

In addition to a list of preset dimensions, the Size option contains auto generate settings for specifying whether or not a bar code will have an equal number columns and rows. The two settings are described below.

  • Auto-Square. Draws the bar code symbol with an equal number of columns and rows.

  • Auto-Rectangle. Draws the bar code symbol with more columns than rows. To use this setting, the amount of data must be small. If the input data is larger than will fit into allowed rectangle sizes, the bar code symbol will be printed as a square.


收缩 UPC 拆分数字

UPC 拆分数字

（这是符号体系特定的选项，仅适用于 UPC-A 和 UPC-E。）

将 UPC 条形码的前若干个数字和后若干个数字与 10 个中心数字拆分后，可以使用供人识读属性页上的收缩 UPC 拆分数字选项来指定这两类最外侧数字的打印大小小于条形码上的其它供人识读字符。

默认情况下启用该选项，这样，BarTender 就会以比 UPC 条形码中其它供人识读字符更小的格式来打印拆分数字。若要以与其它供人识读字符相同的大小来打印拆分数字，只需单击该复选框以禁用此选项。


Codabar 的起始字符

（这是符号体系特定的选项，仅适用于 Codabar。另请参见 Code 39 和 Telepen 的起始/停止字符）

使用条形码属性页上的起始字符选项，可以指定将使用“a”、“b”、“c”或“d”四个字母中的哪一个字母来作为 Codabar 条形码的起始字符。默认设置为“a”。

第五个菜单设置由数据源设置 将指示 BarTender，起始字符由数据源（如“屏幕数据”或“数据源文件”）提供。如果您指定由数据源设置，但未在条形码的数据开头提供四个起始字符之一，BarTender 将自动指定“a”作为起始字符。


起始模式

QR Code 能够包含四种不同模式中每一种内的以下字符。“起始模式”选项决定使用它们当中的哪一个来启动条形码。QR Code 条形码可在字符集之间切换（请参见下文）。该选项的可用选择有：

  • 自动。BarTender 将根据为条形码提供的数据自动确定要使用的字符集。（此为默认设置。）

  • 数字。字符包括 0 – 9。

  • 字母数字。字符包括 0 – 9、大写 A – Z、空格、$、%、*、+、-、.、:、/

  • 日文汉字。Shift JIS 值 8140 (HEX) – 9FFC (HEX) 和 E040 (HEX) – EAA4 (HEX)。（这些值是从 JIS X 0208 中转换过来的。有关详细信息，请参见 JIS X 0208 Annex 1 Shift Coded Representation。）

  • 二进制。符合 JIS X 0201 的 JIS 8 位字符集（拉丁字母和假名）。

  • 手动。条形码将包含以下代码中的一个或多个，它们将决定要使用的字符集。

^N 将切换为数字模式。

^A 将切换为字母数字模式。

^K 将切换为日文汉字模式。

^B 将切换为二进制模式。

从数字模式切换为字母数字模式再到二进制模式的示例如下：（注意：模式更改命令使用粗体。）

^N12345678^AABCDEFG^B1248

注意：如果起始模式设置为默认设置自动，则上述模式更改命令不起作用，因为 BarTender 将自动执行该功能。


Code 39 和 Telepen 的起始/停止字符

对于 Regular and Full ASCII Code 39 和 Telepen, 您可以设置起始字符和停止字符。

Code 39 的默认起始和停止字符均为星号“*”。对于 Telepen，默认起始字符为下划线“_”，默认停止字符为小写“z”。

您可以将起始字符和停止字符中的一个或两者更改为无或由数据源设置。如果设置为后者，BarTender 将接受原始数据源使用的任何起始/停止字符。

注意：起始/停止字符不会随条形码一起传输，且不包含在任何校验位计算中。


补充长度

通过使用补充选项对话框中的长度选项，可以指定您希望补充条形码作为 2 位补充还是 5 位补充打印。默认设置为“无”，指定不在主 UPC 或 EAN 条形码后附加任何补充。三个选项显示为单选按钮，因此只需单击您选定的设置即可。


补充样式

通过使用补充选项对话框中的样式选项，可以为补充条形码指定供人识读字符的高度、位置和布置。有如下五种不同样式可供选择。

样式 | 描述
样式 1 | （默认设置。）补充条形码的顶边和底边与主 UPC/EAN 代码的顶边和底边（不包括保护符）对齐。供人识读字符位于补充的下方。
样式 2 | 补充的底边与主条形码的底边（不包括保护符）对齐。供人识读字符位于补充的上方，并且补充的高度减小，以使供人识读字符的顶边与主 UPC/EAN 代码的顶边对齐。
样式 3 | 补充的顶边和底边与主 UPC/EAN 代码的顶边和底边（不包括保护符）对齐。供人识读字符位于补充的上方。
样式 4 | 补充的底边与主 UPC/EAN 代码上的保护符的底边对齐。供人识读字符位于补充的上方，并且补充的高度减小，以使供人识读字符的顶边与主 UPC/EAN 代码的顶边对齐。
样式 5 | 补充的底边与主 UPC/EAN 代码上的保护符的底边对齐。补充的顶边与主 UPC/EAN 代码的顶边对齐。供人识读字符位于补充的上方。


符号类型

（这是符号体系特定的选项，仅适用于数据矩阵。）

如同大多数二维条形码一样，数据矩阵符号体系支持纠错功能，它采用的方法是将足够多的冗余信息编码到打印符号中，以使扫描仪能够“检测并纠正”错误。使用符号类型选项可以指定在创建数据矩阵条形码时要使用的纠错类型。数据矩阵支持 14 种纠错类型。

BarTender 中默认的数据矩阵纠错级别为 ECC 200。但这是一种较新的标准，并非所有打印机和扫描仪都支持。如果 ECC 200 不可用，ECC 140 将提供最佳纠错级别，尽管这将打印出非常大的符号。您可以使用较低的纠错级别来减小符号的大小。


Codabar 的终止字符

（这是符号体系特定的选项，仅适用于 Codabar。另请参见 Code 39 和 Telepen 的起始/停止字符）

使用条形码属性页上的终止字符选项，可以指定将使用“a”、“b”、“c”或“d”四个字母中的哪一个字母。默认设置为“a”。

第五个菜单设置由数据源设置将指示 BarTender，终止字符由数据源（如“屏幕数据”或“输入数据文件”）提供。如果您指定由数据源设置，但未在条形码的数据末尾提供四个终止字符之一，BarTender 将自动指定“a”作为终止字符。


截断 PDF417 符号代码

有时，当打印的 PDF417 代码的可用空间非常短缺时，可能需要放弃一些通常以 PDF417 符号编码的信息，即使这会导致符号在一定程度上变得难以读懂。启用（选中）截断选项后，单个垂直条形码将取代类似于棋盘的数据区域中右侧的停止模式和包含最右侧的四个条形码的数据列。尽管这确实可以节约空间，但通常不建议这样做，并且一定不要尝试该操作，除非要采用的打印质量和扫描设备均已知并且在您的控制之下。


UCC/EAN-128 和应用标识符规格

在 1991 年上半年，统一编码委员会 (UCC) 和国际物品编码协会 (EAN) 发布了新的条形码标准，供全球范围内的零售、工业和商业产品分类使用。这些新标准通称为“UCC/EAN-128”，它们指定了应用标识符 (AI) 的标准。AI 是一个数字，它位于条形码数据字段示意用途（如批号或保质期）的前面并标识示意用途。例如，AI“01”表示后面紧跟的是 14 位的 EAN.UCC 主标识号，AI“30”则表示后面紧跟的是每个包装内的件数。

启用了条形码属性页上的 UCC/EAN-128 选项或应用应用标识符规格选项后，BarTender 会自动添加某些字符并执行打印 UCC/EAN-128 兼容条形码所需的某些功能，其中包括：

  • 自动生成的先导 FNC1 字符。FNC1 字符将打印在条形码的开头。（如果采用的是 Code 128 符号体系，它将紧跟在 Code 128 起始字符后面出现）。它被用作标识前缀或“标志字符”，表示后面的符号代码遵循新的 UCC/EAN 分类标准。

  • 可以手动输入其它 FNC1 字符。在将多个数据字段合并到一个条形码中时，您可以通过在条形码数据字符串中输入“^1”作为字段分隔符来手动输入 FNC1 字符。有关此种 FNC1 字符用法的详细信息，请参阅以下主题 UCC/EAN 应用标识符和在 UCC/EAN-128 数据字符串中输入功能字符。

  • UCC/EAN 应用标识符。BarTender 支持所有当前的 UCC/EAN 应用标识符。在 UCC/EAN 条形码中，应用标识符后面紧跟着其所标识的字符串。这些应用标识符指示条形码阅读器将出现什么类型的数据字段，并且通常还指示数据字段的长度。

注意：如果某个符号体系总是用于同一应用中，该应用标识符将显示在符号的供人识读部分而不是显示在条形码中。例如，所有 RSS 符号体系都有一个暗含的应用标识符“01”。

  • 自动在特定数据字段中添加校验位。带有应用标识符的特定数据字段使用附加校验位，通常是模数 10。在使用此类数据字段时，BarTender 将自动计算并在数据字段上附加正确的校验位。由于 UCC/EAN 128 支持多数据字段，而每个数据字段所属的类型都可以有其自己的校验位，所以 BarTender 打印的给定条形码可能包含若干数据字段，每个字段都有其自己的校验位。

  • 在供人识读字符中添加额外的空格和小括号。大多数 UCC/EAN 应用都指定在条形码的供人识读文本中添加额外的空格和小括号。在默认模式下，BarTender 将以其最常用的配置自动生成这些字符。不过，您可以使用供人识读属性页上的 UCC/EAN 模板选项来选择其它配置。如果应用要求 UCC/EAN 模板选项不支持的字符，您可以使用 BarTender 的标准字符模板选项来输入这些字符。


UCC/EAN 应用标识符

UCC/EAN-128 规格定义了众多应用标识符。在条形码数据字符串中，应用标识符后面紧跟着其标识的字符串，并且应用标识符指定后面的数据字符串的长度和类型。某些应用标识符指定数据字段包含固定数目的字符，而其它应用标识符则指定数据字段包含数目可变的字符。例如，下面显示的货运包装箱代码是一个固定长度的字段，它正好包含 14 个字符。包装箱代码的应用标识符为“01”。请注意，末尾的“2”是一个校验位，它是 BarTender 自动生成的。

序列号是一个可变长度的字段，它最多可以包含 20 个字符。其应用标识符为“21”并且不要求校验位。

您可以将多个应用标识符及其数据字段合并到一个条形码中。在将可变长度的数据字段与条形码中的其它字段合并时，可变长度的数据字段后面必须紧跟一个字段分隔符（除非它是条形码符号中的最后一个字段 — 请参见下面的“注意”）。FNC1“^1”字符即充当此字段分隔符。它向 BarTender 软件发出信号，指示可变长度的数据字段已经结束，其它数据字段从其起始。

在使用 FNC1 字符作为字段分隔符时，必须手动将该字符添加到条形码数据字符串中，有关这一过程的说明，请参见主题在 UCC/EAN-128 数据字符串中输入功能字符。

注意：如果必须连结多个应用标识符及其字段，而其中只有一个字段的长度是可变的，建议您将可变长度的字段放置在符号的末尾，因为这样做不需要使用分隔符。


UCC/EAN FNC1 前缀

（这是符号体系特定的选项，仅适用于 Code One。在将计算机连接到支持二维功能的 Intermec 打印机上时，BarTender 中只显示 Code One 符号体系及其选项。）

使用此选项可以指定 Code One 条形码中的第一个字符是否为 UCC/EAN FNC1 字符。该选项只能在条形码的其余数据满足 UCC/EAN 规范时方可使用。


UPC 补充选项

全部显示 全部隐藏

（“UPC 补充选项”命令按钮和“补充选项”对话框仅适用于以下符号体系：UPC-A、UPC-E、EAN-13 和 EAN-8。）

在使用 UPC 或 EAN 符号体系为平装书籍和杂志编制条形码时，主 UPC/EAN 代码经常后跟一个比较短的 2 位或 5 位补充代码，它们紧随在主代码的右侧。这种补充条形码的大多数特性（如密度、高度、位置）均以其前面的主 UPC/EAN 代码的特性为基础。

补充选项概述

使用补充选项对话框（通过单击条形码属性页上的 UPC 补充选项按钮来访问）中的选项，可以方便地向已采用所需格式的 UPC 或 EAN 条形码添加补充条形码。补充条形码最重要的规格将自动遵循相应 UPC 或 EAN 条形码的规格。（还可以通过从符号体系选项的下拉列表框中选择“2 位补充”或“5 位补充”来创建补充条形码。但是，使用符号体系选项创建的补充条形码在格式上必须与标签格式中的任何其它条形码类似。不能使用补充选项对话框指定其它条形码的外观，并且 BarTender 不会自动将它们放在适当的位置。）

下面概要介绍了补充选项对话框中的选项。有关这些选项的详细信息，请单击以下相应的标题。

  • 长度。用于指定是在主 UPC 或 EAN 条形码之后附加 2 位补充条形码，还是附加 5 位补充条形码，或者不附加任何补充条形码。

  • 样式。用于指定补充条形码的高度和位置及其供人识读字符的位置。

指定 UPC 补充选项

下面详细介绍了所附加的 2 位和 5 位补充条形码的数据和外观。

主 UPC 条形码及所附加的补充条形码的数据与任何其它条形码的数据非常相似 — 屏幕数据、提示数据或输入文件数据。唯一的差异在于，主 UPC 条形码的数据和补充条形码的数据都是在主 UPC 代码的字段中指定的。

补充条形码的外观是使用补充选项对话框指定的。

如何将 2 位或 5 位补充条形码附加到 UPC 或 EAN 条形码之后

若要将 2 位或 5 位补充条形码附加到 UPC 或 EAN 条形码之后，请执行以下操作：

  1. 在标签格式中创建一个条形码。

  2. 双击该条形码，以显示修改所选条形码对象选项卡式对话框。

  3. 单击条形码属性页上的符号体系选项，以指定所需的 UPC 或 EAN 符号体系。

  4. 单击一次 UPC 补充选项按钮，以打开补充选项对话框。

  5. 使用长度和样式选项指定条形码的外观。完成更改后，单击补充选项对话框中的确定按钮，返回到修改所选条形码对象选项卡式对话框。

  6. 单击数据源选项卡显示数据源属性页。

  7. 通过选择相应的数据源，并（如有必要）键入相应的屏幕数据或提示数据，以指定 UPC 或 EAN 条形码的数据字符串。单击确定按钮。

BarTender 将自动从数据字符串的右侧提取所需数目的数字（2 或 5），并将它们作为补充条形码打印。数据字符串中的剩余数字将作为主 UPC 或 EAN 条形码打印。如果数据字符串中所剩数字不足以打印完整的主 UPC/EAN 条形码，BarTender 将使用前导零填充主 UPC/EAN 代码的左侧。


使用前缀

（这是符号体系特定的选项，仅适用于数据矩阵。）

使用前缀复选框仅适用于符号类型 ECC 200。启用该功能后，您可以选择以下前缀设置之一。

  • UCC/EAN FNC1。符合 AIM International 认可的特定工业标准。

  • Macro 5。将 05 Macro 头部（前缀）和尾部（后缀）缩写成一个符号字符，以减少对数据进行编码所需的符号字符数。

  • Macro 6。将 06 Macro 头部（前缀）和尾部（后缀）缩写成一个符号字符，以减少对数据进行编码所需的符号字符数。

  • 阅读器初始化。指示符号对用于编写阅读器系统的消息进行编码。

注意：如果您在条形码数据的开头指定了特殊的功能字符（如 FNC1 到 FNC6），并且启用了使用前缀选项，则会忽略在 BarTender 中指定的前缀，以支持数据中的特殊功能字符。有关特殊功能字符的详细信息，请参见数据矩阵文档。


Code One 的版本

版本

（这是符号体系特定的选项，仅适用于 Code One。在将计算机连接到支持二维功能的 Intermec 打印机上时，BarTender 中只显示 Code One 符号体系及其选项。）

使用版本选项可以从下拉列表中选择 Code One 条形码的大小。该列表按大小顺序依次显示了大小值，最小值 (A) 位于列表的顶部，最大值 (T48) 位于列表的底部。列表底部的较大值比较小值能够容纳更多的数据。

请注意，以字母“S”开头的三个大小选项（S10、S20 和 S30）只能与数字数据一起使用。


黑底白字

（这是符号体系特定的选项，仅适用于 Aztec 和数据矩阵。）

使用黑底白字选项可以反白显示条形码，这样，当在屏幕上显示条形码或在标签上打印条形码时，其效果就是在黑色背景上显示（或打印）白色的条形码。选中此选项后，反白显示的条形码看上去就像在黑框上显示白色的条形码一样。黑框四周必须达到一定的宽度才能填满非打印区域（如果符号体系要求非打印区域）。

注意：如果选择了黑底白字选项，您将不能再为条形码指定其它颜色。


主显示屏

BarTender 有两种查看模式：一种用于查看和设计标签格式（标签设计视图），另一种用于查看和自定义提示对话框（提示设计视图）。

标签设计视图（如下所示）是 BarTender 的主显示屏，用于访问创建和格式化标签时所需的所有菜单和对话框。单击下图中的不同区域，可以了解主显示屏中各主要元素的相关信息。


键盘等效设置

全部显示 全部隐藏

本帮助主题介绍如何使用键盘上的键和/或键组合，它们可以替代鼠标来执行各种命令。

操纵标签视图区域中的对象

请使用以下键来操纵标签视图区域中的对象。

键 | 等效的鼠标操作
CTRL+Z | 单击编辑菜单中的撤消命令。
CTRL+Y | 单击编辑菜单中的重复命令。
CTRL+X | 单击编辑菜单中的剪切命令。
CTRL+C | 单击编辑菜单中的复制命令。
CTRL+V | 单击编辑菜单中的粘贴命令。
Delete | 单击编辑菜单中的删除命令。
CTRL+A | 单击编辑菜单中的全选命令。

操纵所选对象

请使用以下键来操纵标签视图区域中的对象。

键 | 操作
ALT+ENTER | 打开属性对话框。
ENTER | 使可编辑对象进入编辑模式。打开不可编辑对象的属性对话框。（如果对象为单行文本并已处于编辑模式，按 ENTER 键将退出编辑模式。而如果对象段落并处于编辑模式，则按 ENTER 键将导致回车。）
F2 | 使对象进入编辑模式。该键对于不可编辑的对象无效。
SHIFT+ENTER 或 ESC | 退出编辑模式。
TAB | 如果当前对象不可编辑或未处于编辑模式，则该它可选择下一个对象。否则，将输入一个制表位。
SHIFT+TAB | 选择下一个对象。
CTRL-ENTER | 如果文本对象处于编辑模式，使用 CTRL-ENTER 可以使对象在段落和单行文本这两种状态之间切换。

选择主菜单和主菜单选项

使用以下键可以选择主菜单或主菜单选项。

键 | 操作
ALT+热键字母 | 选择指定热键字母所对应的主菜单。
热键字母 | 选择指定热键字母所对应的菜单选项。

在对话框中进行选择

使用以下键可以代替鼠标在对话框中进行选择。

键 | 操作
ALT+热键字母 | 选择指定热键字母所对应的选项。
TAB | 选择对话框中的连续选项。
SHIFT+TAB | 选择上一次在对话框中选中的选项。
箭头 | 选择选项的不同选择。例如，如果选项带有滚动框列表，使用箭头可以上移或下移突出显示条，从而做出不同的选择。
空格键 | 为带复选框的菜单选项切换启用/禁用状态。
ENTER | 选择所有对话框中的确定按钮。
ESC | 选择取消按钮。

在对话框的数据输入选项中移动光标

有数个选项要求您在数据输入编辑框中键入字符文本或特定值。例如，数据源属性页上的屏幕数据选项和条形码属性页上的高度选项就是这样的选项。在这些选项中输入数据时，可以使用以下键来代替鼠标在数据输入编辑框中移动光标。

键 | 等效的鼠标操作
HOME | 单击行首。
END | 单击行尾。

另请参见：

快捷菜单


显示和隐藏主工具栏

主工具栏

使用查看|工具栏菜单中的主工具栏选项，可以指定是否显示 BarTender 的主工具栏。

主工具栏按钮为 BarTender 的大多数最常用的命令以及文件、编辑、查看和创建菜单中的对话框提供了快捷方式。主工具栏如下图所示。

启用主工具栏选项后（菜单选项旁边有一个选中标记），主工具栏最初显示在主菜单栏的下方，但您可以

  • 将它拖到 BarTender 屏幕的任何其它三侧，

  • 将其拖到任何其它工具栏的上面、下面或一侧。

  • 或将它拖到计算机屏幕上任一地方，使之成为浮动工具栏。

要隐藏或显示主工具栏，只需选择查看菜单中的工具栏，并单击主工具栏选项，或选择工具栏快捷菜单中的主工具栏。

另请参见：

主工具栏

字体工具栏

状态栏

工具箱


显示和隐藏字体工具栏

字体工具栏

使用查看|工具栏菜单中的字体工具栏选项，可以指定是否显示 BarTender 的字体工具栏。

字体工具栏为 BarTender 的字体属性页上的大多数选项提供了快捷方式。字体工具栏如下图所示。

启用字体工具栏选项后（菜单选项旁边有一个选中标记），字体工具栏最初显示在主工具栏的下方，但您可以

  • 将它拖到 BarTender 屏幕的任何其它三侧，

  • 将其拖到任何其它工具栏的上面、下面或一侧。

  • 或将它拖到计算机屏幕上任一地方，使之成为浮动工具栏。

要隐藏或显示字体工具栏，只需选择查看菜单中的工具栏，并单击字体工具栏选项，或选择工具栏快捷菜单中的字体工具栏。

另请参见：

主工具栏

字体工具栏

状态栏

工具箱


显示和隐藏排列工具栏

排列工具栏

使用查看|工具栏菜单中的排列工具栏选项，可以指定是否显示 BarTender 的排列工具栏。

排列工具栏为 BarTender 的对齐和旋转对话框中的各个选项提供了快捷按钮。排列工具栏如下图所示。

启用排列工具栏选项后（菜单选项旁边有一个选中标记），排列工具栏最初显示在标签视图区域的左侧，但您可以

  • 将它拖到 BarTender 屏幕的任何其它三侧，

  • 将其拖到任何其它工具栏的上面、下面或一侧。

  • 或将它拖到计算机屏幕上任一地方，使之成为浮动工具栏。

要隐藏或显示排列工具栏，只需选择查看菜单中的工具栏，并单击排列工具栏选项，或选择工具栏快捷菜单中的排列工具栏。

另请参见：

主工具栏

字体工具栏

状态栏

工具箱


显示和隐藏状态栏

状态栏

使用视图|工具栏菜单中的状态栏选项，可以指定是显示还是隐藏 BarTender 的状态栏。

启用状态栏后（状态栏菜单选项旁边有一个选中标记），它将显示在 BarTender 屏幕的底部。状态栏显示特定于标签格式的信息，如当前打印机设置和当前选定标签对象的位置、大小及说明（若有）。

状态栏：

如果将您的鼠标指针放置在工具栏或菜单项上，则转而显示有关该项的临时帮助行。

临时帮助行：

要隐藏或显示工具栏，只需选择视图菜单中的工具栏并单击状态栏选项，或选择工具栏快捷菜单中的状态栏。

另请参见：

主工具栏

字体工具栏

状态栏

工具箱


工具箱概述

工具箱

BarTender 的工具箱是一组窗格，您可将其中一些可反复使用的对象和子串拖到标签上，从而加快标签的设计速度。

使用查看|工具栏菜单中的工具箱选项，可以指定是否显示工具箱。

启用工具箱选项后（菜单选项旁边有一个选中标记），工具箱最初显示在标签视图区域的左侧，但您可以

  • 将其拖到 BarTender 屏幕的右侧或底部

  • 将其拖到在 BarTender 屏幕左侧或右侧沿垂直方向放置的任何工具栏的任何一侧

  • 或将其拖到计算机屏幕上的任何位置，使之成为浮动工具箱。

要隐藏或显示工具箱，只需选择查看菜单中的工具栏，然后单击工具箱选项，或选择工具栏快捷菜单中的工具箱。（您也可以单击标题栏右端的 X 按钮来隐藏工具箱。）

要打开工具箱中的任一窗格，只需单击其标题栏。可用窗格有：

  • 组件

  • 默认对象

  • 数据源

  • 标准条形码

另请参见：

主工具栏

字体工具栏

排列工具栏

状态栏


组件窗格

有时在设计需要向其添加对象（例如条形码或文本字段）的标签时，对象的属性可能会与您以前在同一标签上或在不同标签上创建的其它对象的属性大体相同。通过利用工具箱上的组件窗格，您可以在其中创建和存储预先配置的对象，甚至创建和存储对象组。通过将此类组件从窗格拖到标签格式上，您可以重复使用它们。

在窗格中组织和浏览

组件窗格的工作方式与标准 Windows 目录很相似。您可以在树、图标和列表视图之间切换。（右键单击窗格的任何空白区域。从上下文菜单中选择查看，然后从子菜单中选择树、图标或列表。）在任何视图中，都将提供标准上下文（右键单击）菜单选项，包括剪切、复制、粘贴、重命名和删除项。可以像在任何目录中一样浏览、移动和复制。（若要在图标或列表视图中上移到父文件夹，请双击标有“. .”的图标。）上下文菜单还提供用于创建新文件夹的选项，以便您可以将组件组织成一些逻辑集合和子集，例如“运输”或“库存控制”。

创建和存储可重复使用的组件

在您向标签添加了新对象并在修改所选 … 对话框中配置了新对象的属性后，可以通过右键单击该对象并从下拉菜单中选择创建组件来存储该对象以供重复使用。表示该组件的图标将出现在组件窗格中（该窗格位于当前所选文件夹中），在其下面有一个突出显示的临时名“组件”。可以用新名称（例如“标准 UPC”或“折扣价”）覆盖该临时名称。

如果您计划重复使用整个对象集，则在标签上创建它们之后组合它们。右键单击该组并选择创建组件。

重复使用存储组件

若要重复使用一个组件，则将它从组件窗格拖到标签格式上的所需位置。如果您要更改任何组件的属性，请双击它以打开修改所选 … 对象对话框。（如果该组件是一组对象，则您首先可能需要解除对它们的编组。）


“默认对象”窗格

对象窗格

要在标签中添加条形码、文本对象、线条、方框或图片，可将对象从工具箱的默认对象窗格中拖到标签中所需的位置。也可以使用创建菜单或在主工具栏上单击相应的按钮来添加对象。


数据源窗格

全部显示 全部隐藏

工具箱的数据源窗格提供以下操作的快捷方式：

  • 向标签添加一个对象并在一步中指定其数据源的类型，

  • 为新对象重复使用特定的数据库字段，或者

  • 为新对象重复使用已命名的子串。

  • reuse a label object string from an existing label object, or

  • reuse a printer code template field.

从“数据源”窗格添加对象

在此窗格中，您可以用在窗格顶部列出的若干数据源类型向标签添加条形码、文本对象或图片。这些数据源包括：

  • 屏幕数据。直接键入标签格式的数据。

  • 日期。从计算机的日期设置读取的数据。

  • 时间。从计算机的时间设置读取的数据。

  • Visual Basic 脚本。从用户定义的 Visual Basic 脚本读取的数据。

  • Label Object String. String data read from another label object.

  • Printer Code Template Field. Data is received from an external print system such as a keyboard terminal, XML enabled printer, or ERP system.

注意：在下面几节中将对这些数据库字段和已命名的子串项加以解释。

单击所需类型的数据源，并且在按住鼠标键的同时将鼠标拖到标签上所需位置并松开鼠标键。这将打开一个快捷菜单，其中包含用于创建条形码、文本对象或图片的选项。选择一个对象并且该对象将被添加到标签上。然后可以通过双击它以打开修改所选 … 对象对话框，修改该对象的属性。

存储数据库字段以供重复使用

只要您将一个数据库字段指定为某一对象或子串的数据源，该字段即出现在数据源窗格的数据库字段目录中。这样不必执行进一步的操作即可使该字段可重复使用。

重复使用数据库字段

若要重复使用数据库字段，请展开数据源窗格中的数据库字段组。单击所需的字段，并且在按住鼠标键的同时将光标拖到标签上所需位置。在松开鼠标键后，将出现一个快捷菜单，提示您选择将该字段用于新的条形码对象、新的文本对象还是新图片。选择其中一项后，该对象即被添加到标签中。然后，可以通过双击该对象以打开修改所选 … 对象对话框，修改该对象的属性。

注意：您还可以通过右键单击数据库字段组并从下拉菜单中选择数据库连接设置，打开数据库连接设置对话框（如果您以前尚未设置一个数据库，则打开数据库连接设置向导）。

存储已命名子串以供重复使用

只要您为子串指定名称，该子串即出现在数据源窗格的已命名的子串目录中。这样不必执行进一步的操作即可使该子串可重复使用。

重复使用已命名的子串

若要重复使用已命名的子串，请展开数据源窗格中的已命名的子串组。单击所需的子串，并且在按住鼠标键的同时将光标拖到标签上所需位置。在松开鼠标键后，将出现一个快捷菜单，提示您选择将该子串用于新的条形码对象、新的文本对象还是新图片。选择一个对象并且该对象将被添加到标签上。然后可以通过双击它以打开修改所选 … 对象对话框，修改该对象的属性。

Reusing Label Object Strings

To reuse a label object string, expand the Label Object Strings group in the Data Sources pane. All available label object strings are automatically listed as the objects are added to the label. Expand the desired object to see what label object strings are available for use. Click the desired label object string and, while holding down the mouse button, drag the cursor to the desired location on the label. When you release the button a shortcut menu will appear giving you the option of using the label object string with a new bar code object, new text object, or new picture. Select one and the object is added to the label. You can then modify the object's properties by double-clicking it to open the Modify Selected … Object dialog.

Reusing a Printer Code Template Field

To reuse a printer code template field, expand the Printer Code Template Fields group in the Data Sources pane. Expand the desired object to see what printer code template field strings are available for use. Click the desired printer code template field and, while holding down the mouse button, drag the cursor to the desired location on the label. You can then modify the object's properties by double-clicking it to open the Modify Selected … Object dialog.


“标准条形码”窗格

要添加已分配了符号体系的条形码，可将其从工具箱的标准条形码窗格中拖到标签中需要它的位置。


Standard RFID Pane

Add an RFID object that has already been fully configured with a standard tag type by dragging it from the Standard RFID pane of the Toolbox to the label. You can also reuse your own configured RFID objects by saving them as components in Components pane.


菜单引用

主菜单栏是横跨屏幕顶部的水平条，可用于下拉各个主菜单：

  • 文件

  • 编辑

  • 视图

  • 创建

  • 修改

  • 排列

  • 工具

  • 窗口

  • 帮助


“文件”菜单

使用文件菜单中的选项可以加载、保存和打印使用 BarTender 创建和修改的标签格式。文件菜单中还包含指定页面设置和打印机设置的选项。另外，使用数据库连接设置对话框中的选项，可以指定 BarTender 打印标签所使用的数据源是外部文本文件、ODBC、SAP IDoc 还是 OLE DB。

下面概述了文件菜单选项。有关各个选项的详细信息，请单击以下相应的菜单名称。

  • 新建。用于创建新的标签格式。

  • 打开。用于打开现有标签格式并将其加载到标签视图区域，以便进行修改或用于打印标签。

  • 关闭。用于关闭活动的标签格式，但不退出 BarTender。

  • 保存。用于使用打开时所使用的文件名保存当前加载的标签格式。

  • 另存为。用于使用新名称命名并保存新创建的标签格式或将现有标签格式保存为新标签格式。

  • 全部保存。用于保存全部打开的标签格式。

  • 数据库连接设置。用于根据数据库中包含的信息指定打印标签时要使用的文本文件、ODBC、SAP IDoc 或 OLE DB 数据源的特性。

  • 页面设置。用于控制标签在页面上的尺寸和方位。

  • 打印预览。用于切换到打印预览模式。

  • 打印。用于打印标签并指定要打印的序列标签数和同样标签的份数。另外，该选项还用于选择打印标签要使用的打印机。

  • 导出图像。用于打开导出图像对话框。

  • 导出打印机代码模板。（仅限企业版。）使用该选项可以打开一个子菜单，您可以从中选择创建打印机代码模板所使用的打印系统。

    •

  • 说明。用于保存有关活动标签格式的简要说明。

  • 最近使用过的文件。用于显示最近打开过的标签格式的文件名。

  • 退出。用于终止程序。

另请参见：

了解标签格式


打开标签格式

打开

文件菜单上的打开命令用于打开现有标签格式并将其加载到标签视图屏幕，以便进行修改或用于打印标签。

“打开文件”对话框

选择了打开命令后，BarTender 将显示打开文件对话框。下面概要介绍了打开文件的各个选项：

  • 查找范围。用于显示可用驱动器的名称。当前指定的驱动器显示在列表的顶部。所选驱动器的内容显示在查找范围字段正下方的列表框中。

  • 文件名。用于指定要加载的标签格式的名称。

  • 文件类型。用于指定查找范围字段正下方的列表框中将显示 BarTender 中创建的文件。这些文件都使用文件扩展名 .BTW。

  • 查看预览/说明。用于显示当前指定标签格式的小型视图或与当前指定标签格式一起保存的说明。

过程：

打开现有的标签格式

另请参见：

开始新建标签格式

了解标签格式


关闭标签格式

关闭

使用文件菜单中的关闭命令可以关闭活动标签格式，但不退出 BarTender。如果对活动格式进行了更改，系统将询问您是否要保存所做更改。

另请参见：

退出 BarTender


关闭全部标签格式

全部关闭

使用文件菜单中的全部关闭命令可以关闭所有打开的标签格式，但不退出 BarTender。如果对格式进行了更改，系统将询问您是否要保存所做的更改。

另请参见：

退出 BarTender


保存标签格式

保存

文件菜单中的保存命令用于保存当前加载的标签格式，保存所使用的文件名与打开文件时所使用的文件名相同。保存命令仅用于保存对现有文件所做的修改。

如果要保存的是新标签格式，BarTender 将在第一次保存该新格式时显示另存为对话框。

另请参见：

使用其它名称保存标签格式

保存全部打开的标签格式


“导出图像”命令

导出图像

从文件菜单中选择导出命令可以将标签格式或标签格式上的所选对象作为图像文件导出。


“导出打印机代码模板”命令

导出打印机代码模板

从文件菜单中选择导出打印机代码模板命令可以打开一个子菜单，在此，您可以选择用于导出打印机代码模板的打印系统。（仅限企业版。）


Format Options or View Options Command

Format Options or View Options

Select either the Format Options command from the File menu or the View Options command from the View menu to open the Format Options dialog.


最近使用过的文件

文件菜单中的最近使用过的文件选项显示最近打开过的标签格式的列表（多达五个文件名）。要打开列表中的某个标签格式，只须单击其文件名即可。

另请参见：

打开现有的标签格式


“退出”命令

退出

从文件菜单中选择退出命令，可以终止程序并返回 Windows。如果您先前没有保存所做的格式更改，则 BarTender 将在结束该程序之前提示您保存。

另请参见：

关闭标签格式


“编辑”菜单

使用编辑菜单中的选项可以在标签视图区域中剪切、复制和删除一个或多个对象。要实现这些功能，可能要借助剪贴板。

您还可以使用编辑菜单撤消或重复操作、编辑对象的屏幕数据、指定“打印时提示”内容的顺序以及从 BarTender 导出对象。

下面概述了编辑菜单选项。有关各个选项的详细信息，请单击以下相应的菜单名称。

  • 撤消。用于撤消上一次操作。

  • 重复。用于重新执行以前撤消的操作。

  • 剪切。用于将所选对象从标签视图区域删除并将其复制到 BarTender 的剪贴板上。

  • 复制。用于将所选对象从标签视图区域复制到剪贴板上。

  • 粘贴。用于将剪贴板上的对象副本插入标签视图区域。使用该选项还可以将在其它程序中创建的位图添加到标签视图区域。

  • 无格式粘贴. Used to create a text object by pasting copied text onto the label so that it uses BarTender's default font, not the font it had when copied.

  • 删除。用于将所选对象从标签视图区域中删除。

  • 全选。用于选择标签视图区域中的所有对象。

  • 选择。用于选择标签视图区域中的对象，一次可以选择一个或多个对象。

  • 数据编辑。用于编辑条形码和文本对象的屏幕数据。

另请参见：

“选中”对象是什么意思


“撤消”命令

撤消

撤消命令 [image] 用于撤消在标签编辑会话过程中执行的操作。在执行了不想做的任何更改后，可立即单击撤消命令。如果要撤消一系列操作，只须重复单击撤消命令，直至标签格式恢复到原来的状态。

如果某个操作可以撤消，则编辑菜单中的“撤消”一词后面会紧跟着一两个描述该操作的词语。例如，如果执行的上一操作是将条形码添加到标签格式中，则命令将显示为撤消添加条形码。

如果某个特定操作不能使用撤消命令撤消，则撤消选项将被禁用。如果刚执行了一系列操作，则命令将显示这些操作中可以撤消的最后一个操作。撤消命令不能用于以下各项：

  • 窗口菜单中的命令。

  • 文件菜单中与文件操作有关的命令，如打开、保存和关闭。

当您选择了撤销命令后，重复命令会立即变得可用。您可使用该命令来恢复刚刚撤消的任何操作。

键盘快捷方式：CTRL+Z。

另请参见：

“重复”命令


“重复”命令

重复

使用重复命令 [image] 可以重新执行以前撤消的操作。如果未撤消过操作，则重复命令将不可用（灰显）。

请注意，在编辑菜单中，“重复”一词后面会紧跟着一两个说明要重复的操作的词。例如，如果您撤消的上次操作是将条形码添加到标签格式中，则命令将显示为重复添加条形码。

键盘快捷方式：CTRL+Y。

另请参见：

“撤消”命令


“剪切”命令

剪切

单击剪切命令 [image] 可以所选对象从标签视图区域中删除并将其复制到 BarTender 的剪贴板中。这样，您将可以使用粘贴命令将这些对象一起复制到同一标签格式的其它部分或其它格式中。

如果标签视图区域中未选择任何对象，则此选项将被禁用。

键盘快捷方式：选择了对象后，按 CTRL+X（或 SHIFT+DEL）可以从标签视图区域中剪切这些对象。

另请参见：

使用快捷菜单剪切、复制和粘贴


“复制”命令

复制

单击复制命令 [image] 可以将标签视图区域中的所选对象复制到BarTender 的剪贴板中。与剪切命令不同，复制命令不会从视图区域中删除所选对象。

如果标签视图区域中当前未选择任何对象，则此选项将被禁用。

键盘快捷方式：选择了对象后，按 CTRL+C（或 CTRL+INSERT）可以从标签视图区域中复制这些对象。

另请参见：

使用快捷菜单剪切、复制和粘贴


“粘贴”命令

粘贴

单击粘贴命令 [image] 可以将最近剪切或复制到剪贴板中的对象副本插入标签视图区域。

选择了粘贴命令后，BarTender 将把剪贴板内容插入到标签视图区域的左上角。若要移动粘贴对象在标签上的位置，只需单击并按住鼠标左键，将对象拖动到所需位置即可。

如果剪贴板中无内容，此选项将被禁用。

键盘快捷方式：CTRL+V（或 SHIFT+INSERT）。

另请参见：

使用快捷菜单剪切、复制和粘贴

将对象粘贴到特定位置

使用“粘贴”命令从其它程序导入位图


Paste Unformatted Command

Paste Unformatted

Click the Paste Unformatted command on the Edit menu to place a copy of the text in the clipboard into the label viewing area. BarTender will place the contents of the clipboard into the upper left corner of the label viewing area. The text will automatically use the default BarTender text font (set on the Font tab of the Modify Default Text Object dialog), not the font it had when copied. (If you want the text to keep its original font, use the Paste command instead.) To position the pasted object on your label, simply click and hold down your left mouse button and drag it into position.

If the clipboard is empty, this option is disabled.

Note: You can also use the Paste or Paste Unformatted command to paste text into an already existing text object. The pasted text will automatically acquire the font in use at the point of insertion regardless of which command you use.

See Also:

Cutting, Copying, and Pasting Using the Shortcut Menus

Pasting an Object into a Specific Position

Using the Paste Command to Import Bitmaps from Other Programs


“删除”命令

删除

从编辑菜单中选择删除命令，可从标签视图区域中删除所选对象。与剪切命令不同，删除命令不会在删除对象之前将其复制到剪贴板中。

如果标签视图区域中未选择任何对象，则此选项将被禁用。

键盘快捷方式：选择对象之后，按 Delete 键可将对象从标签视图区域中删除。


选择所有标签对象

全选

全选命令用于选择标签视图区域中的所有对象，以便能同时对它们进行操作。

键盘快捷方式：CTRL+A。

另请参见：

“选择”命令

使用指针工具选择一组对象


选择标签对象

选择

选择命令 [image] 可激活指针工具，即标准的鼠标光标，可用于选择选项以及在标签视图区域中调整对象的位置及大小。选择对象可激活手柄，从而可以在屏幕上对对象进行操作。选中对象后，可以使用鼠标和/或修改对话框中的选项修改对象。

激活指针工具和选中对象：

使用以下选项之一。

  • 在工具栏中单击 [image] ，然后单击要选中的对象。

或

  • 在编辑菜单中单击选择命令，然后单击要选中的对象。

另请参见：

“全选”命令

使用指针工具选择一组对象


数据编辑工具

数据编辑

选择了数据编辑工具 [image] 后，当您单击文本对象时，如果该文本对象仅包含一个子串，将直接进入编辑模式，这样，您可以直接在标签上编辑对象的文本。不过，如果用数据编辑工具单击的文本对象包含多个子串或任何条形码，BarTender 则会直接显示修改屏幕数据对话框（在标签设计视图下）或修改文本对话框（在提示设计视图下）。在此，您可以更改所选对象的文本，这种方式要比在修改对话框中单击各选项更快捷。

激活数据编辑工具：

使用以下方法之一可以激活数据编辑工具。之后，您就可以单击要编辑的对象了。

  • 在工具栏中单击 [image] 。

或

  • 在编辑菜单中单击数据编辑命令。

虽然上述两种数据编辑工具选择方法都可以达到目的，但由于单击按钮所需执行的单击鼠标的次数最少，因此它是速度最快的方法。

在显示了修改屏幕数据或修改文本对话框后，请以通常的方式编辑标签数据或提示对话框对象。


标签设计视图

标签设计视图模式是您将用来创建和设计所有标签格式的标准屏幕。有关屏幕外观及其主要功能的信息，请参见主显示屏。


提示设计视图

提示设计视图的外观与标签设计视图非常相似。您可以看到并使用很多（但并非全部）相同的设计功能。（工具栏和菜单选项在不可用时将显示为灰色。）与使用标签设计视图设计标签时类似，可以使用提示设计视图来自定义与标签格式关联的提示对话框。

了解提示对话框

当一个或多个标签对象设置为打印时提示时，BarTender 会自动创建一个默认的提示对话框，在该对话框上，BarTender 给每个设置为打印时提示的对象放置了一个用户提示和一个响应框。打印作业开始时，将显示提示该对话框，让用户输入在打印前可能不知道的数据。

设计提示对话框

由于 BarTender 会自动设计提示对话框，因此您甚至不必切换至提示设计视图便可使用打印时提示。不过，如果您希望自定义提示对话框的外观，请参见了解默认的提示对话框。

注意：您对提示对话框所做的更改不会影响标签格式的外观。

另请参见：

了解打印时提示


放大标签

放大

使用查看菜单中的放大命令（以及工具栏中的放大按钮 [image] ），可以将标签视图区域的局部放大到用百分比表示的指定缩放倍数。（缩放倍数百分比是使用查看选项对话框控制的。）每执行一次放大命令，BarTender 都会使您可以更细微地查看标签。

放大标签视图：

  1. 在主工具栏上单击放大按钮，或在查看菜单上单击放大命令。这时，您的光标将变为放大工具的形状。

  2. 将光标置于标签上要放大的位置，然后再次单击。BarTender 将以您在标签视图区域上的单击位置为中心、根据指定的缩放倍数百分比放大视图。

您也可以使用放大工具来选择要放大的特定标签区域。

定义要放大的特定标签区域：

  1. 在主工具栏上单击放大按钮，或在查看菜单上单击放大命令。这时，您的光标将变为放大工具的形状。

  2. 在标签视图区域中，将放大光标置于要放大区域的四个角之一的外侧，然后按住鼠标左键。

  3. 之后，按住鼠标左键不动，将光标从起始角一直拖动到要选择区域的对角。（注意，移动鼠标时，随着鼠标的移动会出现一个细虚线框。）

  4. 当要放大的整个区域都位于该虚线框之内时，松开鼠标键。BarTender 将按指定的缩放倍数百分比来放大您指定的区域。

如果视图区域已经放大到极限，放大命令将被禁用。

另请参见：

缩小标签


缩小标签

缩小

使用查看菜单中的缩小命令（以及工具栏中的缩小按钮 [image] ），可以将标签视图区域的局部缩小到用百分比表示的指定缩放倍数。（缩放倍数百分比是使用查看选项对话框控制的。）重复执行缩小命令可以使您观察到更大范围的标签。

如果视图区域当前已经缩小到极限，缩小命令将被禁用。

另请参见：

放大标签


屏幕上的实际大小

实际大小

查看菜单中的实际大小命令用于缩放标签图像，使之以 Windows 默认缩放比例显示在标签视图区域中，此时屏幕上的一英寸约相当于标尺的一英寸。

另请参见：

使标签适合窗口大小


使标签适合窗口大小

调整到窗口大小

查看菜单中的调整到窗口大小命令（以及工具栏上的调整到窗口大小按钮 [image] ）是一种特殊的缩放命令，使用该命令，可以将标签图像大小立刻调整为正好适合标签视图区域。

另请参见：

屏幕上的实际大小


查看选项

“查看选项”概述

全部显示 全部隐藏

使用查看选项对话框可为 BarTender 标签视图区域指定标尺、网格和缩放等设置。您还可以使用该对话框指定 BarTender 是否在屏幕上（利用淡淡的虚线）表示标签上任何不可打印部分的边界。

有关查看选项对话框中各选项的其它信息，请单击下面相应的选项名称。

标尺

BarTender 将沿着标签视图区域的水平边界和垂直边界显示标尺，它可以帮助您确定标签上各对象的位置。鼠标光标在视图区域中的当前位置总是用淡淡的虚线在水平标尺和垂直标尺上进行表示。

  • 每 <单位> 刻度数。用于指定 BarTender 的水平标尺和垂直标尺上每个度量单位中的刻度数（其中 <单位> 是指英寸、厘米、毫米或系统默认单位）。

  • 对齐。用于启用“对齐标尺”功能。

网格

网格系统是对 BarTender 标尺的补充，它在标签视图区域内显示一定数量的网格点（或点）。在设计和编辑标签时，如果要对对象进行精确定位或精确地调整其大小，这些网格点就可能有用。

  • 每 <单位> 刻度数。用于指定 BarTender 网格上每个度量单位中的刻度数（其中 <单位> 是指英寸、厘米、毫米或系统默认单位）。

  • 显示。用于指定是否在标签视图区域中显示网格。

选项

  • 单位。如果菜单选项在某个方面取决于水平距离值或垂直距离值，则可使用它来指定该菜单选项是使用美制度量单位还是使用公制度量单位。

  • 小数点。用于指定要将哪个字符作为小数字符来显示。

  • 放大倍数。用于指定放大和缩小命令将使用的缩放比例。

  • 显示不可打印区域。用于指定是否在屏幕上使用淡淡的虚线来表示标签上不可打印区域的边界。


指定标尺和网格设置

在标签视图区域的水平边界和垂直边界旁会显示 BarTender 的标尺。BarTender 的网格可补充标尺的功能，您可以沿着 BarTender 视图区域的每个轴显示特定的网格点数。在标签设置期间，特别是在调整对象大小和放置对象时，这些功能非常有用。

指定标尺设置：

  1. 从查看菜单中选择查看选项，显示查看选项对话框。

  2. 在每英寸刻度数（标尺）选项中，输入每个度量单位所需的刻度数。

  3. 如果希望按照标尺的坐标来放置对象和设置对象大小，请单击相应的复选框启用对齐选项。

  4. 单击确定命令按钮。

指定网格设置：

  1. 从查看菜单中选择查看选项，显示查看选项对话框。

  2. 在每英寸刻度数（网格）选项中，输入每个度量单位所需的刻度数。

  3. 如果希望在标签视图区域中显示网格点，请单击相应的复选框启用显示选项。（若要隐藏网格点，请再次单击相应的复选框，禁用显示选项。）

  4. 单击确定命令按钮。


标尺每英寸刻度数

每 <单位> 刻度数（标尺）

使用查看选项对话框中的标尺每 <单位> 刻度数选项（其中的 <单位> 是英寸、厘米、毫米或系统默认设置）可以指定标尺上每个度量单位中的刻度标记数。例如，在默认设置 16 下，标尺中的刻度标记的间隔为 1/16 英寸。同样，如果度量单位设置为厘米，则每厘米标尺中将出现 16 个刻度标记。BarTender 允许您指定范围从每个单位 1 个刻度到每个单位 100 个刻度的值。

另请参见：

对齐标尺


对齐（标尺）

使用查看选项对话框中的对齐选项可以指定是否按照标尺的刻度放置对象以及调整对象的大小。如果启用了对齐，对象的位置和大小将受到标尺刻度标记位置的约束。这样便可以更精确地确定对象位置和调整对象的大小。如果对齐被禁用，则在标签上确定对象位置和调整对象的大小时，可以完全自由地移动对象。

若要启用和禁用对齐选项，只需用鼠标单击对齐复选框以选择或取消选择该选项即可。

另请参见：

标尺每 <单位> 刻度数


网格每英寸刻度数

每 <单位> 刻度数（网格）

使用查看选项对话框中的网格每 <单位> 刻度数（其中的 <单位> 是英寸、厘米、毫米或系统默认设置）可以指定 BarTender 标签视图区域的每个度量单位中平均分布的网格点数。例如，默认设置 8 将在标签视图区域上显示间隔为八分之一英寸的网格点。如果度量单位设置为厘米，网格点将以八分之一厘米的间隔显示在标签视图区域中。BarTender 允许您指定范围从每个单位 1 个刻度到每个单位 100 个刻度的值。

另请参见：

显示网格


显示（网格）

使用查看选项对话框中的显示选项可以指定是否在标签视图区域中显示网格点。

另请参见：

网格每 <单位> 刻度数


度量单位

使用查看选项对话框中的单位选项可以指定英寸、厘米、毫米，或者将计算机的默认设置用作 BarTender 中的度量单位。这会影响到与水平或垂直距离的度量有关的所有菜单选项，如条形码的高度、供人识读字符与条形码的距离，以及对象在标签上的位置。

另请参见：

每 <单位> 刻度数（标尺）

每 <单位> 刻度数（网格）


放大倍数

倍数

查看选项对话框中的放大倍数选项的默认设置为 200%，这意味着标签视图区域中图像的大小将在您每次执行放大命令时都加倍。同样，每次执行缩小命令时，视图区域中图像的大小都缩小一半。可以在 100% 到 500% 的范围内修改放大倍数选项，并且修改幅度最小为 5%。


显示不可打印区域

大多数激光或其它“页面”打印机都会在页面的周围留出一定的不可打印区域。在激光打印机（如 HP LaserJet 系列打印机）上，不可打印区域通常在页面周围 0.200 英寸的页边距以内。为了确保标签上的所有对象都完整地打印在页面上的每个标签上，在确定对象位置时需考虑到此不可打印区域。

在启用了查看选项对话框中的显示不可打印区域选项后，BarTender 将沿着屏幕标签的边界显示一条淡淡的虚线，该虚线非常有用，可帮助您确定对象在标签上的最佳位置。

请记住，虚线所划分的“不可打印”区域代表一种“最坏情形”。只有在标签占满整个页面时，才会对所有标签应用虚线所划分区域的全部四条边。在更常见的情形中（每页都多个标签），页面中最上面的一行标签将受标签顶部的不可打印区域（在屏幕上显示）的影响，左边的一列标签将受标签左侧的不可打印区域（在屏幕上显示）的影响，依此类推。也就是说，只有其边缘紧靠页面边缘的那些标签才会受影响，并且也只有标签的该边缘受影响。


“创建”菜单

使用创建菜单的各个选项可以在标签格式中添加条形码、文本以及各种图形对象。对于这些对象，其每种对象都有自己的创建菜单选项。另外，每个创建菜单选项都与标签视图区域顶部工具栏上的一个按钮相对应。当在标签上创建对象时，您可以也选择使用这些按钮（这样将更快捷）。

下面概述了创建菜单选项。有关各个选项的详细信息，请单击以下相应的菜单名称。

  • 条形码。用于在标签格式中添加条形码。

  • 文本。用于在标签格式中添加文本对象。

  • 线条。用于在标签格式中绘制线条。

  • 方框。用于在标签格式中绘制方框。

  • Ellipse. Used to draw an ellipse in the label format.

  • 图片。用于在标签格式中添加条图片。

  • 从所选对象创建组件。用于创建由当前所选对象构成的组件。

有关在标签视图区域中创建对象以及有关 BarTender 内置对象默认设置的详细信息，请参见创建对象。


创建条形码

条形码

使用创建条形码按钮 [image] （以及相应的光标符号）可以将条形码添加到标签中。

将条形码放在标签上后，可以使用修改所选条形码对象选项卡式对话框中的属性页来调整其外观。也可以使用鼠标直接调整条形码的位置、高度和密度。

过程：

创建条形码对象

另请参见：

创建对象


创建文本对象

文本

使用创建文本按钮 [image] （以及相应的光标符号）可在标签或提示对话框上添加文本。

将文本对象放在标签上后，可以使用修改所选文本对象选项卡式对话框中的属性页来调整其外观。对于放置在提示对话框上的文本对象，则可以使用修改所选对象选项卡式对话框中的属性页。

还可以使用鼠标直接调整文本对象的位置和大小。

过程：

创建文本对象

另请参见：

创建对象


创建线条

线条

使用创建线条按钮 [image] （以及相应的光标符号）可在标签或提示对话框上绘制线条。由于线条的长度是在线条创建时指定的，所以您会发现创建线条按钮的工作方式与创建条形码和创建文本按钮多少有些不同。

在标签上绘制好线条后，可以使用修改所选线条选项卡式对话框中的属性页来调整其外观。对于放置在提示对话框上的线条，可以使用修改所选对象选项卡式对话框中的属性页。

还可以使用鼠标直接调整线条的位置和长度。

过程：

绘制线条


方框

使用创建方框按钮 [image] （以及相应的光标符号）可在标签上绘制方框。和线条命令相似，由于方框的大小是在其创建时指定的，因此，您会发现创建方框按钮的工作方式与创建条形码和创建文本按钮稍有不同。

在标签上绘制好方框后，可以使用修改所选方框选项卡式对话框中的属性页来调整其外观。也可以使用鼠标直接调整分组框的位置和尺寸。

过程：

绘制方框


Create RFID Object

RFID

Use the Create RFID button [image] to add a bar code to your label.

After the object has been placed on the label, you can use the property pages in the Modify Selected RFID Object tabbed dialog to configure it.

Procedure:

Creating an RFID Object

See Also:

Creating Objects

Understanding RFID


导入图片

图片

使用导入图片按钮 [image] （以及相应的鼠标光标符号）可以将图片导入标签格式。BarTender 支持以下图片类型：BMP、DXF、EPS、GIF、IMG、JPG、PCD、PCX、PNG、TGA、TIF、WPG 和 WMF。这些格式中，最后一种不能旋转。

在将图片对象放置于标签格式上后，使用修改所选图片对话框中的图片属性页可以完成导入图片的过程。

步骤：

将图片插入到标签格式中

另请参见：

创建对象


创建组件菜单项

从所选对象创建组件

使用创建菜单中的从所选对象创建组件命令可以创建组件，该组件将由标签上所有当前所选对象构成。


“修改”菜单

通过使用修改菜单和修改选项卡式对话框中的选项，可以根据需要调整标签上对象的外观。使用修改对话框还可以指定条形码和文本对象的数据源。

“修改”选项既可以应用于单个对象，也可以应用于对象组。但是，由于只有一部分“修改”选项与给定的任何对象或对象组有关，因此在任何指定时间显示的属性页都可能包含若干个被禁用（灰显）的选项。另外，与数据库连接设置对话框相似，某些修改属性页包含动态区域，在此，会根据对话框中其它选项的设置而显示不同的选项。

下面概述了修改菜单选项。有关各个选项的详细信息，请单击相应的选项名称。

  • 所选对象。用于修改所选对象的外观。

  • 所选编组。用于修改所选对象组。

  • 默认。用于修改可以放置在标签上的不同类型对象的内置默认设置。

另请参见：

显示所选对象的属性


修改所选对象

全部显示 全部隐藏

以下列表显示了可在 BarTender 中创建的各对象类型的选项卡式对话框中可以显示哪些属性页。请留意如何为多种类型的标签对象显示多页。例如，由于所有对象的位置都可以修改，因此所有选项卡式对话框都可以显示位置属性页的副本。

对象类型 | 可用的属性页
条形码 | 条形码、供人识读、字体、数据源、位置、常规
文本 | 字体、文本、数据源、位置、常规
线条 | 线条、位置、常规
方框 | 方框、位置、常规
Ellipse | Ellipse, Position, General
图片 | 图片、位置、数据源（可选）、常规

属性页概述

下面列出了各属性页的概述。有关介绍各属性页上每个选项的其它信息，请单击相应的选项名。

  • 条形码。用于指定标签上条形码的符号体系和其它特性。

  • 供人识读。用于指定与条形码一起显示在标签上的供人识读字符的位置和可见性。

  • 字体。用于指定标签上文本对象的特性。如果所选对象为条形码，则使用字体选项可以修改条形码的供人识读字符的文本。

  • 文本。用于指定是否使文本对象分布在单个线条上、多个线条上或沿曲线弯曲。

  • 图片。用于指定要在标签格式上显示的图片文件以及与图片的显示方式有关的其它特征。

  • 数据源。用于指定条形码、文本对象以及数据源图片所使用的数据来源并根据需要处理数据。

  • 线条。用于指定标签上线条的长度、线宽和颜色。

  • 方框。用于指定标签上方框的高度、宽度、线宽和其它特性。

  • 位置。用于对标签上各对象的位置进行微调。（请记住，要调整标签上对象的位置，使用鼠标通常最简便。）

  • 常规。用于将对象指定为非打印对象以及用于插入说明。

另请参见：

显示所选对象的属性


内置默认设置

在标题为了解标签格式的帮助主题中，向您介绍了 BarTender 的内置默认设置的概念。正如该主题所介绍的，在为标签格式指定新的默认设置之前，BarTender 将在每次在标签上创建新对象时都使用内置默认设置。

可以使用修改默认对象选项卡式对话框来修改各个标签格式的默认对象设置。若要显示这些对话框，请单击主菜单栏上的修改选项，再单击默认对象菜单选项，然后针对要修改的对象类型再次单击该菜单选项。修改修改默认对象选项卡式对话框中的选项的方法与修改标签格式中选定对象的方法完全相同。

默认对象选项基于以下准则工作：

  • 一旦为给定的对象类型指定了新的默认设置，编辑该格式时创建的其它所有同类型对象都将按照新的默认设置来设置格式。

  • 指定新的默认设置时，只有正在处理的标签格式受影响，而其它标签格式保持不变。


Lock Object(s) Command

Lock Command

The Lock command in the Arrange menu allows you to lock the selected object(s) so that they cannot be inadvertently moved, resized, or rotated.


Unlock Object(s) Command

Unlock Command

The Unlock command in the Arrange menu allows you to unlock the selected object(s) so that they can again be moved, resized, or rotated.


“工具”菜单

使用此菜单上的项可以打开执行 BarTender 管理和配置活动所需的对话框。有关详细信息，请单击下面的项。工具菜单上的可用项会根据 BarTender 的版本而有所不同。

  • 日志文件设置（仅限企业版）

    •

  • IDoc 定义设置（仅限企业版）

    •

  • 消息设置

  • 打印机代码模板设置（仅限企业版）

    •

  • 常规选项

  • 口令设置

  • 登录

  • 管理设置


日志文件设置

显示日志文件设置对话框。（仅限企业版）


IDoc 定义设置

显示 IDoc 定义设置对话框。（仅限企业版）


消息设置

显示消息设置对话框。


“打印机代码模板设置”命令

“设置打印机代码模板”命令

从工具菜单中选择打印机代码模板设置命令可以打开打印机代码模板设置对话框。（仅限企业版。）


常规选项命令

常规选项

显示常规选项对话框。


口令设置

显示口令设置对话框。


登录

显示口令提示。


管理设置

显示管理设置对话框。


“窗口”菜单

窗口菜单用于定义标签格式或提示对话框的另一个或多个视图，以及在这些视图间进行切换。使用该菜单，可以查看多个标签格式、同一标签格式的不同视图、提示设计视图以及所有这些视图的组合。窗口菜单中的选项简化了以下操作：

  • 将标签格式上的标签对象复制并移到另一个标签格式上。

  • 同时查看标签格式的多个缩放视图。

  • 同时查看标签格式的标签设计和提示对话框设计。

下面概述了窗口菜单选项。有关各个选项的详细信息，请单击以下相应的选项名称。

  • 新建标签设计窗口。打开一个新窗口，显示活动标签格式的另一个标签设计视图。

  • 新建提示设计窗口。打开一个新窗口，以提示设计视图模式显示活动标签格式。

  • 层叠。重叠排列所有打开的窗口，但显示这些窗口的标题栏。

  • 横向平铺。排列标签视图区域中所有打开的窗口，一个窗口叠放在另一个窗口的下方。

  • 纵向平铺。排列标签视图区域中所有打开的窗口，一个窗口叠放在另一个窗口的旁边。

  • 排列图标。沿 BarTender 标签视图区域的底部排列所有已最小化的窗口。

  • 打开的窗口列表。显示当前打开的所有窗口的名称，您可以在这些窗口间进行切换。


新建标签设计窗口

使用标签设计视图打开活动标签格式的第二个窗口，以便同一个标签格式有两个或更多视图。例如，您可以在一个窗口中以其实际大小显示标签格式，而在第二个窗口中以 200% 的比例显示同一个标签格式。

当您为某打开的标签格式新建窗口时，BarTender 会直接在该格式名称后面显示一个冒号和数字，表示打开的窗口的编号（例如，FORMAT:1、FORMAT:2）。BarTender 会在以下三个位置之一显示格式名称和窗口号（若适用），从而帮助您跟踪打开的窗口：

  • 当活动窗口以全屏方式显示时，格式名称显示在 BarTender 的主标题栏中。

  • 当活动窗口以部分屏幕方式显示时，仅格式名称显示在 BarTender 的主标题栏中。格式名称和窗口号（若适用）显示在各个窗口的标题栏中。

  • 所有打开窗口的名称都列在窗口菜单的底部。活动窗口用复选标记表示。

重要提示：新建标签设计窗口选项不会启动新的标签格式。要启动新的格式，必须单击主工具栏上的新建按钮，或从文件菜单中选择新建选项。

另请参见：

打开的窗口列表


新建提示设计窗口

使用提示设计视图打开活动标签格式的第二个窗口，以便显示与当前显示的标签格式关联的提示对话框。例如，您可以在一个窗口中以标签设计视图显示标签格式，而在第二个窗口中以提示设计视图显示，即与标签格式关联的提示对话框。

当您为某打开的标签格式新建窗口时，BarTender 会直接在该格式名称后面显示一个冒号和数字，表示打开的窗口的编号（例如，FORMAT:1、FORMAT:2）。BarTender 会在以下三个位置之一显示格式名称和窗口号（若适用），从而帮助您跟踪打开的窗口：

  • 当活动窗口以全屏方式显示时，格式名称显示在 BarTender 的主标题栏中。

  • 当活动窗口以部分屏幕方式显示时，仅格式名称显示在 BarTender 的主标题栏中。格式名称和窗口号（若适用）显示在各个窗口的标题栏中。

  • 所有打开窗口的名称都列在窗口菜单的底部。活动窗口用复选标记表示。

另请参见：

打开的窗口列表


层叠

层叠命令用于重叠排列所有打开的窗口，但显示这些窗口的标题栏。

注意：最小化的窗口以图标形式显示在 BarTender 标签视图区域的底部。


横向平铺

横向平铺命令用于重新排列标签视图区域中所有打开的窗口，使一个窗口叠放在另一个窗口的上方。

注意：最小化的窗口以图标形式显示在 BarTender 标签视图区域的底部。


纵向平铺

纵向平铺用于重新排列标签视图区域中所有打开的窗口，使一个窗口叠放在另一个窗口的旁边。

注意：最小化的窗口以图标形式显示在 BarTender 标签视图区域的底部。


排列图标

排列图标命令用于沿 BarTender 标签视图区域的底部排列所有已最小化的窗口。


打开的窗口列表

窗口菜单的底部显示所有打开的标签格式或提示设计窗口的列表，其中有复选标记的是活动窗口。要将另一个打开的窗口作为活动窗口，只须在列表中单击该窗口的名称。

在下图中，窗口菜单的底部显示两个标签格式（aiag_pt1.btw 和 stock_dn.btw）的视图，每个标签格式各打开两个视图。复选标记表明 aiag_pt1.btw 的视图 2 是活动窗口。

图：打开的窗口列表示例
（两个标签格式各有两个打开的窗口）

另请参见：

新建标签设计窗口

新建提示设计窗口


“帮助”菜单

使用帮助菜单中的选项可以访问有关 BarTender 的联机帮助和产品信息。下面概述了帮助菜单选项。

  • BarTender 帮助。用于访问帮助系统。

  • Visual Basic 脚本帮助。用于访问 Visual Basic 脚本帮助文档。

  • Animated Tutorial. Launches a program that demonstrates BarTender's features.

  • 技术支持。提供有关获取技术支持的信息。

  • 在万维网上注册。用于访问 Seagull Scientific Web 站点的网页，在此，您可以注册您的新 BarTender。

  • 万维网上的 Seagull。用于访问 Seagull Scientific Web 站点的主页。

  • 激活此软件 或激活向导。用于启动激活向导。在您第一次激活软件之前，该命令显示为激活此软件。

  • 激活帮助。提供有关软件激活的信息。

  • 关于。用于显示有关此版本 BarTender 的信息。


帮助主题

显示帮助系统的目录、索引、搜索、收藏夹和词汇表选项卡。

有关帮助的帮助信息，请按 F1 键。

另请参见：

使用和自定义联机帮助系统


Visual Basic 帮助

单击 Visual Basic 帮助可查看比说明选项中显示的简要帮助更为详细的帮助信息。该操作将打开 Microsoft 的完整 Visual Basic 脚本帮助文档。（此文档还包括许多未列在“脚本助理”的类别或名称选项中的 Visual Basic 组件的帮助信息。）

此外，还可以单击此处，了解“脚本助理”中包含的特殊 BarTender 对象、函数和属性的帮助信息。


Animated Tutorial

Animated Tutorial launches a an animated program that demonstrates BarTender's features.


技术支持菜单项

技术支持

使用技术支持可以打开 BarTender 的联机帮助，显示如何获取技术支持的主题。


在线注册

通过在线注册，可以访问 Seagull Scientific 的 Web 站点，在这里您可以注册您的新 BarTender。


万维网上的 Seagull

通过万维网上的 Seagull，可以访问 Seagull Scientific 的 Web 站点，在此您可以找到有关 BarTender 的信息，下载其它打印机驱动程序。


激活此软件

激活此软件或激活向导

使用这些命令可以启动激活向导。如果之前从未激活过软件，此命令为激活此软件。否则，此命令为激活向导。


激活帮助

使用激活帮助可以打开有关软件激活的常见问题解答。


关于本应用程序

关于

关于显示有关 BarTender 版本的程序信息。


快捷菜单

当使用鼠标右键单击界面的相应区域时，BarTender 屏幕界面的某些区域将显示一个由快捷方式命令组成的下拉菜单。例如，如果右键单击标签视图区域中的任一对象，BarTender 将显示一个菜单，如本主题末尾处所示。您将发现，该菜单是创建和修改标签上的对象时常要用到的选项的快捷方式。

使用快捷菜单可能要比从工具栏或主菜单中选择命令更为方便，这主要取决于您个人的工作习惯和所用键盘和鼠标的类型。

BarTender 屏幕界面上一些最常用的快捷菜单列出如下。切记，该列表并不完整，这些快捷菜单（或十分类似的菜单）是大多数 Windows 程序的标准功能。

对象属性

标签视图区域

数据输入字段

工具栏区域

子串列表


数据输入选项快捷菜单

包含在 BarTender 中输入键盘数据时常用选项的快捷方式。数据输入选项包括：文件打开和文件另存为对话框中的文件名选项，以及数据源对话框中的屏幕数据和样本数据选项等。若要显示此快捷菜单，请右键单击 BarTender 的任意数据输入字段。


标签视图区域的快捷菜单

包含在标签视图区域中执行操作时一些常用选项的快捷方式。 若要显示该快捷菜单，请右键单击 BarTender 标签视图区域中的任意位置。（请注意，如果右键单击标签视图区域中的某个对象，则显示的就是对象属性快捷菜单。）

若要显示关于此快捷菜单上的各个命令的信息，请单击下图中相应的图形区域。


对象属性快捷菜单

包含创建和修改标签对象时常用选项的快捷方式。若要显示此快捷菜单，请右键单击任意标签对象。（请注意，如果光标未放置在该对象上，也就是右键单击的是标签视图区域本身，显示的将是标签视图区域的快捷菜单。）

若要显示关于此快捷菜单上的各个命令的信息，请单击下图中相应的图形区域。


工具栏快捷菜单

包含控制 BarTender 是否显示工具栏和工具箱的菜单选项的快捷方式。若要访问此快捷菜单，请右键单击工具栏区域或工具箱的标题栏。（如果未显示工具栏，您将无法访问快捷菜单。在这种情况下，请使用查看 | 工具栏菜单。）

有关此快捷菜单上可用的各个工具栏的更多信息，请单击下图中的工具栏名称。


技术支持

本联机帮助系统和入门手册中的信息可解答大多数技术问题。如果在查阅了这些资料后仍有疑问，可以通过以下任一电话号码和电子邮件地址与我们的技术支持部门联系。

区域 | 语音电话 | 传真 （通过传真发送的技术支持请求将以传真形式答复。） | Internet （通过 Internet 发送的技术支持请求将通过 Internet 答复。）
美国 | +1 425 641 1408 | +1 425 641 1599 | TechSupport@SeagullScientific.com
欧洲 | +34 91 435 55 45 | +34 91 578 05 06 | EuroTech@SeagullScientific.com
亚太地区 | +886 2 3765 2440 | +886 2 3765 2467 | AsiaTech@SeagullScientific.com

注意：对 Visual Basic 脚本的技术支持是有限的。有关支持限制的信息，请参见有关 Visual Basic 脚本的技术支持说明。

您必须注册您的软件才能获得支持

要获得技术支持，您必须在自购买产品之日起十天内单击此链接在线注册您的产品。只有在注册之后，才能得到技术支持。

您必须在计算机旁边拨打电话

在通过电话请求技术支持时，一定要在运行 BarTender 的计算机旁边拨打电话。这将使我们的技术人员更容易帮助您。

退货

如果您是直接通过 Seagull Scientific, Inc. 购买了 BarTender，之后觉得不合用，在购买之日起三十天内可以将其退回 Seagull。不过，您必须先通过上面提供的电话号码与我们的技术支持部门联系。届时，我们将发给您一个退货号码（Merchandise Authorization Number，RMA#）并提供我们的收货地址。

注意：如果您是通过其它渠道购买了 BarTender，则退货条件可能有所不同。有关退货政策的信息，请与您的分销商联系。


有关 Visual Basic 脚本的技术支持说明

“脚本助理”的联机帮助将给大多数用户提供编写其自己的 Visual Basic 脚本所需的全部帮助。如果您遇到困难，Seagull 技术支持将帮助您解决以下问题：

  • 了解数据源属性页的 Visual Basic 脚本部分。

  • 了解“脚本助理”的使用方法。

  • 回答有关 BarTender 的“内置”脚本函数（Seagull 为了简化某些常见脚本编写任务而添加的函数）的问题。

  • 确定是否需要编写脚本来帮助您解决特定的技术难题。

  • 回答有关在 BarTender 中编写 Visual Basic 脚本的简单问题。

不过，由于 Visual Basic 脚本是 Microsoft 产品，又不太适合计算机初学者使用，因此 Seagull 不能提供以下类型的支持：

  • 教您如何成为程序员。

  • 教授 Visual Basic。

  • 帮助编写脚本。

  • 帮助“调试”脚本。

另请参见：

了解 Visual Basic 脚本数据源


License Agreement

Seagull Scientific ("Seagull") grants you a non-exclusive license to use the accompanying computer software and related documentation ("Seagull Software"), subject to the following provisions. You assume full responsibility for the selection of the Seagull Software to achieve your intended results, and for the installation, use, and results obtained from the Seagull Software.

Only the TRIAL EDITION of Seagull抯 BarTender software may be copied and distributed freely. All other versions of BarTender are protected under standard copyright law and may not be copied.

Seagull's thermal printer drivers also may not be copied or distributed, except under either of these two conditions:
1. A BarTender Trial edition must be included with the drivers in a way that makes the recipient clearly and unambiguously aware of the fact that they have the option to install and use the included BarTender software.
2. Otherwise, explicit written authorization must be received from Seagull to distribute the drivers.

Individual users can always obtain Seagull drivers directly from Seagull, either by CD or by downloading them directly from Seagull抯 web page. Printer manufacturers are expressly prohibited from redistributing Seagull抯 thermal printer drivers without written authorization obtained directly from Seagull.

The license granted by this agreement for all non-Trial software is absolutely restricted to you for your own use. You may make a copy of such Seagull Software only for backup purposes. You shall not: (1) permit any third party to use the Seagull Software; (2) use the Seagull Software with the use of a generic name; (3) allow access to the licensed software by timesharing; (4) copy the documentation; or (5) modify the software.

Both the software and the related material are Copyrighted and therefore protected by Federal law. Title to and all rights and interests in the Seagull Software, wherever resident and on whatever media, are and shall remain the property of Seagull. You expressly acknowledge and agree that the Seagull Software constitutes a valuable proprietary product and trade secret of Seagull, embodying substantial creative efforts, which requires protection against unauthorized use and disclosure. You expressly agree to protect the valuable proprietary Seagull Software against unauthorized use and disclosure by taking all reasonable steps necessary to do so, including agreements with employees and others that may have access to the Seagull Software.

Seagull warrants only that the media on which the Seagull Software is furnished will contain the program and that it is free from defects in materials and workmanship under normal use for a period of thirty (30) days from the date of purchase. The warranty is effective from the date of purchase provided that within thirty days of purchase, the purchaser completes and returns the enclosed registration card.

SEAGULL EXCLUDES ALL OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. STATEMENTS BY SEAGULL STAFF OR DEALERS OR ADVERTISEMENTS NOT EXPRESSLY REFERRED TO WITHIN THIS AGREEMENT DO NOT CONSTITUTE PART OF THIS AGREEMENT. THE ENTIRE RISK AS TO THE ACCURACY AND PERFORMANCE OF THE SEAGULL SOFTWARE IS WITH YOU. THE USER IS ADVISED TO THOROUGHLY TEST THE SOFTWARE BEFORE RELYING ON IT. SEAGULL DOES NOT WARRANT THAT THE FUNCTIONS CONTAINED IN THE SEAGULL SOFTWARE WILL MEET YOUR REQUIREMENTS OR THAT THE OPERATION OF THE SEAGULL SOFTWARE WILL BE UNINTERRUPTED OR ERROR FREE.

Seagull's entire liability and your exclusive remedy shall be replacement of any media not meeting Seagull's Limited Warranty returned to Seagull or an authorized Seagull dealer with a copy of your receipt. If the authorized Seagull dealer and Seagull are both unable to deliver replacement media that is free of defects in material and workmanship, you will be given a refund.

IN NO EVENT WILL SEAGULL BE LIABLE TO YOU OR FOR ANY CLAIM BY ANY OTHER PARTY, FOR DAMAGES, INCLUDING LOST PROFITS, LOST SAVINGS OR ANY OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PRODUCT, EVEN IF SEAGULL OR AN AUTHORIZED DEALER HAS BEEN ADVISED OF THE POSSIBILITY OF DAMAGES. SEAGULL'S TOTAL LIABILITY SHALL BE LIMITED TO THE REPAIR OR REPLACEMENT OF THE PRODUCT OR TO AN AMOUNT NO GREATER THAN THE PURCHASE PRICE OF THE PRODUCT.

Some states and provinces do not allow the exclusion of implied warranties or the exclusion of liability for incidental or consequential damages so the foregoing may not apply to you. This agreement gives you specific legal rights that vary from state to state. The allocation of risks under this agreement is deliberate and the consideration for the product was determined accordingly.

This agreement shall be governed by the laws of the State of Washington, USA, and should any legal action be necessary between the parties such legal action shall be filed in Bellevue, Washington. The prevailing party in any litigation arising out of this agreement shall be entitled to be reimbursed for all attorney's fees, expense, and associated costs. If any provision of the agreement shall be held to be invalid, illegal, or unenforceable, the remaining provisions shall nevertheless be given full force and effect.

You acknowledge that you have read and understand this agreement and agree to be bound by its terms and conditions. Further, you agree that it expresses the entire agreement and that it supersedes any advertising, and any prior or contemporaneous communications, oral or written, relating to Seagull products.


数据库连接设置 - 所有数据库树视图

所有数据库树视图

通过所有数据库树视图（位于数据库连接设置对话框的左侧），用户可以访问所有可用的数据库、表和字段，以用于查看、修改、查询和 SQL 语句等。通过单击树视图图标左侧的 (+) 符号或 (-) 符号，可以展开或折叠树视图的任何级别。树视图的根项是所有数据库。在根项下面是您已添加的所有数据库。每一数据库之下是为该数据库选择的所有表的列表。每一表之下是该表中的字段。选择树视图中的特定项将在该树视图右侧的选项卡中显示其相应选项。所选的项将确定哪些数据库连接设置选项卡可用。此外，在任何级别（项）上右键单击都将显示选项的上下文相关菜单。

另请参见：

数据库连接设置


Microsoft ODBC 驱动程序的备选程序

Microsoft 只是分发 ODBC 驱动程序的众多公司之一。事实上，软件制造商经常会提供自己的 ODBC 驱动程序来支持他们自己的产品。

Microsoft 的驱动程序的优点/缺点

Microsoft 的 ODBC 驱动程序的优点是：它们的许可条件比较实在，拥有成本相当低廉。不过，强烈建议您使用制造商提供的 ODBC 驱动程序（只要有）。

备选的 ODBC 驱动程序源

另一个选择方案是一家名为 DataDirect Technologies 的公司。其网址是 www.datadirect-technologies.com，电话号码是：800-876-3101。这家公司开发和销售许多 ODBC 驱动程序。由于 DataDirect Technologies 要收取这些 ODBC 驱动程序的费用，因此 BarTender 的制造商无法使它们的售价和 Microsoft 的 ODBC 驱动程序一样低廉。但是，如果您要寻找 Microsoft 和其它供应商提供的 ODBC 驱动程序的备选程序，这却是一个值得考虑的选择方案。


“排列”工具栏

包含对齐对话框和旋转对话框中各选项的快捷按钮。（请参见“排列”工具栏。）


字符助理

字符助理出现在数据源选项卡上的修改所选条形码对象或修改所选文本对象对话框中，其左侧就是屏幕数据/默认响应文本框。（它还出现在创建打印机代码模板时使用的 <定界符值> 对话框中。）它出现在以下按钮上：

通过此功能，您只需通过突出显示并单击所需的字符，即可插入非可键入字符。单击 Character Assistant（字符助理）按钮将显示所有可用字符的弹出式列表。下面列出了这些可用字符。

字符名称 | 显示为 | 十进制值 | 十六进制值
标题开始 | "SOH" |  |
文本开始 | "STX" |  | 02
文本结尾 | "ETX" |  | 03
传送结束 | "EOT" |  | 04
询问符 | "ENQ" |  | 05
肯定符 | "ACK" |  | 06
报警符 | "BEL" |  | 07
退格 | "BS" | 08 | 08
水平制表符 | "HT" | 09 | 09
换行 | "LF" | 10 | 0A
纵向制表符 | "VT" | 11 | 0B
换页 | "FF" | 12 | 0C
回车 | "CR" | 13 | 0D
移出 | "SO" | 14 | 0E
移入 | "SI" | 15 | 0F
数据链接转义 | "DLE" | 16 | 10
设备控制 1 (XON) | "DC1" | 17 | 11
设备控制 2 | "DC2" | 18 | 12
设备控制 3 (XOFF) | "DC3" | 19 | 13
设备控制 4 | "DC4" | 20 | 14
否认 | "NAK" | 21 | 15
同步空闲 | "SYN" | 22 | 16
结束传送块 | "ETB" | 23 | 17
取消 | "CAN" | 24 | 18
介质结束 | "EM" | 25 | 19
代替 | "SUB" | 26 | 1A
转义符 | "ESC" | 27 | 1B
字段分隔符 | "FS" | 28 | 1C
组分隔符 | "GS" | 29 | 1D
记录分隔符 | "RS" | 30 | 1E
单元分隔符 | "US" | 31 | 1F
删除 | "DEL" | 127 | 7F


分组框

使用 Create Group Box（创建分组框）按钮 [image] （以及相应的光标符号）可在提示对话框上绘制分组框。您会发现创建分组框与在标签设计视图中创建常规方框很相似。

在提示对话框上绘制了分组框后，可以使用修改所选对象选项卡式对话框中的属性页来调整其外观。也可以使用鼠标直接调整分组框的位置和尺寸。

另请参见：

绘制分组框

创建方框


数据模板

输入掩码的第一部分（第一个分号左侧的那部分）就是您希望接收到的数据遵循的模板。数据模板可由控制字符和实际字符组成。有关详细信息，请参见了解输入掩码字符。


允许的字符

如果在打印时从数据源文件读取的字符或用键盘输入的字符，不是允许的字符选项中指定的字符，则这些非法字符将从数据中删除。

例如，如果指定只允许数字，则所有的字母或空格都将删除。在这种情况下，如果启用了有效性属性页上的当数据有效性失败时警告选项，则当系统遇到任何非数字字符时，会显示一条消息指示此类字符已删除。

下面列出了允许的字符的可用设置的说明。

  • 全部。指定接受输入的全部字符。

  • 仅数字。指定只接受输入的数字，因此数据中的所有字母或符号都将删除。

  • 仅字符。指定只接受输入的字母，因此数据中的所有数字或符号都将删除。

  • 仅字符数字。指定只接受输入的字母和数字，因此数据中的所有其它符号都将删除。

  • 由“输入掩码”设置。指定数据必须遵循在输入掩码数据输入框中输入的模板。

  • 自定义。指定数据只包含在字符选项中输入的字母、数字和/或符号。


字符

从允许的字符选项中选择“自定义”后，就会启用字符选项。打印时，在那些从数据文件输入或用键盘键入的数据中，只接受与您在字符选项中输入的字母、数字或符号相符的字符。

示例：

假设在字符选项中输入了字符“ABC123”。如果从某个数据文件中读取了数据“DR341CA”，则标签上只会打印出“31C A”，因为从数据文件中读取的其余字符未被指定为允许的字符。

另请参见：

允许的字符


输入掩码控制字符

在输入掩码中输入控制字符，即是指示 BarTender 在特定字符位置只接受输入的特定字符。输入控制字符时，可以使用键盘输入，也可以使用输入掩码数据编辑框右侧的箭头打开下拉列表，从中进行选择。每个控制字符的说明如下。

掩码字符 | 功能/说明
0 | 数字（必须输入）。要求只输入数字。不允许有加减符号。
9 | 数字或空格（可选输入）。允许数字或空格。不允许有加减符号。
# | 数字/空格/+/- （可选输入）。允许数字或空格。空白位置将转换为空格。允许加减号。
L | 字母（必须输入）。要求只输入字母。
? | 字母（可选输入）。允许字母或空格。
A | 字母或数字（必须输入）。要求只输入字母或数字。
a | 字母或数字（可选输入）。允许字母、数字和空格。
& | 任何字符或空格（必须输入）。要求字母、数字、符号或空格。
C | 任何字符或空格（可选输入）。允许字母、数字、符号或空格。
. , : / | 小数点和千位符号以及时间和日期分隔符。实际使用的字符取决于区域设置属性对话框中指定的区域设置，该对话框可从 Windows“控制面板”中打开。
< | 转换为小写。使随后的所有字母数据都转换为小写。
> | 转换为大写。使随后的所有字母数据都转换为大写。
! | 从右向左填充数据。以从右向左，而不是从左向右的默认方向输入数据。您可以在输入掩码的任何位置输入感叹号。
\ | 单一字符。允许将任何控制字符用作实际字符。例如，\L 不充当控制字符，而是显示字母 L。
"" | 多个数符。允许将控制字符串用作实际字符。例如，“LAC#”只是显示为 LAC#。
0 | 数字（必须输入）。要求只输入数字。不允许有加减符号。


打印实际字符

如果启用了打印实际字符选项，则输入掩码中包含的实际字符将显示在标签视图区域，并打印在标签上。无论是否启用了打印实际字符选项，输入掩码本身仍会影响 BarTender 接收到的数据。

启用时：

将在输入掩码选项的数据模板后面添加一个 0。

例如，如果输入掩码为 (999) 000-0000;0;_，则两个分号之间的 0 表示实际字符将显示在标签视图区域并打印在标签上。

禁用时：

将在输入掩码的数据模板后面添加一个“1”。

例如，如果输入掩码为 (999) 000-0000;1;_，则两个分号之间的 1 表示实际字符将不显示在标签视图区域，也不打印在标签上。

注意：除了选中或取消选中该选项之外，手动在输入掩码数据编辑框中的两个分号之间输入一个 0 或 1，也可以启用或禁用打印实际字符选项。

另请参见：

了解输入掩码

了解输入掩码字符


从右向左填充字符

使用从右向左填充字符选项，可指定屏幕数据和从数据源文件中读取的数据将从右向左输入，而不是按照默认方向从左向右输入。启用该项后，BarTender 将直接在输入掩码的数据模板后面输入一个感叹号 (!)。

例如，如果输入掩码为“(000) 999-9999!”，数据为“4518966”，则得到的数据将显示或打印为“( ) 451-8966”，而不是“(451)896-6”。

注意：该选项只影响从数据源文件中读取的数据和屏幕数据。为响应提示而输入的数据将始终从左向右填充。


输入掩码

输入掩码是一个模板，用于精确控制收到数据的每个个体字符，不管数据是在执行打印作业的过程中从数据源文件读取的还是根据提示用键盘输入的，都可控制。（另请参见了解输入掩码。）

对个体字符的特别要求

您在输入掩码中输入的字符决定数据字段中每个个体字符位置可接收的数据的类型。使用控制字符，可以明确说明任何位置的任一字符是否应当为数字、字母、符号或空格。（有关详细信息，请参见了解输入掩码字符。）

示例：

如果在输入掩码中的某个位置输入一个“0”，则该字符位置只能接收数字。

指定符号来充当分隔符

也可以在输入掩码中输入空格、点、破折号和圆括号之类的字符来分隔输入的变量数据。（有关详细信息，请参见了解输入掩码字符。）

示例：

假设某数据文件中的电话号码字段的数据只包含数字，如 4254567890。您希望在将该电话号码数据打印到标签上时用分隔符分隔，使其显示为 (425) 456-7890。则可以在输入掩码中输入 ( ) - 来定义要在何处打印分隔符和数字。

另请参见：

了解输入掩码

样本数据模板


了解输入掩码字符

在定义输入掩码时，可以输入将决定每个个体字符接受的数据类型的字符（控制字符），以及将随数据一起显示和/或打印的字符（实际字符）。

控制字符

控制字符可用来明确定义特定字符位置将接受的数据类型。您可以在输入掩码中将每个个体字符位置与其它字符分开单独进行定义。

示例

下面这些示例说明输入掩码中的控制字符会对某特定字符位置接受的数据类型产生怎样的影响。

输入掩码样本 | 接受的字符
(999) 000-0000 | 前三个字符可接受数字或空格，而且可以不输入；后七个字符只接受数字且必须输入
9 AAAAA | 第一个字符可接受数字或空格，而且可以不输入；后五个字符可接受字母或数字且必须输入
LL-000 | 前两个字符只接受字母且必须输入；后三个字符只接受数字且必须输入

实际字符

实际字符指会显示在屏幕上或打印出来但并不影响数据的字符。它们用于在 BarTender 接收到的数据中插入额外的字符和符号，以便输入到标签中。虽然一些键盘字符被视为控制字符，但大多数都不是，对于这些字符，只需将其键入输入掩码数据编辑框中，便可直接输入到输入掩码中。

将控制字符用作实际字符

如果您希望将某控制字符用作实际字符，可以直接在该控制字符前面加一个反斜杠 (\) 或在控制字符串前后加上引号。

显示和/或打印实际字符

默认情况下，输入掩码中的实际字符将显示在标签视图屏幕中并打印在标签上。但有时，您可能希望只显示实际字符，以便在打印中使用提示时帮助输入数据，却不想将它们打印到标签上。此时，可禁用打印实际字符复选框。不过，它们将显示在打印作业过程中出现的所有提示对话框的相应响应框中。


输入掩码样本

选择样本掩码对话框提供了以下预定义的输入掩码样本：

掩码名称 | 输入掩码字符 | 样本数据
邮政编码 | 00000-9999 | 98033-4542
社会保险号 | 000-00-0000 | 535-26-0620
电话号码 | (999) 000-0000 | (425) 555-1212
分机 | 99999 | 23154
24 小时制时间 | 00:00 | 14:36
12 小时制时间 | 09:00 >LL | 02:36 PM
精确时间 | 09:00:00 >LL | 2:36:17 PM
简略型日期 | 99/99/00 | 2/28/98
传统型日期 | 99\->L<LL\-00 | 02-Feb-98


了解输入掩码

输入掩码用于精确控制数据的每个个体字符。打印时，它充当模板，强行要求数据遵循指定的模式。从允许的字符选项中选择“由‘输入掩码’设置”，就会启用输入掩码数据编辑框。然后，就可以输入输入掩码字符或从选择样本掩码对话框选择一个预定义的输入掩码来定义您的输入掩码。

输入掩码的三个组成部分

输入掩码由三部分组成，每两个部分之间用分号分隔。默认的输入掩码如下图所示。有关每个组成部分的功能的说明，请单击相应部分的名称。

另请参见：

了解输入掩码字符

输入掩码样本

定义输入掩码


占位符

占位符是指显示在测试选项和提示对话框的响应框中指示要输入字符的位置的字符。从允许的字符选项中选择“由‘输入掩码’设置”，就会启用占位符数据编辑框。这样，您就可以方便地更改将要显示的字符。


测试

测试选项是一个显示区域，在此可以查看输入掩码在提示对话框的响应框中的显示情况。您也可以直接在测试选项中键入数据来查看显示的输入掩码将对它产生怎样的影响。

另请参见：

了解输入掩码


“对话框”属性页

调整提示对话框大小的最简单方法就是使用鼠标。如果在提示对话框的空白处单击，将出现三个大小调整句柄，对话框的底部、右侧和右下角各一个。根据需要拖动这三个句柄之一，可增大或减小提示对话框的高和宽。

也可以使用对话框属性页上的选项来指定提示对话框的尺寸。

属性：

  • 高度。用于指定和/或显示提示对话框的垂直尺寸。

  • 宽度。用于指定和/或显示提示对话框的水平尺寸。

  • 全屏。用于指定提示对话框的大小应和屏幕大小保持一致。

注意：提示对话框的最大尺寸由所用显示器的屏幕分辨率决定。

另请参见：

了解打印时提示


动态区域

对话框的区域

对话框的一部分，根据同一对话框或相关对话框中其它选项的设置来显示不同的选项或状态设置。


将对象粘贴到特定位置

您也可以使用标签视图区域的快捷菜单粘贴对象。使用快捷菜单的主要优点在于，您可以在粘贴对象的同时确定对象的位置。

使用标签视图区域的快捷菜单将对象粘贴到特定位置：

  1. 将指针光标放置于标签视图区域中您想要将对象粘贴到的那一点处。

  2. 右键单击，然后从快捷菜单中选择粘贴命令。BarTender 将粘贴该对象，这样其左上角将位于您单击以便显示快捷菜单的那一点上。


使用快捷菜单复制和粘贴

如果您右键单击标签视图区域中的任何对象，BarTender 将显示对象属性快捷菜单，其中包含创建和修改对象时常用的命令，包括剪切和复制命令。同样，如果您在标签视图区域本身中右键单击（而不是在对象上右键单击），则 BarTender 将显示标签视图区域的快捷菜单，其中将包括粘贴命令。您可以发现，与标准菜单选项或工具栏按钮相比，使用这些快捷菜单更容易。


“所选”对象的定义

“选中”对象是什么意思

您必须先选中一个对象，才能在屏幕上或使用菜单选项对它进行操作。选中对象的最简单方法是启用选择指针工具，然后单击所需的对象。这样可激活对象的手柄。使用这些手柄，您可以在屏幕上调整对象的位置和尺寸，使用菜单选项修改对象的其它特性。

一次可以选中一个或多个对象。单击编辑菜单中的选择命令或主工具栏中的指针按钮，然后用指针单击所需对象，即可选中单个对象。要选中多个对象，请按照使用指针工具选择一组对象中所述的方法进行。


Edition Information Dialog

The Edition Information option on the File menu displays information about the minimum BarTender edition requirements for features used by a label format.

  • Format Name: Name of the current active format.

  • Required Edition: Minimum BarTender edition required to print all elements of the label, including trial features.

  • Edition-Specific Features in Use: Lists all of the trial features that are used in the current active format.

  • Description of Selected Feature: Describes the trial feature and specifies the minimum BarTender edition required to use the feature.


“响应框”属性页

响应框是显示在提示对话框上的数据输入框，用户将在其中输入数据作为对用户提示的响应。 如果定义了默认响应，则该响应将显示在响应框中。

使用响应框属性页上的选项，可以指定响应框的尺寸。您可以根据需要放大或缩小该区域，使之能容纳用户在打印时输入的数据量。

在响应框属性页中，单击提示按钮还可以访问打印时提示选项对话框。

有关更多信息，请单击以下相应的名称。

属性：

  • 行。用于指定默认响应文本可用的垂直空间。

  • 宽度。用于指定默认响应文本可用空间的水平尺寸。

  • 打印时提示选项。用于访问更多数据源选项对话框。

另请参见：

了解打印时提示


“查看文件”按钮

使用查看文件按钮，用户可以通过计算机的默认文本编辑器查看所选的文本文件。一旦完成文本文件数据库设置后，就可以通过在数据库连接设置对话框中提供的浏览选项卡查看设置。


指示应用程序退出

指示 BarTender 退出

如果您预先将 BarTender 加载到内存中，则在完成操作后，可以使用以下命令行指示它退出。

c:\btw\bartend.exe/x

（请参见在文件名称中使用空格）

在上面的命令行中，使用了 /x 参数，该参数指示 BarTender 的当前正运行的副本退出。

另请参见：

命令行参数概述

指定命令行参数的规则


了解 ODBC 驱动程序

对开放式数据库连接概念比较陌生的用户，可以根据 Windows 通过使用不同的 Windows 打印机驱动程序来支持不同打印机的原理，进行简单类推，就能大致了解开放式数据库连接。

与 DOS 打印机驱动程序进行比较

在 Windows 打印机驱动程序出现之前，DOS 程序的开发人员不得不为要支持的每款打印机编写程序自身的打印机支持程序。这不仅是一项艰巨的任务，还意味着每家开发 DOS 软件产品的公司都必须重复这一劳动，因为没有一种标准的方法，可用来使不同的软件制造商能够利用其他制造商开发的打印机支持程序。从不同程序导入数据时，也一直存在同样的问题：对于每个需要导入数据的程序，开发人员都不得不从零开始单独为需要读取的每种数据格式编写支持程序。

与 Windows 打印机驱动程序进行比较

在 Windows 中，能够更有效地处理打印机驱动程序。与之前每个程序都有其自己的支持程序来支持型号繁多的打印机不同，现在，驱动程序要么是 Windows 附带的，要么由打印机制造商提供，要么由 Seagull Scientific, Inc. 之类的软件公司开发。有了这些驱动程序，不同的字处理程序、电子表格、数据库和其它程序都可以打印输出到这些打印机上，而不必像以往那样，对于每台打印机，每个程序都得有自己的内置支持程序。

ODBC 的优点

同理，通过使用 ODBC 驱动程序，数据库也可如此。通过这些驱动程序，需要从各种数据源读取数据的程序，例如，此标签打印程序（类似于打印地址标签的字处理程序），无须有每个所需数据源的内置支持程序就能读取数据。尽管程序仍必须有尖端的内部功能才能支持 ODBC，但一旦增加了此功能，BarTender 立即就能与任何可使用 ODBC 驱动程序的数据源兼容。

ODBC 支持哪些数据源？如何获得这些驱动程序？

现在已经有了许多 ODBC 驱动程序，而且新的驱动程序正在不断涌现。为了推广其开放数据库标准，Microsoft 编写了大量的 ODBC 驱动程序。但 Microsoft 并非 ODBC 驱动程序的唯一来源，其它公司的一些驱动程序也已表现出了卓越的性能。

请注意，Microsoft 支持的许多使用最广泛的驱动程序，都已随 Microsoft Word、Access、FoxPro、Excel 和 Project 免费提供。DataDirect Technologies，这个备选的 ODBC 驱动程序源，甚至开发了更多的驱动程序。（请注意，DataDirect Technologies 仅仅是众多 ODBC 驱动程序备选源中的一家。）

另请参见：

了解 ODBC

设置特定于数据文件类型的 ODBC 参数


使用 dBASE 生成数据文件

因为 BarTender 并不始终支持它当前支持的大量外部数据格式，所以能够将其它程序的数据导出为文本文件曾经非常重要。尽管现在很少要求必须具备这一功能，但很容易就可以具备这一功能。本节提供一个示例，描述如何从 dBASE 或 FoxPro 创建一个文本文件。

如果您正使用的数据库程序不具有内置的数据导出菜单命令，则仍可以混合使用引号和逗号分隔轻松地将数据输出到某一文本文件。这是从 dBASE 的“dot”提示（或者 dBASE 兼容产品中与“dot”提示相当的提示）执行的。

从 dBASE 提示创建文本文件：

  1. 通过键入 USE <数据库文件名> 并在键入后按下 ENTER 键，加载您要从中提取数据的数据库文件名。（如果您希望根据非记录号的其它方面对数据进行排序，则需要在文件名后加上适当的 INDEX 语句。）

  2. 键入 COPY TO <输出文件名> DELIMITED，然后按下 ENTER 键。请记住，尽管此文件是来自您的数据库程序的输出，但它是将由 BarTender 读入的数据源文件。

另请参见：

引号和逗号定界

逗号定界

制表符定界

引号和逗号混用

固定宽度


内置默认设置

通过选择文件菜单中的新建命令，您可以自动将 BarTender 的菜单选项设置为其内置默认设置。这意味着，第一次您将一个对象放置于标签视图区域时，将根据 BarTender 的内置默认设置设置其格式（除非您已修改了该类型对象的标签格式默认设置）。

BarTender 的内置默认设置所指定的条形码被广泛使用，因此您不必对条形码设置进行任何修改即可打印所需的标签。

下面显示了若干最重要的条形码内置默认设置（在打印到 9 针点阵打印机时）。

参数 | 设置
符号体系 | Code 39 — Full ASCII
高度 | 1.2 英寸
代码密度 | 每英寸 5 个字符
供人识读 | 可见，在条形码下


应用程序的默认设置

默认设置

下面以及主修改菜单的帮助屏幕中介绍了 BarTender 的默认设置。

  • 内置默认设置。这些设置是被确定为 BarTender 可以创建的每一对象类型的最常见设置的默认设置。BarTender 在每次创建新对象时使用内置的默认设置（除非您以前指定了替代的标签格式默认设置）。

  • 修改默认设置。这些设置是您可以在每一标签格式的基础上设置的用来取代内置默认设置的默认设置。使用修改菜单中的默认对象选项设置标签格式默认设置。


通过“打印”对话框和“所选记录”选项进行设置

全部显示 全部隐藏

使用通过“打印”对话框和“已选记录选项”进行设置选项，您可以在使用“同样标签的份数”选项中所示的数量的情况下通过在所选记录选项中使用括号覆盖同样标签的份数。您可以使用两种方法来覆盖所选记录的同样标签的份数中所示的数量。

例如，如果您在打印单个标签并且想要某些指定记录的 25 个副本，但对于其它指定记录只需要 14 个副本，则应使用以下过程之一：

方法 1

  1. 在打印对话框上的同样标签的份数编辑框中键入“25”。

  2. 单击与同样标签的份数字段相对应的选项按钮。这将显示同样标签的份数对话框。

  3. 从同样标签的份数对话框中，选择通过“打印”对话框和“已选记录选项”进行设置选项（默认设置）。

  4. 单击确定。

  5. 从打印对话框中，单击选择记录选项按钮。这将显示选择记录对话框。

  6. 从选择记录对话框中，选择要为其打印 25 个副本的记录。在打印对话框的同样标签的份数字段中输入的数值“25”将是为要打印的每一记录在份数列中出现的默认数值。若要覆盖该默认数值，请双击它，然后为要覆盖该默认数值的每一记录键入数值“14”。

或

若要覆盖该默认数值，请在所选记录字段的括号中键入要取代该默认值的数值。

示例：

"1-3,7,8,9(14), 12-40, 41-43(14)"

  7. 单击确定。这将显示打印对话框。

  8. 从打印对话框中，单击确定。

在上述示例中，将为指定了“1-3,7,8,12-40”的每个记录打印 25 个副本，但记录“9, 41, 42 and 43”则为例外情况，对于它们将打印 14 个副本。

方法 2

  1. 在打印对话框上的同样标签的份数编辑框中键入“25”。

  2. 单击与同样标签的份数字段相对应的选项按钮。这将显示同样标签的份数对话框。

  3. 从同样标签的份数对话框中，选择通过“打印”对话框和“已选记录选项”进行设置选项（默认设置）。单击确定。

  4. 从打印对话框中，通过已查询记录下拉列表选择“在打印时选择的”。

  5. 从打印对话框中，键入要打印一组记录，以及键入要通过所选记录字段中的括号取代默认值的数值。

示例：

"1-3,7,8,9(14), 12-40, 41-43(14)"

  6. 从打印对话框中，单击确定。

在上述示例中，将为指定了“1-3,7,8,12-40”的每个记录打印 25 个副本，但记录“9, 41, 42 and 43”则为例外情况，对于它们将打印 14 个副本。


由数据源设置

有时，您可能希望从数据源读取要打印的标签的份数（和/或序列份数）。如果选择使用数据源设置，将显示数据源选项卡。单击此选项卡，访问相关的属性页，指定从数据文件读取份数或在开始打印作业时提示输入份数。有关使用数据源属性页设置同样标签的份数或序列份数的信息，请选择以下所需的主题。

从数据库读取份数

从数据库读取序列份数

提示用户键入份数

提示用户键入序列份数


通过“打印”对话框进行设置

使用“打印”对话框设置选项是同样标签的份数和序列标签数属性页的默认设置。该选项用于指定打印份数值将在打印对话框的相应编辑框中输入。


打印时提示输入同样标签的份数

如果使用数据源属性页上的更多选项按钮为同样标签的份数启用提示，则可以在打印时输入合适的份数。

注意：如果标签格式的数据设置为从数据文件读取，则为同样标签的份数启用“打印时提示”之后，可以为从数据文件读取的每个记录输入不同的份数。

另请参见：

了解打印时提示


打印时提示输入序列标签的份数

如果在数据源属性页上为序列标签数启用打印时提示，则可以在开始打印作业时输入份数。

注意：如果标签格式的数据要从数据文件读取，则为“序列标签数”启用“打印时提示”后，可以为所选的每个记录输入不同的序列标签份数。

另请参见：

了解打印时提示


打印到专业感热标签打印机

打印到感热标签打印机

如果是使用 Seagull Scientific, Inc. 编写的感热打印机驱动程序进行打印，请查阅联机帮助，了解有关解决打印机故障的信息。若要查阅联机帮助，请按照以下说明操作：

  1. 使用文件菜单或工具栏上的打印机按钮访问打印对话框。

  2. 如果尚不能访问，请从打印机名称列表中选择所需的打印机。

  3. 单击属性，访问打印机设置对话框。

  4. 单击帮助，访问所用的特定驱动程序的联机帮助。


字体工具栏

包含字体属性页上的大多数选项的快捷按钮。（请参见字体工具栏。）


获取帮助

要获得一般的帮助信息，随时可以按 F1 键。要获得特定于某对话框的帮助信息，请打开该对话框，然后按 F1 键（或单击帮助按钮）。


“分组框”属性页

在设计提示对话框时，您可能希望围绕一组对象画一个方框，用来表示在某些方面这些对象相互关联。提示设计视图中有一种特殊类型的方框，称作“分组框”。分组框的外观很像一般的方框，只不过它的顶部边缘处有一个内置的标题。此标题通常用于在某方面描述方框中的内容。

使用分组框属性页上的选项，可以编辑标题、调整尺寸和指定分组框在提示对话框上的位置。

有关更多信息，请单击以下相应的名称。

属性：

  • 文本。用于指定分组框的标题。

  • 高度。用于指定分组框的垂直尺寸。

  • 宽度。用于指定分组框的水平尺寸。

  • 对齐方式。用于指定分组框标题文本是位于方框的左侧、右侧还是中央。

另请参见：

了解打印时提示


Create Ellipse

Ellipse

Use the Create Ellipse button [image] (and corresponding mouse cursor symbol) to draw an ellipse on your label. By clicking and dragging the cursor the size of the ellipse can be changed as it is created.

After drawing an ellipse on a label, you can use the property pages in the Modify Selected Ellipse tabbed dialog to adjust its appearance.

You can also directly manipulate an ellipse's position and dimensions using the mouse.

Procedure:

Drawing an Ellipse


“打印系统”命令

从文件菜单中选择导出打印机代码模板命令，然后从列表中选择一个打印系统，这样，将打开打印机代码模板对话框，在此，您可以导出使用所选打印系统的打印机代码模板。


Visual Basic 脚本帮助

Visual Basic 脚本帮助用于加载默认的 Web 浏览器，显示完整的 Microsoft Visual Basic 帮助文档。


“导出打印机代码模板选项”命令

导出打印机代码模板：选项

从文件菜单中选择导出打印机代码模板命令，然后选择选项，可以打开打印机代码模板选项对话框，在此，您可以导出打印机代码模板。


“错误处理”对话框（用于链接式图片）

使用该对话框可以指示 BarTender 在未找到要用作背景的链接式图片的情况下应执行什么操作。

  • 总是终止打印作业。打印作业将被终止。

  • 终止打印作业前询问。如果在打印时无法找到链接式文件，BarTender 将要求您确定是否终止打印作业。

  • 不终止打印作业。打印作业将在没有背景图片的情况下继续执行。


EAN_UCC 复合

EAN.UCC 复合

使用该对话框可以为复合条形码的一维和二维组件创建数据源子串。

  • 主数据。用于设置一维组件的数据源。

  • 辅助数据。用于设置二维组件的数据源。

单击确定后，将打开修改所选条形码对话框的数据源选项卡。条形码将被配置为一个由三个子串组成的对象。第一个子串包含主数据。第二个子串包含“|”字符并表示一维和二维组件之间的分隔符区域。第三个子串包含辅助数据。


打印向导 -“提示”对话框

打印向导 —“提示”对话框

该对话框是使用 BarTender 的打印时提示功能在您所在的公司创建的。请输入要求的数据，然后单击打印或预览。


“打印机时钟选项”对话框

使用该对话框可以确定：在打印标签时，如果由于某种原因导致打印机时钟不可用，打印机将如何响应。

注意：当数据源为日期或时间时，使用修改所选 … 对象对话框的数据源选项卡上的时钟选项按钮可以打开该对话框。

  • 使用 Windows 时钟。打印机将使用计算机的系统日期/时间。

  • 不打印子串。将打印标签，但日期/时间保留为空。

  • 总是终止打印作业。打印作业将被终止。

  • 显示打印时打印机时钟消息。如果对标签上所有使用打印机时钟的子串都取消选中该框，将隐藏打印机时钟：验证消息对话框。


标签格式说明

说明

使用文件菜单中的说明选项可以保存有关活动标签格式的简要说明。当您执行打开命令时，可以通过打开文件对话框查看这些说明，这样，您将可以更快速地确定每种格式的用途。

使用标准 ASCII 和光标键可以输入和编辑要与标签格式保存在一起的说明。

如果启用（选中）说明对话框底部的文件打开后弹出说明选项，BarTender 将在每次打开文件时自动显示说明对话框。该对话框出现后，您可以按以上所述来编辑说明，也可以只是查看一下说明，然后单击确定来继续编辑或打印标签。

另请参见：

打开现有的标签格式


打印向导 -“输入查询数据”对话框

打印向导 —“输入查询数据”对话框

您必须在输入查询数据框中输入响应。只有当输入数据后搜索成功，BarTender 才会继续执行打印作业。

完成搜索并继续执行打印作业：

  1. 在输入查询数据框中输入搜索值。

  2. 按 ENTER 键或单击下一步。

BarTender 将使用指定的字段搜索与搜索值匹配的所有记录。搜索完成后，将显示打印向导的下一个对话框。如果未找到匹配的记录，将显示报告这一情况的消息。

另请参见：

“查询提示”对话框

了解查询提示


数据库连接设置（所有数据库）- 状态

“状态”选项卡（所有数据库）

通过数据库连接设置对话框，可以访问状态选项卡。使用该选项卡，可以显示有关所有数据库树视图中所选项（所有数据库）的信息。该选项卡将显示以下项。

  • 数据库数。显示指定数据库的数目。

  • 刷新按钮。重新加载已命名 ODBC 或 OLE DB 数据源的结构和配置。

另请参见：

数据库连接设置


“错误消息”对话框

使用该对话框可以帮助确定要接收的错误消息和要禁止显示的错误消息。如果未选中忽略所有错误选项，将根据每条错误消息确定是否忽略错误。在错误消息对话框打开后，您可以在其中选择在将来忽略错误消息。如果选择忽略某些错误消息，将在错误消息对话框中显示当前此处忽略的消息列表。

  • 忽略所有消息。如果希望 BarTender 忽略所有错误，请选中此框。

  • 删除。突出显示错误，然后单击该按钮，可以将其从列表中删除。这样，将不会再禁止显示该消息。


选择 ODBC 或 OLE DB 的表类型

选择 ODBC 和 OLE DB 的表类型

使用表类型可以选择要从数据源读取的表的类型。

  • 表。包含数据集的行集合。

  • 查看。查看一张或多张表中数据的替代方法。通常，会将视图创建为一张或多张表中列的子集。视图通常等同于表。

  • 系统表。用于存储有关指定系统（系统目录）或指定数据库（数据库目录）信息的表。系统目录由完全在主数据库中找到的系统表组成。在 Microsoft Access 中，除了在系统对象可见时，系统表都是隐藏的。Excel 使用系统表来列出其数据。

  • 系统视图。查看一张或多张系统表的替代方法。（在 ODBC 中不可用。）

  • 全局临时表。全局临时表对所有数据源连接来说都是可见的。这些数据源不必一定是某用户专用的数据源，也不必是计算机的本地数据源。

  • 本地临时表。本地临时表仅对创建该表的数据源连接可见。

  • 别名。赋予字段、表或数据库的特别名称。当字段名或表名已经更改，但用户仍尝试引用该字段或表时，将会用到该选项。简言之，别名用于弥补命名约定中出现的不一致情况。（依驱动程序而定）。

  • 同表异名。被赋予不同名称的相同的表。（依驱动程序而定）。

  • 输入表名称（仅手动输入）。手动输入表名。

另请参见：

了解 ODBC

了解 OLE DB


“提示调整大小”对话框

“修改所选对象”对话框中的“对话框”选项卡

使用高度和宽度框可以设置用户提示对话框的大小，或选中全屏框。


Reply Box Property Page

A reply box is a data-entry box displayed on the prompt dialog into which data is entered in response to a user prompt. If a Default Reply has been defined, it will be displayed in the reply box.

The options on the Reply box property page allow you to specify the dimensions of a reply box. You can make this area as large or as small as needed to fit the amount data a user will enter at print time.

You may also use the Reply box property page to access the Prompt at Print-Time Options dialog by clicking on the Prompting button.

For additional information, click on the appropriate name below.

Properties:

  • Lines. Used to specify the amount of vertical space available for the default reply text.

  • Width. Used to specify the horizontal dimension of the space available for default reply text.

  • Reading Order. Used to set the reading order for the reply box. Choose Auto to use the reading order of the script set on the Font tab this dialog.

  • More Options. Used to access the More Data Source Options dialog.

See Also:

Understanding Prompt at Print-Time


Ellipse Property Page

The Ellipse property page can be used to modify the dimensions and other properties of the ellipse.

Options on the Ellipse property page are summarized below. For additional information, click on the appropriate option name below.

  • Width. Used to specify and/or display the horizontal dimension of an ellipse.

  • Height. Used to specify and/or display the vertical dimension of an ellipse.

  • Line Thickness. Used to specify the thickness of the lines that make up an ellipse.

  • Fill Interior. Used to specify that an ellipse will be filled with a solid color.

  • Circle. Used to constrain height and width to form a circle.

  • Color. Used to specify the color of an ellipse.


“消息设置”对话框中的“电子邮件”选项卡

使用此选项卡可以指定 BarTender 消息的电子邮件副本的接收者和通过电子邮件发送的消息的结构。

注意：此选项卡仅适用于 BarTender 企业版。

单击启用电子邮件可以激活此选项卡的功能。

  • 邮件系统。此框标识 BarTender 发送电子邮件时使用的邮件/邮件传送系统。除非在此框中更改为其它系统，否则将使用当前登录到该计算机上的用户的默认邮件系统。单击设置可配置将要使用的电子邮件配置文件的详细信息。

    • 如果已选择 Internet Mail (SMTP) 作为邮件/邮件传送系统，则单击设置后，将打开 Internet 邮件设置对话框。

    • 如果选择 Windows Messaging (MAPI) 作为邮件/邮件传送系统，则单击设置后，将打开 Windows Messaging 设置对话框。

  • 收件人。如果使用的是 Internet Mail (SMTP)，请键入一个或多个主要收件人地址（以分号分隔）。如果使用的是 Windows Messaging (MAPI)，请单击选择按钮打开电子邮件地址簿，然后选择收件人。

  • 抄送。如果使用的是 Internet Mail (SMTP)，请键入一个或多个次要收件人地址（以分号分隔）。如果使用的是 Windows Messaging (MAPI)，请单击选择按钮打开电子邮件地址簿，然后选择收件人。

  • 输出类型。从下拉列表中选择要发送的消息文件的格式。可用的选项有：

    • 文本报告。邮件的各个部分将按以下顺序单行显示：日期、时间、邮件编号、邮件类型、邮件类别、邮件响应和邮件正文。

    • 制表符定界。使用制表符分隔邮件的各个部分。

    • 逗号定界。使用逗号分隔邮件的各个部分。

    • 引号和逗号定界。将邮件的各个部分用引号括起来并使用逗号分隔。

单击发送测试邮件按钮可以测试邮件是否抵达正确的收件人，以及是否按所选的输出格式结构化。


导出（图像）对话框

如果需要从 BarTender 中将对象（或整个标签）作为图像导出到其它 Windows 程序，则从文件菜单中选择导出命令，然后从子菜单中选择图像。

如果要将所选对象复制到 Windows 剪贴板中，则在选项区域中，指定剪贴板作为目的地。将对象导出到剪贴板后，可以进入其它 Windows 程序，然后使用该程序的粘贴命令将剪贴板的内容引入其中。

在以下情况下，可以指定文件作为目的地：

  • 希望将对象导出到某个文件供以后使用。

  • 希望将对象导出到某个程序，但该程序无法通过 Windows 剪贴板导入对象。（有些 Windows 程序不能识别 BarTender 的剪贴板所使用的设备独立位图 (DIB) 格式。）

如果选择文件，则可以采用以下位图格式保存导出的对象：BMP、EPS、JPG、PCX/DCX 和 TIF。

注意：如果以 EPS 格式导出，则将生成位图版的文件，而不是包含 PostScript 代码的文件。

下面简要介绍了导出对话框中的其它选项。

  • 颜色数。用于指定导出的位图中要使用的颜色数。

  • 分辨率。用于指定所导出的位图的分辨率，以每英寸点数 (dpi) 计。为获得最佳效果，通常应将此选项保留为打印机的默认设置。如果选择设置自定义分辨率，则可用范围介于 20 到 3000 之间。

  • 仅导出所选对象。用于指定仅导出当前所选对象，而不是整个标签。


“打印机代码模板选项”对话框

全部显示 全部隐藏

使用此对话框可以配置打印机、输出和性能选项。也可用来配置要用于导出打印机代码模板的数据字段名称。有关详细信息，请参见了解打印机代码模板。

“打印机”选项卡

打印机选项卡标识用于生成打印机代码模板的所选打印机。必须使用 Seagull Scientific 提供的打印机驱动程序。

  • 名称。用于生成打印机代码模板的打印机。

  • 文档属性。用于访问当前指定打印机的其它打印机选项。在单击文档属性按钮后设置和保存 的任何选项都仅适用于当前的标签格式。

  • 打印机属性。用于访问当前指定打印机的全局打印机选项。在单击打印机属性按钮后设置和 保存的任何选项将适用于所有标签格式和其它程序。（也可以通过在 Windows 控制面板中选择“打印机”图标来访问这些选项。有关详细信息，请参见 Windows 文档。）

  • 状态。打印作业的状态。例如，“就绪”表示打印机已准备好执行打印作业。

  • 类型。所选打印机的类型（即 HP LaserJet 1100）。

  • 位置。打印机的安装位置或路径。

  • 说明。在 Windows 属性对话框中输入的有关该打印机的任何说明。有关如何更改这些说明的信息，请参见 Windows 帮助。

“作业选项”选项卡

作业选项选项卡用于配置作业选项数据字段。

  • 属性。此列提供每种字段类型的简短说明：

    • 格式 ID/名称。标识打印机的标签格式。

      • Identical Copies. The number of identical copies to print.

    • Serialized Copies. (Dependent on printer support) The number of serialized copies to print.

    • Batch Copies. (Dependent on printer support) The total number of copies (number of identical copies multiplied by the number of serialized copies) to print.

  • 模板字段名称/值。此列中的单元格提供每个字段的值。由于此值将插入到打印机文件中，因此必须使用符 合打印系统要求的值。

  • … 按钮。打开一个对话框，从中可以输入模板字段名称或值。

注意：除了在此选项卡上配置的模板数据字段外，通常还可以配置标签上的一个或多个条形码对象或文本对象， 以使用更多数据源选项对话框指定模板字段名称。

“对象打印方法”选项卡

对象打印方法选项的作用是：当打印机或 Seagull 打印机驱动程序不直接支持某个对象类型时，指定如何在感热打印机上打印对象。

  • TrueType 文本。指定是将 TrueType 字体作为文本输出打印，还是作 为位图打印。当打印机不直接支持彩色 TrueType 文本的某种颜色时（例如，打印机支持红色和黄色，但 TrueType 字体为橙色），此选项将影响打印该文本的方式。如果选择位图，则打印机可以抖动（即混合）不同颜色的点，以生成所需颜色的文本。例如，打印 机会抖动红色和黄色的点来生成橙色字母。但是，呈抖动后颜色的文本阅读起来会比较费力，尤其是字体较小时。如果选择文本输出，则打印机将以 最接近的直接支持的颜色打印文本，因此，打印机将根据橙色的深浅，将橙色文本打印为红色或黄色。

  • 不受支持的一维（或二维）条形码。在打印机或 Seagull 打印机驱动程序不支持一维和二维条形码符号体系的情况下，指定是使用位图还是使用设备线来打印一维和二维条形码。如果将此选 项设置为自动，驱动程序将确定最佳的打印方法。

  • Lines, Boxes, and Ellipses. Specifies whether lines, boxes, or ellipses will print using Raster Graphics or using the printer's device settings if they are unsupported by either the printer or the Seagull Scientific printer driver. 如果将此选项设置为自动，驱动程序将确定最 佳的打印方法。

“性能”选项卡

Seagull 打印机驱动程序选项用于指定 BarTender 在使用 Seagull 打印机驱动程序时如何利用内置的打印机功能。

  • 使用打印机的静态图形。指定 BarTender 将使用打印机的静态图形功能来存储有关所有位图类型对象的规格，这类对象的打印效果对于每个标签完全相同，包括 TrueType 字体。

  • 使用打印机的静态标签。指定 BarTender 将使用打印机的静态对象功能来存储有关所有对象的规格，这些对象的打印效果对于每个标签完全相同，而不管标签是否为位图。其中包括打印机字体、条形码、导 入的图形和 TrueType 字体。

  • 使用打印机的序列。指定 BarTender 在任何适合的情况下使用指定打印机的内置递增功能。（在导出打印机代码模板时，不能关闭此选项。）

重要提示：切记，TrueType 字体是作为图形（而不是作为下载字体）传送到感热打印机的。由于感热打印机只能递增被处理成字体的数据，因此不能使用打印机内置的序列化功能递增 TrueType 字体。如果希望将标签上的某个对象序列化并利用打印机的序列化功能，则必须使用打印机的内置字体之一。

  • 使用打印机的标签格式。指定 BarTender 将使用打印机的数据合并功能来存储标签的格式规格（对象位置、符号体系、字体等），以便只需传送对象数据。

另请参见：

了解打印机代码模板

导出到打印机代 码模板

打印机代码模板设置

打印机代码验证


“导出打印机代码模板”对话框

注意：此功能仅适用于 BarTender 企业版。

通过此对话框，可以使用从导出打印机代码模板子菜单中选择的打印系统来生成打印机代码模板。也可用于指定是将格式和数据信息合并到一个打印机代码模板中，还是将它们一分为二。有关详细信息，请参见了解打印机代码模板。

进行选择后，单击导出按钮。在创建模板之前，BarTender 将检查可能出现的问题。如果发现问题，将打开验证消息对话框。

  • 全部位于一个文件中。选择此选项将导出单一打印机代码模板，其中同时包含打印机格式信息和数据。使用文件名框可以输入打印机代码模板的路径和名称。

  • 单独的格式文件和数据文件。选择此选项可针对格式信息和数据分别生成单独的打印机代码模板。由于采用此选项后，将不再需要随每个标签将格式信息一起发送到打印机，因此可以提高打印机的性能。使用这两个文本框可以输入两个打印机代码模板的路径和名称。

  • 仅打印机代码。如果选中此框，将生成一个格式信息文件，该文件完全采用打印机的语言编写，因此无须经任何打印系统的进一步处理即可发送到打印机。如果未选中此框，则可确保将打印机代码模板设置对话框的定界符选项卡中的所有定界符符都插入到该格式信息文件中。

  • Printer Code Only. Checking the box will produce a formatting information file that is written purely in the language of the printer and, hence, can be sent to the printer without any further processing by any print system. Leave this box unchecked to ensure that the formatting information file has all the delimiters from the Delimiter tab of the Printer Code Template Setup dialog inserted into it.

  • Version. Use the dropdown to select version options to generate compatible printer code templates.

  • 导出。单击此选项可导出打印机代码模板。

  • 更多选项。单击可打开打印机代码模板选项对话框。

另请参见：

了解打印机代码模板

打印机代码导出选项

打印机代码模板设置

打印机代码验证


Format Options

Format Options Dialog

Show All Hide All

The Format Options dialog has these tabs:

View

The View tab enables you to specify the ruler, grid, and zoom (magnification) settings for BarTender's label viewing area. It also allows you to specify whether or not BarTender will indicate on-screen (with a lightly dashed line) the boundary of any possible unprintable portion of your labels.BarTender displays rulers along the horizontal and vertical boundaries of the label viewing area to help you position objects on the label. The current position of the mouse cursor in the viewing area is always indicated by a lightly dashed line in the horizontal and vertical rulers.

  • Show Unprintable Region. Used to specify whether or not the boundary of the unprintable region of the label will be indicated on-screen with a lightly dashed line.

  • Zoom Factor. Used to specify the zoom factor percentage which will be used by the Zoom In and Zoom Out commands.

Rulers

  • Divisions per <unit>. Used to specify the number of divisions per unit of measure on BarTender's horizontal and vertical rulers (where <unit> is inch, cm, mm, or the system default).

  • Snap. Used to enable the "snap to ruler" feature.

Grid

BarTender's rulers are supplemented by a grid system which displays a specific number of grid points (or dots) within the label viewing area. These grid points can be very helpful for the precise positioning and resizing of objects during label design and editing.

  • Divisions per <unit>. Used to specify the number of divisions per unit of measure on BarTender's grid (where <unit> is inch, cm, mm, or the system default).

  • Show. Used to specify whether or not the grid will be visible in the label viewing area.

Regional Settings

The Regional Settings tab enables you to design your label in ways that are appropriate to the languages that will be used on the label.

  • Units. Used to to specify whether an American or Metric unit of measure will be used in measurements of horizontal or vertical distance.

  • Decimal Symbol. Used to specify which character will be as the displayed decimal character.

  • Reading Order. Used to specify the reading order for all edit boxes in the BarTender user interface. (The reading order of text objects on label formats and prompts is set on the properties dialog of each individual object. Double-click the object to open the dialog.)

  • Windows Settings. Opens the Regional Settings dialog of Windows.

Comments

The Comments tab enables you to save a comment about the active label format. These comments may be viewed from the File Open dialog when you execute the Open command, allowing you to determine the intended use of the format.

The standard ASCII and cursor pad keys are used to enter and edit the comments.

If you enable (check) the Pop up comments after file open option at the bottom of the Comments tab, BarTender will automatically display the Comments dialog each time you open the file. You may then either edit the comment or simply view the comment and click OK to proceed with editing or printing your labels.

General

The General tab contains additional controls for Printer Code Modifier functionality that can be associated with label formats.

  • Action List... button. This brings up the Action List dialog, allowing print code to be searched and changed.

  • Visual Basic Script... Brings up the Visual Basic Script assistant dialog, allowing advanced modifications to be made to the print code.

  • Test... Brings up the Test dialog, allowing the Actions and Visual Basic scripting to be tested on real printer code in a file.


提示属性上的“组”框

用户提示上的“组”框

在文本框中键入应作为组名出现在提示上的文字。

在提供的框中设置文本对象的高度和宽度。

选择文本相对于该组的边界的对齐方式：左、居中或右。


修改分组框标题

修改 [分组框] 文本

当您单击提示设计视图中的编辑工具并单击某个分组框后，将打开修改 [分组框] 文本对话框。使用该对话框可以更改分组框的标题。

单击属性按钮可打开对象的属性页。


线条（提示上）属性页

增减线条长度的最简便方法是使用鼠标。不过，您也可以使用线条属性页上的长度选项来手动调整“提示”对话框上的线条长度。


“消息设置”对话框中的“日志文件”选项卡

使用此选项卡可以配置将消息记录到文件中的方式。选择启用日志记录可以激活此选项卡的功能。

  • 日志文件文件夹。输入保存日志文件的目录。

  • 组织。选择有关如何创建和命名日志文件的选项：

  • 一个文件。BarTender 将所有消息都记录到同一个文件中。

  • 按日期。BarTender 将按当前日期命名日志文件，并每天都使用新的日志文件。

  • 输出类型。选择日志文件的格式：

  • 制表符定界。使用制表符分隔所记录的消息。

  • 逗号定界。使用逗号分隔所记录的消息。

  • 引号和逗号定界。将所记录的消息用引号括起来并使用逗号分隔。

  • Encoding. Select the character set of the log file if it is different from the default. For example, you might need to do this if you are using a language other than the default for your version of Windows. Your options are

  • Unicode

  • Unicode (Big Endian)

  • UTF-8

  • 使用系统默认值

  • 阿拉伯语 (1256)

  • 波罗的语 (1257)

  • 中欧字符 (1250)

  • 简体中文 (GB-2312, 936)

  • 繁体中文 (Korea, Big 5, 950)

  • 西里尔字母 (1251)

  • 希腊语 (1253)

  • 希伯来语 (1255)

  • 韩语 (Hangul, 949)

  • 韩语 (Johab, 1361)

  • 日语 (SHIFT-JIS, 932)

  • 泰语 (874)

  • 土耳其语 (1254)

  • 美国、西欧 (ANSI, 1252)

  • 越南语 (1258)

  • 日志文件按钮：

  • 查看。单击可浏览到日志文件。

  • 查看最后一项。单击可打开最新的日志文件。

  • 全部删除。单击可删除所有日志文件。


Internet 邮件设置

“Internet 邮件设置”对话框

如果选择 Internet Mail (SMTP) 作为邮件系统并单击消息设置对话框的电子邮件选项卡上的设置按钮，则将打开此对话框。使用该对话框可以更改 BarTender 用来发送邮件的邮件/邮件传送系统配置文件，还可以设置新的邮件/邮件传送系统配置文件。除非您另外指定，否则 BarTender 将使用计算机当前登录用户的默认配置文件。

  • 邮件服务器。输入邮件服务器的名称。例如，smtp.mycompany.com。

  • 姓名。输入 BarTender 应使用的电子邮件帐户所属用户的姓名全称。

  • 电子邮件地址。输入 BarTender 应使用的电子邮件帐户所属用户的电子邮件地址。

  • 要求身份验证。如果邮件服务器要求用户先登录才能发送电子邮件，则选中此复选框。此操作将启用用户名和口令文本框。

  • 用户名。输入 BarTender 应使用的电子邮件帐户所属用户的邮件系统登录名。

  • 口令。输入该登录名的口令。

  • 端口。输入用来与邮件服务器进行通信的端口。

  • 超时。设置 BarTender 在断定无法连接到邮件服务器之前，尝试发送电子邮件的时间。

  • Encoding. Select the encoding to use for the text of the e-mail message. Your options are:

  • Unicode

  • Unicode (Big Endian)

  • UTF-8

  • 使用系统默认值

  • 阿拉伯语 (1256)

  • 波罗的语 (1257)

  • 中欧字符 (1250)

  • 简体中文 (GB-2312, 936)

  • 繁体中文 (Korea, Big 5, 950)

  • 西里尔字母 (1251)

  • 希腊语 (1253)

  • 希伯来语 (1255)

  • 韩语 (Hangul, 949)

  • 韩语 (Johab, 1361)

  • 日语 (SHIFT-JIS, 932)

  • 泰语 (874)

  • 土耳其语 (1254)

  • 美国、西欧 (ANSI, 1252)

  • 越南语 (1258)

    单击测试按钮以确保 BarTender 能够与邮件服务器通信。


“消息设置”对话框中的“消息”选项卡

使用此选项卡可以确定要显示或记录的消息以及 BarTender 响应这些消息的方式。

  • 顶部的网格通过以下各列列出了 BarTender 中可以显示的消息：

  • #。 消息的唯一 ID 号。

  • 严重级别。消息的严重级别，从提示信息、警告到错误依次递增。

  • 类型。标识消息的类别。（例如打印机、数据库）

  • 对消息的默认响应。BarTender 在自动模式下运行时如何响应消息的当前设置。

  • 消息目标。显示消息的位置。

  • 消息内容窗口。显示当前突出显示的消息的内容。

  • 消息目标。选择显示消息的位置：

  • 对话框：消息将显示在屏幕上。

  • 日志文件：（仅适用于已在日志文件选项卡上启用消息记录的情况。）消息将显示在日志文件中。

  • 自动异常：如果 BarTender 是通过 ActiveX 自动操作从其它程序中运行的，则消息会被传递给该程序，由它负责处理。而如果 BarTender 并非自动运行，选中此选项将没有任何效果。留待以后使用。

  • NT/2000/XP/2003 事件日志：消息将被发送到操作系统的事件日志。

  • 电子邮件通知：（仅适用于已在电子邮件选项卡上启用电子邮件的情况。）消息将作为电子邮件发送到预定义的收件人列表。

  • 对消息的默认响应。有些消息要求获得响应（如单击确定或取消），因此，如果不能向用户显示消息以供其选择响应（如对话框已关闭），BarTender 就必须自动进行响应。这里显示对当前突出显示的消息的可能响应。选择您希望 BarTender 始终自动做出的响应。


修改屏幕数据

使用修改屏幕数据对话框，您无须访问数据源属性页，即可快捷简便地更改当前所选条形码对象或文本对象的屏幕数据。

下面简要介绍修改屏幕数据对话框选项。

  • 子串。用于在标签对象具有多个子串时选择要修改的子串。（仅当您单击的对象具有多个子串时，此选项才有效。）

  • 屏幕数据。用于输入您要在屏幕上为所选的标签对象显示的数据。（使用 CTRL-TAB 可输入制表符。）

  • 数据源。用于访问数据源属性页。

有关访问修改屏幕数据对话框的信息，请参见使用数据编辑工具。


“验证消息”对话框

此对话框提醒您有关标签格式的设计问题，这些问题会影响打印输出（或导出的打印机代码模板）。

该表提供了有关各种问题的简要信息。（有关详细信息，请突出显示一条消息并单击详细信息按钮。）

  • 错误的左侧将出现 [image] 图标。必须先解决所有错误条件才可以继续打印/导出。警告将使用 [image] 图标标记。并非必须先解决警告才能继续打印/导出，但输出结果可能与您的预期不符。（突出显示一个警告并单击详细信息，此时将显示一个对话框，其中指出不解决该问题而继续操作可能带来的后果。）

  • 对象。它标识错误或警告中所涉及的对象的类型。可能的值包括“文本”、“条形码”、“打印机”和“页面设置”。

  • 字段。在适用情况下，它标识导致发生警告或错误条件的打印机代码模板字段。

  • 消息。它提供有关错误或警告性质的简短说明。

右侧是以下按钮：

  • 编辑。突出显示一个错误/警告并单击此按钮，此时将转到 BarTender 对话框以解决问题。例如，如果您突出显示了一个警告，即文本对象已设置为使用打印机模板字段和 TrueType 字体，则单击编辑将转到修改所选文本对象对话框，在此可以更改为基于打印机的字体。

  • 自动修正。单击此按钮，BarTender 将自动修正当前突出显示的错误/警告条件。在完成打印/导出后，可以使用编辑菜单上的撤消命令撤消所有“自动修正”操作。

  • 详细信息。突出显示列表上的任何错误或警告并单击此按钮，此时将打开一个窗口，其中提供有关该问题以及“自动修正”该问题的详细信息。

解决问题后，单击继续。


“高级位置设置”对话框

使用下拉列表选择标签参考点。对象的 X 和 Y 位置坐标将根据标签参考点进行计算。

例如，在一张 2 x 2 英寸的标签上，如果标签的参考点是左上角，某点的 X 坐标和 Y 坐标均设为 0.5 英寸，则该点应在左上角右侧的 1/2 英寸和左上角下方的 1/2 英寸交汇处。因此，该点应位于标签左上象限的中心。如果标签的参考点变成了标签中心，但该点的 X 坐标和 Y 坐标仍为 0.5 英寸，则该点应在右下象限的中心：标签中心的右侧 1/2 英寸和下方 1/2 英寸的交汇处。

重要提示：标签参考点不同于对象参考点。有关两者之间的差别信息，请单击此处。

可用于设置标签参考点的选项有：

  • 标签的左上角

  • 标签的顶部居中

  • 标签的右上角

  • 标签的中部居左侧

  • 标签的中心

  • 标签的中部居右侧

  • 标签的左下角

  • 标签的底部居中

  • 标签的底部居右角


“高级旋转设置”对话框

使用此对话框可以指定对象的旋转点。所谓旋转点就是当您旋转对象时对象将围绕其转动的点。可用的选项有：

  • 使用对象参考点（默认）。对象将围绕其自己的参考点转动，该参考点在修改所选 … 对象对话框中的位置属性页上指定。

  • 标签中心。对象将围绕标签的中心转动。对于圆形标签（如 CD 标签），该选项尤其有用。

  • 标签上的位置。对象将围绕您在标签上指定的点转动。使用 X 坐标框和 Y 坐标框可以指定旋转点相对于标签参考点的位置。（标签的参考点在高级位置设置对话框中设置：单击修改所选对象对话框中位置属性页上的第一个高级按钮可打开该对话框。）

  • 锁定。如果您希望指定的点在标签上完全保持不变，即使您以后移动了指定该点时所选的对象也不例外，则请选中此选项。如果不选中此选项，则该点将随对象的移动而移动。

注意：要快速进行旋转，请使用主工具栏上的旋转工具。也可以从排列菜单中选择旋转，使对象围绕其中心点旋转。


“许可证管理”选项卡

使用此对话框可以配置 BarTender 与 Seagull License Server 的连接。

自动查找 Seagull License Server。选中此选项以作为指定精确网络地址的备选方案。（如果 Seagull License Server 当前正在网络路由器后运行，则无法找到它。）

首选和备选

使用这些部分可以配置与首选 Seagull License Server 的连接，另外，还可以配置与备选 Seagull License Server 的连接。如果 BarTender 由于任何原因而无法连接到首选服务器，则会使用备选服务器。

  • 地址。指定 Seagull License Server 的精确网络地址。

  • 端口。指定一个端口 ID，介于 1024 与 65535 之间。

  • 超时。指定 BarTender 在放弃之前应坚持查找 Seagull License Server 的时间。

  • 重试次数。指定 BarTender 在放弃之前应查找 Seagull License Server 的次数。

  • 测试。单击此按钮可以验证 BarTender 能否通过指定的端口连接到 Seagull License Server。

注意：在此所做的设置均存储于在管理设置对话框上设置的配置文件中。通过工具菜单可以打开该对话框。


Priority and Specifications

(These are symbology-specific options that are only enabled for Japanese Postal Code.)

Japanese Postal Code has two additional settings, described below.

  • Highest Priority. If checked, sets the filler character to Highest Priority.

  • Hold To Specifications. If checked, the height of the bar code cannot be altered.


“定界符值”对话框

在打印机代码模板对话框上的定界符选项卡的任意行中单击 … 按钮，将打开一个定界符值对话框（以定界符命名）。使用此对话框可以输入要赋予定界符的值。

若要输入控制字符，则单击文本框右侧的字符助理按钮。此时将打开字符助理。


“模板字段”对话框

<模板字段> 对话框

在打印机代码模板选项对话框上的作业选项选项卡的任意行中单击 … 按钮，将打开一个 <模板字段> 对话框（以字段命名）。使用此对话框可以输入要赋予字段的名称/值。

若要输入控制字符，则单击文本框右侧的字符助理按钮。此时将打开字符助理。

也可以使用此对话框指定模板字段的类型。以下是可用的类型：

  • 一个基本的模板字段起着占位符的作用。在打印时，打印系统将使用实际数据替换该字段名称。例如，您可以使用“NumberOfCopies”作为打印份数字段的值。（在打印机代码模板中，您在打印机代码模板对话框的定界符选项卡上指定作为起始字段定界符值的字符将紧位于该名称之前。同样，该名称之后将紧随结尾字段定界符的值。例如，如果您将“<”和“>”分别设置为起始字符和结尾字符，并将“NumberOfCopies”设置为字段名称，则 BarTender 会将“<NumberOfCopies>”（不带引号）放入打印机代码模板中。）

  • 常数字段类型将作为文字值插入到打印机代码模板中。例如，您可以使用“1”作为 打印份数字段的值。BarTender 会将“1”（不带引号）放入文件中，但不会在该值周围放置字段定界符。

  • 如果使用由驱动程序设置字段，驱动程序将在生成打印机代码模板时提供该字段名称。（此选项并不适用于每种模板字段。）


Select Supported Printers

Use this dialog to ensure that all installed printers that are supported by your Ultralite Edition of BarTender are available for label printing.

Any supported printers that have not been renamed are already available and are checked on the list. Check the names of any supported printers that have been renamed since they were originally installed.


选择样本掩码

在为允许的字符选项选择“由‘输入掩码’设置”后，将启用选择样本掩码按钮，点击该按钮可访问选择样本掩码对话框。（另请参见了解输入掩码。）

为方便起见，选择样本掩码对话框包含常用的输入掩码，如邮政编码和社会保险号。您可以使用这些样本掩码中的任何一个，根据需要编辑样本掩码，也可以在输入掩码数据编辑框中输入输入掩码字符来创建自己的掩码。

另请参见：

样本数据模板

了解输入掩码字符


修改提示文本

“修改提示文本”对话框

当您单击提示设计视图中的编辑工具并单击某个文本对象后，修改[提示]文本对话框随即打开。使用该对话框可更改文本。

单击属性按钮可打开对象的属性页。


提示静态文本属性

用户提示上的静态文本

在文本框中键入应出现在提示上的文本对象中的文字。

在宽度框中设置文本对象的宽度。

选择文本在文本对象（由对象的手柄标记的矩形）中的对齐方式：左、居中或右。


“保存卷”对话框

要添加新类别，请突出显示类别框的内容并键入新类别名。（这不会删除框中的原有类别名。

要添加新的卷类型，请在类别框中选择该卷类型的类别，然后突出显示卷名框中的内容并键入新卷类型的名称。（这不会删除框中的原有名称。


“试用功能”对话框

The Trial Features option on the File menu lets you try out features from more advanced BarTender editions. (Since the RFID Enterprise edition already provides all available BarTender features, it does not have this menu option.)

“当前格式”选项卡

当前格式选项卡列出并描述当前打开的格式中使用的所有试用功能。（有关 BarTender 这一版本的所有试用功能的详细信息，请参阅下面的“试用功能”选项卡部分。）

如果单击停止以此格式使用试用功能按钮，则将从当前格式中删除所有列出的试用功能。选中该项后，您可以在免费试用期过后继续使用该标签格式，但将删除已在该标签上使用的全部试用功能。如果不希望自动删除试用功能，则可以打开相应的对话框，替换或关闭相应的功能，以单独删除不同的试用功能。

“试用功能”选项卡

该选项卡简要介绍免费试用期，并告知您的免费试用期还剩下多长时间。

如果单击所有试用功能的列表按钮，则将显示免费试用期内可用的全部功能的列表及其说明。

通过如何升级按钮可以链接到 Seagull Scientific 的 Web 站点，以访问有关升级到 BarTender 其它版本的信息。

As its name indicates, deselecting the Enable Trial Features checkbox will hide the menu items and dialog options that implement the various trial features. This option is especially useful when you want to ensure that you do not inadvertently use a trial feature on a label that you want to continue using after the 30 day trial period has expired.

“警告选项”选项卡

使用警告选项选项卡可以打开或关闭您的 BarTender 版本所显示的每项试用功能的警告。

警告类型包括：

  • 总是在距试用期过期 5 天内发出警告。 这与前一警告相同，但仅在试用期最后 5 天且未启用前一警告的情况下才显示。

  • 总是在选择了不支持的打印机时发出警告。 BarTender 的每个版本并不支持所有的打印机。如果所选的打印机不受支持，将显示一条警告消息。

  • 总是在使用试用功能打印标签时发出警告。 如果所打印的标签格式使用了试用功能，系统将显示一条警告消息，指示在试用期过后将以演示模式打印您的标签。

  • 总是在从工具栏使用试用功能时发出警告。 用来访问试用功能的大多数按钮和菜单项的标题均使用“（试用）”标注。某些按钮（工具栏上）没有标题，在这种情况下，将显示一条警告指示您正在使用试用功能。

  • Always warn when opening a format that uses Trial Features. Opening a format that uses trial features will display a warning telling you that your labels will be printed in demonstration mode if your trial period has expired.

  • Always warn when creating objects that use Trial Features. Creating an object that uses trial features will display a warning telling you that your labels will be printed in demonstration mode if your trial period has expired.


打印机代码模板警告：消息详细信息

消息详细信息

此窗口提供有关在验证消息对话框上突出显示的警告或错误的详细信息。使用这些信息可确定是使用 AutoFix 还是手动更改标签格式来解决问题。（您不必解决警告事项即可继续操作，但必须更正错误才能继续操作。）

  • 类型。警告或错误。

  • 消息 #。错误或警告的标识号。

  • 对象。标识错误或警告所涉及的对象的类型。可能的值包括“文本”、“条形码”、“打印机”和“页面设置”。

  • 字段。在适用情况下，标识导致发生警告或错误条件的打印机代码模板字段。

  • 问题。问题的说明。

  • 结果。说明如果不解决警告事项而继续操作可能带来的结果。

  • 自动修正。说明 AutoFix 功能所执行的操作。

注意：在此对话框上有一个图钉按钮 [image] 。当此按钮处于下陷状态 [image] 时，即使您将焦点切换到其它窗口，该对话框仍将保持打开状态。


VB 脚本

“VB 脚本”选项卡

有时，您可能需要为对象执行自定义的数据确认或数据处理操作。使用更多数据源选项对话框中的 VB 脚本属性页可以访问“脚本助理”，然后，您就可为这些特殊情况指定自己的 Visual Basic 脚本例程。根据更多数据源选项对话框中的有效性、截短、最小和最大等选项卡上的选项对数据进行处理之后，将运行上述脚本。（要打开该对话框，请单击修改所选 … 对象对话框中数据源选项卡上的更多选项按钮。）

在使用该选项卡上的选项之前，请先查看 BarTender 中的 Visual Basic 脚本概述。

注意：一般情况下，仅当对象的数据来自屏幕、数据库或系统日期/时间时，您才会通过此选项卡访问 Visual Basic 脚本。如果您希望脚本本身成为对象的数据源，则应该在修改所选 … 对象对话框的数据源选项卡上将对象的数据源设置为 Visual Basic 脚本。单击该选项卡上的编辑按钮打开“脚本助理”，您可以在其中创建脚本。

  • 使用 VB 脚本。选中此框可以启用 Visual Basic 脚本。

  • 选择要编辑的事件。请首先突出显示所列出的某个项，然后单击编辑按钮。

    • 函数和子例程。实际上此项并不是事件，它只不过是一个由您编写的 Visual Basic 脚本函数和例程组成的集合，该集合可供您为真正的事件（如 OnProcessData 事件）所创建的脚本使用。

    • OnProcessData。在执行打印作业期间，文本或条形码对象每访问一条记录，就会发生一次此事件。对于每条记录，此事件都是在 BarTender 处理了您在该对话框中的提示、有效性、截短、最小和最大等选项卡上选择的选项（如果有的话）之后、但在处理您在序列化选项卡上选择的选项之前发生。（每个文本或条形码对象都有其自己的 OnProcessData 事件。）例如，如果您使用最小选项卡在对象数据的末尾填充字符，则在执行与此事件关联的任何脚本之前，就已经添加这些字符了。相应地，如果脚本处理数据，它将对新的添加了字符的数据（而非原始数据）进行操作。从另一方面来看，如果标签格式的设置是为每条记录生成三个序列标签，则不会为其中每个标签运行三次此事件。

    • OnPostSerialize。仅当在序列化选项卡上启用了序列化之后，此事件才会列出。对于序列值集内的每一个成员，此事件都将发生一次。

  • 编辑。打开“脚本助理”。

注意：在此对话框上有一个图钉按钮 [image] 。当此按钮处于下陷状态 [image] 时，即使您将焦点切换到其它窗口，该对话框仍将保持打开状态。


水平滚动条

当信息内容超出了 BarTender 的标签视图区域的可视范围时，可以通过位于标签视图区域底侧的水平滚动条向左或向右移动活动窗口的内容。


提示的文本属性页

文本属性页

使用文本属性页上的选项可以编辑提示对话框中的文本、指定用户提示和常用文本对象的大小以及文本在对象中是否换行，还可确定文本的对齐方式。

有关更多信息，请单击以下相应的名称。

属性：

  • 文本。用于编辑用户提示和常用文本对象的文本。

  • 宽度。用于指定文本可用空间的水平尺寸。

  • 对齐方式。用于指定文本是与对象的左侧或右侧对齐还是居中对齐。

另请参见：

了解打印时提示


ImageReferences

ImaageReferences

Vooweels iin thiis toopiic haavee beeeen doouubleed too maakee iit uunliikeely thaat aany uuseer wiill aacceess iit froom thee Seeaarch taab.

Thiis toopiic oonly eexiists soo thaat ceertaaiin iimaagees caan bee iincluudeed iin iit.

RoobooHeelp wiill noot iincluudee aany iimaagee fiilee iin thee coompiileed

*.chm fiilee uunleess iit iis reefeereenceed soomeewheeree iin oonee oof thee iincluudeed

*.htm fiilees.

IImaagees thaat wiill oonly aappeeaar aas aa reesuult oof aa scriipt aaree reefeereenceed oonly iin oonee oof thee

*.js fiilees. Heencee, theey doon't geet iincluudeed iin thee .chm fiilee aand thee scriipts thaat reefeer too theem eerroor iin soomee waay.

Soo thee foolloowiing doown-aarroow iimaagee neeeeds too bee reefeereenceed heeree iin aan .htm fiilee.


标签

标签视图区域中表示活动标签的较小白色部分。


Label Object Data Source

Label Object String

A Label Object String uses an object on the label as a data source when you print the label. When you select Label Object String as the source, the following controls appear in the Options area of the Data Source tab of the Modify Selected � Object dialog.

  • Object Name. Select a label object name to use.

  • String. Option availability will depend on the object selected and what object strings it has. The options are:

    • Main Data Source. The same data source as the referenced label object.

    • Human Readable Text. The Bar Code Human Readable Text data of the referenced label object, if available.

    • Hexadecimal Encoded Data. The RFID Hexadecimal Encoded data of the referenced label object, if available.

  • More Options. Opens the More Options dialog.


标签视图区域

标签设计屏幕上供您创建和编辑标签格式的区域。


许可证管理配置文件

支持许可证的 BarTender 版本附带一个名为 BTLM.ini 的文件，该文件保存了在常规选项对话框的许可证管理选项卡上所做的许可证管理设置。有关更多信息，请参见该文件本身的内容。


主菜单栏

标签视图区域顶部的水平条，用于访问主下拉菜单。


主工具栏

包含指向某些最常用命令的快捷按钮。（请参阅主工具栏。）


Media Usage Reporter

Show All Hide All

A special component included with BarTender is the inventory tracking component called Media Usage Reporter. Adding this component, by dragging it to a label format from the Toolbox, ensures that each time you execute a print job with the format, your media supplier automatically receives an e-mail telling it the number of labels printed. The media supplier keeps track of your label stock usage and sends you new supplies of stock before you run out.

How it Works

When added to a label format (see below), the component appears to be a simple text object with default text reading "Media Usage Reporter."

However, this text is configured to be invisible when the format is printed, so the component is actually never seen on a printed label. Its purpose is to associate certain Visual Basic scripts with the format. These scripts e-mail to your media supplier the number of labels printed in each job.

Adding the Component to Your Label Formats

After you install BarTender, the first major step in using the component is add it to one or more of your label formats. Do the following for each label format whose stock you want to track:

  1. Open the format in BarTender.
  2. Open the Components pane in the Toolbox.
  3. Open the Samples folder.
  4. Open the Media Usage Reporter folder.
  5. Left-click the component and, while holding down the mouse button, drag it to the label. Since the component never prints visibly, it does not matter where you put it. You can even put it in the dark area of the label design view just off of the label.
  6. Select Page Setup from the File menu, and open the Stock tab on the Page Setup dialog.
  7. Select a stock.
  8. Click OK.
  9. Save the label format.

Set Up Access to the E-mail Server (Configure Email.ini)

The second major step is to add some information about your e-mail system to the file Email.ini. You do this only one time, not for every label format. The path to this file varies with your version of Windows:

Windows 2000/XP: C:\Documents and Settings\All Users\Application Data\Seagull\BarTender

Window 98: C:\Windows\All Users\Application Data\Seagull\BarTender

  1. Open the file in any plain text editor, such as Windows Notepad.
  2. The file itself contains the instructions about how you should add values to the parameters. See the illustration below. Simply type the requested values while keeping these points in mind:
    • There should be no space after any ?span class="Code">=?sign.
    • If your mail server requires that users login before they can send e-mail, then type ?span class="Code">Yes?as the value of the Authenticate= parameter.
    • Put the customer ID assigned to you by your media supplier as the value of the Subject= parameter.
    • Put the sender抯 e-mail address as the value of the From= parameter.
    • For the value of the To= parameter obtain an address from your media supplier.

The contents of the file are shown here:

[Label Inventory Tracker]

'--- Enter the name of the mail server to be used at the printing site.

MailServer=

'--- Enter Yes or No depending on the requirements of the email server.

Authenticate=

'--- If Authenticate is Yes, then specify the desired LoginName and Password.

LoginName=

Password=

'--- Enter the customer ID. This will be included in the body of the email.

Subject=

'--- Enter the stock Category that is required and the name of the label

' vendor, separated by a comma. There should be no spaces on either side

' of the comma. If the user prints a format not using this stock category,

' an error message will be displayed. Leave blank if you do not need this

' behavior. The label vendor name is used in a couple of error messages.

' If it is left blank, generic text will be used instead.

Message=

'--- Specify the email address of the label vendor.

To=

'--- Specify the From email address.

From=

'--- These two settings almost never need to be changed. Don't change them

' unless you know exactly what you are doing.

Port=25

Timeout=60

'Sample of a completed section

'[Label Inventory Tracker]

'MailServer=mail.mycompany.com

'Authenticate=Yes

'LoginName=me@mycompany.com

'Password=myPassword

'Subject=myCustomerID

'Message=Quality Media,Quality Media Corp.

'To=labelInventoryTracker@qualitymedia.com

'From=me@mycompany.com

'Port=25

'Timeout=60

Testing the Component

Test the configuration of the label format and Email.ini with these steps:

  1. Make a copy of Email.ini under the name OriginalEmail.ini.
  2. Open Email.ini in a text editor and change the value of the To= parameter to your own e-mail address. Save and close the file.
  3. Open any label format on which you have added the Media Usage Reporter and select Print from the File menu to open the Print dialog.
  4. Set the Identical Copies of Label and Number of Serialized Labels values to values greater than 1.
  5. If the label format is linked to a database, then in the Selected Records box specify a small number of records, such ?-4?and click the Print button. (Refer to BarTender's online help for instructions in how to setup a database.)
  6. After the print job completes, verify that you received an e-mail message and it correctly identifies your stock type and that the number of labels specified in the message matches the number that actually printed.
  7. Rename Email.ini to TestEmail.ini and then rename OriginalEmail.ini to Email.ini.


Media Handling

The full range of media handling options are only available in BarTender if

  • The active printer has the physical apparatus to cut, pause, and/or detect when a label has been removed,

  • A Seagull driver for that printer is installed.

If the printer does not support media handling actions or does not have a Seagull driver, you can still make use of the general Use Driver's Settings or Page Break options.

Media Handling and Optimization

If a label format has more than one label per page and media handling is in use, printer optimizations will be turned off.

Note: some action and trigger options may not be visible if they are trial features in your version of BarTender.


MicroPDF417 中的列

MicroPDF417 符号体系的结构为多个信息行，每一行看上去都像一个非常窄的条形码。已编码的信息看上去有点像不规则的棋盘。另外，还有一到四个行地址模式，每个模式的宽度为 10 个模块。

当列设置为自动时，此棋盘数据区域中的行数和列数将进行调整，以使其总体形状尽可能接近正方形。您还可以指定 1 到 4 列。

注意：只可能使用行和列的某些组合。因此，根据在列下拉列表中选择的列数，行下拉列表中的可用行数将有所不同。


PDF417 中的列

自动控制 PDF417 符号的形状

PDF417 符号体系的结构为几个信息行，每一行看上去都像一个非常窄的条形码。如果您仔细检查这些行就会发现，前五个和最后五个条形码扩展了该符号的整个高度，与传统条形码中的情形非常相似。它们表示开始模式和结束模式，可以帮助扫描仪确定 PDF417 是正在扫描的条形码类型。在开始模式和结束模式的内部，已编码的信息看上去有点像不规则的棋盘。当列设置为“自动”时，此棋盘数据区域中的行数和列数将进行调整，以使其总体形状尽可能接近正方形。

手动控制 PDF417 符号的形状

作为“自动”设置的备选设置，您可以手动指定要在棋盘数据区域中显示的列数。列由四个条形码和空格组成，它定义已编码数据的基本单位。每一行至少包含数据区域棋盘部分中的三列信息（12 个条形码和空格）。这是因为左侧和右侧始终存在包含“指示器代码字”的一列，其中的信息将告诉扫描仪使用哪种编码方法来对其余的每行数据进行编码。在这两列（8 个条形码和空格）之间至少有一列（4 个条形码和空格）信息。使用列选项可以将这部分数据区域中的列数设置为 1 到 30。

此消彼涨：符号宽度与高度

应该注意的是，在任何给定的纠错级别设置下，如果减少列数，对相同数据量进行编码所需的行数就会增加。因而，尽管您可以选择减少列数以使 PDF417 符号比“自动”设置下相对较宽的尺寸变得更窄，但这样做会使符号成比例纵向加长。因此，在对大量数据进行编码时，低数值的列设置可能会导致 PDF417 太“高”而无法全部显示在标签上。


填充方框内部

方框内部

通过方框属性页上的填充方框内部选项，可以使用纯色填充当前指定的方框对象。黑色是默认的纯色。但是，您可以使用颜色对话框将该方框更改为任何一种可用颜色。


方框的高度

高度

指定方框（或“提示设计”中的分组框）高度的最简便方法是使用鼠标。然而，您也可以通过在方框或分组框属性页上的高度选项中输入值来指定高度。下面将分别介绍这两种方法。

鼠标方法：

（为了获得最高的准确度，请确保启用查看选项对话框中的对齐选项。）

  1. 单击要更改高度的方框。

  2. 将指针光标放在方框的顶部或底部手柄上，然后单击并按住鼠标左键。

  3. 按住鼠标左键，拖动所选的手柄，直到方框达到所需的高度。

  4. 松开鼠标键。

注意：使用边角手柄可以同时调整高度和宽度。

如果您需要指定方框的确切高度或方框位于标尺的指定对齐点之间的高度，则可以使用以下方法，在方框或分组框属性页上的高度选项中输入确切的值。

属性页方法：

  1. 双击要更改其高度的方框，以显示修改所选方框选项卡式对话框。

  2. 选择相应属性页上的高度选项。

  3. 在编辑框中键入所需的方框高度。

  4. 单击确定按钮。

注意：在指定标签上的方框高度时，如果您指定的方框高度导致方框超出了标签视图区域，则只会打印方框在标签边界内的部分。


（方框的）宽度

指定方框（或“提示设计”中的分组框）宽度的最简单方法是使用鼠标。然而，您还可以通过在方框或分组框属性页上的宽度选项中输入一个值来指定方框宽度。下面将分别介绍这两种方法。

鼠标方法：

（为了获得最高的准确度，请确保启用查看选项对话框中的对齐选项。）

  1. 单击您要更改宽度的方框。

  2. 将指针光标放在方框的左侧或右侧手柄之一上，然后单击并按住鼠标左键。

  3. 继续按住鼠标左键并拖动选定的手柄，直到方框达到所需的宽度。

  4. 松开鼠标键。

注意：使用边角手柄可以同时调整高度和宽度。

如果您需要指定方框的确切宽度或方框位于标尺的指定对齐点之间的宽度，则可以使用以下方法，在方框或分组框属性页上的宽度选项中输入确切的值。

属性页方法：

  1. 双击要更改其宽度的方框，以显示修改所选方框选项卡式对话框。

  2. 单击相应属性页上的宽度选项。

  3. 将所需的方框宽度键入编辑框中。

  4. 单击确定按钮。

注意：在指定标签上的方框宽度时，如果您指定的方框宽度导致方框超出了标签视图区域，则只会打印方框在标签边界内的部分。


“基本/高级”按钮

在基本模式下，该按钮将显示为高级，单击它将切换到基本模式。

在高级模式下，该按钮将显示为基本，单击它将切换到高级模式。

注意：如果您在高级模式下将对象设置为使用多个来源或与另一个子串共享数据，则基本按钮将灰显。因此，您将无法返回基本模式。


默认响应（屏幕数据选项）

默认响应

使用默认响应选项可以指定要显示在提示或查询提示对话框上的响应框中的文本，并按标签格式上的示例文本进行显示。首次将对象设置为“打印时提示”时，默认响应为“样本响应”。如果希望设置为其它的默认响应，可以在数据源属性页上的默认响应编辑框中直接输入该响应。

将标签对象设置为“打印时提示”时，默认响应可能来自许多不同的来源，具体取决于所选的数据源类型。位于响应选项组顶部的默认响应消息显示了当前标签对象默认响应的来源。

当默认响应在打印时显示在提示框上时，要覆盖它，请将数据键入响应框中，此时新的数据将打印到标签上。如果您未输入响应，则默认响应将打印到标签上。

另请参见：

了解打印时提示

数据输入选项快捷菜单

打印时用户提示

打印后更新默认响应

合并不同的数据源


Printer Code Template Field Options

Whenever the source for the selected data substring is set to "Printer Code Template Field" the dynamic area of the Data Source property page will display the appropriate options. On the Basic Data Source property page, the options will be displayed in the area of the property page titled Options. On the Advanced Data Source property page, the options will be displayed on the Template Field tab. The Printer Code Template Field source is used to specify that an object will receive its data from an external print system (e.g. keyboard terminals, XML enabled printers, and ERP specific systems).

See Also:

Combining Different Data Sources


子串的样本数据

样本数据

样本数据选项与屏幕数据选项类似，为样本数据选项输入的任何数据均显示在标签视图区域中。但在打印时，实际标签上的样本数据会被使用数据文件字段 # 选项所指定的字段中的数据替代。

若要输入样本数据，只需使用键盘直接将所需的数据键入样本数据选项。

另请参见：

数据输入选项快捷菜单


屏幕数据选项

在您第一次将条形码或文本对象插入标签格式时，BarTender 会将其显示为使用屏幕数据作为默认数据源。屏幕数据是您直接输入到 BarTender 中的对象的数据，通常是键入的。如果未指定使用来自其它数据源类型的数据，BarTender 会在打印时将屏幕数据用于条形码或文本对象。

在将对象的数据源设置为屏幕数据后，将在数据源属性页上显示屏幕数据选项。

  • 屏幕数据。用于直接在 BarTender 中输入对象的数据。

对于使用屏幕数据的对象，如果启用了打印时提示，屏幕数据选项的名称将显示为“默认响应”。

  • 默认响应。用于为设置为在打印作业开始时提示的对象输入默认响应。

    • 注意：如果希望 BarTender 在打印时提示您输入其匹配数据库记录所使用的数据，则不要使用屏幕数据选项。使用从数据库读取选项和查询提示功能。

另请参见：

数据输入选项快捷菜单

合并不同的数据源


序列化数据

全部显示 全部隐藏

您可以对屏幕数据、输入文件数据、提示数据或 Visual Basic 脚本应用序列化选项。也就是说，序列的起始值可以是屏幕数据选项中的数据子串、数据源文件指定字段中的数据、为响应打印时提示而输入的数据或使用已编程的 Visual Basic 脚本生成的数据。

例如，假定当前所选对象的屏幕数据选项中的值为“001Y7”。如果您启用序列化选项并保留全部序列化选项均设置为其默认值，则对于输出的前五个标签当前所选对象的数据将按如下方式递增：

标签 #1：001Y7

标签 #2：001Y8

标签 #3：001Y9

标签 #4：001Z0

标签 #5：001Z1

请注意，BarTender 支持大写字母和所有数字的代码递增。如果要在数据字符串的左侧或右侧附加字母，但不希望它们随数字递增而递增，其方法很简单，仅需使用高级数据源属性页上的子串列表选项，在当前所选对象的数据中添加包含所需字母的子串即可。

“打印同样标签的份数”如何影响序列化

在设置序列化标签格式的数据并在打印对话框的同样标签的份数选项中输入数字后，将为序列中的所有值打印相同的同样标签的份数。以前面的示例来说明：

假定将同样标签的份数设置为“5”。于是，标签 #1 将打印五个同样的标签，标签 #2 将打印五个同样的标签，序列中的所有值都依此类推。

从数据文件中的字段读取“同样标签的份数”

有时，如果标签格式从数据文件读取数据，您可能希望更改各序列化标签的同样标签的份数。为此，您需要在打印对话框上选择选项按钮，然后设置要从数据文件中的字段读取的同样标签的份数。有关说明，请参见从数据文件读取同样标签的份数。

如果标签带有从数据文件读取的份数计数，在打印同样的标签时，您可能希望序列化某个标签对象，也可能不希望这样做，具体情况，取决于您的生成标签任务。使用标签/记录选项可以指定是否序列化标签对象。

如果设置为“记录”

在打印多份相同标签数据时，当前指定的对象或子串将保持不变。

如果设置为“标签”

则不管是否打印多份标签，当前指定的对象或子串都将随每个打印的标签而递增一次。

另请参见：

序列化选项

设置一个计数字段


命名和共享子串

全部显示 全部隐藏

您可能会有这样的标签，在标签上可能会有两个或更多对象要使用相同的数据，而您又不希望多次指定这些数据。所有不同源类型都可以与其它子串共享数据。

使子串可共享

  1. 双击使用要与其它对象共享的数据子串的对象。BarTender 将显示修改所选条形码或文本选项卡式对话框。单击数据源选项卡显示数据源属性页。单击高级按钮，然后单击共享/名称子选项卡，显示共享/名称选项。

  2. 如果标签对象包含多个子串，而您要共享的子串并不是当前指定的子串，请在子串列表中单击要共享的子串。

  3. 单击名称选项，然后键入用于引用该子串的名称。

  4. 单击确定按钮。这样，已命名的子串将显示在工具箱的数据源窗格中。

使用可共享的子串

重要提示：在共享子串之前，您必须首先按上述使子串可共享部分的说明来命名子串。

以下多种方法可用于重复使用可共享子串：

方法 1

  1. 打开工具箱的数据源窗格。

  2. 展开已命名的子串目录，然后单击所需的子串。按住鼠标键，将该子串拖动到标签上的所需位置。

  3. 松开鼠标键。这时，将显示一个快捷菜单，您可以从中选择是创建条形码、文本对象，还是图片。

  4. 选择一个选项后，对象将显示在标签上。

方法 2

  1. 创建对象（该对象应使用其它子串的数据），然后双击该对象。BarTender 将显示修改所选 … 对象选项卡式对话框。单击数据源选项卡显示数据源属性页。单击高级按钮，然后单击共享/名称子选项卡，显示共享/名称选项。

  2. 如果标签对象包含多个子串，而要使用其它子串数据的子串并不是当前指定的子串，请在子串列表中单击所需的子串。

  3. 单击紧跟在名称选项后面的向下箭头，展开当前可共享子串名称的列表。然后，单击包含要与当前所选子串共享的数据的子串名称。

  4. 单击确定按钮。


“更多选项”按钮

单击更多选项按钮时，将显示更多数据源选项选项卡式对话框，通过该对话框可以访问诸如“序列化”和“有效性”等其它数据源选项。然后，您可以通过单击选项卡在不同的属性页之间进行切换。

下面概括介绍了更多数据源选项对话框上可用的功能。有关其它信息，请单击以下相应的选项名称。

  • 提示。用于启用打印时提示、输入提示文本和定义处理响应的方式。

  • 有效性。用于强制数据符合指定的规则。

  • 截断。用于从数据中删除不需要的字符和空格。

  • 最小。用于指定可输入的最少字符数。

  • 最大。用于限制可输入的字符数。

  • VB 脚本。用于编写 Visual Basic 脚本，以执行自定义的数据处理或有效性检验。

  • 序列化。用于指定增加或减少数据的方式。

  • 常规。用于指定当未提供特定数据时不打印标签对象，或当标签对象用作条形码的供人识读字符时，该标签对象可见。


不打印子串

不打印，如果选项指定了如果下一个（或上一个）子串为空，则在打印作业期间将忽略所选子串的内容。对于某些项目而言，可能需要从包含一些空字段的数据源文件中读取数据，但您不想在标签输出中看到空白区，则该选项可能尤其有用。

示例：

以下这个常见示例说明了不打印，如果选项在标签系统中的用处：即打印从客户数据库生成的数据文件中的地址标签。假设您要打印的地址标签包括客户名称、公司名称、街道地址、城市、州/省和邮政编码，如下面的记录示例所示。

"Jake Diamond","Diamond, Inc.","PO Box 60","Gem Town","NV","50897"

"Meg Reilly","","148 Circle Drive","Maple","WA","98005"

"","All-State Trucking","5601 Interstate","Huntsville","IN","40890"

如果您将标签格式设置为将每个字段作为单独的文本对象进行打印，则标签输出可能如下所示：

Jake Diamond | Meg Reilly |
Diamond, Inc. |  | All-State Trucking
PO Box 60 | 148 Circle Drive | 5601 Interstate
Gem Town, NV 50897 | Maple, WA 98005 | Huntsville, IN 40890

请注意，样本数据文件第二个记录中的第二个空字段和第三个记录中的第一个空字段是如何导致标签上出现跳行的。

通过指定以下项，可以避免出现这些跳行：

  • 使用 BarTender 的段落设置（在文本属性页上），将整个地址作为单个段落输出。

  • 只要上一个子串为空，BarTender 就会取消回车。下图显示了如何为段落文本设置数据字符串。

子串 | 内容 | 数据源 | 不打印，如果
#1 | 客户名称 | 输入文件数据 | 禁用
#2 | 回车 | 屏幕数据 | 启用
#3 | 公司名称 | 输入文件数据 | 禁用
#4 | 回车 | 屏幕数据 | 启用
#5 | 街道地址 | 输入文件数据 | 禁用
#6 | 回车 | 屏幕数据 | 启用
#7 | 城市 | 输入文件数据 | 禁用
#8 | 逗号和空格 | 屏幕数据 | 禁用
#9 | 州/省 | 输入文件数据 | 禁用
$10 | 两个空格 | 屏幕数据 | 禁用
#11 | 邮政编码 | 输入文件数据 | 禁用

现在，BarTender 将不会添加行（回车），除非包含指定回车符的子串之前的子串确实包含数据。使用这种方法，我们前面打印的这三个标签将显示如下（没有跳行）：

Jake Diamond | Meg Reilly | All-State Trucking
Diamond, Inc. | 148 Circle Drive | 5601 Interstate
PO Box 60 | Maple, WA 98005 | Huntsville, IN 40890
Gem Town, NV 50897 |  |


字段名

该选项用于指定将在打印时替换当前指定子串的样本数据的数据库字段。

如果在未指定字段名的情况下从文本文件读取数据，BarTender 将从左至右读取数据文件中每个记录中的字段。例如，如果您选择“字段 3”，BarTender （在打印时）将用数据文件中第三个字段的数据来替换当前所选子串的屏幕数据。（样本数据仅在打印标签上替换，而不在屏幕上替换。）

假定在上述示例中数据文件中某记录的字段为

"LA","32014","Oranges","California Transport"

则第三个字段中的数据“Oranges”将替换当前所选对象的屏幕数据。


用作供人识读字符时可见

使用高级数据源属性页，可以指定给定条形码对象或文本对象的数据将由多个子串合并，而不是来自一个字符串。这些子串可以是屏幕数据、提示数据、输入文件数据、时间或日期的组合。虽然组合字符串中的所有字符都将被编码成显示的条形码，但有时，您可能并不希望在条形码的供人识读字符中出现一个或多个子串的数据。

如果为某个条形码（或条形码中的子串）启用了用作供人识读字符时可见选项，BarTender 将打印该子串的供人识读字符。如果未启用该选项，则不打印任何供人识读字符。

注意：供人识读属性页上的可见性选项的优先级高于此选项：如果前者设置为完全或无，则该选项将被禁用，变得无效。如果将供人识读属性页上的可见性选项设置为由数据源选项设置，则用作供人识读字符时可见选项将决定数据是否可见。


显示所选对象的属性

可以使用以下任何一种方法来显示所选对象的主属性页。显示主属性页后，单击位于修改对话框顶部的任何选项卡，可以查看该对象的其它可用属性页。

  • 双击要修改的对象。这是最简单的方法，因为这可以立即显示所选对象的主属性页。

  • 右键单击要修改的对象。此时将显示对象属性快捷菜单。显示快捷菜单后，单击快捷菜单中的属性选项，以显示所选对象的主属性页。

  • 使用修改菜单。（这是最慢的方法，因为它单击鼠标的次数最多。对于熟悉该程序的用户，前两种方法更快一些。）选择要修改的对象后，单击主菜单栏中的修改选项。然后，单击所选对象或所选编组菜单选项，以显示所选对象的属性页。


修改现有已命名的 ODBC 数据源

有时，如果数据文件已被移走或重命名，您可能需要修改以前创建的已命名 ODBC 数据源。如果需要修改现有已命名的 ODBC 数据源，请按以下步骤执行。

警告：如果其它某个 Windows 应用程序需要使用您要修改的 ODBC 数据源，您应该创建一个新数据源，而不应该修改现有的数据源。

  1. 从文件菜单中选择数据库连接设置选项。

  2. 在所有数据库树视图中，指定一个现有已命名的 ODBC 数据源。

  3. 在选项选项卡中，根据要对 ODBC 数据源进行的更改，单击紧靠 ODBC 管理器按钮左侧的设置按钮或单击 ODBC 管理器按钮。

  4. 根据您的需要在 ODBC 设置对话框或 ODBC 管理器中修改设置。请注意，对数据源的最常见修改是更改数据源的名称和修改指定的文件目录或数据库名称（这控制 ODBC 数据源将能访问哪些文件）。某些数据源使用的 ODBC 驱动程序可能还会显示与该驱动程序有关的其它设置。

  5. 根据您是否要保存所做更改，单击确定或取消按钮。

另请参见：

指定现有已命名的 ODBC 数据源

新建已命名的 ODBC 数据源


Line Color

The Line Color option on the Box or Ellipse property page is used to change the color of the lines making up the the currently specified object. Black is the default color. However, you can use the Color dialog to change the object to any of the available colors.


定义输入掩码

您可以采用以下两种方法之一来定义输入掩码：

  • 从选择样本掩码对话框中选择现有的样本输入掩码。

  • 在输入掩码数据编辑框中输入输入掩码字符。您可以使用键盘来输入字符，也可以使用单击输入掩码数据编辑框右侧的向右箭头时显示的下拉列表来输入字符。

数据模板如何影响已接收的数据

定义输入掩码后，BarTender 将强制接收的数据遵守指定的模式。下面的示例说明了输入掩码字符如何确定可接收的数据的类型。有关可能的输入掩码字符的详细信息和详细列表，请参阅了解输入掩码字符。

示例：

(999) 000-0000 — 默认输入掩码：“9”表示输入时可接受数字或空格，并且输入操作是可选的；“0”表示输入时仅接受数字，并且输入操作是必需的。

LL-AAAA：“L”表示输入时仅接受字母，并且输入操作是必需的；“A”表示输入时可接受字母和数字，并且输入操作是可选的。

另请参见：

了解输入掩码

输入掩码样本


正确设置数据库

在设置 BarTender 将从中导入图片的数据库时，该数据库必须通过名称引用外部图片文件。BarTender 不能导入直接存储在数据库中或嵌在数据库中的图片。

由于您的图片文件和 BarTender 程序文件不大可能存储在一个文件夹中，所以您可以在数据库的图片文件引用字段中输入路径，也可以在 BarTender 的默认路径选项中输入路径。如果所有图片文件都存储在一个文件夹中，则可以使用默认路径选项来指示 BarTender 到何处查找图片文件。

数据库图片文件引用示例

仅引用文件名

picture.pcx

引用路径和文件名 c:\graphics\picture.pcx

过程：

将图片导入标签格式中


添加分组框

  1. 从菜单栏中选择创建并单击文本，然后单击工具栏上的创建分组框按钮。

  2. 将鼠标光标置于提示对话框中要在该处添加文本对象的位置，然后单击鼠标左键。提示对话框中将出现一个文本对象。

若要编辑默认的分组框标题，请参见编辑文本。

请参见下一节：

添加线条


添加线条

  1. 从菜单栏中选择创建并单击文本，然后单击工具栏上的创建线条按钮。

  2. 将鼠标光标置于提示对话框中要在该处添加文本对象的位置，然后单击鼠标左键。提示对话框中将出现一个文本对象。

请参见下一节：

在提示对话框中移动对象


添加常用文本对象

  1. 从菜单栏中选择创建并单击文本，或者单击工具栏上的创建文本按钮。

  2. 将鼠标光标置于提示对话框中要在该处添加文本的位置，然后单击鼠标左键。提示对话框中将出现一个文本对象。

若要编辑样本文本，请参见编辑文本。

请参见下一节：

添加分组框


向提示对话框中添加对象

除了用户提示和响应框以外，您还可以添加常用文本对象、分组框以及线条以增强提示对话框的外观。有关如何在提示对话框中放入其它对象的说明，请单击下面相应的主题。

  • 添加常用文本对象。

  • 添加组合框。

  • 添加线条。

请参见下一节：

在提示对话框中移动对象


在提示对话框中移动对象

移动提示对话框对象不仅仅是改变提示对话框的外观。根据响应框位置的不同，您还可以更改提示用户输入数据的顺序。

移动提示对话框对象的最简单方法是使用鼠标。若要使用鼠标移动提示对话框对象，请单击对象，然后按住鼠标左键将对象拖至相应的位置。

若要进行更多的控制，可以在提示对话框上移动对象时查看网格。若要准确定位，请使用提示对话框对象的位置属性页。

重要提示：移动多个用户提示和响应框时，请确保不要使它们距离太远。否则，可能会意外地将错误的提示和响应框组合在一起，从而导致在打印时输入错误的数据。

请参见下一节：

更改提示顺序


提示频率

使用提示频率选项可以指定提示对话框在打印作业期间要求用户输入的频率。大多数情况下都使用默认设置每个打印作业一次。但是，如果标签格式设置为从外部数据文件中读取，则标签上的对象既可以设置为在打印作业开始时请求一次数据，也可以设置为对于从数据文件中读取的每个记录都请求数据。

  • 每个打印作业一次。用于将对象设置为在打印作业开始时请求输入。将在每个标签上为来自数据文件的每个记录打印相同的信息。“每个打印作业一次”是大多数标签对象的默认设置。

  • 每个记录。用于将对象设置为对于从数据文件中读取的每个记录都请求输入。此选项将对读取的每个记录都显示一个提示，从而可以对每个标签都打印不同的信息。如果设置为在打印时提示的对象或子串是从外部数据文件中读取数据的，则每个记录是唯一可用的设置。


打印时用户提示

当为某个对象启用“打印时提示”时，可以使用打印时用户提示来输入将在提示对话框中显示的说明。这些说明将提醒用户在关联的响应框中输入数据。用户提示的默认文本是“样本提示”，不过可以通过在打印时用户提示数据输入框中键入任何文本来覆盖该默认文本。

另请参见：

了解打印时提示

创建打印时提示

数据输入选项快捷菜单

打印后更新默认响应


只读

只读选项可用于指定在打印时显示对象的数据，但不允许用户更改默认响应。当对象的数据会影响用户在响应另一个提示时可能输入的数据时，尤其当默认响应是从数据文件读取时，您可能要使用只读。

示例：

如果是给库存项打印标签，则可能首先要知道产品的编号或说明才能在打印时输入数量或价格。通过将产品编号和说明标签对象设置为打印时提示，却同时启用只读，您就能在打印时看到作为默认响应的这些对象的数据，却又不会误改它。然后，您就可以在数量和/或价格响应框中输入所需的数据。


出现制表符时跳过数据输入框

使用出现制表符时跳过数据输入框选项可以指定，当在打印时的提示对话框中输入数据时，光标将跳过响应框。有时，您可能因为默认的响应数据很少改变而想要跳过响应框。但是，如果您需要输入不同的响应，可以很容易地使用鼠标将光标置于响应框中，然后编辑数据。


视回车符为制表符

使用视回车符为制表符选项可以指定，在打印时的提示对话框中输入数据时，光标将自动在您按 Enter 键时从当前的提示响应框移至下一个提示响应框。默认情况下，此选项启用。如果禁用了此选项，按 Enter 键将关闭提示对话框并启动打印作业。


自定义提示对话框

虽然 BarTender 会自动为您设计一个默认的提示对话框，但有时，这个对话框可能不符合您的需要。对于 BarTender 自动放置在提示对话框上的用户提示和响应框，您可能希望移动其位置或调整其大小。另外，您可能还希望添加常规文本对象、方框和线条来自定义提示对话框的外观，或调整提示对话框的大小，使之能容纳所有必需的对象。

要自定义提示对话框，需要切换到提示设计视图。在提示设计视图中，屏幕上显示的不再是标签格式，而是提示对话框。设计提示对话框的过程与设计标签的过程非常相似。移动、调整大小和编辑操作都使用相同的基本工具来执行。

切换到提示设计视图：

  1. 从菜单栏中选择视图。

  2. 单击提示设计视图。

有关各自定义功能的信息，请单击以下所需的项：

  • 向提示对话框中添加对象。

  • 在提示对话框中移动对象。

  • 调整提示对话框上对象的大小。

  • 调整提示对话框的大小。

请参见下一节：

响应打印时提示


了解默认提示对话框

当您设置一个或多个要在打印时提示的标签对象时，BarTender 会创建一个提示对话框。默认情况下，用户提示和响应框在提示对话框上的布局是：每行一个用户提示、一个响应框。它们在提示对话框上的排列顺序与给它们设置的打印时提示顺序相同。

由于 BarTender 会自动排列用户提示和响应框，所以您可以使用默认的提示对话框轻松打印。不过，出于各种原因，您可能希望自定义提示对话框。

请参见下一节：

自定义提示对话框

另请参见：

了解打印时提示


编辑用户提示

创建用户提示

全部显示 全部隐藏

用户提示用于指导用户在相关响应中输入什么内容。因此，使用户提示贴切明了，可为用户提供帮助。例如，假定在设计发货标签，标签上的重量需要在打印时输入，此时，既可以创建一个用户提示“重量”，也可以给出完整的说明“输入包装重量（圆整到最接近的磅数）”。

用户提示可在标签设计视图或提示设计视图中编辑。

在标签设计视图中

  1. 双击要为其输入用户提示的标签对象。

  2. 单击数据源选项卡（如果尚未选定）。

  3. 单击更多选项…按钮，然后从列表中选择提示，访问子串选项对话框并选中打印时提示选项卡。

  4. 在打印时用户提示数据输入框中单击，然后键入相应的提示。

  5. 根据需要设置其它选项。

  6. 单击确定按钮，返回到数据源属性页。

  7. 单击确定，返回标签格式。

在提示设计视图中

  1. 双击提示对话框上的用户提示。

  2. 单击“文本”选项卡（如果尚未选定）。

  3. 在文本数据输入框内单击鼠标光标。

  4. 根据需要编辑文本。

  5. 单击确定，返回提示对话框。

请参见下一节：

编辑默认响应


编辑默认响应

默认响应是样本响应，它显示在打印时的提示对话框中的响应框中。但是，根据选择的数据源类型的不同，默认响应还可能显示在标签格式以及提示设计视图中的提示对话框中。

可以根据需要输入将显示为默认提示响应的任何文本。甚至可以输入一个在大多数情况下都适用、但也可能更改的默认响应。

例如，发货标签上的对象可被设置为发货方式提示。如果标准发货方式为“UPS Ground”，那么在设计标签时可以将“UPS Ground”作为默认响应输入。打印时，“UPS Ground”将显示在响应框中。如果打印时未在响应框中输入响应，“UPS Ground”将打印在标签上。不过，用户可以根据需要通过输入另一种发货方式来覆盖默认响应。

如果将标签对象设置为“打印时提示”，那么，根据选择的数据源类型的不同，默认响应可能来自任意数目的不同数据源。如果数据源类型设置为“屏幕数据”，应按照下面的步骤来编辑默认响应。对于其它数据源类型，请参见默认响应消息，该消息位于默认响应来源的打印时提示选项对话框中的响应选项部分。

输入默认响应

  1. 双击要为其输入默认响应的标签对象。

  2. 单击数据源选项卡（如果尚未选定）。

  3. 启用打印时提示（如果尚未启用）。

  4. 在数据源属性页上的默认响应数据输入框中输入默认响应。

  5. 单击确定。

  6. 对于要求在打印时输入数据的每个对象重复上述步骤。如果对象有多个子串，则应对需要为其提示数据的每个子串分别启用“打印时提示”。

请参见下一节：

了解默认提示对话框


更改提示顺序

如果在打印时显示具有多个响应框的提示对话框，则每次按 Tab 或 Enter 键时光标将从一个响应框移至下一个响应框。光标移过响应框的顺序取决于响应框在对话框中的位置。

若要更改提示顺序，只需重新确定响应框的位置即可。

重要提示：提示顺序是按从左至右、从上至下的顺序来确定的。因此，如果同一行有两个响应框，左侧的响应框将在右侧的响应框之前提示输入数据。但是，如果右侧响应框的位置比左侧响应框的位置稍高，则右侧响应框将首先提示。

请参见下一节：

调整提示对话框上对象的大小


调整提示对话框上对象的大小

有时您可能希望调整提示对话框上对象的大小。尽管可以在提示对话框上放置若干个不同类型的对象，但是增加或减小每个对象的大小的基本过程是相同的。调整大小的最简单方法是使用鼠标。

使用鼠标调整对象大小：

  1. 单击要调整大小的对象。此时将出现大小调整手柄。

  2. 将鼠标光标置于某个手柄上。

  3. 单击并按住鼠标左键拖动鼠标，直到对象大小适宜。

还可以使用所选对象的相应属性页来调整对象的大小。下面是提示对话框对象列表、相应的属性页以及调整大小所必需的选项。

对象 | 属性页 | 调整大小
用户提示 | 文本 | 宽度
响应框 | 响应框 | 行、宽度
常用文本对象 | 文本 | 宽度
分组框 | 分组框 | 高度、宽度
线条 | 线条 | 长度

请参见下一节：

响应打印时提示


打印后更新默认响应

使用此选项可以指定，为响应打印时提示而输入的最后一个响应将显示为新的默认响应。如果启用此选项，在完成每个打印作业后，为响应提示而输入的数据将显示为下一个打印作业的新默认响应数据。在最后一个打印作业结束而退出提示模式后，屏幕上的数据将被更新以反映为响应最近执行的提示而输入的数据。

  • 打印后更新默认响应。用于指定为响应打印时提示而输入的最后一个响应将显示为新的默认响应。

另请参见：

打印时用户提示

创建打印时提示

了解打印时提示


序列化同样标签份数

序列化同样标签份数选项指定即便相同标签副本上的子串数据也应序列化。

另请参见：

递增和递减数据

归位/复位

保留子串长度

打印后更新序列号


递增和递减数据

递增选项由四部分组成，这四部分结合在一起，确切地指示 BarTender 如何序列化数据子串。

递增选项的第一部分有两个单选按钮，用于指定您希望子串数据是递增还是递减。第二部分用于填写指定子串数据的递增或递减幅度的值。选项的第三和第四部分用于指定数据递增或递减的频率。

该选项的默认设置指定子串“每 1 个 标签递增 1”。在大多数情况下，这些设置都很适用。但是，假定您希望子串数据每隔一条记录减少 5。则需要将该设置改为“每 2 条记录减少 5”。

另请参见：

归位

保留子串长度

序列化同样标签份数

打印后更新序列号


保留子串长度

该选项指定：当子串值达到该子串允许的最长值或最短值后，子串中的字符总数是否增加（或减少）一。

默认情况下，保留子串长度选项是禁用的。这意味着，当指定的子串达到其最大（或最小）值时，它会自动正常增加（或减少）到其下一个值。例如，三个字符的数字子串在递增到 999 后，将继续向 1000、1001、1002 递增，如此逐个增加。同理，三个字符的数字子串在递减到 100 后，将继续向 99、98、97 递减，如此逐个减小。

当启用保留子串长度选项（且指定的子串被设置为递增）时，BarTender 将把子串递增到该子串允许的长度的最大值。达到该值后，BarTender 将重新从该子串允许的长度的最小值开始。例如，三个字符的数字子串在递增到 999 后，将按 001、002、003 的顺序重新开始。同理，三个字符的数字子串在递减到 001 后，将按 999、998、997 的顺序重新开始。

另请参见：

递增和递减数据

归位/复位

序列化同样标签份数

打印后更新序列号


归位/复位

归位

使用归位选项可以指定允许的最大（或最小）值，超过（或低于）该值的数据无法递增（或递减）。与递增/递减选项类似，归位选项包含多个部分。使用复选框可以启用或禁用该选项。启用该选项后，可以使用该选项的第二部分填入最大归位值或复位值（如果子串设置为“递减”）。使用该选项的最后一部分可以指定当发生归位或复位时应重置的值。

例如，假定您希望某个子串递增到值 5,000，然后从 1,000 重新开始。首先，应对指定的子串启用归位复选框。然后，将限制设置为“5,000”，将归位为设置为“1,000”。

另请参见：

递增和递减数据

保留子串长度

序列化同样标签份数

打印后更新序列号


指定序列化的自定义字符集

指定序列化子串数据的自定义字符集

序列选项和类型选项结合使用，显示用于序列化子串数据的字符集样本。如果已经选择了“自定义”设置，使用序列选项可以键入要用来序列化子串的任何自定义字符集。

重要提示：BarTender 不允许两次指定自定义字符集中的同一个字符。如果指定的数据字符串中出现重复字符，BarTender 将自动在重复的字符前终止序列。例如，如果键入了五个字符的序列 24682，BarTender 将仅使用该序列中的前四个字符。


指定序列化的字符集

指定序列化子串数据的字符集

类型选项指定用于序列化子串数据的字符集。“字母数字”设置适用于大多数用途，是默认设置。不过，您也可以从其它六种设置中进行选择，其中包括“自定义”设置，该设置与序列选项结合使用，可以指定任何独特的字符集。

注意：在接下来的内容中，“字母”仅指大写字母。不支持小写字母序列。

请选择以下设置之一：

  • 自动希腊字母或数字。如果使用此设置，BarTender 在打印时会自动判断要序列化的子串中的首字符是数字还是字母，并与该字符集保持一致。也就是说，如果要序列化的字符以数字开头，那么序列化后的数据将继续为数字；如果要序列化的字符以字母开头，则序列化后的数据将继续为字母。

  • 数字（基数为 10）。序列化后的子串中的字符集仅包含 0 到 9 十个数字。

  • 字母。序列化后的子串中的字符集仅包含字母。（虽然此字符集中有 26 个字符，但不能就此认为其基数为 26，因为它不像标准计数系统那样以 0 开始。）

  • 字母数字。序列中使用的字符集将包含从 0 到 9 十个数字和从 A 到 Z（以这种顺序）26 个字符。（与“自动字母或数字”设置不同，该设置将使用两个字符集，而不是非此即彼。）由于该字符集中包含 36 个字符，所以有时被称为以 36 为基数。

  • 不包括 I 和 O 的字母数字。除了没有字母“I”和“O”外，该设置与字母数字字符集一样，略去这两个字母是为了避免与一和零混淆。

  • 十六进制（基数为 16）。包括从 0 到 9 的十个数字和从 A 到 F（以这种顺序）的六个字母。

  • 自定义。用于指定任意的字符集来进行序列化。


打印后更新序列号

打印后更新子串

启用该选项后，已序列化子串的屏幕数据将在打印作业后更新，以反映由于递增或递减而导致的任何数据变化。

另请参见：

递增和递减数据

归位/复位

保留子串长度

序列化同样标签份数


用户提示

用户提示是显示在提示对话框上的消息，它要求用户在关联的响应框中输入数据。用户提示不会打印出来，仅供说明。


响应框

响应框是显示在提示对话框上的数据输入框，用户将在其中输入数据作为对用户提示的响应。如果定义了默认响应，该响应将显示在响应框中。打印时，用户既可以接受默认响应，也可以在响应框中输入新数据。如果未输入对用户提示的响应，将打印默认响应。


修改文本

使用修改文本对话框可以轻松快捷地更改文本对象或分组框的文本，而无需访问文本或分组框属性页。下面概要介绍了修改文本对话框选项。

  • 文本。用于输入要显示在提示对话框上的文本。

  • 属性。用于访问文本或分组框属性页。

有关访问修改文本对话框的信息，请参见使用数据编辑工具。


设置特定于数据文件的 ODBC 参数

许多类型的数据文件都具有只有在使用该特定类型的文件时才适用的配置参数。例如，当从 dBASE 文件中读取数据时，需要指定从 dBASE III 文件还是从 dBASE IV 文件读取数据。同样，FoxPro 和其它许多程序也支持较早的数据文件版本，因此您需要指定要使用的版本。此外，有时还必须指定将与数据源表关联的一个或多个索引文件。

如果您使用的是已指定的现有 ODBC 数据源，则这些参数应该在最初设置该数据源时已指定。但是，有时您可能需要通过 ODBC 数据源管理器来更改设置。ODBC 管理器对话框的两个最重要的功能如下：

  • 指定数据文件版本

  • 指定要使用的索引文件

另请参见：

了解 ODBC


指定要使用的索引文件

ODBC 管理器的驱动程序配置设置对话框有时会列出一个或多个索引文件供您选择。正确指定要使用的索引对于系统性能至关重要。

BarTender 支持的许多数据源文件类型都有相关的索引信息，ODBC 驱动程序无需您的帮助就能自动找到并使用这些信息。但是，某些类型的数据源文件不允许您访问任何索引信息，除非您明确指定了要使用哪些索引。（索引文件包含已排序的信息，这使得在数据文件中查找记录更快捷些。）

以下列表指定了一些通用的数据文件类型，并指定了 BarTender 使用的 ODBC 驱动程序是否能够自动找到它们的索引信息。

支持自动检测索引

Access

dBASE IV

FoxPro for Windows 2.5（或更高版本）

Paradox

要求明确指定要使用的索引文件

dBASE III

FoxPro 2.0

如这些列表中所示，当读取 dBASE IV 文件时，BarTender 使用的 ODBC 驱动程序将自动查找相关的索引文件。dBASE IV 是目前常用的多种数据库平台之一，它使用“复杂”的索引文件，该文件通常包括多个单独的索引。例如，一个名为 CUSTOMER 的复杂索引文件可能包含多个单独的索引，每个索引分别对应于客户名称、地址、城市、州/省以及电话。如果索引文件的根名称与数据库的相同，ODBC 驱动程序就能轻松检测到它并使用。因此，除非在最初创建索引文件时有意使用了不标准的命名约定，否则，ODBC 驱动程序都将找到您的 dBASE IV 索引文件，即使您在 BarTender 的 dBASE 设置对话框中没有明确指定要使用哪些索引文件。但是，当读取 dBASE III 文件时，则不是这样。


指定数据文件版本

仅仅选择一般数据文件类型（如 dBASE、FoxPro 或 Paradox）通常是不够的。例如，dBASE III 和 dBASE IV 的文件类型不同，并且不能向后兼容。同样，FoxPro 2.0、2.5 和 2.6 的文件格式也具有重大的区别。因此，当指定 ODBC 数据源时，应检查驱动程序的配置设置对话框，以查看是否支持多个文件版本，如果是，则查看默认选定的是哪个版本。


占位符定义

占位符

输入掩码的第三部分（第二个分号的右侧）表示将在提示对话框的测试选项和响应框中显示的占位符。

在默认的输入掩码中，作为占位符输入的字符是下划符。在占位符数据编辑框中输入新字符，或直接在输入掩码数据编辑框中输入新字符，可以更改占位符。


指定是否打印实际字符

输入掩码的第二部分（位于两个分号之间）指示 BarTender 是否将数据模板中包含的任何实际字符显示在标签视图区域中并打印在标签上。

首次选择允许的字符选项中的“由‘输入掩码’设置”时，默认输入掩码将从位置中的零开始。这意味着输入掩码中的实际字符将与屏幕数据一起显示在标签视图区域、提示对话框中的响应字段以及打印出来的数据中。

如果取消选中打印实际字符选项或删除零字符而代之以一，输入掩码的实际字符将只显示在提示响应字段中，而不会打印出来。

有关详细信息，请参见了解输入掩码字符。


访问应用程序的启动命令行

访问 BarTender 的启动命令行

使用以下步骤可以访问 BarTender 的启动命令行。

  1. 如果您的桌面上没有快捷方式图标，请使用资源管理器找到 bartend.exe 文件并将鼠标光标放在该文件上。

  2. 单击并按住鼠标左键，然后将指针拖到桌面上。随即将自动创建一个快捷方式图标。

  3. 右键单击 BarTender 快捷方式图标，然后单击属性。

  4. 单击快捷方式选项卡。

  5. 在目标编辑框中输入所需的命令行参数。


删除对象

使用删除命令可以从标签视图区域中删除当前选中的对象。（要从标签视图区域中删除某个对象，但同时在剪贴板中保存一个与其规格等同的副本，请使用剪切命令，而不要使用删除命令。）

删除某对象但在剪贴板中保存一个与其规格等同的副本：

  1. 单击要删除的对象。

  2. 单击主工具栏上的剪切按钮 [image] 。对象将从标签格式中删除，但剪贴板上会保存一个与其规格等同的副本，供在同一标签格式的其它部分或在另一个标签格式中使用。

删除不再需要的某规格的对象：

使用快捷菜单删除某对象：

  1. 右键单击要删除的对象。

  2. 单击快捷菜单中的删除命令。

使用编辑菜单删除某对象：

  1. 单击要删除的对象。

  2. 单击主菜单栏上的编辑菜单选项。

  3. 单击编辑菜单中的删除命令。BarTender 将从标签视图区域中删除选中的条形码。

键盘快捷方式：单击相应的对象后，按 Delete 键将其从标签视图区域中删除。


调整对象的大小

更改对象大小的最简单方法是使用鼠标拖动对象的某个手柄，直到对象达到您需要的大小。

使用鼠标调整对象大小：

  1. 单击要调整大小的对象以将其选定。

  2. 将指针光标置于某个角部手柄（共四个）上，以同时调整高度和宽度。若要仅沿着一个方向调整大小，请将指针置于某个侧边手柄上，或者置于顶边中心手柄或底边中心手柄上。

  3. 单击并按住鼠标左键。

  4. 继续按住鼠标左键并拖动选定的手柄，直到对象达到您需要的大小。

  5. 松开鼠标键。

另请参见：

条形码的密度

条形码的高度

文本的大小

线条的长度

方框的高度

方框的宽度


设置标签对象以从输入数据文件读取数据

设置标签对象以从数据源文件读取数据

指定了要从中读取数据的数据文件之后，您需要设置一个或多个标签对象从该文件读取标签数据。以下操作步骤假定从文本文件而不是从已命名的 ODBC、OLE DB 或 SAP IDoc 或 OLE DB 数据源读取数据。

设置标签对象，使之从数据源文件读取数据：

  1. 双击您希望从数据文件读取其标签数据的标签对象。修改所选对象选项卡式对话框随即显示。

  2. 如果没有显示，请单击数据源选项卡，显示数据源属性页。

  3. 单击来源选项右侧的向下箭头，显示来源类型下拉列表。默认来源类型为屏幕数据。

  4. 从列表中选择数据库字段。数据源属性页上显示的可用选项将更改为只适用于数据源文件的选项。

  5. 使用使用数据文件字段 #选项，在包含要读入该对象的信息的数据文件中指定字段号。（如果是从 ODBC 或 OLE DB 数据源而不是从文本文件读取数据，则该字段称作字段名，此时，您要指定的就是一个字段名称而不是字段号。）

  6. 单击确定，返回标签格式。


缩小对象

缩小标签视图区域中的格式

单击主工具栏上的缩小按钮 [image] 。标签视图区域将按照缩放倍数百分比缩小。

另请参见：

缩小命令


放大对象

放大标签视图区域中的格式

单击主工具栏上的放大按钮 [image] 。标签视图区域将按照缩放倍数百分比放大。

另请参见：

放大命令


指定数据库

在读取的数据库类型中，最简单的是其字段有定界或有固定宽度的文本文件。以下步骤说明如何指示 BarTender 从简单的文本文件中读取数据。

指定从中读取标签数据的文本文件：

  1. 单击主菜单中的文件，然后单击数据库连接设置，显示添加数据库连接向导设置对话框。读取了添加数据库连接向导第一页后，单击下一步>。

  2. 在添加数据库连接向导 — 类型对话框中，指定定界方式。然后单击下一步>。（定界是 BarTender 确定一个字段的结束位置以及另一个字段的开始位置的方法。默认的定界方式为“引号和逗号混用”。有关四种定界方式的详细信息，请参见帮助索引中的“定界”。）

  3. 在添加数据库连接向导 — 文件对话框中，单击选择文件，指定要从中读取数据的文件。指定数据文件对话框随即显示。使用该对话框找到文件夹和文件名。

  4. 选定了要使用的数据文件后，单击打开。

  5. 单击下一步>，显示添加数据库连接向导 — 定界对话框，然后选择定界类型。单击下一步>。

  6. 在添加数据库连接向导 — 字段对话框中，对显示的问题回答“是”或“否”，然后单击完成。

  7. 若要返回标签格式，请单击数据库连接设置对话框中的确定。

另请参见：

指定现有已命名的 ODBC 数据源

新建已命名的 ODBC 数据源

了解 OLE DB

了解 SAP IDoc


修改条形码对象和文本对象的数据源

  1. 若要修改条形码对象和文本对象的数据源，请执行以下操作。

  2. 双击要修改其数据的对象。BarTender 将显示修改条形码或修改文本选项卡式对话框，具体取决于对象类型。

  3. 单击数据源选项卡，显示数据源属性页。

  4. 若要更改所选对象的数据源，请单击来源选项右侧的向下箭头显示数据源列表。再次单击所需的数据源。

  5. 根据需要，使用数据源属性页上的其它选项修改数据。

另请参见：

“数据源”属性页

标签对象的可用数据源


修改条形码对象和文本对象的屏幕数据

新的条形码对象或文本对象始终使用屏幕数据作为其默认的数据类型。更改文本对象或条形码对象的屏幕数据的最简单方法是：如下所述，使用主工具栏上的数据编辑按钮。（您也可以在修改对象选项卡式对话框中的数据源选项卡内编辑屏幕数据。）

修改文本对象或条形码对象的屏幕数据：

  1. 单击主工具栏上的数据编辑按钮 [image] 。

  2. 单击所需的文本或条形码对象。BarTender 将显示修改屏幕数据对话框。屏幕数据选项中的光标将开始闪烁，提示您可以为所选对象键入数据。

  3. 使用键盘为文本对象或条形码对象输入数据。

  4. 单击确定按钮。BarTender 将使用新的屏幕数据重新绘制该对象。

另请参见：

数据编辑工具

显示数据源属性页


打印标签

  1. 单击主工具栏上的打印机按钮 [image] （或文件菜单中的打印选项）显示打印对话框。

  2. 确定选择了正确的打印机名称。（我们强烈建议您在选择了错误的打印机名称时切勿设计标签，否则会明显降低打印性能。）

  3. 如果标签格式中有对象使用数据源文件中的数据，应启用数据库复选框。启用之后，您可以使用数据库连接设置按钮显示数据库连接设置对话框。

  4. 在同样标签的份数选项中键入每个标签需要打印的份数。

注意：如果您需要使用数据文件或打印时提示来指定同样标签的份数，请单击选项按钮访问同样标签的份数属性页。

  5. 如果要指定一序列标签，请在序列标签数选项中键入该序列的长度。（切记，要指定一序列标签，必须为一个或多个标签对象启用数据源属性页上的序列选项。）

注意：如果需要使用数据源文件或打印时提示来指定序列标签的份数，请单击选项按钮访问序列标签数属性页。

  6. 单击打印按钮，BarTender 将执行以下操作之一：

    • 如果标签格式上的对象只使用屏幕数据或数据库数据，则BarTender 将开始打印您的标签。

    或

    • 如果标签格式中有对象设置为打印时提示，BarTender 将显示提示对话框。输入完打印标签所需的全部数据后，单击打印按钮，BarTender 将开始打印您的标签。如果需要帮助，请单击提示对话框中的帮助按钮。

另请参见：

打印

“数据库连接设置”对话框


选择打印机

  1. 单击主工具栏上的打印机按钮 [image] （或文件菜单中的打印选项）显示打印对话框。

  2. 单击名称选项右侧的向下箭头显示已安装的打印机驱动程序下拉列表。

  3. 单击打印时要使用的打印机的名称。如果需要，请单击属性按钮显示和修改所选打印机的打印机设置。

  4. 单击关闭按钮返回标签视图区域。

另请参见：

打印


设置对象以提示输入数据

设置对象以便提示输入数据：

  1. 双击要在打印时为其输入数据的对象。BarTender 将显示修改对话框。

  2. 单击数据源选项卡显示数据源属性页。

  3. 单击提示按钮访问打印时提示选项对话框。

  4. 单击打印时提示选项框启用“提示选项”和“响应选项”。

  5. 使用打印时用户提示选项输入相应的提示。

  6. 根据需要设置其它选项。

  7. 单击确定按钮，返回到数据源属性页。

  8. 如果所选数据源是屏幕数据，请将默认响应输入数据源属性页上的默认响应数据输入框。单击确定按钮。

  9. 对于要求在打印时输入数据的每个对象重复上述步骤。如果您希望提示输入数据的对象有多个子串，则必须为每个子串分别启用“打印时提示”。

另请参见：

了解打印时提示


设置一个计数字段

有时可能需要设置一个字段来计算标签数。例如，1/5、2/5、3/5 等。以下说明可帮助您完成此操作。

  1. 将一个文本对象放在标签格式上。

  2. 双击它进入数据源属性页。

  3. 在屏幕数据选项中键入“1”。

  4. 单击更多选项按钮。系统随即列出其它选项。

  5. 从列表中选择序列化。更多数据源选项对话框随即显示，其中序列化选项卡已选中。

  6. 选中序列化复选框。

  7. 关闭打印后更新子串。

  8. 单击确定按钮，返回到数据源属性页。

  9. 若要添加其它子串，请单击高级按钮查看数据源高级选项。在子串列表选项中，您将看到一个子串。

  10. 双击列表尾部的空子串单元格。将下拉来源列表。

  11. 从数据源列表中选择屏幕数据。

  12. 在屏幕数据编辑框中，键入一个空格、“/”及另外一个空格。

  13. 双击列表尾部的空子串单元格。

  14. 从数据源列表中选择屏幕数据。（如果有一个字段包含要打印的标签总数，您可以从列表中选择数据库字段，然后在字段名称选项中指定正确的字段。）

  15. 在屏幕数据选项中键入“1”。但是，由于要打印的标签总数有可能改变，您最好与打印对话框中的序列标签数选项共享该子串。为此：

  • 单击共享/名称选项卡

  • 单击共享名称选项的内部

  • 键入“要打印的标签数”

  16. 单击确定，返回标签格式。

  17. 使用工具栏按钮或文件菜单，打开打印对话框。

  18. 单击序列标签数旁边的选项…按钮。

  19. 选择由数据源设置，然后单击数据源选项卡。

  20. 使用以前设置的共享名称共享此字段：

  • 单击高级

  • 单击共享/名称选项卡

  • 单击共享名称选项旁边的向下箭头，显示可用共享名称列表，然后选择“要打印的标签数”。

  21. 单击屏幕数据选项卡，然后单击更多选项按钮，并从列表中选择提示。

  22. 单击该复选框启用打印时提示。

  23. 在打印时用户提示选项中，键入“要打印的标签数”。

  24. 单击确定，返回打印对话框。

  25. 单击关闭，返回标签格式。

  26. 如果打印该标签格式，则打印作业开始时会出现一则提示，要求您输入要打印的标签数。打印机不仅会打印您所输入的标签份数，还会在标签上打印您输入的数字并顺序打印每个标签，直至完成指定数目。例如，在完成前面的步骤之后，您的标签的格式将读取为“1/1”。如果在打印时，在“要打印的标签数”提示中输入“4”，则打印出的标签将如下所示：

    1/4

    2/4

    3/4

    4/4


提示设计屏幕

提示设计视图用于自定义提示对话框。许多用于创建标签以及设置标签格式的工具也可用于设计提示对话框。主要不同在于所显示的是提示对话框而不是标签格式。

可以通过选择查看菜单中的提示设计视图从标签设计视图切换为提示设计视图。


调整大小按钮（适用于 BarTender 应用程序）

调整大小按钮（用于 BarTender 主窗口）

这些按钮用来指定 BarTender 窗口是以最大化、常规窗口还是最小化为图标的形式显示。


调整大小按钮（用于 BarTender 格式窗口）

调整大小按钮（用于标签格式窗口）

这些按钮用来指定活动标签格式窗口是以最大化、常规窗口还是最小化为图标的形式显示。


旋转工具

使用鼠标旋转对象：

  1. （可以按照任意顺序执行此步骤与下一个步骤。）选择要旋转的对象（如果尚未选定）。

  2. 单击主工具栏上的旋转工具按钮 [image] 。对象上的某些手柄将从正方形变为圆形。

  3. 将光标移至某个圆形手柄上。它将变为旋转光标。

  4. 按住鼠标左键拖动手柄，围绕旋转点旋转对象。对于线条、方框和图片，可以通过将旋转光标置于距离旋转点更近或更远的位置来控制对象旋转的程度。若要小幅度地增加旋转角度，请在旋转时朝远离旋转点的方向拖动光标。若要大幅度地增加旋转角度，请在旋转时朝靠近旋转点的方向拖动光标。线条、方框和图片的旋转幅度可以精确到 0.1 度。

注意：还可以使用旋转对话框（从排列菜单中访问）或排列工具栏上的三个旋转按钮来旋转对象。

注意：可以从高级旋转设置对话框（通过单击修改所选对象对话框中的位置选项卡上的第二个高级按钮来访问）中更改旋转点。


标尺

可以借助沿着标签视图区域的顶部和左侧显示的水平和垂直标尺确定对象在标签上的位置。


启动应用程序

运行 BarTender

  1. 单击 Windows 的开始按钮。

  2. 指向程序，然后定位到 BarTender 文件夹。

  3. 单击 BarTender 图标。

另请参见：

从其它程序运行 BarTender


特殊符号字体

全部显示 全部隐藏

BarTender 提供 Seagull Scientific, Inc. 的几种特殊 True Type 符号字体，使您只需键入字母或数字，而不必导入或链接到图形文件，就能在标签上放置某些复杂的符号。由于这些符号是字体字符，而不是图像，所以您可以像对待其它 True Type 字体一样，将它们放大或缩小。

若要将这些符号之一放在您的标签，请创建一个文本对象，在选择字体时选择所需的特殊字体，然后按表示该符号的按键。根据需要调整字体大小。

单击下面的字体名称，打开包含字体符号以及相应按键的表。（对于某些字体来说，一些按键没有对应的符号。）

Seagull ADR（European Agreement Concerning the International Carriage of Dangerous Goods by Road，国际危险货物陆路运输的欧洲协议）

符号 | 按键 | 符号 | 按键
! | ! | G | G
" | " | H | H
# | # | I | I
$ | $ | J | J
% | % | K | K
& | & | L | L
' | ' | M | M
( | ( | N | N
) | ) | O | O
* | * | P | P
+ | + | Q | Q
, | , | R | R
- | - | S | S
. | . | T | T
/ | / | U | U
0 | 0 | V | V
1 | 1 | W | W
2 | 2 | X | X
3 | 3 | Y | Y
4 | 4 | Z | Z
5 | 5 | [ | [
6 | 6 | \ | \
7 | 7 | ] | ]
8 | 8 | ^ | ^
9 | 9 | _ | _
: | : | ` | `
; | ; | a | a
< | < | b | b
= | = | c | c
> | > | d | d
? | ? | e | e
@ | @ | f | f
A | A | g | g
B | B | h | h
C | C | i | i
D | D | j | j
E | E | k | k
F | F | l | l
 |  | m | m

Seagull 电气

符号 | 按键 | 符号 | 按键
0 | 0 |  | C
1 | 1 | D | D
2 | 2 | E | E
3 | 3 | F | F
4 | 4 | G | G
5 | 5 | H | H
6 | 6 | I | I
7 | 7 | J | J
A | A | a | a
B | B | b | b

Seagull 紧急情况

符号 | 按键 | 符号 | 按键
! | ! | I | I
" | " | J | J
# | # | K | K
$ | $ | L | L
% | % | M | M
& | & | N | N
' | ' | O | O
( | ( | P | P
) | ) | Q | Q
* | * | R | R
+ | + | S | S
, | , | T | T
- | - | U | U
. | . | V | V
/ | / | W | W
0 | 0 | X | X
1 | 1 | Y | Y
2 | 2 | Z | Z
3 | 3 | [ | [
4 | 4 | \ | \
5 | 5 | ] | ]
6 | 6 | ^ | ^
7 | 7 | _ | _
8 | 8 | ` | `
9 | 9 | a | a
: | : | b | b
; | ; | c | c
< | < | d | d
= | = | e | e
> | > | f | f
? | ? | g | g
@ | @ | h | h
A | A | i | i
B | B | j | j
C | C | k | k
D | D | l | l
E | E | m | m
F | F | n | n
G | G | o | o
H | H |  |

Seagull 危险材料

符号 | 按键 | 符号 | 按键
! | ! | I | I
" | " | J | J
# | # | K | K
$ | $ | L | L
% | % | M | M
& | & | N | N
' | ' | O | O
( | ( | P | P
) | ) | Q | Q
* | * | R | R
+ | + | S | S
, | , | T | T
- | - | U | U
. | . |  | V
/ | / | W | W
0 | 0 | X | X
1 | 1 | Y | Y
2 | 2 | Z | Z
3 | 3 | [ | [
4 | 4 | \ | \
5 | 5 | ] | ]
6 | 6 | ^ | ^
7 | 7 | _ | _
 | A | ` | `
B | B | a | a
C | C | b | b
D | D | c | c
E | E | d | d
F | F | | | |
G | G | } | }
H | H | ~ | ~

Seagull 徽标

符号 | 按键 | 符号 | 按键
0 | 0 | Z | Z
1 | 1 | [ | [
2 | 2 | \ | \
3 | 3 | ] | ]
A | A | a | a
B | B | b | b
C | C | c | c
D | D | d | d
E | E | e | e
F | F | f | f
G | G | g | g
H | H | h | h
I | I | i | i
J | J | j | j
K | K | k | k
L | L | l | l
M | M | m | m
N | N | n | n
O | O | o | o
P | P | p | p
Q | Q | v | v
R | R | w | w
S | S | x | x
T | T | y | y
U | U | z | z
V | V |  | {
W | W | | | |
X | X | } | }
Y | Y | ~ | ~

Seagull 包装

符号 | 按键 | 符号 | 按键
a | a | i | i
b | b | j | j
c | c | k | k
d | d | l | l
e | e | m | m
f | f | n | n
g | g | o | o
h | h | p | p

Seagull 油漆

符号 | 按键 | 符号 | 按键
! | ! | D | D
" | " | E | E
# | # | F | F
$ | $ | G | G
% | % | H | H
& | & | I | I
' | ' | J | J
( | ( | K | K
) | ) | L | L
* | * | M | M
+ | + | N | N
, | , | O | O
- | - | P | P
. | . | Q | Q
/ | / | R | R
0 | 0 | S | S
1 | 1 | T | T
2 | 2 | U | U
3 | 3 | V | V
4 | 4 | W | W
5 | 5 | X | X
6 | 6 | Y | Y
7 | 7 | Z | Z
8 | 8 | [ | [
9 | 9 | \ | \
: | : | ] | ]
; | ; | ^ | ^
< | < | _ | _
= | = | ` | `
> | > | a | a
? | ? | b | b
@ | @ | c | c
A | A | d | d
B | B | e | e
C | C |  |

Seagull 废品回收

符号 | 按键 | 符号 | 按键
0 | 0 | L | L
1 | 1 | M | M
2 | 2 | N | N
3 | 3 | O | O
4 | 4 | P | P
5 | 5 | Q | Q
6 | 6 | R | R
7 | 7 | S | S
8 | 8 | T | T
9 | 9 | U | U
: | : | V | V
; | ; | W | W
< | < | X | X
= | = | Y | Y
> | > | Z | Z
? | ? | [ | [
@ | @ | \ | \
A | A | ] | ]
B | B | ^ | ^
C | C | _ | _
D | D | ` | `
E | E | a | a
F | F | b | b
G | G | c | c
H | H | d | d
I | I | e | e
J | J | f | f
K | K |  |

Seagull 风险用语

符号 | 按键 | 符号 | 按键
 | 1 | T | T
 | 2 | U | U
3 | 3 | V | V
4 | 4 | W | W
5 | 5 | X | X
6 | 6 | Y | Y
7 | 7 | Z | Z
8 | 8 | [ | [
9 | 9 | \ | \
: | : | ] | ]
; | ; | ^ | ^
< | < | _ | _
= | = | ` | `
> | > | a | a
? | ? | b | b
@ | @ | c | c
A | A | d | d
B | B | e | e
C | C | f | f
D | D | g | g
E | E | h | h
F | F | i | i
G | G | j | j
H | H | k | k
I | I | l | l
J | J | m | m
K | K | n | n
L | L | o | o
M | M | p | p
N | N | q | q
O | O | r | r
P | P | s | s
Q | Q | t | t
R | R | u | u
S | S |  |

Seagull 纺织品保养

符号 | 按键 | 符号 | 按键
! | ! | P | P
" | " | Q | Q
# | # | R | R
$ | $ | S | S
% | % | T | T
& | & | U | U
' | ' | V | V
( | ( | W | W
) | ) | X | X
* | * | Y | Y
+ | + | Z | Z
, | , | [ | [
- | - | \ | \
. | . | ] | ]
/ | / | ^ | ^
0 | 0 | _ | _
1 | 1 | ` | `
2 | 2 | a | a
3 | 3 | b | b
4 | 4 | c | c
5 | 5 | d | d
6 | 6 | e | e
7 | 7 | f | f
8 | 8 | g | g
9 | 9 | h | h
: | : | i | i
; | ; | j | j
< | < | k | k
= | = | l | l
> | > | m | m
? | ? | n | n
@ | @ | o | o
A | A | p | p
B | B | q | q
C | C | r | r
D | D | s | s
E | E | t | t
F | F | u | u
G | G | v | v
H | H | w | w
I | I | x | x
J | J | y | y
K | K | z | z
L | L | { | {
M | M | | | |
N | N | } | }
O | O | ~ | ~

Seagull 警告

符号 | 按键 | 符号 | 按键
! | ! | G | G
" | " | H | H
# | # | I | I
$ | $ | J | J
% | % | K | K
& | & | L | L
' | ' | M | M
( | ( | N | N
) | ) | O | O
* | * | P | P
+ | + | Q | Q
, | , | R | R
- | - | S | S
. | . | T | T
/ | / | U | U
0 | 0 | V | V
1 | 1 | W | W
2 | 2 | X | X
3 | 3 | Y | Y
4 | 4 | Z | Z
5 | 5 | [ | [
6 | 6 | \ | \
7 | 7 | ] | ]
8 | 8 | ^ | ^
9 | 9 | _ | _
: | : | ` | `
; | ; | a | a
< | < | b | b
= | = | c | c
> | > | d | d
? | ? | e | e
@ | @ | f | f
A | A | g | g
B | B | h | h
C | C | i | i
D | D | j | j
E | E | k | k
F | F | l | l


“选择配置文件”对话框

“Windows Messaging 设置”对话框

从消息设置对话框中的电子邮件选项卡可以打开该对话框（当 Windows Messaging (MAPI) 被选作邮件系统时）。使用该对话框可以更改 BarTender 用来发送邮件的邮件/邮件传送系统配置文件，还可以设置新的邮件/邮件传送系统配置文件。除非您另外指定，否则 BarTender 将使用计算机当前登录用户的默认配置文件。

单击使用配置文件，激活该对话框的各项功能。

  • 配置文件。从下拉列表中选择一个配置文件，或单击设置按钮在 Windows 中设置一个配置文件。有关详细信息，请参见 Windows 帮助。

  • 口令。输入所选配置文件的口令。

另请参见：

了解邮件/邮件传送配置文件


状态栏

显示特定于标签格式以及当前选定的标签对象的信息。不过，当鼠标指针置于工具栏或菜单项上时，将显示有关该项目的临时帮助文本行。（请参见状态栏。）


子串单元格

显示在子串列表选项中的任意单行文本。每个子串单元格都包含单个数据子串的数据。子串列表可以包含任意多个子串单元格，其中每个单元格都包含 BarTender 使用的五种数据类型中的任意一种数据。左侧的图形显示具有两个单元格的子串列表。上面的单元格是空的，等待为其指定数据类型。第二个单元格包含屏幕数据子串的样本数据。


子串

分配给条形码或文本对象的数据字符集，该字符集将在打印时为该对象打印出来。此数据可能包含屏幕数据、输入文件数据、打印时提示数据、日期或时间。虽然它通常只有在条形码和文本对象要从单个子串中接收其数据时才是必要的，但是有时当标签对象要从多个子串中接收其数据时也有必要使用子串。


标题栏

位于 BarTender 程序窗口顶部的水平栏，显示 BarTender 的名称和活动标签格式的名称。


工具箱定义

工具箱

即一个窗格集，通过它们，用户能很快为其标签添加基本对象、预定义组件、可再用组件、数据源以及特定符号体系的条形码。有关详细信息，请参见工具箱。


透明效果

启用常规选项对话框中的使用透明效果，可以应用以下效果：

  • 标签外混合。当某个对象有一部分在标签外时，不在标签上的部分将变为半透明。

  • 屏幕操作时半透明化。当使用鼠标移动、旋转某对象或调整某对象大小时，该对象将变为半透明，以便用户能看到它覆盖住的那些对象。

注意：在未装图形卡的计算机上使用此选项，可能会降低对象的移动速度和 BarTender 窗口的大小调整速度。


了解邮件/邮件传送配置文件

了解邮件/邮件传送系统配置文件

通过邮件/邮件传送系统，使 BarTender 之类的应用程序可以在不需要用户干预的情况下发送电子邮件，或使用其它邮件系统功能。

如果在消息设置对话框中的 电子邮件选项卡上配置该应用程序，使其使用 Windows Messaging (MAPI) 而不使用 Internet Mail (SMTP) 作为邮件系统；则与计算机用户通常必须登录到网络一样，该应用程序必须登录到邮件/邮件传送系统。就像网络必须记录用户名和口令一样，邮件/邮件传送系统也必须有配置文件及其相关联口令的记录。配置文件中包括的内容有：地址簿、邮件文件夹以及一个或多个邮件服务。邮件服务是用于传递邮件的系统或协议。常用的一些邮件服务有：SMTP、POP3、Lotus CC:Mail 和 Microsoft Exchange。贵公司甚至可能有自定义的邮件服务。

配置文件通常与用户和某台计算机这两者相关联。登录到同一计算机的不同用户可能有不同的配置文件，而某用户在不同的计算机上可能有不同的配置文件。

除非另外指定，否则 BarTender 将使用计算机当前登录用户的默认配置文件。单击消息设置对话框中的电子邮件选项卡上的设置按钮，可以指示 BarTender 使用其它配置文件。随即打开的对话框会有所不同，具体取决于该按钮左侧邮件系统框中选定的邮件服务。

每当 BarTender 要发送邮件时，它都会使用指定的配置文件和口令登录到邮件/邮件传送系统发送邮件，无需用户干预。


了解打印时提示

如果要设计一种标签，但在打印之前无法知晓一个或多个标签对象的数据，则可以对 BarTender 进行配置，使其在打印作业开始时显提示对话框，供您输入必要的数据。 例如，假定您需要一个标准的发货标签，其中包括包装重量，但在打印前又无法知道包装重量。

有关使用打印时提示和提示对话框的详细信息，请单击以下所需的主题。

  • 启用打印时提示

  • 编辑用户提示

  • 编辑默认响应

  • 了解默认提示对话框

  • 自定义提示对话框

  • 更改提示顺序

  • 响应打印时提示

  • 了解打印向导

注意：如果您希望提示输入的数据不是将显示在标签上的数据，而是将在打印时执行的 SQL 查询中充当条件的数据，那么请使用 BarTender 的查询提示功能，而不是打印时提示功能。


Understanding Reading Order

There are two senses in which text can have a reading order. Each language has an inherent reading order and, in text that mixes languages, there is a reading order for the separate runs of characters from each language.

Reading Order Inherent to a Language

The inherent reading order of a language is the direction in which its symbols are read and written. Most languages read from left to right, as does English, Spanish, and Russian. A few, such as Hebrew and Arabic, read from right to left. Examples:

English is Left-to-Right (LTR):

People ought to wear more hats.

Start→

Hebrew is Right-to-Left (RTL):

אנשים צריכים ללבוש יותר כובעים.

←Start

Reading Order in Directionally Mixed Text

When a line includes text from both RTL and LTR languages, then it consists of separate runs of characters from each language. Within a run, the characters use the language's inherent reading order. But the series of runs also has a reading order, defined by the author's intent. When some Hebrew is included in text intended for English readers, then the overall reading order is LTR. In this example, the numbers indicate the reading order of the runs and the arrows show the reading order within each run:

The Hebrew word for hat is כובע, which is hard to pronounce.

|1→ |←2| 3→ |

When English is included in Hebrew, the overall reading order is RTL:

המילה של אנגלית לכובע hat, שקשה לבטא.

| ←3|2→| ←1|

Directionally Mixed Text in BarTender

When text is printed with the wrong reading order, the results can be dramatic. The following text, which is a translation into Hebrew of the English term 2.5" Screw, is displayed LTR as intended.

2.5" הברג

|1→ | ←2|

If the text were displayed RTL, it would look like this:

2.5" הברג

| ←2|1→|

For this reason, BarTender enables you specify the reading order of runs in directionally mixed text. You can set a reading order for all edit boxes in the BarTender user interface on the Format Options dialog. Each text object on a label format has its own Reading Order setting on the Text tab of the Modify Selected Text Object dialog for the object. Similarly, every prompt object that has text has its own Reading Order setting on the Modify Selected Objects dialog.


了解参考点

标签上的对象是通过 X 轴坐标和 Y 轴坐标来定位的。X 轴坐标是对象相对于标签上某个点的左右距离。Y 轴坐标是相对于同一个点的上下距离。该点称为标签参考点。设计标签时，可以将标签上的任意九个位置选定为标签参考点。在下图中显示为红色方框的九个点即为您可以选择的标签参考点。（左上角为默认选项。）

注意：红色方框仅作图解之用，而不会出现在实际的标签设计屏幕上。

如果标签为圆形或椭圆形，则上述九个可能的参考点将位于一个不可见矩形的中心和周边，该矩形的四边将与标签的最高点、最低点、最右侧点和最左侧点相交。

要精确定位，需要解决另一个问题：对象上的哪个点（中心？左上角？等等）应是精确放置在 XY 轴坐标上的点？该点称为对象参考点，当设计标签以及在标签上放置对象时，对上述问题可有九种选择。在下图中显示为绿色方框的九个点即为您可以选择的对象参考点。（左上角为默认选项。）

标签参考点充当笛卡儿坐标系的中心，而对象参考点是该坐标系中的一点。因此，对象的 X 轴坐标是对象参考点相对于标签参考点的左右距离。Y 轴坐标是对象参考点相对于标签参考点的上下距离。

注意：线条对象的对象参考点将始终是线条的中心点。此外，您不必通过指定对象参考点相对于标签参考点的 XY 轴坐标来指定线条的位置。可以选择使用线条的两个端点之一相对于标签参考点的 XY 轴坐标。


可能的基于脚本的操作

以下仅仅是可以使用 BarTender 的脚本执行的某些操作。

  • 启动一个特殊的输出文件。

  • 写入文件中。

  • 弹出消息。

  • 取消打印作业。

另请参见：

可能的基于脚本的数据处理任务


可能的基于脚本的数据处理任务

以下仅仅是可以使用 BarTender 的脚本执行的某些数据处理任务：

  • 丢弃子串数据的一部分。

  • 将所有字符都更改为大写。

  • 设置数字数据格式以使其类似价格。

  • 计算自定义校验位。

  • 对数值执行某些数学运算。

  • 修改其它子串中的数据。

另请参见：

可能的基于脚本的操作


“OnIdenticalCopies”事件的性能警告

如果将打印对话框上同样标签的份数选项设置为大于 1 的值，BarTender 通常会利用打印机中内置的某些高速功能。BarTender 可以向打印机发送一次标签，指示打印机打印所需的份数。这样，BarTender 就不必反复向打印机发送每个要打印标签的同样的图像，从而节省了时间。

不过，如果您为 OnIdenticalCopies 事件编写了脚本，则在打印每张标签时都将执行该脚本，即使标签相同也如此。这就要求 BarTender 禁用前面提到的打印机优化功能，否则会大大降低性能。


OnNewRecord

如果从数据源文件中读取数据，在每次在打印时从数据库或文本文件中读取新的记录时都将执行 OnNewRecord 事件脚本。


OnScreenUpdate

OnScreenUpdate 是唯一的，因为执行并不限于只有在打印时才能进行。OnScreenUpdate 事件脚本将在更新屏幕上的标签对象的任意时间执行。标签对象将作为对许多事件的响应在屏幕上更新。

  • 单击确定可退出对话框。

  • 从“提示设计”视图返回“标签设计”视图。

  • 在打印作业开始和结束时的几个实例中。

虽然可能存在其它使用情况，但是该事件最重要的标签任务是编写脚本，以便将屏幕值赋给用于创建打印作业日志文件的非打印对象。


OnSerialize

当标签格式可能发生序列化时将调用 OnSerialize。执行 OnSerialize 事件的频率取决于要打印的序列标签数。无论序列标签数是在 BarTender 的打印对话框中指定的还是从数据文件中读取的，该事件的频率都受其制约。

如果为打印对话框中的序列标签数指定了一个设定的值，并且未从数据文件中读取序列化值，则该值将指定每个标签作业调用 OnSerialize 事件的次数。

如果“序列标签数”的值是从数据文件中读取的（这意味着每个记录都有一个新的序列化值），则为每个记录读入的值都指定将为每个对应的记录调用多少次 OnSerialize 事件。（每个标签作业 调用 OnSerialize 的总次数与为每个记录读入的序列化值的总和相等。）

对于将调用的 OnSerialize 脚本，不需要为标签上的任意对象启用序列化。只要 OnSerialize 事件包含脚本，就按照上面指定的频率调用该脚本。


定义和使用全局变量

在使用事件控制脚本时可用的“函数和子例程”脚本，可用于声明能供一个标签对象子串的多个脚本访问的变量。不过，由于 Visual Basic 脚本的工作方式，从传统意义上来说，BarTender 并不支持对整个标签设计而言（从而可供不同标签对象的脚本共享）的全局变量。但是，共享子串（可用 BarTender 的数据源属性页在其高级模式下定义），为我们提供了两种使用 Visual Basic 脚本时在多个标签对象之间共享数据的常用方法。

在标签对象之间共享脚本输出

如果您需要做的一切就是将某个脚本的输出与多个标签对象共享，则可为要共享的脚本定义一个共享名称。然后，双击希望其数据来自共享脚本的其它任何标签对象，并指定相同的共享名称。设置完共享后，您将发现，每个关联的子串在“数据源”属性页中均包含相同的脚本。（使用多行脚本时，不要忘了没有任何输出可以共享，除非脚本的最后一行以“value =”开头，后面跟着要共享的输出值。）

定义多个标签对象的脚本可用的“全局”变量

在标签对象之间共享脚本输出（如前一段所述）并不能满足从多个标签对象的脚本内部访问和修改某变量的需求。不过，BarTender 并不能以大多数 Visual Basic 编程人员熟知的传统方式支持真正的“全局”变量。您只可以将一个或多个有共享名称的子串当作全局变量使用。

创建全局变量的补充说明

由于您能从任何 Visual Basic 脚本内部访问和/或修改任何指定的子串，因此，尽管这些子串未用传统的 Visual Basic 技术定义，但实际上是全局变量。


使用子串共享名称定义全局变量

注意：以下过程为每个所需的全局变量定义一个包含一个子串的标签对象。不过，通过启用不打印对象，实际上，我们已从打印的标签上剔除了它。换言之，尽管我们创建了一个标签对象，但并不真正将其用作标签对象。（如果在屏幕上您觉得该对象会分散您的注意力，始终可以用鼠标将其移到标签之外。如果您愿意，还可以将文本的颜色改为白色。但要记住它的位置，以免丢失！）请注意，虽然我们为每个子串都指定了一个共享名称，但不必为了要引用您脚本中的共享名称而让另一个对象共享此数据。

  1. 按常规方式在标签设计区域中创建一个文本对象。

  2. 双击该文本对象，打开修改对象对话框。

  3. 单击常规选项卡，启用不打印对象选项。

  4. 单击数据源选项卡，然后单击高级按钮。

  5. 单击“子串”组框中的常规选项卡，在共享名称编辑框中键入所需变量的名称。

  6. 单击屏幕数据编辑框，并用要将变量初始化到的值替换“样本文本”。

重要提示：第一次加载标签格式时，变量只能初始化为“屏幕数据”中指定的值。如果存储在变量中的值因执行了脚本而改变了，而您在开始打印作业时又需要有一个已知的起始值，那么，您必须使用事件控制脚本和 OnPrintStart 事件来初始化变量。

如果您只需要这一个全局变量，则您已经完成了所有操作。否则，请继续执行以下步骤：

  1. 若要定义另一个全局变量，请单击子串列表末尾的空白框。

  2. 在来源选项中，指定屏幕数据。

  3. 如第 5 步和第 6 步所述，为新变量输入共享名称，并用所需的初始化值替代“样本文本”。

  4. 对要定义的其余每个全局变量，重复执行第 7、8 和第 9 步。


脚本的两种主要用途

可以编写 Visual Basic 脚本以执行大量的任务。但是，基于脚本的解决方案可能会很好地处理某些情况，而对其它情况则不然。BarTender 的脚本编写功能通常用于测试条件或等待事件，然后：

  • 更改已读入 BarTender 的数据或用特殊方式将它与其它数据组合。

AND/OR

  • 触发用户定义的操作。

可能导致脚本启动或影响其运作的可能测试条件。

可能导致脚本启动的可能事件。

可以使用脚本执行的数据处理示例。

可以使用脚本执行的操作示例。


启动脚本响应应用程序事件

启动脚本响应事件

软件程序与计算机语言之间的术语稍有不同，有时，“事件”和“测试条件”的定义相同。不过，通常“测试条件”包含对某些数据的检测和 if 比较关系。而“事件”则与 when，而不是 if 相关。

为避免不必要的混淆，BarTender 的“脚本助理”不支持不同类型的事件，除非 Visual Basic 脚本数据源的类型选项设置为“事件控制脚本”。在这种情况下，可以编写为响应任意多个事件执行的脚本，例如，打印作业的开始或结束，或正从数据库读取的新记录。

有关事件和事件处理的详细信息，请参见事件控制脚本。


测试条件

在软件用语中，Visual Basic 脚本中的“测试条件”是指对某些数据的检查，而检查的结果将导致操作执行或数据改变。下面的示例并非 Visual Basic 代码，而仅仅是一些表达形式，以说明某些常用的测试条件。

  • 如果数据字段具有前导或尾部空白字符，那么…

  • 如果在字段中找到短划线字符或逗号，那么…

  • 如果价格字段中的数据大于 $100，那么…

  • 如果数据字段包含任何非数字字符，那么…

  • 如果数据字段的长度超过 25 个字符，那么…

  • 如果数据字段为空，那么…

测试不需要如上所述逐个执行，而是可作为测试组的一部分执行，测试组中的各项测试可通过任意数目的运算符（如“and”和“or”）连接。例如：

  • 如果“this”和“this”，那么…

  • 如果“this”或“this”，但不同时满足“this”，那么…

最后，如果未通过某个条件测试，可以选择使用“else”子句，且该子句可以包含自己的其它测试条件。（如果您将“else”一词设想为“otherwise”，则下面的示例可能更具可读性。）

具有简单“else”的示例：

如果价格大于 $100，那么

执行函数、计算或更改数据

else（否则）

执行替代函数或计算，或者通过其它途径更改数据

包含替代测试条件的“else”示例：

如果客户姓名字段包含任意尾部空格字符（或“空白”）

删除尾部空格

否则，如果客户姓名字段包含任意前导空格字符

将前导空格更改为星号


不同类型的事件脚本

两个特殊的事件脚本

显示在事件列表顶部的函数和子例程脚本和 OnAutoSelectedEvent 脚本与列出的其它脚本不同，有必要专门讨论一下。有关详细信息，请参见两个特殊的事件脚本。

常用事件脚本

单击事件列表中的某个名称后，该事件将突出显示，并可在编辑框区域创建或编辑关联的脚本。有关可用事件列表，请参见常用事件脚本。

另请参见：

事件控制脚本

使用脚本助理


垂直滚动条

使用沿着 BarTender 的标签视图区域的右边缘放置的垂直栏，可以在信息无法全部显示在标签视图区域中时，上下移动活动窗口的内容。


分组框标题的对齐方式

对齐方式

在向提示对话框添加分组框时，标题文本自动沿着分组框的顶部放置。使用分组框属性页上的对齐方式，可以指定此文本是否沿着对话框的顶部放置。

下面列出了不同对齐方式选项，并分别说明了这些选项如何影响分组框标题。

  • 左。用于将标题文本放置在分组框的左边缘。（默认设置）

  • 中。用于将标题文本放置在分组框的左边缘与右边缘之间。

  • 右。用于将标题文本放置在分组框的右边缘。

另请参见：

了解打印时提示


调整提示对话框的大小

使用鼠标调整大小：

  1. 单击提示对话框。

  2. 若要调整高度，请将鼠标光标置于底部手柄上。
    若要调整宽度，请将鼠标光标置于右手柄上。
    若要同时调整高度和宽度，请将鼠标指针置于右下角手柄上。

  3. 单击并按住鼠标左键。

  4. 拖动选定的手柄，直到提示对话框达到您需要的大小。

  5. 松开鼠标键。

使用属性页调整大小：

  1. 双击提示对话框以显示对话框属性页。

  2. 将光标置于高度或宽度数据输入框中，然后键入相应的大小。

  3. 单击确定按钮。

另请参见：

了解打印时提示


调整响应框的大小

调整响应框大小的最简单方法是使用鼠标。不过，使用响应框属性页上的行和宽度选项可以手动输入响应框的准确行数和宽度。下面分别介绍了这两种方法。

鼠标方法：

  1. 单击提示对话框上的相应响应框。

  2. 将鼠标指针置于相应的大小调整手柄上。

  3. 单击并按住鼠标左键。

  4. 拖动选定的手柄，直到文本对象达到您需要的大小。

  5. 松开鼠标键。

如果您需要指定准确的大小，可以使用以下方法在文本属性页上的行和宽度选项中手动输入相应的值。

属性页方法：

  1. 双击该对象以显示修改所选对象选项卡式对话框。

  2. 单击与响应框属性页对应的选项卡。

  3. 选择行以输入准确的行数，并在数据输入框中键入相应的数字。

  4. 选择宽度以输入准确的水平大小，并在数据输入框中键入相应的宽度。

  5. 单击确定按钮。

另请参见：

了解打印时提示


提示对话框对象中文本的对齐方式

对齐方式

对齐方式用于指定文本在用户提示或常用文本对象中是放置在对象的左边缘、右边缘还是在左右边缘之间居中。下面给出了一些示例。

左对齐（默认设置）
创建和打印标签对于新手和有经验的用户都同样容易。

居中对齐
创建和打印标签对于新手和有经验的用户都同样容易。

右对齐
创建和打印标签对于新手和有经验的用户都同样容易。

另请参见：

了解打印时提示


调整文本对象的大小

调整用户提示或常用文本对象大小的最简单方法是使用鼠标。不过，也可以使用文本属性页上的宽度指定宽度。下面分别介绍了这两种方法。

鼠标方法：

  1. 单击提示对话框上的相应对象。

  2. 将鼠标指针置于左大小调整手柄或右大小调整手柄上。

  3. 单击并按住鼠标左键。

  4. 拖动选定的手柄，直到文本对象达到您需要的大小。

  5. 松开鼠标键。

如果您需要指定准确的大小，可以使用以下方法在文本属性页上的宽度中输入相应的值。

属性页方法：

  1. 双击该对象以显示修改所选对象选项卡式对话框。

  2. 单击与文本属性页对应的选项卡（如果该选项卡未自动显示）。

  3. 选择宽度以输入准确的水平大小，并在数据输入框中键入相应的宽度。

  4. 单击确定按钮。

另请参见：

了解打印时提示


编辑文本

使用文本属性页或分组框属性页上的文本，可以为用户提示、常用文本对象或提示对话框上的分组框标题输入和编辑文本。还可以使用主工具栏和修改文本对话框上的数据编辑按钮编辑文本。下面分别介绍了这两种方法。

属性页方法：

  1. 双击该对象以访问修改所选对象选项卡式对话框。

  2. 选择文本选项卡。

  3. 在文本数据输入框内单击鼠标光标。

  4. 根据需要编辑文本。

  5. 单击确定按钮。

“修改文本”对话框方法：

  1. 单击工具栏上的数据编辑（或 I 形条）按钮。

  2. 单击要编辑的对象。此时将出现修改文本对话框。

  3. 在数据输入框内单击鼠标光标。

  4. 根据需要添加或删除文本。

  5. 单击确定按钮。

另请参见：

了解打印时提示


工具栏

BarTender 提供以下工具栏和状态栏。

  • 主工具栏。提供最常用命令的快捷方式。

  • 字体工具栏。提供最常用文本格式命令的快捷方式。

  • 排列工具栏。提供影响标签对象的方位和方向的命令的快捷方式。

  • 状态栏。为标签格式显示当前打印机设置并显示有关所选对象的信息。不过，当鼠标指针置于工具栏或菜单项上时，将显示有关该项目的临时帮助文本行。

可以使用查看菜单上的工具栏选项显示或隐藏不同的工具栏和状态栏。当看到列出可用的不同工具栏的次级菜单时，请注意工具栏名称左侧的复选标记。复选标记意味着工具栏当前处于活动状态，您可以在屏幕上看到它。如果未显示复选标记，则说明该工具栏是隐藏的。

显示或隐藏工具栏

  1. 单击查看菜单上的工具栏选项。

  2. 单击所需工具栏的名称。

注意：若要显示或隐藏工具栏，还可以右击工具栏或状态栏区域，然后从工具栏快捷菜单中选择需要的工具栏。